Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Korrupted

[HowTo] Update to 10.4.7 from 10.4.6 (Intel ONLY)

256 posts in this topic

Recommended Posts

**NOTE: THIS IS FOR INTEL PROCESSORS ONLY CURRENTLY. ALSO YOU CAN **ONLY** UPDATE FROM 10.4.6. THIS IS JUST THE INTEL UPDATE, NOT THE COMBO UPDATE.**

 

Credit goes to JaS, for his excellent work on this release.

 

It's simple.

 

1. Download the updater from demonoid.com(do NOT post links here).

2. Run the installer.

3. Repair permissions(with disk utility in /applications/utilities, or through terminal[diskutil repairpermissions /]).

4. sudo update_prebinding -root / -force

5. reboot.

 

What's in this update?

1. The essential files to upgrade from 10.4.6 to 10.4.7

2. Semjaza's decrypts(finder, etc)

3. 10.4.7 Frameworks

 

What's *not* in this update?

1. AMD Support

2. 10.4.7 Kexts(get those from apple, lazy people :) )

Share this post


Link to post
Share on other sites

yeah, wish that'd been in the torrent package alas, installed it on my AMD system before this thread had the intel only mention in it and hosed my OSX install. Oh well, needed to repartition anyway.

 

edit: meant to post that in the main 10.4.7 thread as this one obviously does say intel only. sorry bout that :)

Share this post


Link to post
Share on other sites
Oh. Is 10.4.7 out?

 

If it wasn't, I wouldn't have made this topic. :)

 

The first question: Will it support 855 Intel Graphics Card?

 

I doubt it.

Share this post


Link to post
Share on other sites

I already have all of my graphics (w/ QE), sound, and network drivers set up and working in 10.4.6. Will updating using your guide mess any of that up?

Share this post


Link to post
Share on other sites
I already have all of my graphics (w/ QE), sound, and network drivers set up and working in 10.4.6. Will updating using your guide mess any of that up?

 

Kexts are not included in this release, so no, none of your settings should be affected.

Share this post


Link to post
Share on other sites

The one that's being seeded is Jas' release, not the official Apple one.

Share this post


Link to post
Share on other sites

Hey tanks for that!

 

will there be a patched 10.4.7 DVD avalible - maybe with boris' ati patch in the future?

That would be great!

Share this post


Link to post
Share on other sites

Okay, I'll install this in 10 minutes (my pop tarts are ready) and see how it goes.

Btw, I love how this community is so on top of things; on the day of release there is already a hacked torrent available and a short tutorial to go along with it. And there are people up at 2:30am to respond to your replies in seconds...

Share this post


Link to post
Share on other sites

I don't know about the boris part, but I'm sure a dvd will pop up one of these days.

Share this post


Link to post
Share on other sites

Credit goes to JaS for the release. I'm just the one who started seeding it. ^^;

Share this post


Link to post
Share on other sites

yeah thanks a lot again!!!

 

I successfully installed 10.4.7

 

then i installed all Extensions from the Original Update with Parcifist.

No crash! But again no sound and no QE/CI so i have to replace the 10.4.7 with 10.4.6/10.4.3 kext

so you can savely install the Extensions but you have to replace/repatch the onece you need.

 

btw Xbench score went from 110.x to 112 with old 10.4.6 kexts :D

Share this post


Link to post
Share on other sites

10.4.7 OPENGL.FRAMEWORK FROM COMBO NEEDED, bad Apple package, 10.4.7 doesnt run the 10.4.7 OPENGL.FRAMEWORK, u need to download it and extract it from the COMBO ;) enjoy

Share this post


Link to post
Share on other sites

Just finished the update and all previouse hardware under sig and user settings in tact, as well as the mouse tearing.

 

chears..

Share this post


Link to post
Share on other sites

sorry to say that, but this new installation has nothing to deal with 10.4.7 until u use the 10.4.7 kexts...

im waiting for Semjaza patch

Share this post


Link to post
Share on other sites

kexts? Since when did it ever make a difference which version kexts we use? Maybe the you mean kernel. Our ATI, nVidia, audio, wifi kexts will never be enhanced by Apple as long as we work on a hacked OS. It will always be hacked and kexts never be geared to users like us unless devs make it so.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    •   Thank you Baio77. Here is my CLOVER folder and the Hack info. 
            For Some Reason I can't upload my CLOVER folder. But here you can download...
      https://www.dropbox.com/s/vjprxs1idtj9pt7/CLOVER.zip?dl=0     Thank you again!!!   HackInfo_Report.zip
    • The brightness is NOT from Sierra, in my signature you find tools with which to give info on your system .....
      Post Hack Info and the clover folder ......
      Only in this way can I help you ......
    • Few more minutes to go before going live again with https://OSXLatitude.com
          So you can lock this topic again @Allan Hopefully for a bit longer than a couple of weeks this time hehe.
    • ok, I am having a weird glitch with my Primary bios after modding it myself. can I get some help getting a Clean osmosis modded (for High Sierra and beyond) Bios Image?   https://www.gigabyte.com/us/Motherboard/GA-Z87X-UD5-TH-rev-1x#support-dl   the version I have always stuck with was F4, because the F5d.  I use a custom iMac 14,2 configuration that has been stable, the issues I have with stability come from not being able to get Access to the Bios, and prior to my attempt to mod it has been stable with up to High Sierra using clover, and up to Sierra with my very very old Ozmosis 894m F4 rom. I am not opposed to installing Ozmosis on the EFI Partition, But Gigabyte locked the Bios loading .efi Files, there is no shell to Force it to load HFS+ or APFS drivers.   so what I am asking for is assistance ether unlocking a Shell for my Bios, or getting a bios with the APFS, HFS+, and Ozmosis related files in it.   thanks again for everyones assistance. HBP
    •     Install from fresh again. This time without Tony Tools, follow some guide in this topic. Install IntelHD kexts as usual in S/L/E and thats it. Everything works again, except for backlight, I never could have this work, also got heating problem and when boots apple logo dissapears from like 5 seconds and then appear the login window... Any ideas on any of this????  


×