Jump to content

Marvell Yukon 8001 - the driver


m.musashi
 Share

409 posts in this topic

Recommended Posts

I have P5Q-E board with Marvell 88E8056 and 88E8001. Using Snow Leopard Retail. First NIC work with IONetworkingFamily.kext, but 80001 does not work. So, wil this kext help? Can I put it in Extra/Extenssions to be loaded by chameleon, or i have to go to S/L/E ?

 

Thanks.

Link to comment
Share on other sites

Yes. I have a P5Q Deluxe myself and it has the same Ethernet chips as yours.

I use skge in /S/L/E and it does the trick.

 

* It may work on /Extra/Extensions, but for now I can only make it work by ignoring boot caches(-f), or coping IONetworkingFamily.kext to /E/E.

Link to comment
Share on other sites

Thanks, I tried and it works well.

 

First I tried in /Extra/Extensions, but wont work. Second I tried copying it in S/L/E via Finder, and still nothing. Then I used Kexthelper B7, and it worked.

 

I duno how it wont work via Finder, because kexthelper does the same thing :( . But most important thing is that I do not have to buy PCI LAN card now :D .

Link to comment
Share on other sites

  • 2 weeks later...

I have an 88E8001 and installed the new skge.kext in Snow Leopard, but I'm getting a self-assigned ip problem. There are no error messages, just the normal boot messages. I have no problems in 10.5.x. Any ideas?

 

Edit (Solved): I downloaded 10.6.2 update from my working Leopard installation, updated snow kitty, and ethernet worked after the first reboot.

Link to comment
Share on other sites

Awesome!

Thanks a lot!

 

I built my SL HackMac based on the GA EX-58 UD5 and that board is using a Realtek 8111.

There is currently no way to get that to work properly in 64bit mode so I jumped for joy as I just stumbled over this post. I immediately purchased the DLink 530T and will try to get everything to work as soon as it arrives (hopefully in two days from now).

I will update this post then.

 

Again, thanks for your effort and time spent!

Link to comment
Share on other sites

Hi there!

 

Thanks again for providing the 64bit kext. I got myself a DLink 530T and I can confirm that it works with skge 0.2f in 64 bit. I have a GA EX-58 UD5 with RTL 8111 onboard and this thread - or the availability of a 64bit driver for the Marvel chip - made me get this extra PCI add-card to finally get my 64bit kernel running.

Unfortunately I had to switch back to the RTL and 32 bit kernel again because unfortunately the performance of the skge kext is absolutely unaccetable. Instead of nearly 900mbps (on the GigE link) I get with my RTL I only get about *FIVE* mbps with the skge.

 

Is anyone else experiencing this problem? Or even better: would anyone have a solution for this?

 

Best regards,

 

Marcus

Link to comment
Share on other sites

  • 1 month later...

@blase

 

I have the same motherboard, and mine would kernel panic when I updated to 10.5.6 and had the skge.kext loaded. It would give me a panic report of a conflict with IONetworkingfamily.kext, etc..

 

After about a weeks worth of troubleshooting, I solved the problem by removing the dsdt.aml I had generated and installed pre-update, and replacing AppleHPET.kext with the 10.5.5 version. (This was solved by accident, as I was replacing the HPET to fix my firewire.)

 

Hope this saves someone some headaches!

 

I have Mac OS 10.5.7 and 0.2e gives me kernel panic, while 0.2f lets me boot but no ethernet is seen by the OS. I'd like to try your AppleHPET.kext (10.5.5 version), maybe this could help :D

Could you please attach it here?

Thanks,

Kar.ma

 

 

Notebook: ASUS A6VA-Q036H

CPU: Intel Centrino Pentium M 750 (1.8GHz)

Chipset: Mobile Intel 915PM Express

Link to comment
Share on other sites

  • 2 weeks later...

I'm runing SL on Asus P5B Deluxe mobo with two lan ports. The funny thing is that the first GGbit controller is Marvell 8056 and the second is 8001 which is running flawlessly with 0.2f version of the driver. Too bad I found that i have two different cards after a week full of KP and reinstalls. GL guys and keep up the good work!

 

 

 

P.S Yeah I know about my english...

Link to comment
Share on other sites

  • 2 months later...
  • 2 weeks later...
  • 4 weeks later...
  • 3 weeks later...
  • 1 month later...
  • 3 months later...
  • 7 months later...

ASUS P4P800 (Marvell Yukon 80E8001)

+iDeneb 10.5.6

+skge 0.2f - installed in S/L/E

 

I get "cannot resolve dependencies for kernel extension /System/Library/Extensions/skge.kext" in the system logs. This results in card not being detected.

 

I noticed a few posts with similar results. Anyone knows what this "dependency" is?

 

EDIT:

My fix was to use skge 0.2(e) with Seatbelt.kext downgraded to version 10.5.5.

Edited by T0Pspeed
Link to comment
Share on other sites

  • 3 months later...

The attached skge.kext works for me on 10.7 in arch=i386 installed in /S/L/E.

skge.kext_02g_release.zip = Release build 10.6 & 10.7, arch = i386 & x86_64.

skge.kext_02g_debug.zip = Debug build 10.6 & 10.7, arch = i386 & x86_64.

The instructions are the same as the first post for installation.

 

 

I expect it to work for 10.6 and 10.7 both i386 and x86_64.

10.5 will NOT work.

 

Alterations to allow loading with 10.7 (assuming 10.6 also). I added the ID for the Belkin 5005 card I have.

I altered the source to remove the gotos and compiled it with Xcode 4.1 against the 10.6 SDK.

 

Changes to the Info.plist to allow loading on 10.7 otherwise I got:

11/08/11 2:27:31.000 AM kernel: kxld[com.musashi.skge]: ___stack_chk_fail

11/08/11 2:27:31.000 AM kernel: kxld[com.musashi.skge]: ___stack_chk_guard

 

The main alterations are com.apple.kpi.*

 

<key>OSBundleLibraries</key>

<dict>

<key>com.apple.iokit.IONetworkingFamily</key>

<string>1.0.0b1</string>

<key>com.apple.iokit.IOPCIFamily</key>

<string>1.0.0b1</string>

<key>com.apple.kpi.bsd</key>

<string>8.0.0b1</string>

<key>com.apple.kpi.iokit</key>

<string>8.0.0b1</string>

<key>com.apple.kpi.libkern</key>

<string>8.0.0b1</string>

</dict>

skge_02g_source.zip

skge.kext_02g_release.zip

skge.kext_02g_debug.zip

Link to comment
Share on other sites

I have problems with the onboard network card on my hackintosh

I used kalyway 10.5.2 installation cd to install it on my extended partition. my nic is a marvel yukon 8001 on a i848 gigabyte motherboard.

my mac os x doesn't recognize the NIC. If I go to System Preference -> Network it sees only two serial built in ports and none ethernet port.

I tried to install the skge.kext_02g package but it still doesn't work. when I reboot it says something that it can't load that extension.

I will come back with the exact message from the dmesg.

any ieas what can i do?

 

if I will install a second PCI NIC do you think that this will solve the problem and the os x will see the NIC?

10x

Link to comment
Share on other sites

on dmesg I received the following message:

.....

skgeosx is not compatible with its superclass 20IOEthernethController superclass changed?

Failed to load extension com.musashi.skge

couldn't alloc.class "skgeosx"

......

 

 

I've tryed to install a tp-link nic on a pci slot still doesn't detect any ethernet port....

Link to comment
Share on other sites

Partially solved

 

I installed the Marvell.Gigabit.pkg

 

http://forum.insanelymac.com/index.php?act...ost&id=9959

 

open Terminal

sudo /usr/bin/installer -pgk 'your pakage path'/Marvell.Gigabit.pkg -target /

 

and after a few seconds it detected my yukon 88e8001 onboard NIC

and I was able to conect to internet

 

I said partially because of that

my ISP uses dhcp. I first configured my ethernet port to use dhcp , but after reboot, I wasn't able to conect

the ethernet port was still there but under it wrote "no ip address"

I enter manually the ip, dns, gateway and now I was able to conect

I don't know if this configuration will work next time I reboot (and after my ISP change my IP I will have to change it)

 

Does anyone know why is that happening ?

Link to comment
Share on other sites

  • Allan unpinned this topic
 Share

×
×
  • Create New...