Jump to content

scorpio rising

Members
  • Content count

    31
  • Joined

  • Last visited

About scorpio rising

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
    Male
  • Location
    Nice (France)
  1. Snow on Asus P5B Deluxe.

    I'm having a problem now with my new Snow installation. Could you remind me if i've done all the things to do ? 1- Booting with last Empire EFI CD. 2- Formating my disk with 1 GUI partition called "HD" in my case. 3- Installation of Snow Leopard Retail CD 10.6.3 4- Rebooting with Empire CD boot. 5- Some Apple updates, then rebooting with Empire CD again. 6- Installation of NVInject last version, then Logitech Control Center for my Mouse & Keyboard. 7- Reboot 8- Installation of Chameleon latest V2 RC-R684 boot to an EFI/GUI: a/ in Terminal : "diskutil list" to find out where my EFI partition is. In my case : /dev/disk1 #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *82.0 GB disk1 1: EFI 209.7 MB disk1s1 2: Apple_HFS HD 81.6 GB disk1s2 b/ Using manual method installation: - newfs_hfs -v EFI /dev/disk1s1 - mkdir /Volumes/EFI mount_hfs /dev/disk1s1 /Volumes/EFI - Install boot0 to the MBR: ./fdisk -f boot0 -u -y /dev/rdisk1 - Install boot1h to the bootsector of the EFI partition: dd if=boot1h of=/dev/rdisk1s1 Then, copy the file "boot" to it: cp boot /Volumes/EFI - In order to prevent the File System Events Daemon (fseventsd) from logging on the EFI partition, which can cause it to become unmountable, i typed: touch /Volumes/EFI/.fseventsd/no_log - then: 1) ./fdisk -e /dev/rdisk0 (Ignore any “fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory” error) 2) f 1 3) w 4) q c/ Copying the extra, themes, extensions folders, Extensions.mkext, my DSDT.aml, and my com.apple.Boot.plist into EFI Volume d/ Un-mount and delete the mountpoint: umount /Volumes/EFI rm -rf /Volumes/EFI 9- Reboot and.......Kernel problem (see Kernel Log attached). I think it's because of my Logitech USB harware. How to fix it ? I tried to put IOUSBFamily.kext in Exra folder but then i have Kernel panic with a message like: "SYSYTEM UPTIME IN NANOSECONDS : 54645343548" Thx !!! Kernel_Log.zip
  2. Snow on Asus P5B Deluxe.

    Hi Beer' I've attached ACPIs tables and LSPCI's logs for you. I don't know why my 88E8001 didn't work but now it's clean and it works fine ! For my video card, i use NVInject 0.2.1 kext in S/L/E. I have dual screen and it seems working fine, but i don't know if i have "acceleration", and i don't even know too if it will be probably "better" with NVEnabler.kext. I hope you will help me to understand what is APIC, HPET, OEMB...tables, and how to inject in DSDT.aml LAN and onboard Sound device codes. Just for a remind: I get my DSDT.aml with errors corrected onto windows, then i go onto OS-X, and here, i inject ACPI tables fixes, LAN and soundboard codes (with DSDTSE)....? Am i right ? I'm gonna check Masterchiefs thread deeply ! ACPI_tables.zip Lspci_logs.zip
  3. Snow on Asus P5B Deluxe.

    Hello Beer' There are a lot of very interesting things in your reply, i read it carefully and i will probably ask you later some questions about my Video card. For the moment and thanks to your advise, i stopped to the DSDTSE "problem". I extracted my DSDT.dsl file on windows XP and i repaired warnings with help of "DSDT Fixes" box. I have now no error, and i'd like to inject some DSDT Hacks for my CPU....but my hardware is not listed (Video card, Lan Ethernet....etc). I've made the same thing onto Snow OS-X and i have the same DSDT, so i've created my DSDT.aml with fixes and Hacks, and i'm gonna post it to you with my Everest's report too. For my LAN, i've put skge.kext into S/L/E but it doesn't work, and in my DSDT.aml file, i can't find any suggestion about 88E8056 and 88E8001 code. I don't know what does it mean : "I have the 88E8056 set as EN0 (primary LAN) in OS X)". How can you set that in OS X ? Then when you have a valide DSTD.aml, wich ,kext in /E can you remove ? Thx for your kindness and helpful attention ? Report_ACPI.htm DSDT_Files.zip
  4. Plein de questions

    Salut Eagle, merci pour ton petit post aux airs enthousiastes ! Alors au niveau de l'installation, j'ai moi aussi acheté la dernière version de Snow (10.6.3 !!!!) Je suis passé par la dernière version de l'installeur de Empire EFI vs 1.085 avec des .kexts sélectionnés en fonction de ma config. J'ai juste un petit soucis avec un de mes ports LAN (le 88E8001 pour être précis), mon port firewire, ma carte son onboard Soundmax AD1988B et mon disque dur externe eSATA. A part ça, le tout reste pour le moment assez stable, mais je pense, il me semble, qu'avec un DSDT bien configuré, mon hackintosh aura la gueule d'un vrai mac, solide et robuste face aux updates qui font parfois tourner la tête de certains de la communauté. Alors j'ai effectivement lu l'amas de tutos concernant le DSDT, de Darwin au pape Benoit XVI, mais comme tu dois le savoir mieux que moi,il y a pas mal de manières de patcher ce fichier. Alors ce n'est pas que l'anglais soit un frein à la compréhension, of course not, but disons voir que c'est avant tout the fact i'm a little noob on that world, and i'm a little bit scared de faire de grosses bétises, ce qui me pousse à prendre certaines précautions informatives....et pourtant, c'est en se trompant que l'on apprend ! J'ai déjà réinstallé pas mal de fois ce fichu Léopard des neiges, et franchement c'est vrai que j'ai découvert et compris des choses intéressantes, mais DSTD.aml reste assez loin de ce passé "simple" que j'ai réussi à apprivoiser. La on parle de0000x0, avec des "[" et des "{"...bref j'y compris quedalle voyez-vous ! Alors j'ai fouillé et puis, sans conviction, je suis tombé sur le ACPI Patcher 0.2 beta 5 (Windaube). Il me semble que c'est une approche efficace et pas trop compliquée du DSDT. Bref, j'ai téléchargé mon bios.rom, et j'ai voulu me lancer dans la création du fichier graal, mais il y a des options surréalistes qui m'empêchent d'entrevoir le saint trésor. C'est quoi ces cases à cocher ? HPET, Aliases Patch, RTC Patch ? Et puis en ce qui concerne les options Network, la je nage avec passion, pareil pour le Hardware location de la carte video, et puis ce PEGP, franchement, ca ne me parle pas du tout, tout comme le "Use DSDT GFX", et puis le "Use HDEF Audio" il faut dire que ce n'est pas encore mon copain. Mais si ce n'était que cela.....! Je ne sais même pas si mon boot est un boot Chaméléon, et je ne sais même pas comment faire pour en connaître la version. D'ailleurs ca va changer quoi que je me tape la vs 1.21354645343435 au lieu de la 1.22313546876 ??? Y'a tant de trucs qui changent d'une version à l'autre ? Tout ceci pourrait rendre un fou...fou....et c'est bien celà qui me plait !!!! Ah oui sinon ce que je voulais savoir, parce que je lis des tas de trucs sur "com.apple.Boot.plist", c'est est-ce que ce fichier sert à quoi quelque chose et si non, pourquoi et quand....? Ouais bon, y'a des gens qui mettent des lignes en plus dans ce fichier...ca sert à quoi ? Et puis aussi, comment on sait si on est en 32 ou en 64 bits ? Et quelle heure fera t il demain ? Bon, merci en tout cas de t'être deplacé
  5. Snow on Asus P5B Deluxe.

    Hi Beerkex'd. Thx for your reply. I have to tell you i'm a noob. I read lot of threads about DSDTs, but i can't find a real simply tutorial for understanding and editing a personnal DSDT file. I think "ACPI Patcher 0.2 beta 5" is a good soft cause i can use my latest bios.rom in order to extract all my mobo's informations. Do i made a good choice with that one ? But there are some kind of things to check on the soft i don't really undestand. Maybe you know this soft, even if you don't maybe you could help me. I want to use it in order to get a DSDT.aml file, but i have some options and i don't know what to do whith them: General tab: do i have to check HPET Patch, Aliases Patch, RTC Patch ????? Network tab: Hardware location is PCI, PEX, POP, and i can choose 0 to 9, so wich one is correct (and why ) ? i can choose between LAN0 and GIGE, Wich one (and why ) do i have to check "Use time machine fix" ? Graphics tab: My model is a GeForce 7300 GT (Silent) with 256 MB, so i selected those options, but what about nVCAP, cause i have my first screen on VGA, my second screen on DVI, then i have TV-out too, and there are no option like VGA + DVI + HC1 or 2...., so can you confirm i have to select "DVI+VGA" ? Should i check "Use DSDT GFX" ? My video card is a PCI-X one. So wich hardware location should i select ? I have choice between PCI, PEX, POP... from 0 to 9, with PEGP check box...??? Audio tab: My onboard audio is not listed here, so it will be probably unselect. Do i have to check "Use HDEF Audio" ? Thx
  6. Plein de questions

    Allez un petit UP pour un grand newbie !!!!! :sorcerer: :construction:
  7. Plein de questions

    Bonjour à tous. Je viens de réaliser une installation de Snow via le boot Empire EFI 1.085 (dernière version) sur une double partition IDE (une pour le boot, une pour le système). J'ai mis à jour quelques .kext dans mon répertoire /Extra, "repacké" mon fichier Extensions.mkext....et je me suis arrêté là car c'est tout ce que je sais faire pour le moment. J'ai pu néanmoins activer ma carte vidéo ainsi que le double affichage. J'ai également pu installer ma carte son PCI M-Audio 24/96 et mon clavier et ma souris USB Logitech avec le Logitech Control Center téléchargé sur le site officiel. Cependant, il me reste quelques problèmes à régler: - Pas d'USB en face avant de ma tour. - Disque dur Externe eSATA non détecté. - Disque dur interne SATA non détecté. - Carte son SoundMAX ADI AD1988A non détectée. - Port Firewire invisble et/ou non détecté. - DVD-ROM non détecté, mais peut s'ouvrir et se refermer via le bouton d'éject. - Absence du petit icone pour éjecter le CD en haut, dans la barre, à côté de l'heure. Par ailleurs, lorsque je vais dans "A propos de ce Mac" je remarque que: - Un de mes port Ethernet (88E8001) n'est pas détecté et après vérification, il ne fonctionne pas. - Certaines informations sont erronées (nom de la carte vidéo, nom du constructeur des barrettes de RAM etc etc.....) Alors j'ai lu les petits tutos intéressants sur le site Darwinx86, mais je vous avouerez que j'ai tout de même du mal à comprendre certaines choses et je me pose quelques questions. - Dois-je créer un fichier DSDT.aml, et si oui, je n'arrive pas à trouver un tuto pour les newbies. - Qu'en est il du fichier SMBios.kext. J'ai un petit peu customisé un SMBIOSReselver.kext que j'ai mis dans mon répertoire /Extra, mais il ne semble pas trop régler les problèmes d'informations dans "A propos de ce mac". - J'aimerais bien également un tuto pour newbies concernant les GFX-Strings. - Dois-je créer un nouveau fichier Kernel ? - Comment connaitre la version de mon boot ? J'ai installé le boot qu'il avait dans le CD d'Empire EFI, mais je ne crois pas que ce soit la dernière version Chaméléon, et je souhaiterais évidemment la mettre à jour, le cas échéant. - Je ne sais pas si mon fichier com.apple.Boot.plist dans /Extra est à jour.... - En mode Verbose, je peux voir cette ligne: "please correct the following to launchd: etc/mach_init.d/dashboardadvisoryd.plist". Comment corriger l'erreur ? - Pas d'image quand je les ouvre avec "Aperçu". J'ai le programme qui s'ouvre et puis j'ai un fond gris. Bon je vais m'arrêter là pour le moment Je vous met la liste des .kext (/Extra). A part les packages de mon clavier/souris et de ma carte son qui installent automatiquement des .kext dans /S/B/E, ce dernier répertoire n'a pas été modifié et il n'y a aucune erreur de permission. Mon système est assez stable pour le moment. - AHCPIPortInjector.kext - fakesmc.kext - JMicronATA.kext - LegacyAppleYukon2.kext - NullCPUPowerManagement.kext - OpenHaltRestart.kext - PlatformUUID.kext - SMBIOSResolver.kext Merci pour votre aide !
  8. USB PORTS NOT WORKING AFTER UPDATE

    Same problem on an Asus P5B Deluxe
  9. Aide débutant: Snow Léopard et ASUS P5B Deluxe

    Merci pour le lien. J'ai installé Snow 10.6.3 avec le CD officiel donc aucune mise à jour de version. J'ai mis à jour les .kext, mais j'ai encore quelques problèmes notamment avec mon disque dur eSATA (en externe donc). J'ai un troisième disque dur SATA interne et celui-ci est reconnu et fonctionne parfaitement, tandis que mon disque externe quant à lui n'est absolument pas reconnu. Par ailleurs, les informations contenues dans "A propos de ce mac" sont erronées au niveau de l'onglet matériel en particulier. Comment ordonner d'autres informations à ce niveau (vitesse du bus, identifiant du modèle, nom du modèle.....), et comment connaître les réelles informations de mon matériel ? Merci.
  10. Snow on Asus P5B Deluxe.

    Fantastic. That's a great clear explanation !!!! I've got some good news. - 88E8056 is working at 100MBps but not at 1Gbps ! - JMicron information ("about this mac" -> "Material" -> "ATA Series") is now working with AHCIPortInjector.kext (in /E/E folder) Still have trouble with: - 80E8001 Lan adaptor - eSATA disk (i'have no information about it on my motherboard's guide) - Sound card integrated on motherboard: SoundMAX ADI AD1988A - Firewire adaptator - No eject icon and no information about my DVD drive ! I'd like to know how can i see if i'm in 32 or 64 bits mode, and how can i switch between boths ? When i'm in verbose mode at start, i can see this line: "please connect the following to launchd: etc/mach_init.d/dashboardadvisoryd.plist" How can i fix it ? Maybe i have some things to do with my Bios options...??? Thx.
  11. Snow on Asus P5B Deluxe.

    Great, that's what i've done with The Extensions's Folder in order to get a new .mkext. Some things to say. I made a new installation because Snow was crazy slow, with 2 partitions. One for the Mac called HD, another one for the boot, with those folders and files: -boot -/Extra -/Library -pfix -pfix.log -/System -/usr I'v installed this boot partition with the latest Empire EFI 1.085 version On the /extra folder i have a repack Extensions.mkext with those /Extra/Extensions files -fakesmc.kext -LegacyAppleYukon2.kext -NullCPUPowerManagement.kext -OpenHaltRestart.kext -PlatformUUID.kext First thing to say is that Snow reboot quickly, no more freezing, but still have a problem with my 88E8056 LAN. I use 88E8001 and it works fine. Now i have a second problem. I haven't the eject icon of my SATA DVD-Drive at the top of my screen (near the time icon), and it's impossible to open the drive when i press on the eject button. My eSATA disk is still not recognize, i will see that in my motherboard's guide if i (we) can get an issue ! But the most important thing for the moment is, that my Snow doesn't want to boot without Empire EFI boot CD, and i think my Boot partition is not recognize as the first boot drive. I want to active Boot's partition as my first partition... How can i do that ? And can you just explain me that: ""validating" doesn't matter, the Chameleon bootloader doesn't care about permissions on the kernel extensions in your /Extra/Extensions folder or mkext. " Why must we put some .kext in Extra/Extensions folder, and some others in S/L/E folder, and why files in Extra/Extensions are there if bootloader doesn't care about them ? Thx Beerkex'd EDIT: Snow is now booting on boot partition without Empire EFI CD. I've put JMicronATA.kext in /Extra/Extensions folder and of course, repacked my Extensions.mkext. Internet LAN connection is a little bit crazy. Now my 88E8001 is not working, but my 80E8056 is ok. Incredible !!! Still have problem with eSATA. in "about this mac" windows: - "PCI Cards", i have ethernet----Ethernet controller-----No-----PCI----Slot-2 (it's my 88E8001 lan connection) - "Firewire", i haven't got my firewire slot detected - "Disc burner", i have no DVD detected See ya !
  12. Snow on Asus P5B Deluxe.

    I'm gonna check later for the eSATA controller I/O, 'cause i have "bad" news. I have problems with .kext and .mkext files, i don't know if i can manage with those files........and i've lost my internet connection. First, You told me to do this with Extensions.mkext: "Drag and drop it onto kext utility's main icon to unpack and repack it." So, when i drag .mkext on Kext utility's icon, it creates a folder calls "Extensions.mkext_content". In this folder i have 4 or 5 .kext files. I don't need some of them cause it's like NullCPU*****.kext etc... Do i have to replace files in this folder with files on my Extra/Extensions files, and then, drag this folder on kext utility's icon in order to have a new Extensions.mkext ? Secondly, you say that: "Put back an unmodified IONetworkingFamily in S/L/E and use the attached kext in /Extra/Extensions.mkext or /Extra/Extensions for your 88E8056 LAN. This will fix your permission issues. LegacyAppleYukon2.kext.zip ( 2K ) Number of downloads: 1" So you gave me original IONetworkingFamily.kext, i've replaced file in S/L/E, that's ok. What's the procedure with the attached .kext ? Do i simply have to put it in the Extra/Extensions folder without "validate" it with Kext utility tool or do i have to unpack .mkext, then put attached .kext in the folder, and then repack .mket and replace in /Extra......or do i have to do those 2 manipulations ! I'm sorry but i understand some things, and some others are a little bit more difficult to acquire. Thirdly: After booting, when desktop appears, snow is F G slow. I have to wait 5 minutes in order to move docs and open applications !!!! Fourthly: Last week, i have done my first install with Snow, i had some others problems 'cause it was a bad installation, but all my HDs were recognized and i don't remember how i got this ! Sorry for my english, and really thx for your help and your patience.
  13. Snow on Asus P5B Deluxe.

    It's an external Sata disk I'm gonna reboot with Snow retail CD and repair disk permissions and post the result in a few minutes. Thank for the kext and for your help !
  14. Snow on Asus P5B Deluxe.

    After rebooting there are some bad things. First, at start, snow is very slow. When desktop appears, it freezes for 4/5 minutes, then it works fine. I have repaired permissions, but still have this problem constantly. I repair, then, again, same problem. Here is my console disk utility log: 2010-05-11 00:18:22 +0200: Réparation des permissions pour « Macintosh HD » 2010-05-11 00:19:45 +0200: Les autorisations sont différentes sur « System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext/Contents/CodeDirectory », elles devraient être lrwxr-xr-x au lieu de -rwxr-xr-x . 2010-05-11 00:19:45 +0200: « System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext/Contents/CodeDirectory » réparé. 2010-05-11 00:19:45 +0200: Les autorisations sont différentes sur « System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext/Contents/CodeRequirements », elles devraient être lrwxr-xr-x au lieu de -rwxr-xr-x . 2010-05-11 00:19:45 +0200: « System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext/Contents/CodeRequirements » réparé. 2010-05-11 00:19:45 +0200: Les autorisations sont différentes sur « System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext/Contents/CodeResources », elles devraient être lrwxr-xr-x au lieu de -rwxr-xr-x . 2010-05-11 00:19:45 +0200: « System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext/Contents/CodeResources » réparé. 2010-05-11 00:19:45 +0200: Les autorisations sont différentes sur « System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext/Contents/CodeSignature », elles devraient être lrwxr-xr-x au lieu de -rwxr-xr-x . 2010-05-11 00:19:45 +0200: « System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext/Contents/CodeSignature » réparé. 2010-05-11 00:20:00 +0200: 2010-05-11 00:20:00 +0200: Réparation des permissions terminée I checked my IONetworkingFamily.kext version in S/L/E . It's 1.9. Where can i find original version for snow 10.6.3 ?
  15. Snow on Asus P5B Deluxe.

    Hello Beerkex'd Thx for your help !!!! I've delete NullCPUPowerManagement.kext & FrameBufferDisabler.kext. Where can i find IONetworkingFamily.kext non modified for Snow 10.6.3 ??? I don't know how can i modify Extensions.mkext, but maybe it's the same thing if i put your attached LegacyAppleYukon2.kext.zip in Extra/Extensions. I have big problem with external Sata disk. This one is not recognize or bad recognize. It's an NTFS disk. I have another internal Sata NTFS disk. This one works fine. I can download files on my OS X Desktop, but when i try to do this with my external sata drive, OS X unmount it automatically...... Well, i'm gonna check utility disk in order to repair permissions now...and i'll post here for the next (last) step. Thx
×