Jump to content

[Compilation] Dell XPS M1330, M1530, Vostro 1400, 1700, Inspiron 1420, 1520, 1720

* * * * * 1 votes

  • Please log in to reply
4332 replies to this topic

#721
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,615 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
Did you install with Kext Helper?

#722
justin2net

justin2net

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
tried both ways macgirl. I really appreciate your help.

funny thing is, it used to work (as i said, it worked after i used kexthelper, then it would not work after next startup, and over and over again).

then for some reason while i was trying to fix that, now it doesnt give sound at all! i think the permissions are screwed up?

#723
kristoff

kristoff

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
By the way, thanks to Superhai for modding the usb kext so we have sleep! I was close to selling my vostro and getting a used macbook pro, but with sleep working, it feels more like a real mac!



;)

#724
Superhai

Superhai

    InsanelyMac Legend

  • Retired Developers
  • 1,425 posts

3. desktopMode
It says that this code is sent from graphics, and I think that is what is blocking for clamshell sleep. Any other ideas? Or someone here good at kernel programming that can make a kext doing that? I will try it, but any help is appreciated. :P


I was able to make a kext that changes that value, and now it is able to sleep when I close the lid. The problem is now that after coming up from sleep the display driver resets this value. So I need to make a logic that sets it after coming from sleep as well.

Update, now I have added wakeup from sleep capability to my kext and I think it is ready for a beta ride. But remember this is only if you have working sleep but not able to sleep from lid close. It will not work if AC or External Display is connected, as that is per design from Apple. If you want to remove it you can use sudo rm -R /System/Library/Extensions/TurnLidOn.kext and then sudo touch /System/Library/Extensions and a reboot after that.

Attached Files



#725
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts
Hi,
I tried your kext on an Inspiron 9400. sleep comes with lid closing, but unfortunately, i get KP or system freeze after wake up.
System log mention:
19:40:23 roros-mac-pro kernel[0]: TurnLidOn: We are still awake


#726
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,615 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
Superhai, the kext is working but sometimes at fresh reboot Lappy does not go to sleep.

So I check on Terminal:
ioreg -n IOPMrootDomain | grep AppleClamshellCausesSleep
| | | "AppleClamshellCausesSleep" = No

But after unloading the kext:
ioreg -n IOPMrootDomain | grep AppleClamshellCausesSleep
| | | "AppleClamshellCausesSleep" = Yes

Then I load the kext and stays on "Yes".

Another way to make it change is to manually set it to sleep, so after wake the kext sets AppleClamshellCausesSleep to Yes.

Thank You

Hi,
I tried your kext on an Inspiron 9400. sleep comes with lid closing, but unfortunately, i get KP or system freeze after wake up.

sonotone, did you try my script, does it makes a KP also?

#727
Superhai

Superhai

    InsanelyMac Legend

  • Retired Developers
  • 1,425 posts

Superhai, the kext is working but sometimes at fresh reboot Lappy does not go to sleep.


Ok, it is made so it sets the value when it starts, 10 seconds after and 30 seconds after the kext is loaded or coming back from sleep. I will add a point 60 seconds after and you can see if it stays. (how long is your boot time on your laptop?)

#728
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,615 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
Let me measure it, last time I did was 25-35 seconds.

BRB

EDIT:
First measure 33 seconds. (all menus loaded an ready to click on any app or menu).

#729
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts

sonotone, did you try my script, does it makes a KP also?

Yes i tried, and it's not causing KP. But your command:

/path_to/sleep.sh&

does not work, that what i get:
2] 1655
[1]   Exit 127				/veille/slepp.sh
roros-mac-pro:~ roro$ /veille/sleep.sh: line 3: state=: command not found
/veille/sleep.sh: line 4: if: command not found
/veille/sleep.sh: line 5: then: command not found
/veille/sleep.sh: line 6: #echo: command not found
/veille/sleep.sh: line 7: #/usr/bin/osascript: No such file or directory
/veille/sleep.sh: line 8: /usr/bin/pmset: No such file or directory
/veille/sleep.sh: line 9: fi: command not found
/veille/sleep.sh: line 10: sleep: command not found
The script is defenetly working, i tested it directly on terminal.
EDIT: sorry, i forget to remove "&" after .sh
There is a way to get it works with boot?

#730
Superhai

Superhai

    InsanelyMac Legend

  • Retired Developers
  • 1,425 posts
Can you paste in the kernel panic?

Here is another version which should also activate it after 60 seconds, but it really shouldn't make any difference. And it seem like the powermanagment system is not updating if you are on ac power or not so it is able to sleep also when ac power is connected.

Attached Files



#731
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,615 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
Worked !

Thanks again.

Only 2 more things to remove the pain in the ass (Onboard Ethernet and Restart/Shutdown) :rolleyes:

#732
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts
It's seems to work properly with 0.9.1.
Just one KP after installing, but i reboot twice and after few tests, no problems at all.
Thanks for your job, i will post logs if there is a problem.

#733
GimmeRed

GimmeRed

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 287 posts
Thanks Syperhai 0.9.0 seems to be working fine so far on my inspiron 1720. Sleep has been working fine for me for the most part with the only problem being is that sometimes I can't get the bluetooth to restart after sleep.

It now sleeps when I close the lid and restarts when I open it.



Edited to add: I've got the blutooth working a little better after wake by opening the advanced tab in the bluetooth preference and selecting open the bluetooh setup assistant at startup when no device is present. I also set my wireless switch in my bios to turn control my bluetooth only. If it doesn't wake I can just turn it off and back on and it will normally connect.

#734
parpwhick

parpwhick

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
You guys got a working sleep with the sleep-kernel, not the speedstep one, right?

Macgirl, i found this link that might have helped you with the lid-sleep interaction problem (sorry i'm so late about it!): http://www.semaja2.net/insomniaxinfo

#735
yeye

yeye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 292 posts
Firstly, Thank you so much macgirl and superhai!

Secondly, I've successed to update in 10.5.2 but I can't have audio. I've tried to reinstall txt with apple HDA patcher but it doesn't work! How should I do?

edit: forget it, that works perfectly!! All update up to date! (Excuse me for my english!)

Everything is perfect

I hope intel drivers will be released soon and I hope that you will find a solution to get reboot/shutdown working! Anyway, THANK YOU ALL ESPECIALLY MAC GIRL!!

Do you know what's exactly the problem with shutdown/reboot or you don't have any idea (excepting that you know it came after graphic kext install)?

By the way, do you know if it's possible to remove .mac icon on the top because I don't see any option speaking about that so I think that specialists like you may know :( (edit: I've found: You press CTRL or ALT and click on the icon and put it in the trash...!)

#736
Van Wildonher

Van Wildonher

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
How long would it take a noob to get a 90% working install on a M1330? I say 90% because I see there is still no working wireless support for the onboard agn card? Also nothing for the ethernet?

I'm getting iATKOS ver. 1.0ir2.

Thanks for any help, I'm sure I'll be needing it!

#737
realityloop

realityloop

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Gender:Male
  • Location:Australia

How long would it take a noob to get a 90% working install on a M1330? I say 90% because I see there is still no working wireless support for the onboard agn card? Also nothing for the ethernet?

I'm getting iATKOS ver. 1.0ir2.

Thanks for any help, I'm sure I'll be needing it!


I'm probably about to give this a go on my M1330 as well! and likewise any help would be very much appreciated.

#738
yeye

yeye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 292 posts
I'd like to report something about sleeping.
Have you noticed that after waking up, battery life seems to be very longer?
For me, having put my laptop to sleep all the night, this morning, when I waked up it, battery life said 4h and after half an hour of use, it keeps saying 3h20

Now, I've rebooted and it says 1h40!

So I'd like to know if I'm the only to notice that and it could be a good news for our battery life if that's true!

#739
Superhai

Superhai

    InsanelyMac Legend

  • Retired Developers
  • 1,425 posts

For me, having put my laptop to sleep all the night, this morning, when I waked up it, battery life said 4h and after half an hour of use, it keeps saying 3h20
Now, I've rebooted and it says 1h40!
So I'd like to know if I'm the only to notice that and it could be a good news for our battery life if that's true!


I think it is because of the calculation. I don't think you will see improved battery life after sleep (unless the CPU wakes up in low power mode with reduced speed).

#740
yeye

yeye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 292 posts

I think it is because of the calculation. I don't think you will see improved battery life after sleep (unless the CPU wakes up in low power mode with reduced speed).

You may be right, I've done another sleep test after reboot and now it says 2h40 instead of 4h. But when it says 4h, I've noticed that % were decreasing more slowly than now but I'm not very sure since it has only happened one time.
I'll inform you if this happens again

Anyway, good luck for your work with our lappy :lol:





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy