Jump to content

AppleHDA Patcher Results


  • This topic is locked This topic is locked
243 replies to this topic

#21
plas

plas

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
Computer Type: PC
Sound Card Vendor: Analog Devices
Codec: Analog Devices AD1988B
Vendor Id: 0x11d4198b

Working: Nothing
Not Working: Anything

Patcher Version used: 1.1.7 /1.1.9
System Version: 10.5.1

obs: With 1.1.7 two devices appear but no output. With 1.1.9 nothing shows up in the sound preferences.

Dont worry im confused as well. I thought this board was a realtek board but when i did a linux codec dump it reported it was a AD1988B. Im guessing the latest ubuntu detects it incorrectly or doesnt have the drivers for it. I will do some more hunting around and post more info later.

edit again: Sorry looks like i confused myself with another board.

Attached Files

  • Attached File  dump.txt   10.71KB   225 downloads

Edited by plas, 06 December 2007 - 05:07 PM.
Im confused.. Do you have AD1988b from Analog Devices or ALC883 from Realtek ?!


#22
celtikmind

celtikmind

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Location:Wraithspace
Computer Type: PC
Sound Card Vendor: ADI
Sound Card Model: AD1988b
Vendor Id: 0x11d4198b

Working: Nada
Not Working: Everything

Patcher Version used: up and until 1.19
System Version: Leo 10.5.1

Only 1.17 showed two outputs in system preferences panel but no sound.

Attached Files



#23
the.nightfly

the.nightfly

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
Computer Type: PC
Sound Card Vendor: Realtek
Sound Card Model: ALC882D
Vendor Id:i dont know (Abit AB9 Pro integrated)

Working: Line Out (tested)
Not Working: Mic, Headphones (tested)

Patcher Version used: 1.13
System Version: Leopard 5 (ToH RC2)
Code dump: ALC882_0x1043e601 from here http://psykopat.free..._0x1043e601.txt

#24
Fichico

Fichico

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Computer Type: PC (with mobo Asus P5LD2)
Sound Card Vendor: Realtek
Sound Card Model: ALC882
Vendor Id: 0x10ec0882

Working: Line Out, SPDIF Out
Not Working: Mic, Headphones

Patcher Version used: 1.19
System Version: Leopard 5 (ToH RC2)
Codec used: 882.txt

There is a solution for Mic/Line out? i can usa skype ;)

Edited by Fichico, 06 December 2007 - 06:42 PM.
Edit you post to mention your motherboard brand and model


#25
inferno0270

inferno0270

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Computer Type: LAPTOP
Sound Card Vendor: Realtek
Sound Card Model: ALC268
Vendor Id: 0x10ec0268

Working: Built-in speakers
Not Working: Mic, Headphones, linein

Patcher Version used: 1.19
System Version: Tiger 4.11 *edit updated to leopard, still working

Got audio from azalia.pkg in koolkal.

Attached Files



#26
Nuphor

Nuphor

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
Computer Type: PC - Bad Axe2
Sound Card Vendor: SigmaTel
Sound Card Model: STAC9274D
Vendor Id: 0x83847621

Working: None
Not Working: All

Patcher Version used: 1.1.9
System Version: Leopard 10.5.1

obs:

AppleHDA Patcher - 2006/2007 by Taruga v1.19 

Leopard Darwin Kernel Version 9.1.0

* Patching AppleHDA.kext to 0x83847621	 Done
* Checking AppleHDA for patch	 Done
000172aa	cmpl	$0x83847621,%edx
0001886a	cmpl	$0x83847621,%edx
* Checking for SPDIF Out Detected
* Checking for SPDIF In Not Detected
* Using the following nodes in pathmap

Back Mic: 7 27 21 11
Speaker : 13 2
Spdif Out: 33 30

* Copying new config to destination	 Done
* Repairing Permissions	 Done

** Done patching - You can reboot now **

No sound after reboot, no sound devices shown in system preferences. Dump used attached.

Attached Files



#27
ontoid

ontoid

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Location:poland
Computer Type: PC
Sound Card Vendor: Realtek
Sound Card Model: ALC883
Vendor Id: 0x10ec0883

Working: Headphones OUT - front one, Line Out, SPDIF Out, Rear MIC, Rear LineIn
Not Working: Front Mic

Patcher Version used: 1.1.9
System Version: 10.5.1

obs: Front mic was ok under tiger and also with tiger kext on LEO Beta's

#28
jimmy j

jimmy j

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male
Computer Type: PC (Abit AA8XE i925XE)
Sound Card Vendor: Realtek
Sound Card Model: ALC880
Vendor Id: 0x10ec0880

Working: Nothing
Not Working: Everything

Patcher Version used: 1.16-1.19
System Version: Leopard 10.5.0

obs: Using some of the other ALC880 dumps the patcher reports just the audio output detected, but output doesn't work. Using my own attached dump nothing shows up as detected or works either.

Attached File  Abit_AA8XE_alc880.txt   7.35KB   106 downloads

#29
gu3d3s

gu3d3s

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 441 posts
  • Location:Fort-CE-BR
Hi.

Computer Type: PC - Bad Axe2
Sound Card Vendor: SigmaTel
Sound Card Model: STAC9274D
Vendor Id: 0x83847621

Working: None
Not Working: All

Patcher Version used: 1.1.9
System Version: Leopard 10.5.1

obs:

[code=auto:0]AppleHDA Patcher - 2006/2007 by Taruga v1.19

Leopard Darwin Kernel Version 9.1.0



Use taruga patch 1.1.6 this works for me with same Mboard...

[]'s

#30
Nuphor

Nuphor

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

Hi.
Use taruga patch 1.1.6 this works for me with same Mboard...

[]'s


This works but mute doesn't work at all. Still, it's weird that the new Leopard versions of the patcher don't work with this. Anyway, back on topic.

#31
mikemore

mikemore

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 550 posts
Computer Type: Laptop
Sound Card Vendor: Conexant
Sound Card Model: CX20549 (Venice)
Vendor Id: 0x14f15045

Working: Nothing
Not Working: All

Patcher Version used: 1.1.9
System Version: Leopard 10.5

obs: When i put my linux dump on Taruga icon i read that conexant isn't supported..........or anything like this. (i have speaker output whit AzaliaAudio but mic and phonejack don't work)

This my linux dump:

M'n'M

Attached Files



#32
kaze

kaze

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Computer Type: Laptop - Packard bell BU45
Sound Card Vendor: Realtek
Sound Card Model: ALC 660
Vendor Id: 0x10ec0660

Working: None
Not Working: All

Patcher Version used: 1.1.9
System Version: Leopard 10.5.1


AppleHDA Patcher - 2006/2007 by Taruga v1.18

Leopard Darwin Kernel Version 9.1.0

* Patching AppleHDA.kext to 0x10ec0660 Done
* Checking AppleHDA for patch Done
000172a0 cmpl $0x10ec0660,%edx
00018860 cmpl $0x10ec0660,%edx
* Checking for SPDIF Out Not Detected
* Checking for SPDIF In Not Detected
* Using the following nodes in pathmap

Speaker :

* Copying new config to destination Done
* AppleAzalliaAudio detected
* Removed Done
* Repairing Permissions Done

** Done patching - You can reboot now **

#33
Solique

Solique

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Computer Type: PC Abit IP35 Pro
Sound Card Vendor: Realtek
Sound Card Model: ALC888
Vendor Id: 0x10ec0888

Working: Left and right speakers
Not Working: Headphones (though it may not be internally connected - I've not tested it before). 5.1 output via jacks, not SPDIF(according to Audio MIDI Setup)

Other ports not tested due to lack of mic & SPDIF equipment.

Patcher Version used: 1.1.9
System Version: 10.5.1

Shows Internal mic, Line in and Digital in Sound panel Input. Shows Line Out, Headphones, Digital Out in Output.

As an observation, I spend ages launching the app then dragging the dump to the app in the dock. I think it's worth clarifying the main post exactly what to do for dozy clots like me. Maybe in bold. :)

Codec dump from Ubuntu 7.10 live CD attached. (codec not present in Knoppix - old ALSA version?)

Thanks for all the hard work on this Taruga, you're a star - nice turtle too :hysterical:

Attached Files



#34
caracols

caracols

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
Computer Type: PC (Asrock ConRoe 945g-dvi)
Sound Card Vendor: Realtek
Sound Card Model: ALC888 (ICH7)
Vendor Id: 0x10ec0888

Working: Nothing
Not Working: ...

Patcher Version used: 1.20
System Version: Leopard 10.5.1

obs: 1.20 patcher applies correctly, reports several output and input devices which is pretty cool but fails to output any sound from any of those. Tried every ALC888 available codec and got the same result.
Posted Image
Posted Image

Attached Files



#35
Matt Frusciante

Matt Frusciante

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Location:Islas Caimanes
hi taruga wlecome back


omputer Type: PC
Sound Card Vendor: Realtek
Sound Card Model: ALC82 (ICH7)
Vendor Id: dont know

Working: seems like all exept multispeaker
Not Working:

Patcher Version used: 1.17
System Version: Leopard 10.5

#36
cybermiguel

cybermiguel

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:Antofagasta, Chile
Computer Type: PC (Intel D945GCL)
Sound Card Vendor: Sigmatel
Sound Card Model: 9220
Vendor Id: 0x83847680 (revision 1036)
Working: Nothing
Not Working: Mic, Headphones, Line out, Line in
Patcher Version used: 1.16
System Version: Tiger 4.11
obs: The system boots normally and the "Line Out" option shows in the preferences pane, however, I cannot get any sound come from the motherboard, and I cannot record any sound either. I've tried all the connectors and I only get silence.

I have a codec dump and here it is

Computer Type: PCSound Card Vendor: Intel HDASound Card Model: SigmaTel STAC9221 A1 (it is labeled as Sigmatel 9220)
Vendor Id: 0x83847680
Working: Nothing (Internal speakers are recognized in prefs, volume slider works, but no actual sound comes out from the speakers, tried all the jackets)
Not Working: Everything
Patcher Version used: 1.1.8
System Version: Leopard 5.1 (ToH 9.1 kernel).

I just wanto to point out that AppleHDAPatcher has never (ever) worked for me, tried every single version, several different dumps. Not even with Tiger.


I have EXACTLY THE SAME problem. :(

Attached Files


Edited by Taruga, 07 December 2007 - 01:41 PM.
Version 2.00 should fix it


#37
echo

echo

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
Computer Type: PC (Intel 946GZIS)
Sound Card Vendor: Sigmatel
Sound Card Model: STAC9227
Vendor Id: 0x83847618
Subsystem Id: 0x8086a201

Working: Nothing
Not Working: Speakers, Mic, Headphones

Patcher Version used: 1.20
System Version: Leopard 10.5.1

obs: Nothing using the patcher (Screenshots below), No output devices

Posted Image Posted Image

Here's the linux codec dump (with unix line breaks)

Attached Files



#38
编号9527

编号9527

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
three, exactly D945gcl mb

leopard 10.5 patch v1.18

Maybe 9221 is different to 9220/9223, according to this file http://www.sigmatel....9221-pb-0-8.pdf
And I have read and try several Info.plist, they are not a real 9221 driver

only internal mic and speaker item, no sound





Computer Type: PC (Intel D945GCL)
Sound Card Vendor: Sigmatel
Sound Card Model: 9220
Vendor Id: 0x83847680 (revision 1036)
Working: Nothing
Not Working: Mic, Headphones, Line out, Line in
Patcher Version used: 1.16
System Version: Tiger 4.11
obs: The system boots normally and the "Line Out" option shows in the preferences pane, however, I cannot get any sound come from the motherboard, and I cannot record any sound either. I've tried all the connectors and I only get silence.

I have a codec dump and here it is
I have EXACTLY THE SAME problem. :P

Attached Files


Edited by Taruga, 07 December 2007 - 01:42 PM.
Version 2.00 should fix it


#39
sadeesh

sadeesh

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male
  • Location:india
Computer Type: Laptop, Lenovo y400
Sound Card Vendor: Realtek
Sound Card Model: ALC861-VD
Vendor Id: 0x10ec0862

Not Working: No sound on speakers, headphones, except sound icon displayed. Output device listed as HDA, no input devices found


Patcher Version used: 1.19
System Version: Tiger 10.4.9

obs: SPDIF In & Out not detected, hence the speakers.

Output of Patcher:

AppleHDA Patcher - 2006/2007 by Taruga v1.18


* Patching AppleHDA.kext to 0x10ec0862 Done
* Checking AppleHDA for patch Done
000172a0 cmpl $0x10ec0862,%edx
00018860 cmpl $0x10ec0862,%edx
* Checking for SPDIF Out Not Detected
* Checking for SPDIF In Not Detected
* Using the following nodes in pathmap

Speaker :

* Copying new config to destination Done
* AppleAzalliaAudio detected
* Removed Done
* Repairing Permissions Done

** Done patching - You can reboot now **


Help me gettin sound on my speakers ;)
Codec dump is attached:-

Attached Files


Edited by Taruga, 07 December 2007 - 01:43 PM.
Im working on it, just wait. Version 2.00 should fix it


#40
kaze

kaze

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
AppleHDA Patcher 1.20:
Not working with my alc 660 dump
Give a white window with no text output at all.

[codebox]Computer Type: Laptop - Packard bell BU45
Sound Card Vendor: Realtek
Sound Card Model: ALC 660
Vendor Id: 0x10ec0660

Working: None
Not Working: All

Patcher Version used: 1.2.0
System Version: Leopard 10.5.1

[/codebox]

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy