Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Taruga

AppleHDA Patcher Results

244 posts in this topic

Recommended Posts

AD198x users please attach your ioreg ( command: ioreg -lw0 > /ioreg.txt ). Thanx

 

Use a template like this to post here:

 

 

Computer Type: PC (PC or laptop, if PC state motherboard brand and model)

Sound Card Vendor: Realtek

Sound Card Model: ALC882

Vendor Id: 0x10ec0882

 

Working: Line Out, SPDIF Out

Not Working: Mic, Headphones

 

Patcher Version used: 1.1.7

System Version: Tiger 4.11

 

obs: Mic seems to be working, but don´t ear anything. Volume too low ?!

 

Replace the bold fields with your own info, but no need for you to post in bold, ok ? :P

Also, optional... if you have a linux codec dump from your machine attach it with your post. Most important for notebook users

Edited by Taruga

Share this post


Link to post
Share on other sites

Computer Type: Laptop

Sound Card Vendor: AD

Sound Card Model: AD1986a

Vendor Id: 0x11d41986

 

Working: nothing

Not Working: everything else

 

Patcher Version used: 1.18

System Version: Leo 10.5.1

Share this post


Link to post
Share on other sites

Computer Type: PC Desktop (Tower)

 

Soundcard Vendor: Sigmatel

 

Soundcard Model: STAC9271D

 

Vendor Id: 0x83847627

 

Working: Everything is working with sound out

 

Not Working: Can´t test Mic as i have no microphone. I saw signal there. No sliders for Mic.

 

Patcher Version Used: Kext install with the files from here: http://forum.insanelymac.com/index.php?act...st&id=18344

 

and then the kext helper v0.7

 

System Version: JaS 10.4.8 updated to 10.4.10 with Koolkal´s comboupdate. Using the SMBIOS.kext 1.0.1 from Hackint0sh.org team

 

Obs: Internal Speaker should be called Mic. I do of course not know how it should look with all features. Maybe there should also be slider for Mic gain and input?

Share this post


Link to post
Share on other sites

omputer Type: Laptop

Sound Card Vendor: AD

Sound Card Model: AD1986a

Vendor Id: 0x11d41986

 

Working: nothing

Not Working: everything else

 

Patcher Version used: 1.16

System Version: Leo 10.5.1

 

With 1.16 I have only disabled slider for a Vol. Can't move it. still no sound.

Share this post


Link to post
Share on other sites

Computer Type: Laptop

Sound Card Vendor: ALC

Sound Card Model: ALC0861

Vendor Id: 0x10ec0861

 

Working: speakers

Not Working: microphone

 

Patcher Version used: 1.18

System Version: Leo 10.5.1

 

I had to use AppleHDA.kext from alc861testing.zip. Microphone is visible in SND Preferences, but when trying to record (Audacity) silence im speakers.

 

Taruga: Try this ALC861 kext

hda.txt

Edited by Taruga
kext for testing

Share this post


Link to post
Share on other sites

Computer Type: PC,intel pentium d processor 3.4 ghz,d946gzis motherboard,nvidia geforce7100 gra

c card,1gb ram  Sound Card Vendor: sigmatel Sound Card Model: STAC9227Vendor Id: 0x83847618Working:  all detected with patcherPatcher Version used:1.16, 1.17,1.18,System Version: leopard 1.5 cant hear anything after reboot any solutions have codec dump from fedora linuxComputer Type: PC,intel pentium d 3.4 ghz,intel d946gzis motherboard,1gb ram,nvidia geforce 7100 graphic card Sound Card Vendor: sigmatel Sound Card Model: STAC9227Vendor Id: 0x83847618Working: all detected with patcherNot Working: not detected after rebootPatcher Version used:1.16, 1.17,1.18System Version: leopard 1.5cant hear r anything. HELP WANTED

Share this post


Link to post
Share on other sites

Computer Type: PC

Sound Card Vendor: Realtek

Sound Card Model: ALC883

Vendor Id: 0x10ec0883

 

Working: HD Audio Output

If the output device has this name, then you´re using the wrong driver, use AppleHDA Patcher v1.17 and a codec dump for alc883.

Not Working: Everything Else

 

Patcher Version used: 1.18

System Version: Tiger 4.10

 

obs: Only two channel out from speaker port at the back. No headphones, no inputs. I have an MSI 945GM3-F motherboard. Better than nothing, though. 1.18 is the first patcher version to give any sound for the card/motherboard combo.

 

edit: Second Try with Patcher v1.17

Working: None.

 

obs: No inputs/outputs shown at all in Audio Midi Setup. I've seen that many people on this forum are having trouble getting anything more than 2 channel out working with this soundcard/mobo combo. It's ICH7. I've attached the dump I used (which I made myself in ArchLinux) as well as the IOreg dump. I'll also send them to the appropriate email address. Back to v1.18 with the weird output name :/.

 

edit 2: Back to Patcher v1.18

 

Working: None.

 

obs: Suddenly same result as with 1.17. The first time I used it, it probably didn't get rid of Skippy's Azalia kext properly. Got excited for a bit there.

Thanks again, for all your hard work, Taruga. I have a lot of respect for someone that does something of this magnitude for the good of the community!

alc883_msi_945gm3_f.txt

alc883_msi_945GM3_f_ioreg.txt

Edited by Taruga
Seems to be some kind of permissions problem, applehdacontroller is not loaded, and at least that one should be loaded. I sent to your email an installer for you to try

Share this post


Link to post
Share on other sites

Computer Type: Desktop

Sound Card Vendor: AD

Sound Card Model: AD1986a

Vendor Id: 0x11d41986

 

Working: analog 2channel out

Not Working: line in, mic,

 

Patcher Version used: 1.13-1.17

System Version: Tiger 4.11

 

Got volume slider working with azalia.pkg from kalyway 4.10 dvd.

Share this post


Link to post
Share on other sites

Computer Type: PC

Sound Card Vendor: Intel HDA

Sound Card Model: SigmaTel STAC9221 A1 (it is labeled as Sigmatel 9220)

Vendor Id: 0x83847680

 

Working: Nothing (Internal speakers are recognized in prefs, volume slider works, but no actual sound comes out from the speakers, tried all the jackets)

Not Working: Everything

 

Patcher Version used: 1.1.8

System Version: Leopard 5.1 (ToH 9.1 kernel).

 

I just wanto to point out that AppleHDAPatcher has never (ever) worked for me, tried every single version, several different dumps. Not even with Tiger.

Edited by Taruga
I´m trying to fix the mute issue, a lot of people has it. That will make a whole bunch of more codecs to work if I figure it out

Share this post


Link to post
Share on other sites

Computer Type: PC

Sound Card Vendor: Realtek

Sound Card Model: ALC883

Vendor Id: 0x10ec0883

 

Working: None

Not Working: Mic, Headphones, Line Out, Digital Out

 

Patcher Version used: 1.1.8

System Version: Leo 10.5.1 (ToH)

 

obs: Patched with below codec dump, all the options appear in the preference pane and it all looks functional but no sound in or out. I'm using a ECS 945GCT-M V1.0 (Intel 945GC & ICH7)

after using the patcher, make an ioreg dump to take a look

ioreg -lw0 >/alc883-txt

send it to codecs@netcabo.pt

 

Sent the ioreg. (Wed Dec 5 13:43:09 PST 2007)

alc833_ECS_945GCT_M_V1.txt

Edited by Taruga
Strange issue, all loaded, nothing works. For what I see at least headphones should be working. Damn ! These random issues are killing me :P

Share this post


Link to post
Share on other sites

Computer Type: PC (Dell E520)

Sound Card Vendor: Sigmatel

Sound Card Model: 9227

Vendor Id: 0x83847618

 

Working: Nothing

Not Working: Everything

Patcher Version used: 1.18

System Version: Leopard 10.5.1

 

obs: Kext Loads but no input or output device found.

 

Your 1.16 patcher worked nicely in Tiger 10.4.10 :D

The patched kext from Tiger should also work on leo.

 

Thanks Taruga, I tried the Tiger kext again and this time it worked.

My recollection was that booting -v it told me I had the wrong version of iokit or something similiar.

Possibly I had mismatched ALCInject.kext and AppleHDA.kext

Edited by wmarsh
obs

Share this post


Link to post
Share on other sites

Computer Type: PC

Sound Card Vendor: SIGMATEL Sound Card Model: 9247d

Vendor Id: dont know

 

Working: Line Out, SPDIF Out(with glitch in sound)

Not Working: mic(dont mind, didnt test)

 

Patcher Version used: 1.1.6and 1.1.7

System Version: Tiger 4.10&leo10.5

 

obs: why i got glitc in sound and how i fix it? only need digital out

pls help..

Edited by Taruga
I don´t know why, sometimes it happens if you´re using a kernel with the wrong fsb, or something else...

Share this post


Link to post
Share on other sites

Computer Type: Laptop // [samsung Sens R20 Plus] < Family Name // [NT-R20F/P180] < Model Name

Sound Card Vendor: Realtek

Sound Card Model: ALC262

Vendor Id: 0x10ec0262

 

Working: Integrated Speaker, Mic [Pink 3.5mm]

Not Working: Headphone or Speaker [Green 3.5mm]

 

Patcher Version used: I don't know because I used the beta-kext what you uploaded.

System Version: Leopard 5.0 and 5.1 [DVD made by Dong-jjok-ha-neul // Revision #3]

Share this post


Link to post
Share on other sites

Computer Type: PC

Mobo BadAxe2

Codec: SigmaTel STAC9274D

Address: 2

Vendor Id: 0x83847621

Subsystem Id: 0x80860419

Revision Id: 0x100201

 

Working: None

 

Patching Version used: 1.1.6, 1.1.7 and 1.1.8

System Version: Leopard 10.5.1 kerenel staock 9.0.1

 

Dump of 1.1.8 patch:

 

AppleHDA Patcher - 2006/2007 by Taruga v1.18

 

Leopard Darwin Kernel Version 9.1.0

 

* Patching AppleHDA.kext to 0x83847621 Done

* Checking AppleHDA for patch Done

000172aa cmpl $0x83847621,%edx

0001886a cmpl $0x83847621,%edx

* Checking for SPDIF Out Detected

* Checking for SPDIF In Not Detected

* Using the following nodes in pathmap

 

Back Mic: 7 27 21 11

Speaker : 13 2

Spdif Out: 33 30

 

* Copying new config to destination Done

* Repairing Permissions Done

 

** Done patching - You can reboot now **

 

 

but afeter restart Pc no sound is detect :)

 

Any help will wellcome!

Share this post


Link to post
Share on other sites

Computer Type: Laptop

Sound Card Vendor: SigmaTel

Sound Card Model: STAC9205

Vendor Id: 0x838476a0

 

Working: Nothing

Not Working: Mic, Headphones, Speakers

 

Patcher Version used: 1.18

System Version: Leopard 10.5.1

 

obs: Patcher seems to accept codec, SPDIF Out Detected, SPDIF In not detected, no nodes listed in pathmap. Do get the message "Done patching - You can reboot now"

Share this post


Link to post
Share on other sites

Computer Type: Laptop

Sound Card Vendor: SigmaTel

Sound Card Model: STAC9228

Vendor Id: 0x83847616

 

Working: nothing

Not Working: everything else

 

Patcher Version used: 1.18

System Version: Leo 10.5.1

 

Same problems with 1.17 but i get sound out of jack if I use 1.16.

Share this post


Link to post
Share on other sites

Computer Type: PC Asus Basswood 1

Sound Card Vendor: Realtek

Sound Card Model: ALC885

Vendor Id: 0x10ec0885

 

Working: None/no sound

Not Working: All

 

Patcher Version used: 1.1.7

System Version: Leopard 10.5.1

 

obs: With Brizallian patch (minus the mach_kernel, since I using pc_efi), have sound OUT only during fresh install. After install Targus patcher with codec dump from Linux, no sound icons,sound at all

Share this post


Link to post
Share on other sites

Computer Type: Laptop

Sound Card Vendor: Realtek

Sound Card Model: ALC861

Vendor Id: 0x10ec0861

 

Working: Line Out, Headphones, Mic (listed in Sys Pref, not tested)

Not Working: Mute/Volume Control

 

Patcher Version used: Alpha ALC861 applehda.kext + alcinject.kext

System Version: Tiger 4.10

 

 

Taruga: Try this ALC861 kext

Edited by Taruga
Kext for testing

Share this post


Link to post
Share on other sites

Computer Type: PC

Sound Card Vendor: Realtek

Sound Card Model: ALC888 ICH7 ???

Vendor Id: 0x10ec0888

 

Working: Internal Speakers

Not Working: Headphones

 

Patcher Version used: 1.1.8

System Version: Leopard 10.5.1

 

obs: Headphones is listed but you don´t hear anything.

 

At this point i just want Headphone output, any help is appreciated.

 

 

 

 

post-113259-1196896256_thumb.png

post-113259-1196896302_thumb.png

Edited by Taruga
Try v1.19 and let me know

Share this post


Link to post
Share on other sites

Computer Type: PC

Sound Card Vendor: Analog Devices

Codec: Analog Devices AD1988B

Vendor Id: 0x11d4198b

 

Working: Nothing

Not Working: Anything

 

Patcher Version used: 1.1.7 /1.1.9

System Version: 10.5.1

 

obs: With 1.1.7 two devices appear but no output. With 1.1.9 nothing shows up in the sound preferences.

 

Dont worry im confused as well. I thought this board was a realtek board but when i did a linux codec dump it reported it was a AD1988B. Im guessing the latest ubuntu detects it incorrectly or doesnt have the drivers for it. I will do some more hunting around and post more info later.

 

edit again: Sorry looks like i confused myself with another board.

dump.txt

Edited by plas
I´m confused.. Do you have AD1988b from Analog Devices or ALC883 from Realtek ?!

Share this post


Link to post
Share on other sites

Computer Type: PC

Sound Card Vendor: ADI

Sound Card Model: AD1988b

Vendor Id: 0x11d4198b

 

Working: Nada

Not Working: Everything

 

Patcher Version used: up and until 1.19

System Version: Leo 10.5.1

 

Only 1.17 showed two outputs in system preferences panel but no sound.

mf_adi_1988b_codec0.txt

Share this post


Link to post
Share on other sites

Computer Type: PC

Sound Card Vendor: Realtek

Sound Card Model: ALC882D

Vendor Id:i dont know (Abit AB9 Pro integrated)

 

Working: Line Out (tested)

Not Working: Mic, Headphones (tested)

 

Patcher Version used: 1.13

System Version: Leopard 5 (ToH RC2)

Code dump: ALC882_0x1043e601 from here http://psykopat.free.fr/apple/AppleHDA/rea..._0x1043e601.txt

Share this post


Link to post
Share on other sites

Computer Type: PC (with mobo Asus P5LD2)

Sound Card Vendor: Realtek

Sound Card Model: ALC882

Vendor Id: 0x10ec0882

 

Working: Line Out, SPDIF Out

Not Working: Mic, Headphones

 

Patcher Version used: 1.19

System Version: Leopard 5 (ToH RC2)

Codec used: 882.txt

 

There is a solution for Mic/Line out? i can usa skype ;)

Edited by Fichico
Edit you post to mention your motherboard brand and model

Share this post


Link to post
Share on other sites

Computer Type: LAPTOP

Sound Card Vendor: Realtek

Sound Card Model: ALC268

Vendor Id: 0x10ec0268

 

Working: Built-in speakers

Not Working: Mic, Headphones, linein

 

Patcher Version used: 1.19

System Version: Tiger 4.11 *edit updated to leopard, still working

 

Got audio from azalia.pkg in koolkal.

codec.txt

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×