Jump to content

10.4.3 broadcom wireless effort


  • This topic is locked This topic is locked
234 replies to this topic

#41
outoftheboxx10

outoftheboxx10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Interests:mostly hardware

has anyone tried patching the kext from the darwin cd? or using the AppleAirPortBrcm4311.kext and istumbler? please let me know

brcm4311kext doesnt work with 4306, nothing shows up in ifconfig, successful load, but no card recognized i guess....not sure

#42
MacL0ver

MacL0ver

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
could we just compile the file on 10.4.3? because certain kexts are version specific.

#43
taber

taber

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Someone with a 4320 (Dell truemobile 1300) could edit the plist, then reboot. You should see something like: AirPortPCI_MM: Ethernet address 00:90:4b:7b:xx:xx during boot (and in dmesg).


Hey, ohpossum.

I have a Broadcom 4320. I edited the Info.plist, as you suggested, and can see that the IO80211Family.kext and AppleAirPortBrcm4311.kext are loaded at boot by calling kextstat from the terminal. However, nothing shows up regarding AirPortPCI_MM during boot or in dmesg.

Additionally, running the airport PrivateFramework gives me this error:

WirelessAttach: getInterfaceWithName failed
error: bootstrap_status 1102 for port name "com.apple.SystemConfiguration.configd.airport"

After that, if I run kextstat again, IO80211Family and AppleAirPortBrcm4311 have disappeared from the loaded kext list.

Have any helpful tips? Thanks!

I'm running 10.4.3 8F1099.

#44
Tak

Tak

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts

could we just compile the file on 10.4.3? because certain kexts are version specific.


The Darwin source for AppleAirport2.kext is not available. If it was, it would have already been compiled and there would be no need for this thread ;)

#45
suleiman

suleiman

    Your Anchorman

  • Retired
  • 640 posts
  • Gender:Male
  • Location:USA, UK, and CANADA :)
  • Interests:OS X
if it's not available then how was the code for the initial hack to get wireless working in 10.4.1 made available?

#46
Tak

Tak

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
The initial hack did not require the original source code for the kext.

lagnat used the Darwin precompiled kext and added a couple of functions that were missing. The driver was relinked with these functions - this can be done without needing the original source code.

It was all documented back in August here

#47
Mark Roth

Mark Roth

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Hi all,

I've been messing around and I'm hoping someone here could tell me if I've officially stumbled onto something:

I'm using 10.4.3 8f1099 and have read the posts in this thread.

I also am able to get IO80211Family.kext loaded, which loads AppleAirPortBrcm.kext. If you look at "extensions" under System Profiler, you can see that both report dependency errors such as com.apple.iokit.IO80211Family: No valid version of this dependency can be found
com.apple.iokit.IONetworkingFamily: No valid version of this dependency can be found
even though those seem OK.

But if you look at IOKit and IOKit6, it says under "Get Info String" Pseudoextension . (false extension?)

So I was wondering if that is where the problem lies. I don't know much about Darwin and even less about Xcode, but IOKit is available for compile on the apple website.

Thoughts and ideas are appreciated!!
Mark

#48
loop

loop

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Just posting in here to express my EXTREME interest in this project. Seriously.

we KNOW it CAN work - I have a working OSX install 10.4.3 with wireless networking, and as described on the first page I get the wirelesss ONLY until i reboot, at which point the OS seems to forget that it was ever connected...

I look forward to any developments.

#49
Spyrow

Spyrow

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Which wifi device are you using?

#50
loop

loop

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Which wifi device are you using?




pretty sure it's a broadcom but i'm not home to tell for sure.

part of the problem is that it's one of the spare d610's from my office - and about half of them were upgraded to the intel 2200's when we bought them for better linux compatability (well, easier setup anyway :().

i'll know later today, in about 6 or 7 hours, when i get home. i'll open it and tell you exactly which.
i'm using build 8f1099, if that matters.

#51
Mark Roth

Mark Roth

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
OK, scratch my earlier post. I think I understand the pseudo extension thing now.

But hey, I can get the IO80211family and brcm kexts loaded, but can't use the ./airport -s method. I would settle for that at this point.

Also, for those of you that can get it working with ./airport method, when you look under System Profiler does it show dependencies satisfied for IO80211Family and AppleAirportBrcm4311?

thx!

#52
fallingup

fallingup

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts

pretty sure it's a broadcom but i'm not home to tell for sure.

part of the problem is that it's one of the spare d610's from my office - and about half of them were upgraded to the intel 2200's when we bought them for better linux compatability (well, easier setup anyway :gathering:).

i'll know later today, in about 6 or 7 hours, when i get home. i'll open it and tell you exactly which.
i'm using build 8f1099, if that matters.


did you find out what card you were using? and does anyone actually have a working broadcom with dev id of 4320? i really would like to get back to using mac

#53
f1r3f1ght3r

f1r3f1ght3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Location:Fly Over Country
Dell Truemobile(broadcom) 1450 card works with no mod to any kext.

full install of 10.4.3 not upgrade from 10.4.1

Wireless Card Type: AirPort Extreme
Wireless Card Locale: USA
Wireless Card Firmware Version: 100.2 (3.120.x)
Current Wireless Network: NETGEAR
Wireless Channel: 11

I have been running since the begining of the week and have had zero issues.

DEV ID 4324

#54
outoftheboxx10

outoftheboxx10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Interests:mostly hardware

Dell Truemobile(broadcom) 1450 card works with no mod to any kext.

full install of 10.4.3 not upgrade from 10.4.1

Wireless Card Type: AirPort Extreme
Wireless Card Locale: USA
Wireless Card Firmware Version: 100.2 (3.120.x)
Current Wireless Network: NETGEAR
Wireless Channel: 11

I have been running since the begining of the week and have had zero issues.

DEV ID 4324

CAN ANYONE ELSE CONFIRM THIS???!!!?!?!???
if so im off to ebay to buy another broadcom card =x

#55
theweaselslayer

theweaselslayer

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

CAN ANYONE ELSE CONFIRM THIS???!!!?!?!???
if so im off to ebay to buy another broadcom card =x


Check this post out:
He says he's got the 1450 running on a native 10.4.3 install. He says it's recognized as an Airport Extreme automatically; no need to modify any kexts. He also states he can even use the Fn keys on his laptop to turn it on and off. Also, he says it survives reboots.

Do a search on eBay, you'll find these cards extremely cheap. I'm just about to pick one up for $30 with free shipping :-) If it works, I'll post it ASAP. I've also got an RT2500 miniPCI coming in the mail to test out as well. I'll let you guys know what I find.

#56
outoftheboxx10

outoftheboxx10

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Interests:mostly hardware

Check this post out:
He says he's got the 1450 running on a native 10.4.3 install. He says it's recognized as an Airport Extreme automatically; no need to modify any kexts. He also states he can even use the Fn keys on his laptop to turn it on and off. Also, he says it survives reboots.

Do a search on eBay, you'll find these cards extremely cheap. I'm just about to pick one up for $30 with free shipping :-) If it works, I'll post it ASAP. I've also got an RT2500 miniPCI coming in the mail to test out as well. I'll let you guys know what I find.


i also jumped the gun and bought one of the 1450's(should be here next week)...i had been looking for an rt2500 minipci for a while and never browsed across one or just didnt use the right search terms i guess....you wouldnt still happen to have the link or brand of the minipci rt2500 would you?

#57
ohpossum

ohpossum

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts

Dell Truemobile(broadcom) 1450 card works with no mod to any kext.

full install of 10.4.3 not upgrade from 10.4.1

Wireless Card Type: AirPort Extreme
Wireless Card Locale: USA
Wireless Card Firmware Version: 100.2 (3.120.x)
Current Wireless Network: NETGEAR
Wireless Channel: 11

I have been running since the begining of the week and have had zero issues.

DEV ID 4324



Have you tried 8f1111? 1111a/g?

Thanks!

#58
theweaselslayer

theweaselslayer

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

i also jumped the gun and bought one of the 1450's(should be here next week)...i had been looking for an rt2500 minipci for a while and never browsed across one or just didnt use the right search terms i guess....you wouldnt still happen to have the link or brand of the minipci rt2500 would you?


The miniPCI with the RT2500 chipset I bought on eBay first was a Billionton MIWLGRL MiniPCI. It was the only one I found on eBay after days of searching :-(.

The second card I purchased is the Dell TrueMobile Wireless 1450 802.11g/b/a WLAN Mini PCI as stated before. I will test both of them. If they both work, I will resell the Billionton and my original Broadcom 4306 on eBay and keep the Dell (the Dell is a/b/g, the Billionton and my Broadcom are only b/g.)

#59
theweaselslayer

theweaselslayer

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
I haven't tried this myself, and I probably don't know what I'm talking about... but I can't help but wonder if the 4309 (from the Dell 1450) works, isn't it close enough to the 4306 that you could just edit the Info.plist in the kext? I don't even know which kext it is in 10.4.3, I'm just throwing ideas out there...

#60
Celery 2.39ghz w/PB and Firewire

Celery 2.39ghz w/PB and Firewire

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Well I hope that f1r3f1ght3r is right and the 1450 works. I just jumped the gun and picked one up off of ebay:

http://cgi.ebay.com/...1QQcmdZViewItem


$35 shipped Priority mail. Im hoping this will work on my Thinkpad. As it is now I've got an upgraded Broadcom 4306 based B/G miniPCI, does NOT work with 10.4.3 build 1099. Off topic I might add that I ran Mac Office and Adobe Suite on my Celery Tower today ;].. . .same build





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy