Jump to content

[Guide] Test MacOs 10.10 PublicBeta or DeveloperPreview


  • This topic is locked This topic is locked
120 replies to this topic

#81
ethan9482

ethan9482

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts

Just a quick update about iMessage - mine stopped working all of a sudden. I got an error saying to contact apple with a verification reference. 

 

According to a pretty detailed guide on another site there are further verification checks being carried out and if you use many serials / uuids it will block your account.

 

Anyhow, called apple and they unblocked it but if you get that message then its not about your system, its your account. The other messages around activation still appear to be system led rather than account.

 

Hope that helps someone.



#82
JahStories

JahStories

    Elijah

  • Donators
  • 2,787 posts
  • Gender:Male
  • Location:Tyson III

UPDATE:

 

SurfacePro 1°Gen Files Package V.0.5

 

This time, thanks to Mirone who patched the kext, we can enjoy higher quality audio, plug auto detection and even more system stability.

includes only one set of DSDT and SSDT.

Clover installer have been updated to the latest ver.

 

This Pack is compatible with:

Maverick from 10.9.0 up to 10.9.4 

Yosemite Both DP and PB every ver. (includes new usbxhci)

 

P.s.

the last step for us is to get the internal wifi to work, but it's still to yet for it.

P.p.s.

Testers wanted for the applehda kext on SP2, if it works, i'll update the files pack for sp2 asap.

 

to update from 0.4 to 0.5:

delete applehdadisabler.kext and voodoohda.kext from system/library/extensions

install applehda.kext with kextdrop from drivers folder.

 

 

   Happy hackintosh tablet  :lol:



#83
BRAHMAN

BRAHMAN

    InsanelyMac Protégé

  • Banned
  • Pip
  • 26 posts

Can someone running 10.10 pls post the touch driver? I would like to try using it with Clover....hopefully it will work and incredible that it hasn't been done already.

 

Can PM with a link. Thanks in advance!



#84
JahStories

JahStories

    Elijah

  • Donators
  • 2,787 posts
  • Gender:Male
  • Location:Tyson III

Brahman that's already been asked, and no one figured out on how to do that.

 

 

About your previous post i've already hidden, you'd better understand that this is a public forum providing free services, 

and you should be greatful for what it gives you, trying always to being polite.

 

This is not the first time you've been "trolling" here, and that's simply unacceptable!



#85
JahStories

JahStories

    Elijah

  • Donators
  • 2,787 posts
  • Gender:Male
  • Location:Tyson III

Update:

 

Surface Pro 1°Gen FilesPackage V0.5.1

 

see changelog for details.



#86
wen1

wen1

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 187 posts

{surfacepro}

 

I managed to install Yosemite public beta 2 using the v0.5.1 files on Surface Pro 1. Thanks to all the folks supporting this forum and JahStories.

 

I do have one problem. It boots fine but my screen is washed out (white hazy look and i can barely see whats on the screen). I see the graphics adapter being detected as HD 4000 with 1024MB Vram.

 

I even removed the DSDT and just injected 0x01660004 via clover config file. But same behavior with those changes.

 

I will keep trying but wondering if anyone else ran into this.

 

Same problem as described in the thread below but that thread is about mavericks

http://www.insanelym...amebuffercapri/

 

Thanks



#87
JahStories

JahStories

    Elijah

  • Donators
  • 2,787 posts
  • Gender:Male
  • Location:Tyson III

you need the dsdt, don't remove it, are you sure you are using the provided config.plist without modifing any startup parameter?

 

i personally never experienced this issue.



#88
wen1

wen1

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 187 posts

Thanks for the quick response, you are the man. I must have messed something up before. It works perfectly now.

 

Thanks again.



#89
wen1

wen1

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 187 posts

Stil having an issue with audio though. 

 

I copied the kexts in Yosemite folder to kexts folder in EFI/CLOVER. 

 

Even tried to install the two kexts "AppleHDA.kext" and "EADPFix.kext" to S/L/E with no luck.

 

Any thoughts on this one?

 

Thanks

 

Edit:got it working. Kext Wizard i was using was not working right. I used kext drop to install the kext and it seems to work well.

 

Now, Display port out is not working. I need to see how i can get the external monitor working.



#90
JahStories

JahStories

    Elijah

  • Donators
  • 2,787 posts
  • Gender:Male
  • Location:Tyson III

check this post if you are experiencing audio issues.



#91
wen1

wen1

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 187 posts

I got the display port working by patching the AppleIntelFrameBufferCapri.kext manually. Now it detects the external monitor properly and supports full resolution via that port. Also detects audio port (verified via DPCIManager, but did not test actual sound output).

 

The HD4000 card in surface has the revision id of 0x0009. So i modified the kext above for that platform id to support the LVDS in surface pro and modified the DSDT and the config file to inject 0x01660009 instead of 0x01660004.

 

Let me know if there is any interest and i can post the the files used.

 

Thanks



#92
wen1

wen1

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 187 posts

here is a kext that i used in my post above. Hope this is allowed.

Attached Files



#93
JahStories

JahStories

    Elijah

  • Donators
  • 2,787 posts
  • Gender:Male
  • Location:Tyson III

i did not even tested the hdmi output yet on Yosemite....

 

thanks for sharing!

i'll test it and if working i'll probably add it to the next files package ;)



#94
wen1

wen1

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 187 posts

Thanks.

 

Just to note you will also need a tweak to the DSDT and the config.plist as i mentioned above to inject 0x01660009. I did not post those two file to avoid confusion.

I sure can send them to you if needed.



#95
JahStories

JahStories

    Elijah

  • Donators
  • 2,787 posts
  • Gender:Male
  • Location:Tyson III

1660009 was causing sleep issues, 

 

this is why we are using 1660004, thats working for dual screen too on Maverick

 

i'll look into it when i have same spare time :)


please send me the file via PM...

 

i've edited your previous message to avoid users confusion for now...



#96
pokenguyen

pokenguyen

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 614 posts
  • Gender:Male
Revision is not ig-platform-id, they are not related at all. You shouldn't be confused.

#97
JahStories

JahStories

    Elijah

  • Donators
  • 2,787 posts
  • Gender:Male
  • Location:Tyson III

pokenguyen is right, btw the 0x01660004, was and is the only ig platform to provide dual screen and sleep on Mav.

 

and usually you don't have to patch both dsdt and config.plist to inject the platformid,  but just one of those and i always used the last one.



#98
wen1

wen1

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 187 posts

Got it,

 

May be you guys will have better luck with it. I will try the sleep to see how that works now with this. I did not see any issues with the Yosemite version of the kext. But it is too soon for me to say though.



#99
wen1

wen1

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 187 posts

JahStories,

 

Somehow i could not send an attachment to you by PM.

 

Here is my DSDT and Kext. Seems like the config file is also injecting the platform id. So you need to change that too to test this.

 

Thanks

Ravi

Attached Files



#100
JahStories

JahStories

    Elijah

  • Donators
  • 2,787 posts
  • Gender:Male
  • Location:Tyson III

thanks wen, i hided your files again to avoid confusion, i'll test it and let you know!







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy