Jump to content

[Guide] Gigabyte Z77X UD5H Clover UEFI Install/Tweak guide

Gigabyte Z77X UD5H Clover UEFI Gigabyte Guide

  • Please log in to reply
337 replies to this topic

#21
danif

danif

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
Hi, and thanks for this guide!

I´m trying to follow it but with macmini6,2 profile it doesn´t boot it stays at the verbose output without loading Windows Manager. With imac13,2 there is no problem, any ideas?

My specs:
Z77X-UD5H (rev 1.1) F16c
eVGA GTX660 TI
i7 3770k (not OCed)
Clover 1794

Bios HD400 enabled with 64MB
Display connected to HD4000 DVI-D

Thanks

#22
danif

danif

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
I´ve solved the problem.

I changed HD4000 memory to 32MB in bios and I've also made some changes in IGPU _dsm in dsdt:


Method (_DSM, 4, NotSerialized) // _DSM: Device-Specific Method
		 {
			 Store (Package (0x06)
				 {
					 "device-id",
					 Buffer (0x04)
					 {
							 0x66, 0x01, 0x00, 0x00
					 },

					 "AAPL,ig-platform-id",
					 Buffer (0x04)
					 {
							 0x0A, 0x00, 0x66, 0x01
					 },

					 "hda-gfx",
					 Buffer (0x0A)
					 {
						 "onboard-1"
					 }
				 }, Local0)
			 DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
			 Return (Local0)
		 }


#23
kn6600

kn6600

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Location:Macedonia

Originally Posted by stasio Posted Image

Update with new BIOS:

GA-Z77X-UD5H - F16c
- Improve system compatibility
- Apr-Jun 13


But it seem to be very stable beta bios.

#24
D-an-W

D-an-W

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 444 posts
Can any fellow Z77X-UD5H users that also use the onboard audio and have front panel audio plugs connected please confirm if there are any issues when playing back audio?

#25
indigital

indigital

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
First and foremost I would like to thank thouroughly you for your detailed description of how to install and use Clover in combination with the Gigabyte mainboard.

I would be, however, even more thankful if you could share your thoughts about some points that have crossed my mind and started bothering me :-)

The recently published inofficial "F16c mod2" bios by Statsio for our mainboard (http://forums.tweakt...html#post457945) apparently comes with new and/or improved functions.
Do we have to consider anything with regards to your guide if we shift to that BIOS version?

The next point is, at least I have slight difficulties in understanding how to use your guide if I start from the scratch, that means plan to install a fresh Mac OS 10.8.x + Clover on a naked system.
I my case that means I do all the preparation stuff inside a virtual machine of Mac OS 10.8.x under VMWare that runs on Windows 8.
My first and yet unsuccessful experiences with Clover I got with BDUtility as described in that post: http://www.projectos...indpost&p=28400

Moreover I would like to hear a comment from you about graphic cards that are equipped with an UEFI Bios. I own some Asus GTX 680 that received a first UEFI BIOS update from Asus.
How does that concern the BIOS settings of the mainboard and does it have an influence on the steps described in your guide.

I wouldn' mind as well if you describe shortly if I have to consider anything special if I intend to use the audio interface of the mainboard instead

It would be great if you would comment on the points.

#26
danif

danif

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
hi!

I have been testing the system for some days and i have some problems/questions:

- Is it possible to sleep with both Integrated and Discrete Graphics enabled? I cannot.

Bios F16c clean and patched with pjalm´s gigabyte-discrete-hd4000 patches.

After waking the computer, no screen so I have to reboot

No problem when only Discrete is enabled. Sleeps works

- I think the voltage readings from fakeSMC plugins are wrong after I boot with CSM set to never (I get RAM=2v and CPU fixed to 1.056V)

- Firewire GUID error after sleep even with Uefi driver.

Is there anyway to prevent the system from logging this error until the problem is solved?

Thanks

#27
Captain Dunsel

Captain Dunsel

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
I tried this on a fresh install using chameleon. Did it step by step and while it did boot my smbios settings do not stick at all and during the verbose boot which I would love to get rid of it says my CPU is undetected.. I do not know if this the right place to ask for help but I definitely need some..

#28
xpamamadeus

xpamamadeus

    InsanelyMac Legend

  • Donators
  • 587 posts
  • Gender:Male
  • Location:Croatia

There  are some  improvements using mavericks over ml.

 

Mountain Lion

 

e6CVtZE.png

 

Mavericks

 

BNf45av.png


  • sbg likes this

#29
kantok

kantok

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

@xpamamadeus,
 
Firstly I want to say thanks for your detailed instruction for the board. This thread helps me a lot for my build.
 
But one thing i want to ask you is about rc scripts.
For me that would not work at startup.
 
Typing manually sudo /etc/rc.local & rc.shutdown.local in terminal, I can get the logs and EFI mounting. Nvram contents is saved with Emuvariables.
 

Clover.MountEFI 5531118A-3C7A-4E61-AA21-9C545F3C3756
Clover.RamDisk 01BA6A9F-90E7-446C-92D4-72CC1930D159
Clover.BackupDirOnDestVol Yes
Clover.Theme black_green
Clover.LogEveryBoot 10
Clover.LogLineCount 3000
Clover.NVRamDisk Yes
Clover.KeepBackupLimit 3

I may be missing something. But could you please tell me how to shoot my trouble?
 
 
p. s.
Wow! You already testing Mavericks? And even 16941 is great score than mine!!

 

 

EDIT: I'm using 15r bios.



#30
EvgeniX

EvgeniX

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male

There  are some  improvements using mavericks over ml.

 

Mountain Lion

 

e6CVtZE.png

 

Mavericks

 

BNf45av.png

can you show as how to install mavericks pls?



#31
sbg

sbg

    InsanelyMac Protégé

  • Donators
  • 66 posts

There  are some  improvements using mavericks over ml.

 

Mountain Lion

 

e6CVtZE.png

 

 

 

Can you please publish your SMBIOS for iMac13,2?

 

Thanks.



#32
EvgeniX

EvgeniX

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male

Big Thanks for Guide!!!

 

Now I have fully working 10.9 Mavericks with Clover UEFI!!!!

 

Video,Audio,Network, USB 3.0 Alll works!!! nice!!!

 

 i7-3770К, GA-Z77X-UD5H, GTX 680 4GB



#33
EvgeniX

EvgeniX

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male

any way to get read off thunderbolt firmware update 1.2 in app store for SMBIOS for iMac13,2 ? Thx

 

I did try to use full SMBios:

<key>SMBIOS</key>
	<dict>
		<key>BiosReleaseDate</key>
		<string>10/12/2012</string>
		<key>BiosVendor</key>
		<string>Apple Inc.</string>
		<key>BiosVersion</key>
		<string>IM131.88Z.010A.B05.1211151146</string>
		<key>Board-ID</key>
		<string>Mac-FC02E91DDD3FA6A4</string>
		<key>BoardManufacturer</key>
		<string>Apple Inc.</string>
		<key>BoardSerialNumber</key>
		<string>C02KM7XXXXMP</string>
		<key>ProductName</key>
		<string>iMac13,2</string>
		<key>SMfamily</key>
		<string>iMac</string>
		<key>SerialNumber</key>
		<string>C02KM7XXXXMP</string>
	</dict>

but it does not change ROM version in system info to this one after boot....  any way to make it change? 



#34
xpamamadeus

xpamamadeus

    InsanelyMac Legend

  • Donators
  • 587 posts
  • Gender:Male
  • Location:Croatia

@xpamamadeus,
 
Firstly I want to say thanks for your detailed instruction for the board. This thread helps me a lot for my build.
 
But one thing i want to ask you is about rc scripts.
For me that would not work at startup.
 
Typing manually sudo /etc/rc.local & rc.shutdown.local in terminal, I can get the logs and EFI mounting. Nvram contents is saved with Emuvariables.
 

Clover.MountEFI 5531118A-3C7A-4E61-AA21-9C545F3C3756
Clover.RamDisk 01BA6A9F-90E7-446C-92D4-72CC1930D159
Clover.BackupDirOnDestVol Yes
Clover.Theme black_green
Clover.LogEveryBoot 10
Clover.LogLineCount 3000
Clover.NVRamDisk Yes
Clover.KeepBackupLimit 3

I may be missing something. But could you please tell me how to shoot my trouble?
 
 
p. s.
Wow! You already testing Mavericks? And even 16941 is great score than mine!!

 

 

EDIT: I'm using 15r bios.

Sry cannot help about this,try in clover thread.

I wass never having problems with scripts.


can you show as how to install mavericks pls?

Will update guide when we Maverick goes final.


Can you please publish your SMBIOS for iMac13,2?

 

Thanks.

Smbios its automatically genereated with Clover,

i have only this and serial generated with chameleon wizard

<key>ProductName</key>
 <string>iMac13,2</string>


#35
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,942 posts
  • Gender:Male

Xpamamadeus, your CPU is overclocked, high? Otherwise these numbers are close to a supernatural event.


P.S.: anyway, i can also confirm the huge performance boost with Mavericks: got over 11.600 points with my Core i5 3570 at stock speed!



#36
xpamamadeus

xpamamadeus

    InsanelyMac Legend

  • Donators
  • 587 posts
  • Gender:Male
  • Location:Croatia

Xpamamadeus, your CPU is overclocked, high? Otherwise these numbers are close to a supernatural event.


P.S.: anyway, i can also confirm the huge performance boost with Mavericks: got over 11.600 points with my Core i5 3570 at stock speed!

Yes its overclocked to 4.7ghz.

Its all like in this guide.

I just wanna point that they are doing something good under the hood.



#37
sbg

sbg

    InsanelyMac Protégé

  • Donators
  • 66 posts

Wake up from sleep?

I can put my system to sleep without problem but waking up from sleep triggers restart in about 50% of the cases.

Any suggestions are appreciated.

 



#38
xpamamadeus

xpamamadeus

    InsanelyMac Legend

  • Donators
  • 587 posts
  • Gender:Male
  • Location:Croatia

Double check all bios settings, many settings can broke wake from sleep!!



#39
kdp

kdp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts
  • Gender:Not Telling
  • Location:Los Angeles, CA

I installed windows just to flash the UEFI GOP bios to my msi 660 TF, disabling CSM now actually saves in the bios and I get full native resolution in bios and clover so I know it's working via full UEFI. My install won't sleep either, My bios settings are identical to xpamamadeus, bios F15r, not sure what version of it. I think I basically have the exact same hardware. I'm booting from discrete, everything works but sleep, I don't really use sleep much, if ever, but would be interested in solving it.

 

Thanks for the great resources, you've really helped me understand how clover works and I feel like I have a decent grasp of it after knowing nothing about it prior.



#40
EvgeniX

EvgeniX

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male

I installed windows just to flash the UEFI GOP bios to my msi 660 TF, disabling CSM now actually saves in the bios and I get full native resolution in bios and clover so I know it's working via full UEFI. My install won't sleep either, My bios settings are identical to xpamamadeus, bios F15r, not sure what version of it. I think I basically have the exact same hardware. I'm booting from discrete, everything works but sleep, I don't really use sleep much, if ever, but would be interested in solving it.

Thanks for the great resources, you've really helped me understand how clover works and I feel like I have a decent grasp of it after knowing nothing about it prior.


I'm not suture for 100% I did not done all testing before I upgraded my bios to 16c its much better...

But sleep does not work cos of 15r or I think cos of just nvidia HDMI fix....

What I want to say sleep didn't work for me cos I just apply nvidia HDMI patch... But when I apply hd4000 then nvidia patch sleep works fine... Looks strange but how it worked for me...





Also tagged with one or more of these keywords: Gigabyte Z77X UD5H, Clover UEFI, Gigabyte, Guide


3 user(s) are reading this topic

1 members, 2 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy