Jump to content

danif

Members
  • Content count

    64
  • Joined

  • Last visited

About danif

Profile Information

  • Gender
    Male
  1. danif

    Clover General discussion

    Two days ago, I had the same problem, if I tried to compile myself with BuildClover (10.12.6 xcode8) I had that error, if I tried booting with file from SF, there was no problem (same rev)... I downgraded-compiled, downgraded-compiled ... until I found the last rev I could compile without this error ( it was 4232 I think).. Now I cannot confirm because since I updated to Xcode9, buildClover 4.5.5 -> 4.5.6 and clover to rev4247 I was able to compile sucessfully As you are not using buildClover, and already commited > 4247 then maybe problem is xcode, are you using xcode 8?
  2. danif

    Clover General discussion

    @fabiosun, 
 what are your problems with new autopatching feature? Random reboots? I've been using it for two months without any problem. I didn't try 10.13 yet but in 10.12.6 my setup is stable.
 I will share some info about my config so that you can test as we have same mobo. Which aptio fix are you using? Since June I droped nick`s solution and I've been using apianti's solution (loading an efi driver he wrote from clover shell to inspect memory map and then using aptiofixv2 with slide boot arg pointing to a big chunk of memory, in our mobo its slide=128 at least in my current 1504 bios version). I can boot with thunderbolt enabled in bios and of course with one nvidia gfx card (never tried two or more). 
 Bios: attached screencaps for cpu config Clover: attached my efi folder with latest clover, you will have to adapt to your config. In config plist I deleted smbios so you can use yours. You will have to change also ssdt for pm. If you need any other config from bios just tell me. BiosCpu.zip EFI-X99-Deluxe2.zip
  3. danif

    HWSensors3

    Sorry but I'm travelling and I won't have access to my computer until Tuesday or so. Hopefully someone else can report kernel messages before. Thanks!!
  4. danif

    HWSensors3

    Nouveau linux drivers for nvidia has implemented 10 days ago initial support for pascal temperature sensor: https://github.com/skeggsb/nouveau/blob/master/drm/nouveau/nvkm/subdev/therm/gp100.c
  5. danif

    Clover General discussion

    Problem solved in r4144, now xcpm is enabled automatically without kernel patches in config.plist Thanks syscl
  6. danif

    Clover General discussion

    No sorry, it doesn't enable xcpm, that's the problem. I can and could boot ok with r4141 and r4143 without any kernel patch in config.plist but it doesn't enable xcpm it tries to enable AppleIntelCPUPowerManagement mode. You can see it in my latest logs file name: "systemLatestClover.log" with my previous clover revision (i think it was 4076) it enables xcpm, obviously with config.plist kernel patches. You can check it in "systemOldClover.log". Sorry for my english.
  7. danif

    Clover General discussion

    Thanks, you are right, I can boot with only one of them. Thanks, as @PMheart noted, this wasn't the problem. I'm attaching new logs with new and old clover info. Let me know if you need any other logs Broadwell-E test2.zip
  8. danif

    Clover General discussion

    I had this 4 patches in config.plist when booting clover 4070: 10.12.x, _cpuid_set_info() Fix for Broadwell-E © Pike R. Alpha 83c0e9 -> 83c0e1 10.12.6, Enable XCPM on Broadwell-E © Pike R. Alpha 8d43c483 f822 -> 8d43bc83 f822 10.12.x, Reboot fix #1 © Pike R. Alpha 554889e5 41574156 41554154 53504189d64189f7 4889fb45 85ff0f84 -> c39089e5 41574156 41554154 53504189d64189f7 4889fb45 85ff0f84 10.12.x, Reboot fix #2 © Pike R. Alpha 005de908 0000000f 1f840000 000000554889e541 -> 005de908 0000000f 1f840000 000000c39089e541
  9. danif

    Clover General discussion

    Hi, I have a Broadwell-E cpu and I can help with testing if you guide me. I have alredy compiled r4141 and I'm attaching config.plist, AppleIntelInfo, bootlog and maclog output (by the way is there any option for maclog to only log the last boot?) XPCM is not enabled. should I add a new boolean key in config.plist? Running 10.12.6 Thanks. Broadwell-E test1 .zip
  10. danif

    Clover Bug/Issue Report and Patch

    @apianti, I tried to boot replacing aptiofix-free2000 with your OsxMemoryRelocationDxe.efi and adding slide=128 into config.plist but I get this error: "Error allocating 0x800 pages at 0x0...10200000 alloc type 2 Error loading kernel cache (0x9) Boot failed, sleeping..." Should I do something different? Attaching memmap memmap.txt
  11. danif

    Clover Bug/Issue Report and Patch

    Hi Apianti, thanks for trying to find a better way to fix this issue. This is for Asus X99 Deluxe 2 I boot with "Above 4g Decoding" option enabled in BIOS. Also attached txt file with it disabled. OsxMemoryRelocationDxe-4g.txt OsxMemoryRelocationDxe-no4g.txt
  12. danif

    AppleALC — dynamic AppleHDA patching

    Ok Toleda has written about this in other forum and seems to be a problem with Pascal Web Drivers:
  13. For me it´s ok if: - BIOS - Above 4G = Enabled - Use PMHeart's AptioFixDrv from this post Edit: I can see in your signature you are using ElCap, then Above 4G = enabled cannot be used.
  14. danif

    AppleALC — dynamic AppleHDA patching

    Thanks for helping joevt, I dont understand what you propose to be sure it´s not AppleALC problem. Specifically "redo your graphics card audio tests" I have this in SSDT Scope (\_SB.PCI0) { Device (HDEF) { Name (_ADR, 0x001B0000) // _ADR: Address Method (_INI, 0, NotSerialized) // _INI: Initialize { Store (Zero, \_SB.PCI0.ALZA._ADR) } Method (_DSM, 4, NotSerialized) // _DSM: Device-Specific Method { If (LEqual (Arg2, Zero)) { Return (Buffer (One) { 0x03 }) } Return (Package (0x04) { "layout-id", Buffer (0x04) { 0x07, 0x00, 0x00, 0x00 }, "PinConfigurations", Buffer (Zero) {} }) } } } Scope (\_SB.PCI0.BR3A.H000) { Name (_STA, Zero) // _STA: Status } Scope (\_SB.PCI0.BR3A.H001) { Name (_STA, Zero) // _STA: Status } Scope (\_SB.PCI0.BR3A.D080) { Name (_STA, Zero) // _STA: Status } Scope (\_SB.PCI0.BR3A) { Device (GFX1) { Name (_ADR, Zero) // _ADR: Address Method (_DSM, 4, NotSerialized) // _DSM: Device-Specific Method { If (LEqual (Arg2, Zero)) { Return (Buffer (One) { 0x03 }) } Return (Package (0x12) { "NVCAP", Buffer (0x14) { /* 0000 */ 0x05, 0x00, 0x00, 0x00, 0x00, 0x00, 0xFF, 0xFF, /* 0008 */ 0xFF, 0xFF, 0x00, 0x00, 0x00, 0x00, 0x00, 0x0E, /* 0010 */ 0x00, 0x00, 0x00, 0x00 }, "@0,connector-type", Buffer (0x04) { 0x04, 0x00, 0x00, 0x00 }, "@1,connector-type", Buffer (0x04) { 0x00, 0x04, 0x00, 0x00 }, "@2,connector-type", Buffer (0x04) { 0x00, 0x04, 0x00, 0x00 }, "@3,connector-type", Buffer (0x04) { 0x00, 0x08, 0x00, 0x00 }, "@4,connector-type", Buffer (0x04) { 0x00, 0x04, 0x00, 0x00 }, "@5,connector-type", Buffer (0x04) { 0x00, 0x08, 0x00, 0x00 }, "hda-gfx", Buffer (0x0A) { "onboard-1" } }) } } Device (HDAU) { Name (_ADR, One) // _ADR: Address Method (_DSM, 4, NotSerialized) // _DSM: Device-Specific Method { If (LEqual (Arg2, Zero)) { Return (Buffer (One) { 0x03 }) } Return (Package (0x04) { "hda-gfx", Buffer (0x0A) { "onboard-1" }, }) } } } Compiled AppleALC in debug mode, and this is the output: 2017-04-16 14:26:09.573402+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) util @ getOSData vendor-id has 8086 value 2017-04-16 14:26:09.583298+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) util @ getOSData device-id has 8D20 value 2017-04-16 14:26:09.583524+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) util @ getOSData revision-id has 5 value 2017-04-16 14:26:09.726256+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) util @ getOSData layout-id has 7 value 2017-04-16 14:26:09.735694+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) util @ getOSData AAPL,ig-platform-id was not found 2017-04-16 14:26:09.745170+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ found 1 audio controllers 2017-04-16 14:26:09.754153+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ validating 0 controller 8086:8D20:5 2017-04-16 14:26:09.763757+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing to 0 mod 8086:A2F0 2017-04-16 14:26:09.773240+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing to 1 mod 8086:8D21 2017-04-16 14:26:09.782494+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing to 2 mod 8086:8D20 2017-04-16 14:26:09.791809+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ found mod for 0 controller 2017-04-16 14:26:09.800563+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ applying patches for 1 kext 2017-04-16 14:26:09.809295+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ applying 0 patch for 1 kext 2017-04-16 14:26:09.950001+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ codec entry misses properties, skipping 2017-04-16 14:26:09.958631+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ found supported Realtek ALC1150 codec revision 0x100001 2017-04-16 14:26:09.982688+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ applying patches for 3 kext 2017-04-16 14:26:09.990818+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ will route callbacks resource loading callbacks 2017-04-16 14:26:09.999643+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ applying patches for 3 kext 2017-04-16 14:26:10.007903+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ applying 1 patch for 3 kext 2017-04-16 14:26:10.016533+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ applying 2 patch for 3 kext 2017-04-16 14:26:10.024935+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ applying 3 patch for 3 kext 2017-04-16 14:26:10.034115+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ applying 5 patch for 3 kext 2017-04-16 14:26:10.043198+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) layout call 55 48 89 E5 41 57 41 56 41 54 53 41 89 CE 49 89 2017-04-16 14:26:10.052167+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) platform call 55 48 89 E5 41 57 41 56 41 54 53 41 89 CE 49 89 2017-04-16 14:26:10.215989+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ resource-request arrived layout 2017-04-16 14:26:10.225518+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ checking codec 10EC:900:100001 2017-04-16 14:26:10.234983+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ selecting from 6 files 2017-04-16 14:26:10.244066+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 0 layout 1/7 2017-04-16 14:26:10.252896+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 1 layout 2/7 2017-04-16 14:26:10.261754+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 2 layout 3/7 2017-04-16 14:26:10.270504+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 3 layout 5/7 2017-04-16 14:26:10.278897+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 4 layout 7/7 2017-04-16 14:26:10.287252+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) Found layout at 4 index 2017-04-16 14:26:10.303813+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ resource-request arrived layout 2017-04-16 14:26:10.311993+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ checking codec 10EC:900:100001 2017-04-16 14:26:10.320054+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ selecting from 6 files 2017-04-16 14:26:10.327790+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 0 layout 1/7 2017-04-16 14:26:10.335331+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 1 layout 2/7 2017-04-16 14:26:10.342886+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 2 layout 3/7 2017-04-16 14:26:10.350228+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 3 layout 5/7 2017-04-16 14:26:10.357559+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 4 layout 7/7 2017-04-16 14:26:10.364667+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) Found layout at 4 index 2017-04-16 14:26:10.387875+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ resource-request arrived paltform 2017-04-16 14:26:10.395367+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ checking codec 10EC:900:100001 2017-04-16 14:26:10.402750+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ selecting from 6 files 2017-04-16 14:26:10.409927+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 0 layout 1/7 2017-04-16 14:26:10.416987+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 1 layout 2/7 2017-04-16 14:26:10.424235+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 2 layout 3/7 2017-04-16 14:26:10.431344+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 3 layout 5/7 2017-04-16 14:26:10.438375+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 4 layout 7/7 2017-04-16 14:26:10.445416+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) Found platform at 4 index 2017-04-16 14:26:10.460728+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ resource-request arrived paltform 2017-04-16 14:26:10.467762+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ checking codec 10EC:900:100001 2017-04-16 14:26:10.474818+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ selecting from 6 files 2017-04-16 14:26:10.481526+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 0 layout 1/7 2017-04-16 14:26:10.488171+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 1 layout 2/7 2017-04-16 14:26:10.494585+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 2 layout 3/7 2017-04-16 14:26:10.501169+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 3 layout 5/7 2017-04-16 14:26:10.507676+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) alc @ comparing 4 layout 7/7 2017-04-16 14:26:10.513992+0200 localhost kernel[0]: (kernel) AppleALC: (DEBUG) Found platform at 4 index And there aren't any apparent difference in IOREG HDAU device comparing before-after changing the video card. As for applehda log there seem to be a new sound assertion comparing before-after changing the video card: gtx970: kernel: (AppleHDA) Sound assertion in AppleHDAEngine at line 9539 gtx1070: kernel: (AppleHDAController) Sound assertion in AppleHDAController at line 1434 kernel: (AppleHDA) Sound assertion in AppleHDAEngine at line 9539 I dont know how to continue troubleshooting... Also it would be interesting if anybody with pascal video card could confirm if their hdmi audio is working using AppleALC. Thanks
  15. danif

    AppleALC — dynamic AppleHDA patching

    Hi, I have upgraded my graphic card to pascal gtx 1070 from gtx 970 and I've lost HDMI/DP Audio when using AppleALC. I've tried VoodooHDA and it detects HDMI outputs and reproduce sound. Could this be an AppleALC problem or maybe a Nvidia Web Driver problem? Any thoughts? Thanks.
×