Jump to content

Lenovo ThinkPad T420 with UEFI Only

* * * * * 45 votes UEFI ThinkPad T420 Lenovo Clover

Best Answer tluck, 08 October 2013 - 02:47 PM

Lenovo T420 Clover Guide  19-May-2017 Update

Various Releases and Tweaks over Last 6 months

Spoiler

Overview

Spoiler

New Installation Steps and Details

Spoiler

Part 1 - OS Installation

Spoiler

Part 2 - Post OS Installation and Setup on HD

Spoiler

Known Issues and Random Tips:

Spoiler

Notes on Custom Kexts

Spoiler

General Notes, Fixes, and Features

Spoiler

Optional: Create a custom SSDT

Spoiler

Go to the full post


  • Please log in to reply
3572 replies to this topic

#381
tluck

tluck

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,806 posts
  • Gender:Male
  • Location:NC, USA

Great news.

Not sure about restart issue. where does it hang?
Sound - should be easy to solve with voodoohda or there is alc269 codec applehda.kext available.
Wifi - have to get usb wifi (like the one you selected). it probably is RTL8191 or RTL8192 based. I have 3 of these in various sizes. they work ok.

or get apple-compatible internal wifi express card  - but then this gets a bit more tricky - first you have to replace the card and 2nd you must use a BIOS with WL removed 

Glad to see new things on this thread!



#382
okcakep

okcakep

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

Dear Expert,

 

Why im always kp on AppleIntelPower Management  if boot from HD ? but boot from USB stick its OK :(



#383
artur_pt

artur_pt

    InsanelyMac V.I.P.

  • Moderators
  • 6,240 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

have in the hd nullcpupowermanagement.kext ? to prevent that until u don't have native cpu power management ?

 

probably not.. but in the installer pen .. sure u have..

 

http://olarila.com/f...php?f=28&t=1716

 

good hack



#384
tluck

tluck

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,806 posts
  • Gender:Male
  • Location:NC, USA

@okcakep - as artur-pt points out, the lack of KP on the USB boot is probably due to having nullcpupm kext there.

 

are you booting your HD with Clover or Chameleon. either way, on your HD, you will need to make sure you patch AppleIntelCPUPowerManagement. Clover can do it automatically. 

related to this issue, is making sure you have a proper SSDT - are you dropping the SSDT table and having the bootloader generate a proper table? 

 

you did not give any details on what system your are running on, what OS, what boot loader.  as many of us do, please add a signature to help set the context for the problem.



#385
okcakep

okcakep

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

Dear Expert thanks for your fast answer,

 

@artur-pt thanks...i'll check..

 

@tluck thanks for your answer,

 

This is my step :

---------------------------------------------------------------------------------------------------------------------------------

My system T420 4236CTO

2G RAM

100G HD

VGA Intel 3000 no dual, intel 3000 only

Bios 1.46 version

--------------------------------------------------------------------------------------------------------------------------------

From Kogen Mantis setting BIOS

 

Essential:
Config > Serial ATA (SATA) > SATA Controller Mode Option [AHCI]
Security > Memory Protection > Execution Prevention [Enabled]

Security > Intel ® VT-d Feature [Disabled] ---> i dont have this setting

My other settings:
Security > Security Chip > Security Chip [Disabled]
Startup > UEFI/Legacy Boot [Both]
Startup > UEFI/Legacy Boot Priority [UEFI First]

 

--------------------------------------------------------------------------------------------------------------------------------

From your guide in post #1

1.

- 8GB+ USB pen-drive
- Legal copy of Mountain Lion install app ( 10.8.3 Golden )
- and an app called Lion Disk Maker
- my custom Clover Package: zip.gif  Clover_v2_r1625k0.pkg.zip 

- Till Making install media bootable on your ThinkPad

- Im replace EFI on pen-drive with T420-EFI-Clover-b1972

- Success, pen-drive ready for the boot

-------------------------------------------------------------------------------------------------------------------------------

After that

2.

- Boot from pen-drive -succes with lenovo logo, lion logo

- Format HD with GUID partition ( 2 partition - LION & DATA )

- Install Mountain Lion to -> LION Partition

- +_ 10 minute done

- Reboot

- Chose Mountain Lion from

- No Luck !!!

- Hard shutdown !!! with press shutdown button more than 5 time !!! :)

- Try boot with NoCaches, PCIRootUID=1/0, GraphicsEnabler=No/Yes, npci=0x3000/2000 no luck..!!!

- Hard shutdown, unplug power ( cable & battery ) wait 5 minute

- Luck...can boot to Installation process...:)

What the problem in this part ?????? pls help...

- Installation process +_ 20 minute, chose country, keybord, etc

- Yess...ML 10.8.3 on display

------------------------------------------------------------------------------------------------------------------------------

Step make booting from HD

3.

-Using - Clover Package: zip.gif  Clover_v2_r1625k0.pkg.zip

-Install clover on LION partition

-Mounting EFI,

 - mkdir /Volumes/efi

 - mount -t /dev/disk0s1 /Volumes/efi

-Replace CLOVER in /EFI/CLOVER directory with packet CLOVER in T420-EFI-Clover-b1972

------------------------------------------------------------------------------------------------------------------------------

Customize

4.

-Rename on directory OEM with 4236CTO

-Install dsdt.aml ( from Kogen Mantis ) on EFI/OEM/4236CTO/ACPI/patched/

-Using KextWizard install package from 1. Download Extra Folder: zip.gif  Extra.zip  post #1

-Reboot

 

------------------------------------------------------------------------------------------------------------------------------

No Luck !!! :D

5.

-No Luck boot from HD with anything parameter :)

-Luck boot from Pen-Drive with parameter NoCaches

-But glitch still appear

-No sound -->> Kogen Mantis patch post #22

 

-------------------------------------------------------------------------------------------------------------------------------

 

I hope can solve :)

 

Thank you...

 

 



#386
tluck

tluck

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,806 posts
  • Gender:Male
  • Location:NC, USA

@okcakep

 

the T420-EFI-Clover zip file should have everything you need to get up and running - custom kexts matching the included newer dsdt.aml.  you wont need to install kogens package or extra zip files.

i had some problems with kogens dsdt when i tested it at one point (audio issues primarily)

 

you should be able to get running with slight modification in your steps 3 and 4 above. reread my post (closely at bottom) -            #241             it has some instructions on how to install/replace your ESP (/Volumes/EFI) entirely /EFI/Boot /EFI/Clover (need both inititially) - instead of using the older 1625 version kogen packaged up.

 

without the OEM folder matching,  this should allow you to boot up using a totally vanilla OSX. (not everything works of course). But from there, then you can complete the customization - install/replace the kexts in the zip 10.8-SLE into your /S/L/E directory. (i have all the kexts in /EFI zip kext folder in my /S/L/E.)

then you can rename the 4236AT9 and make any mods to match your CPU and display -  1600x900 vs low-res. 

 

do you have 2.5Ghz i5 CPU? if not, you need modify the config.plist CPU section to match in the OEM folder.



#387
Tetonne

Tetonne

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 428 posts
  • Gender:Male

10.8.5 ok here.

 

Install, before reboot, put kexts in SLE

repair

reboot

 

 

to update config

in the OS start the Terminal and enter:

/usr/local/bin/clover-genconfig >config.plist
 
new config structure config is required 
not so easy to update
here is mine


#388
okcakep

okcakep

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

@tluck   Work !!!.....but..in minute KP :(



#389
okcakep

okcakep

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

Done...using chrome for MAC

Using 10.8.4 ( after upgrade ) no issue

 

@Tluck, how to get VGA out ?



#390
ag6952563

ag6952563

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts

 

10.8.5 ok here

 

 

to update config

in the OS start the Terminal and enter:

/usr/local/bin/clover-genconfig >config.plist
 
new config structure config is required 
not so easy to update
 
config configurator doesn't allow to import config.plist to customize it

 

Hi Tetonne-

Any special instructions to upgrade to 10.8.5? Did you have to restore any of the custom kexts?

 

Thanks,

AJ



#391
okcakep

okcakep

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

Done...using chrome for MAC

Using 10.8.4 ( after upgrade ) no issue

 

@Tluck, how to get VGA out ?

I'll try with your post #325 :)

Wait for update



#392
tluck

tluck

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,806 posts
  • Gender:Male
  • Location:NC, USA

T420 users. 

 

2 quick things .... and will update a final/new 10.8.5 zip using clover 2082 later on when I get it stabilized.

 

1) 10.8.5 Update: took awhile but building a successful 10.8.5 installer was not obvious! (vs using the combo update process).  There is an issue with BlueTooth that kept hanging me up. In the end, i was successful in making a Clover UEFI ML Disk tool (Lion Disk Maker) installer for 10.8.5 as well as a "you-nibeest" MBR installer. essentially I had to disable BT in the BIOS to get these to work. Then later on reenable BT and then I had to edit the BT kext (which seems to change in 10.8.5)

/System/Library/Extensions/IOBluetoothFamily.kext/Contents/PlugIns/BroadcomBluetoothHostControllerUSBTransport.kext/Info.plist - change 8532 to 8575. 

 

2) Clover 2082 Update: quite a bit changed in the layout of the config.plist structures, so i will repost with this version soon too! They moved and expanded some of the variable structures. i still seem to need to need a custom ssdt.aml but it does a lot better job on figuring out the CPU and and bus speeds automatically. i now get SpeedSteps 31x and 32x! (dont recall those from before).

 

Bottom line. 10.8.5 does replace a few of the custom kexts so be prepared to replace them. I will look at patching up the AppleHDA for 10.8.5 as well. but for a quick fix, rollback works.



#393
Sheep_Reaper

Sheep_Reaper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
  • Location:Palmerton, PA, USA

Tluck,

 

I'm interested in testing both the 10.8.5 update and the Clover update on my T430. So It you have something I can test, please let me know. I tried using a plain install of the new Clover but was unable to boot with my current config. I haven't applied the 10.8.5 update either. I don't have any custom kexts loaded in OSX so I don't think that the update will break it, but how does it affect the custom kexts I load through clover? I'm still figuring out clover.


Great news.

Not sure about restart issue. where does it hang?
Sound - should be easy to solve with voodoohda or there is alc269 codec applehda.kext available.
Wifi - have to get usb wifi (like the one you selected). it probably is RTL8191 or RTL8192 based. I have 3 of these in various sizes. they work ok.

or get apple-compatible internal wifi express card  - but then this gets a bit more tricky - first you have to replace the card and 2nd you must use a BIOS with WL removed 

Glad to see new things on this thread!

Also @Tluck

 

It hangs after the system unloads. the console outputs all of the kill messages and then the console itself unloads, but then it hangs at the black. Backlight's still on, and the fan's running but I assume that the system is down at that point. I remember someone mentioning something about this earlier in the thread, but it might have been related to a different machine. How would I log the events at the end of system life? I'm sure there is some additional output after the display output unloads but before the full system shutdown. I have no experience in system shutdown process. I'm operating on the assumption that it's opposite of the boot process.



#394
TimeWalker75a

TimeWalker75a

    InsanelyMac Legend

  • Gurus
  • 1,249 posts
  • Gender:Male

It hangs after the system unloads. the console outputs all of the kill messages and then the console itself unloads, but then it hangs at the black. Backlight's still on, and the fan's running but I assume that the system is down at that point. I remember someone mentioning something about this earlier in the thread, but it might have been related to a different machine. How would I log the events at the end of system life? I'm sure there is some additional output after the display output unloads but before the full system shutdown. I have no experience in system shutdown process. I'm operating on the assumption that it's opposite of the boot process.

It's a bug with UEFI firmware (Tiano) that only happens when booting UEFI Clover. The bug is as old as the option to boot UEFI Clover (dating all the way back to June 2012). There wasn't any solution to this problem and more and more people (even on desktop machines) are getting this issue. One of the developers (apianti) has promised to look into the issue, but without logs and memmap dumps (DarwinDumper) from both CloverEFI and UEFI Clover from same machine there is no way it can be solved. Developers need debug material to work with (this is how immediate restart after sleep issue on AMI Aptio was solved on desktop boards).



#395
Sheep_Reaper

Sheep_Reaper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
  • Location:Palmerton, PA, USA

Thanks TimeWalker,

 

I wish people were this helpful offline as well  :lol:

 

Now pardon my ignorance:

What is the difference between CloverEFI and UEFI Clover? I was not aware of the distinction. Are you referring to Clover being able to boot in both EFI mode and legacy mode? Or am I way off the mark here?

 

Sorry in advance...


@All

 

I've noticed significant differences between UEFI vendors. I am wondering if others have had similar encounters. The UEFI on my ASUS K55A allows me to directly boot from any fat32 partition where it finds /boot/EFI/bootx64.efi or /EFI/bootx64.efi Boot sectors are not required at all. I first noticed this when I converted a Win8 install from MBR with BIOS boot to GPT with UEFI boot. It was super simple and didn't require copying boot sectors. I can also add UEFI boot options to my Boot menu as I want. I can actually install multiple bootx64.efi's in the same partition and create a separate Boot option for each one. I thought this was pretty cool. However, on my T430 which presumably is more advanced, has no such options.

 

Any thoughts?



#396
tluck

tluck

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,806 posts
  • Gender:Male
  • Location:NC, USA

@bryan G - 

 

CloverEFI means essentially booting by MBR to the Clover GUI vs using UEFI directly to bring up the Clover GUI

 

 

(BIOS MBR -> boot0->boot1->boot->CloverX64.efi) versus

 direct UEFI (UEFI -> CloverX64.efi). 

 

on the laptop, if i select a GPT disk to boot, it will scan the ESP partition and look for /EFI/Boot/bootx64.efi - which is exactly the same thing as /EFI/CLOVER/Cloverx86.efi. 

however, if i select boot from a MBR formatted disk, then it will look in the MBR for boot0. 



#397
tluck

tluck

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,806 posts
  • Gender:Male
  • Location:NC, USA

Updated 8-Oct-2013 - This old and pretty out of date -  moved on to Mavericks and Yosemite (10.9 and later) here Clover UEFI on T420 Guide

 

Attached is a current full /EFI pack for T420 on Clover and OSX 10.8.5 (12F45)

 

see instructions from post 486

 

Update 4-Oct-2013

  • Revised DSDT
    • for Shutdown hang (thanks to TimeWalker75a)
    • for native ACPIPlatform kext - no need to rollback or patch AppleACPIPlatform.kext - can use unmodified v1.8 from 10.8.5 (see notes below).
    • made a change/fix to reset LEDs upon wakeup.
  • Updated Clover to b2165 b2184
  • Updated AppleIntelE1000e.kext
  • Updated FakeSMC
  • Updated VoodooPS2Controller
  • Added Patched AICPUPM kext for Chameleon compatibility.

Attached is a current full /EFI pack for T420 on Clover and OSX 10.8.5 (12F45)

  • Updated config.plist for Clover 2k
  • OEM 4236AT9 is for 1600x900 i5-2520M (with ssdt.aml)
  • OEM 4236Y33 is for 1366x768 
  • Removed CPU sections from the config.plist (as Clover compute Bus Speed ok now - check it though! should be around 99676 - 99700 
  • Kext Bundle for 10.8.4 is post #241

ACPI Notes:

  • the new DSDT conforms (more) to the native unmodified kexts ACPI spec... so dont have to replace the AppleACPIPlatform.kext. 
  • native AppleACPIPlatform.kext v1.8 (10.8.5)  some issues with Power button lights after wake. - fixed with new DSDT.
  • native AppleACPIPlatform.kext v1.7 (10.8.4) works but does not wake as well when you have external eSATA/USB drives. 

Notes:

there are 2 kext folders 

10.8 (which are good for vanilla boot) before using OEM folder and/or modified kexts are in place.

  • FakeSMC.kext (v5.2.877) - Kozlek's core hack mechanism + plugins - Note: Follow link to download full package - so you can install HWMonitor.app etc (just select Plugins ACPI and CPU)
  • VoodooPS2Controller.kext (v1.8.8) - RehabMans's PS2 Keyboad/Trackpad -   Note: Follow link to get full package and installation instructions to install daemon may still be subject to random sleep/wake issues... versions 1.8.5+ are proving to be more reliable.
  • AppleIntelE1000e.kext (v2.5.4) - gigE - goes in /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns

10.8-SLE which can be combined with above and will replace your /S/L/E versions.

  • AppleHDA.kext (v2.4.7 patched from 10.8.5)- for full audio support - note: requires matching DSDT sections using Conexant Codec and layoutID 12.
  • AppleACPIPlatform.kext (v1.7) - upgraded to ErmaC's Patched ML kext for sleep/wake + battery
  • ACPIBatteryManager.kext (v1.40) VoodooBattery.kext - Rehabman's kext configured for v3 ACPI per his instructions to show/track battery info on menu bar - requires rollback AppleACPIPlatform.kext
  • BroadcomBluetoothHostControllerUSBTransport.kext (v4.1.7 with patched Info.plist from 10.8.5) - adds ProductID 8575 to make BT work! Put/replace one in /S/L/E/IOBluetoothFamily.kext/Contents/PlugIns
  • IOAHCIBlockStorageInjector.kext -  makes DVD an internal device so iDVD player works. 

​10.8-Chameleon - extra patched kexts for use with Chameleon 

  • AppleIntelCPUPM.kext (patched v214.0.0 from 10.8.5) - not really necessary to install/replace with clover since it does the patching. Optional Install in /S/L/E for Chameleon compatibility.

 

The DSDT (in OEM) has some new mods in the IGPU are that seem to remove glitches/hangs on either Clover or Chameleon - go figure?! And there is generic/low-res dsdt for non-1600x900 users to try.

 

Basic instructions and notes:

  1. install vanilla 10.8.5 to GUID formated disk - use USB or other method
    1. You can use this zip to build a clover based USB built by Lion Disk Maker - or other method create an Installer
    2. Note: you may need to disable BlueTooth in the BIOS to install 10.8.5 directly. Enable later when you boot up.
  2. install standard Clover into ESP - use link to download from sourceforge.
  3. mount ESP on /Volumes/ESP and replace /Volume/ESP/EFI with contents in zip
  4. boot up vanilla 10.8.5 with clover - this will use the kexts and "top" level config.plist (rename OEM to OEM.NU for now)
  5. now install kexts from ESP or zip to boot drive into /S/L/E (from /EFI/CLOVER/kexts/10.8 and 10.8-SLE) or use myhack method. see notes above
  6. here is the tricky part - fix OEM folder to match your system 
  7. DO NOT just hastily rename the folder OEM to match your productID -  you may need to modify some things to make it compatible with your specific model details.
    • If you have 1600x900 LCD, you can probably just use items as is - that is rename 4236AT9 to match your product name.
    • If you have 1366x768 LCD, you can probably just use items as is - that is rename 4236Y33 to match your product name.  Note: if you have similar CPU as i5-2520, the SSDT.aml from 4236AT9 may work for you (copy from 4326AT9/ACPI/patched)

Update: There is just a slight differences between these 2 config.plist files now - really just about the LCD resolution and EDID injection for high-res.

Attached Files


Edited by tluck, 24 January 2016 - 08:46 PM.


#398
Sheep_Reaper

Sheep_Reaper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
  • Location:Palmerton, PA, USA

Link to your zip?



#399
Sheep_Reaper

Sheep_Reaper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
  • Location:Palmerton, PA, USA

Thanks, so far everything T420 related has been useful in figuring out T430 stuff. So anything I can use from you guys is always helpful.

 

Also, I believe that I've just confirmed that Gendalo's and my DSDT's are identical. Unless I did something wrong: I dumped my DSDT.aml using Clover. I decompiled it and Gendalo's with a DSDT utility, and then made plain text's from them so I could plug them in to a text file comparator and they came up equal. So, unless I did something wrong, for which there is lately a large possibility, I think they are the same. Both of our machines are 2349XXX so is it likely that they would share the same DSDT?



#400
tluck

tluck

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,806 posts
  • Gender:Male
  • Location:NC, USA

@Bryan - good to know! generally the dsdt will be similar on each model. each BIOS update may tweak minor stuff.

 

Note: the source dsdt.dsl from the T420 is in the zip - marked with comments (look for tjl )

 

yeah I too used Clover and its capability to patch the DSDT. I booted up without my custom DSDT using fixmask 0xFFFF and extracted the DSDT using EVO DSDT. then hand edited/retrofitted some other fixes from other folks. many of the edits/fixes etc in the T420 dsdt should apply.

 

The zip is back on the post above.







Also tagged with one or more of these keywords: UEFI, ThinkPad, T420, Lenovo, Clover

  Topic Stats Last Post Info

4 user(s) are reading this topic

1 members, 3 guests, 0 anonymous users


© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy