Jump to content

Lion kernel testing on AMD (don't ask help here: use the Help Topic)


  • Please log in to reply
605 replies to this topic

#261
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male
Hi, Shane!

Yes, they do: no need to use the insn patcher. Hats off to Bronzovka also for this. Until now, the only major issue is VMWare Fusion not working and crashing the system (that also happened on 10.6.8 with AnV's kernel, though). The crash can be reproduced: it always happen in the moment i try to open the application. In the end, this is an advantage, since it's easier to investigate than a random type of KP. I'll do more testing later today.

Best regards.

My FX8120 is booting with connactics 10.7.5 kernel to the point where the Desktop should show up!
For me, with a GTX660 the 10.7.5 isn´t usable!


Hi, misterfrista: the connactic 10.7.5 should work without issues with your Bulldozer. The problem here is the Keppler card (GTX660) which only started to be used very recently with real Macs. Mountain Lion support Keppler natively, as should Lion 10.7.5: try either booting with GraphicsEnabler=No or using Clover to boot your system.

Best regards!

#262
misterfrista

misterfrista

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Münster
Thanks for the advice Theconnactic!
I will try this tomorrow as I did a clean install of 10.7.4 a few minutes ago and will update to 10.7.5 tomorrow maybe fortuna is with me :-D
I am just using Clover as chameleon gives me random KPs i dont get with Clover! I will report my results!

#263
Shaneee

Shaneee

    AMD Dev Tester

  • Local Moderators
  • 1,002 posts
  • Gender:Male
  • Location:Scotland
  • Interests:Web Design. OS X. Music.
Just installed and updated to 10.7.5 using Bronzovka's 10.7.5 kernel with arch=i386 and its working with no problems so far. Graphics is fully working on my GT 430. Audio and Ethernet also working. Geekbench giving a low score for some reason but it doesn't bother me.

Booting with arch=x86_64 results in the same problem as ML with black screen.

Using the latest version of Chameleon.

#264
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male
Perhaps the low Geekbench score is because of Spotlight indexing. If you try it after it's finished, it should improve.

Best regards!

#265
misterfrista

misterfrista

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Münster
Hey there!

Did my testing but it really seems to be graphic related! Tested both latest Chameleon with GraphicsEnabler=No and Clover!

With brov´s 10.7.5 kernel with arch=i386 / arch=x86_64 the system boots up and loads NVDAGK100Hal and nothing happens, not even a grey window!

I think the driver for my graphics is available in 10.7.5 as 10.7.4 doesnt find my graphicscard and starts the desktop without qe/ci but 10.7.5 doesnt start the desktop at all !

I´ll try to delete the NV related kexts and look if it boots up to locate the problem!

Greetings!

Edit: With deleted NV drivers the system boots up fine! My first impression is: Super! Stable 32bit and 64bit apps work without a problem and the response time of the whole desktop is much faster the in my 10.7.4 installation!

#266
Shaneee

Shaneee

    AMD Dev Tester

  • Local Moderators
  • 1,002 posts
  • Gender:Male
  • Location:Scotland
  • Interests:Web Design. OS X. Music.

Perhaps the low Geekbench score is because of Spotlight indexing. If you try it after it's finished, it should improve.

Best regards!


You were right. System been running stable now for 13 hours and here is Geekbench result,

http://browser.prima...kbench2/1684244

#267
Duran Keeley

Duran Keeley

    InsanelyMac Sage

  • Local Moderators
  • 349 posts
  • Gender:Male
I don't know if this has been answered, if so sorry for my double post.

Has anyone been able to run Xcode in Lion on AMD? booting with Bronzovka's 10.7.4 kernel in either x86_64 or i386 and running Xcode 4.6 for Lion. I just need it to get xcodebuild to work to use the command line. Tried "xcodebuild -licence" in terminal and that just skipped the part where the licence was ment to show up and I could type agree (so basically it crashed before showing the licence in terminal).

#268
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male
With Bronzovka's kernel, running 32-bit with support for 64-bit processes, ssse3 built-in, 10.7.4, Adobe CS6:

Working until now:

Flash
Flash Builder
Audition
DreamWeaver
FireWorks
InDesing
AcrobatPro
Speedgrade
MediaEncoder (sometimes)

Bridge starts but crashes when you try to actually use it.

Photoshop and Illustrator doesn't start. Premiere, Prelude and After Effects freeze while loading.

By the way, trying to boot the kernel in 64-bit mode (arch=x86_64) gives me the same kind of graphics corruption i get with Mountain Lion, rendering unusable.

Best regards.

#269
Duran Keeley

Duran Keeley

    InsanelyMac Sage

  • Local Moderators
  • 349 posts
  • Gender:Male

With Bronzovka's kernel, running 32-bit with support for 64-bit processes, ssse3 built-in, 10.7.4, Adobe CS6:

Working until now:

Flash
Flash Builder
Audition
DreamWeaver
FireWorks
InDesing
AcrobatPro
Speedgrade
MediaEncoder (sometimes)

Bridge starts but crashes when you try to actually use it.

Photoshop and Illustrator doesn't start. Premiere, Prelude and After Effects freeze while loading.

By the way, trying to boot the kernel in 64-bit mode (arch=x86_64) gives me the same kind of graphics corruption i get with Mountain Lion, rendering unusable.

Best regards.


@theconnactic

Have you got Xcode working in Lion? I have an idea for CS6 to use Wine. Problem is my Xcode doesn't wanna work.
You also said you had Bioshock working, is Bioshock in a Cider port or Wineskin? Cause then might be able to take a shortcut with compiling wine and macports.

My ATI works fine in Lion on x86_64 (using both Bronzovka's and IiTz ShAnE) but graphics corruption on ML.

#270
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male
No, it's retail (Bioshock).

Have you got Xcode working in Lion? I have an idea for CS6 to use Wine. Problem is my Xcode doesn't wanna work.
You also said you had Bioshock working, is Bioshock in a Cider port or Wineskin? Cause then might be able to take a shortcut with compiling wine and macports.


Use Wineskin Winery! About Xcode, i'll download it and test it in a minute. It used to work like a charm with 10.6.8 and AnV's kernel.

#271
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male
Confirmed: Xcode also doesn't work with Bronzovka's 10.7.4 kernel in 32-bit kernel mode, either 3.2.6 or 4.5.x. Booting in 64-bit kernel mode with -x (safe boot) bypasses the graphics corruption, so i tested both Xcode and the CS6 Suite running full 64-bit. Unfortunately, both don't work, although i was able to grab some crash reports.

Best regards!

#272
Duran Keeley

Duran Keeley

    InsanelyMac Sage

  • Local Moderators
  • 349 posts
  • Gender:Male
@theconnactic

Wine seems to be the best workaround I can find at the moment, Just did a Wine install on SL (booted with i386 -force64) and boom Photoshop CS6 opens.

See attached

Kind Regards
Duran Keeley

EDIT: Xcode 3.2.5 works in Lion & Xcode 4.1 for Lion, right click on Xcode and tick Open in 32-bit Mode.

BUT still got a problem with xcodebuild in terminal with Xcode 4.1

Attached Files



#273
byransays

byransays

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Upstate NY

UPDATE 3: My first seemingly random KP in 72 hours: happened when i was trying to install a 10.7.4-compatible Sleepenabler (there aren't many around, and i used that: http://www.osx86.net...&id=2710&page=3). As soon as i typed my password in KextUtility, the dreaded multilingual box of death appeared. Unfortunately, i wasn't in verbose mode, and log log of it persisted in my system, so i cannot be sure of what caused it, since it just repeated the process and nothing happened.


Hey, did you ever get sleep working? Thats all I need now but I cant seem to get it with any of these 64-bit kernels. It used to work fine with the old legacy ones.

#274
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male
Yes, i did: see my post in the previous page. But i'm using 32/64-bit hybrid mode (arch=i386) with Bronzovka's latest 10.7.4 kernel (link in the Kernel Database wiki page).

Duran, the 32-bit workaround did just fine for Xcode 3.2.6, thank you. Unfortunately, Xcode 4.x is 64-bit only. Goin to wrap Photoshop CS6 for Windows with Wineskin Winery to see if i succeed.

Best regards!

#275
byransays

byransays

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Upstate NY

Yes, i did: see my post in the previous page. But i'm using 32/64-bit hybrid mode (arch=i386) with Bronzovka's latest 10.7.4 kernel (link in the Kernel Database wiki page).

Duran, the 32-bit workaround did just fine for Xcode 3.2.6, thank you. Unfortunately, Xcode 4.x is 64-bit only. Goin to wrap Photoshop CS6 for Windows with Wineskin Winery to see if i succeed.

Best regards!


Yes same here, I have tried arch=i386 -force64, arch=x86_64 and both with his 10.7.4 kernel and 10.7.5 kernel. No dice with any.

#276
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male
Well, i think we can live with Xcode 3.2.6, but it's the imperfection inside the kernel which is shown by 64-bit versions of Xcode and the main Adobe apps not opening that bothers me.

Best regards!

#277
Duran Keeley

Duran Keeley

    InsanelyMac Sage

  • Local Moderators
  • 349 posts
  • Gender:Male
theconnactic, Yeah would be great if they worked but that is what hackintosh is all about :) for now Wine seems to be the way, let me know how wineskin does, I know in the Wine AppDB they had to install some wine tricks for some independices, but I'm not sure if that was just for the install. Lucky to build a custom engine with those independices needs Xcode which I think we have got sorted now, does xcodebuild work in terminal on Xcode 3.2.6 in lion?

EDIT: theconnactic, Wineskin works like a dream in Lion. Photoshop CS6 using Wineskin, see attached.

Attached Files



#278
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male
Great! Going to test it here already!

Best regards!

#279
Duran Keeley

Duran Keeley

    InsanelyMac Sage

  • Local Moderators
  • 349 posts
  • Gender:Male

Great! Going to test it here already!

Best regards!


Are you gonna use the Officially Adobe Installer? Cause i've tried 2 portables of Illustrator, one crashed and another opens but as soon as you create a new document, or even open a document it crashes.

#280
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male
Yes, the retail installer of the entire suite.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy