Jump to content

iMessage not working - iCloud/Internet etc working - Changed boot.plist file and network.plist file - Help


  • Please log in to reply
419 replies to this topic

#201
3square

3square

    InsanelyMac Protégé

  • Members
  • PipPip
  • 90 posts

Hi
This method works great.
I installed clover to usb then stuck my kext from my extra folder in to the efi kexts folder and dsdt.aml in to root of usb.
Rebooted from usb and took not of the s/n it gave me + 1 to 6 in numbers added it to the config.plist and rebooted with usb stick
Imessage then gave me an error about i could not use this apple id contact support.
I signed in on my iPod then retried and bingo all working fine.
The bonus is now when i boot into chameleon its stays logged in as i had boot1 error trying to install clover to my hdd

in plist file


<key>RtVariables</key>
<dict>
<key>MLB</key>
<string>XXXXXXXXXXX123456</string>
</dict>

Link to clover r980 http://sdrv.ms/SkZSLc


awesome this is what i've done too. usb and it stay logged in.

thanks

#202
fau7i

fau7i

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 111 posts
  • Gender:Male
  • Location:Malaysia

MLB is not the same as serial number. It starts with the same few characters but it is the the Main Logic Board (i.e. motherboard) serial number which is not the same as system serial number. I don't think it's yet known if that needs to be unique so try creating a dummy one with the first 3 characters of your system serial number (i.e. C02) and then 14 other characters. For ROM, use the ethernet mac of en0 on your hack. I don't have time to test whether this works but its worth a shot for those of you without a real mac to use the values from.

Worked this way for me. Clover adds the ROM for you from the ethernet MAC so it's not necessary.

With Clover r980, adding 5 more characters at the end of system serial number ( C02XXXXXXXXXFAU7I ) does the job. And yes, ROM isn't necessary here.

#203
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

Download and install Clover_v2_rL980.zip and use default settings other than setting it to HFSPlus.efi, OsxFatBinaryDrv-64.efi because i have a Gigabyte GA-EP45-UD3P (rev 1.1), F10 Bios, then and

<key>RtVariables</key>

<dict>

<key>MLB</key>

<string>XXXXXXXXXXX123456</string>

</dict>

to some kind of plist, and I'm good?

It's added to the config.plist which is Clover's version of org.chameleon.Boot.plist. The MLB is going to be the same serial # your already using/have now that can be seen in System Information. You just need to add some junk to make it a little longer, i.e. 17 digits instead of only 11 digits.

#204
dannymichel

dannymichel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 298 posts
  • Gender:Male
Ok, so the other stuff was correct then? About using that option for my board, and leaving the other settings as default when I install clover to / on my HDD?

#205
Regi Yassin

Regi Yassin

    Who am I ?

  • Members
  • PipPipPipPipPip
  • 278 posts
  • Gender:Not Telling
i have already raid0 setup for my hack, and usechameleon to boot, i would like to use clover to fix this issue, but how to install clover to raid0, just use the installer pkg?
sorry if outoftopic

#206
cosmo1t

cosmo1t

    InsanelyMac Protégé

  • Developers
  • 98 posts
  • Gender:Male
Please quit spamming this thread w/ clover install issues. moderator could you lock this thread unless people have any more valuable information to post.

#207
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
I'd rather keep it open for now, since fix is still new, on topic discussion may still be needed.

So please stay on topic people!

Clover questions and stuff go here: Clover General discussion

Will try to put together a quick and easy "how to" or something a bit later.

#208
dannymichel

dannymichel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 298 posts
  • Gender:Male

I'd rather keep it open for now, since fix is still new, on topic discussion may still be needed.

So please stay on topic people!

Clover questions and stuff go here: Clover General discussion

Will try to put together a quick and easy "how to" or something a bit later.

aw man, ok, fantastic. I will hold off trying to do this on my own until you post the how to!

#209
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Posted a how-to here: http://www.insanelym...ges-fix-how-to/ I may have missed somethings, but hope it helps. I'll keep it pinned at the top of the list for a week or two.

#210
dannymichel

dannymichel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 298 posts
  • Gender:Male
YES! We all owe eep357 our first daughters for making fixing iMessage easier!

#211
Kynyo

Kynyo

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 246 posts
  • Gender:Male
  • Location:Not your bisnizz...
  • Interests:
I think I need to complete "SMBIOS" zone in config.plist, hard try, again again and again "Call support" error ....

#212
dannymichel

dannymichel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 298 posts
  • Gender:Male
Can't wait for the new MyHack installer with Clover

#213
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 757 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

I think I need to complete "SMBIOS" zone in config.plist, hard try, again again and again "Call support" error ....

+1. Struggling to make it work.

I think I need to complete "SMBIOS" zone in config.plist, hard try, again again and again "Call support" error ....

+1. Struggling to make it work.

#214
ncmontas

ncmontas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
<key>SMBIOS</key>
<dict>
<key>BiosReleaseDate</key>
<string>02/29/08</string>
<key>BiosVersion</key>
<string>MP31.88Z.006C.B05.0802291410</string>
<key>Family</key>
<string>MacPro</string>
<key>Manufacturer</key>
<string>Apple Inc.</string>
<key>ProductName</key>
<string>MacPro3,1</string>
<key>SerialNumber</key>
<string>xxxxxxxxxxx</string>
<key>Board-ID</key>
<string>Mac-F42C88C8</string>
</dict>
<key>RtVariables</key>
<dict>
<key>MLB</key>
<string>xxxxxxxxxxx234567</string>

I already installed clover r980 and added the MLB on config.plist as stated above, booted fine, but unfortunately still cannot get iMessage to work. Any help is appreciated

#215
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 757 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

<key>SMBIOS</key>
<dict>
<key>BiosReleaseDate</key>
<string>02/29/08</string>
<key>BiosVersion</key>
<string>MP31.88Z.006C.B05.0802291410</string>
<key>Family</key>
<string>MacPro</string>
<key>Manufacturer</key>
<string>Apple Inc.</string>
<key>ProductName</key>
<string>MacPro3,1</string>
<key>SerialNumber</key>
<string>xxxxxxxxxxx</string>
<key>Board-ID</key>
<string>Mac-F42C88C8</string>
</dict>
<key>RtVariables</key>
<dict>
<key>MLB</key>
<string>xxxxxxxxxxx234567</string>

I already installed clover r980 and added the MLB on config.plist as stated above, booted fine, but unfortunately still cannot get iMessage to work. Any help is appreciated

What did you get about the error?

#216
rcork

rcork

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 167 posts

<key>SMBIOS</key>
<dict>
<key>BiosReleaseDate</key>
<string>02/29/08</string>
<key>BiosVersion</key>
<string>MP31.88Z.006C.B05.0802291410</string>
<key>Family</key>
<string>MacPro</string>
<key>Manufacturer</key>
<string>Apple Inc.</string>
<key>ProductName</key>
<string>MacPro3,1</string>
<key>SerialNumber</key>
<string>xxxxxxxxxxx</string>
<key>Board-ID</key>
<string>Mac-F42C88C8</string>
</dict>
<key>RtVariables</key>
<dict>
<key>MLB</key>
<string>xxxxxxxxxxx234567</string>

I already installed clover r980 and added the MLB on config.plist as stated above, booted fine, but unfortunately still cannot get iMessage to work. Any help is appreciated


Do you have the ending </dict> for the RtVariables section. You can also try setting ROM variable but that shouldn't matter.

#217
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 757 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

Do you have the ending </dict> for the RtVariables section. You can also try setting ROM variable but that shouldn't matter.

Hi, rcork. Do you have answers for the call Apple issue ?
Ive changed my appleid's password and the time. But it just didn't work. :(

#218
rcork

rcork

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 167 posts

Hi, rcork. Do you have answers for the call Apple issue ?
Ive changed my appleid's password and the time. But it just didn't work. :(

I don't. I've never seen that error. Are you setting both the ROM and MLB variables?

#219
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 757 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

I don't. I've never seen that error. Are you setting both the ROM and MLB variables?

Nope. Only the MLB values. I tried setting both, not working.

#220
rcork

rcork

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 167 posts

Nope. Only the MLB values. I tried setting both, not working.


By chance do you have a real mac to try logging in with your apple id to see if you still get the error. That would help narrow down to whether this is a problem with the hack or a problem with your apple id.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy