Jump to content

10.8.2 Final! (C54)


  • Please log in to reply
127 replies to this topic

#21
Ricksterm

Ricksterm

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:England
No issues with the update with the specs below - all working great! :)

#22
XanthraX

XanthraX

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:Romania
Me the same. But at the finishing of the installation it said: Could not install the update because of an error occured. After restart it was 10.8.2.

#23
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,822 posts
  • Gender:Male
Did you update via App Store, Xanthrax? With my system was just the same: error message but everything worked as expected after reboot.

#24
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 740 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

Did you update via App Store, Xanthrax? With my system was just the same: error message but everything worked as expected after reboot.

mine works fine.
but my battery isn't as good as yours :(

#25
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,822 posts
  • Gender:Male
PH, did your battery get better with ML (especially the updates), did it get worse or stayed just the same as with Lion/Snow Leopard?

Remember that mine is a netbook. With Windows 7, it used to get easily 240+ minutes (because of full sleep/speedstep support, which i don't achieve yet with Mountain Lion).

#26
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 740 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

PH, did your battery get better with ML (especially the updates), did it get worse or stayed just the same as with Lion/Snow Leopard? Remember that mine is a netbook. With Windows 7, it used to get easily 240+ minutes (because of full sleep/speedstep support, which i don't achieve yet with Mountain Lion).


:) maybe it's better to quote my post, so that I can notice your reply to me.

I don't think I achieve better battery life.
Even worse, when my battery is low, my hack even cannot tell me how much time I left
But when it's full or much left, my hack were ale to tell me nearly 2 hours left

After one night's sleep, both windows and mac drop nearly 20% battery life.
So I suppose they would be almost same.

#27
Snow

Snow

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 364 posts
  • Gender:Male

if your computer wont boot or acpi state not working try this kext.



Exactly what I needed to do to avoid KP, thanks a lot m8!
Too bad hack updates are still a game of lottery, even with very compatible hardware.
What would be the cause of the ACPI panic?

#28
stackcheese

stackcheese

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
how do you use the AppleACPIPlatform.kext.zip?

#29
b0dyr0ck2008

b0dyr0ck2008

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:UK, London
I got this when I updated and rebooted, not a KP - don't know what it is but won't go any further:

Attached File  ImageUploadedByTapatalk1348135718.873424.jpg   217.1KB   280 downloads

#30
RobertX

RobertX

    InSanelyMac Maverick

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Not Telling

I got this when I updated and rebooted, not a KP - don't know what it is but won't go any further:

Attached File  ImageUploadedByTapatalk1348135718.873424.jpg   217.1KB   280 downloads

...i'm thinking it is a panic...caused by a plugin inside fakesmc.kext(OemSMbios.kext) ...find and remove that...reboot

#31
b0dyr0ck2008

b0dyr0ck2008

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:UK, London
Removed oemsmbios and repaired permissions etc. now got Voodoohda KP so going to delete that and see what happens

#32
Snow

Snow

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 364 posts
  • Gender:Male
@ stackcheese and bodyrock2008:

DL Kext Utility and AppleACPIPlatform kext

Now, I do this manually but I think Kext Utility will do this automated by replacing the kext.
Do not open Kext Utility instead slide the AppleACPIPlatform kext onto the Kext Utility icon, it should then ask for your admin password, replace the file and repair permissions, reboot and report back.
In case it does not want to replace remove the kext first from System/Library/Extensions, manualy move the new one in and then open up Kext Utility which will repair permissions, reboot and report back.

Good luck!

#33
b0dyr0ck2008

b0dyr0ck2008

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:UK, London

@ stackcheese and bodyrock2008:

DL Kext Utility and AppleACPIPlatform kext

Now, I do this manually but I think Kext Utility will do this automated by replacing the kext.
Do not open Kext Utility instead slide the AppleACPIPlatform kext onto the Kext Utility icon, it should then ask for your admin password, replace the file and repair permissions, reboot and report back.
In case it does not want to replace remove the kext first from System/Library/Extensions, manualy move the new one in and then open up Kext Utility which will repair permissions, reboot and report back.

Good luck!


All done and booted ok. Now how do I know if everything is working as it should? I'm an old hat at windows but this is all a little new to me

#34
khe91

khe91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
  • Location:Germany

if your computer wont boot or acpi state not working try this kext.



After I disabled VT-d in BIOS it also works with the original 10.8.2. AppleACPIPlatform.kext.
Using a Gigabyte GA-Z77X-UP5 TH with BIOS F9.

#35
bergoulle

bergoulle

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
  • Gender:Male
Update went fine here. Huge Boost performances
Whats the version of the new AppleACPIPlatform.kext ?

Mine is still showing this :


AppleACPIPlatform:

Version: 1.6
Last Modified: 25/06/12 08:03
Kind: Intel
Architectures: x86_64
64-Bit (Intel): Yes
Location: /System/Library/Extensions/AppleACPIPlatform.kext
Kext Version: 1.6
Load Address: 0xffffff7f807ad000
Valid: Yes
Authentic: Yes
Dependencies: Satisfied

Edited by bergoulle, 20 September 2012 - 04:40 PM.


#36
quis

quis

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
Used the combo this time.
Re-added my 4850 id and replaced AppleHDA with my working one and it's done.
No problem.

#37
stefano.85

stefano.85

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
  • Gender:Male
  • Location:Italy
Updated fine just 15 minutes ago here on first system in signature... just had to replace applehda for audio and relaunch trimenabler for ssd trim support... all works fine! cheers

#38
Riley Freeman

Riley Freeman

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 848 posts
  • Gender:Male
  • Location:The Streets

Update went fine here.
Whats the version of the new AppleACPIPlatform.kext ?


Confusingly, the version is still 1.6. But the binary inside has changed. I md5-summed the old and new ones to see for myself.

Anyone who needed to rollback ACPIPlatform, are you using the ACPISensors or OemSMBIOS kexts? I'm just wondering what triggers the problem with the updated kext. I use Kozlek's HWSensors branch of FakeSMC but only with the CPU, GPU and MB sensor kexts.

#39
iRipper

iRipper

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 151 posts
  • Gender:Male
Updated with no issues :)

#40
mtek

mtek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts
Updated my Toshiba Qosmio laptop successfully through software update but it wouldn't go past the apple logo on reboot - (no such issues with 10.8.1 update before.
Solution? Replaced the AppleACPIPlatform.kext forom unixservice - thanks a lot for that!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy