Jump to content

Intel 82566mm Ethernet works on Mac OS X (Leopard 10.5.3)


  • Please log in to reply
186 replies to this topic

#21
Flatfoot

Flatfoot

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
Hi Riccardo70,

Could you explain me how to install this drivers step by step?

I have a HP Pavillon m8125X with the same ethernet card and I don't know what to do with this files.

Thanks for your help!

#22
SticMAC™

SticMAC™

    "Nobody likes a SmartASS"

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,590 posts
  • Gender:Male
  • Location:Da Bathroom!!
Has anybody PM'ed BigDADDYRob, to let him know he can update his signature now!!


StiCMAN

#23
chriswong

chriswong

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
I have a Lenovo X200, but still no clue how it works..
tried to install by kexthelper b7 but failed..

#24
kytzu

kytzu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 295 posts
  • Gender:Male

Hi Riccardo70,

Could you explain me how to install this drivers step by step?

I have a HP Pavillon m8125X with the same ethernet card and I don't know what to do with this files.

Thanks for your help!


put the *.kext file on your desktop and use pcwiz's tool (kext installer button) and install it on osx partition and reboot.

#25
chriswong

chriswong

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Just installed on Lenovo X200 (Centrino 2) and finally works!

I work it on kext helper 0.7

Unzip and open Intel82566MM folder
copy the Intel82566.kext folder to kext helper 0.7

easy install

then a new ethernet is detected! As simple as that!

#26
riccardo70

riccardo70

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Italy-Sicily
Flatfoot listem me.....download the last version of the kext in this link http://techresearchinfo.blogspot.com/ ..this is the dingguijin forum...download the package in the first post...the first link!!!!unzip
you will find many files but you only take the Intel82566MM.kext


1 - open the terminal and digit kextstat - enter...
to catch your system information: the version of com.apple.iokit.IONetworkingFamily - com.apple.iokit.IOPCIFamily - com.apple.kpi.bsd - com.apple.kpi.iokit - com.apple.kpi.libkern - com.apple.kpi.mach.

2 - now open and scroll the
Intel82566MM.kext /content/info.plist you'll see this:

<key>OSBundleLibraries</key>
<dict>
<key>com.apple.iokit.IONetworkingFamily</key>
<string>1.6.0</string>
<key>com.apple.iokit.IOPCIFamily</key>
<string>2.4.1</string>
<key>com.apple.kpi.bsd</key>
<string>9.3.0</string>
<key>com.apple.kpi.iokit</key>
<string>9.3.0</string>
<key>com.apple.kpi.libkern</key>
<string>9.3.0</string>
<key>com.apple.kpi.mach</key>
<string>9.3.0</string>
</dict>

.................change your system information in the same voice..and save.

istall the Intel82566MM.kext in ....../system/library/extensions ....and you're done!
i have install with the Kext Helper b7.

and thanked dingguijin for all!!!!!!!


PS:sorry 4 my english...let there be clear!
bye

#27
GLXOZ

GLXOZ

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
Not work on my MOBO. (in signature) :D

#28
Flatfoot

Flatfoot

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
I would like to thanks Kytzv and Riccardo70 with yours help everything works fine.

P.S. Riccardo70, english is my second language. :)

#29
bmw000

bmw000

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I am running a dell xps 410 with the ideneb 1.3.

I have the intel 82566dc - 2 and followed the instructions.

I changed the version numbrs in the file and my device id is listed and installed it with the kext installer but my ethernet does not seem to be detected still.

Any ideas?

#30
dingguijin

dingguijin

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
try latest kext package from http://techresearchinfo.blogspot.com.

#31
leciak

leciak

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

try latest kext package from http://techresearchinfo.blogspot.com.


works like a charm on x61t, big thx!

#32
samex

samex

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
  • Gender:Male
  • Location:GERMANY
Hey, its Work fine, but always when i install the NetworkDriver it crashed my Sound Driver!

I use AzaliaTurboTP1984 , Driver. I have tried 2 times (reinstallMAC) but doesnt work.

My OSX : leo4all_v3 - 10.5.2

DeviceID from my Audio Hardware : 0x17AA20AC

Know somebody a Solution for This Problem?

#33
bmw000

bmw000

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

try latest kext package from http://techresearchinfo.blogspot.com.


I tried the latest and still no go.

LSPCI recognizes the card, but nothing shows in apple system profiler or in the network settings under network prefs.

Is there something else I need to do to make it active? Is there another driver I need to install or some other setting I need to enable to make it become detected and operate?

Thanks,
Brian

#34
scififan68

scififan68

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 151 posts
  • Gender:Male
I installed with kext helper and after a minute a pop up said it found a new network interface then the onbard Intel lan was working :thumbsup_anim: nice work!

#35
bmw000

bmw000

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I gave up.

I went to bestbuy and got a new 10/100 pci nic from dynex (DX-E102) which has the realtek 8139 chipset. Installed it and it works right out of the box with no special drivers or hacking. It cost me $17.99 plus tax.

Now I need to figure out how to change the screen resoluton as it is stuck at 1024x768.

Also need to try the sound drivers from another thread.

I may end up just buying a new cheap video card (fanless) and sound card, just to get it all going good. All this integrated hardware seems just to incompatible. I guess that's what I get for getting a dell.

#36
BlackCH

BlackCH

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,611 posts
  • Gender:Male
  • Location:BCN
It works on a 82562GT and 10.5.5 (editing the plist)!
Thanxs!

#37
wuzzle

wuzzle

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Canada
HP/Compaq 2710p Tablet - Success!

With latest release off your blog, installed with OSX86Tools and then all maintenance scripts run and a reboot, the driver came up great. Listed at 10Mb/sec only, but at least I get better speed than wifi only now :) Thanks a lot!

#38
drew630

drew630

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Help please. I followed the instructions and keep getting an error when placing the file into the extensions folder. The error reads, "The system extension "/System/Library/Extensions/Intel82566MM.kext" was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update."

Anyone know whats wrong? I am using Jas OSx86 10.5.4 and I have an Intel 82566DC-2 Lan.

#39
rajindia

rajindia

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:chennai tamil nadu india
Attached File  Intel82566MM.tar.gz   12.44KB   984 downloadsAttached File  Intel82566MM.tar.gz   12.44KB   984 downloads



worked like a charm on Intel d33fb motherboard.

Lan working.

#40
dingguijin

dingguijin

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Help please. I followed the instructions and keep getting an error when placing the file into the extensions folder. The error reads, "The system extension "/System/Library/Extensions/Intel82566MM.kext" was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update."

Anyone know whats wrong? I am using Jas OSx86 10.5.4 and I have an Intel 82566DC-2 Lan.


Try to make sure you have untar/unzip the package.

cd Intel82566MM.kext and Check is there a directory named "Content"?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy