Jump to content

[How To] GMA900 with QE and CI support on Leopard.


  • Please log in to reply
364 replies to this topic

#41
tgparis

tgparis

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
it worked perfectly, thanks to you all
what a relief for me i really started to fell like n escape from the gma 900 with leopard issue !.
I still have to have my belkin fd7050 v1 for wireless working ! and my acl 880 for sound and then i could at last enjoy plently leopard !

#42
ktrust

ktrust

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
it's not working for me. i've installed the graphics update, rebooted but the display is {censored}ed up. have u remove the kext first and copied the needed one's first and after that rebooted?

#43
flibblesan

flibblesan

    Lenovo hackbook guru

  • Members
  • PipPipPipPipPipPip
  • 469 posts
  • Gender:Male
  • Location:Nottingham, UK

it's not working for me. i've installed the graphics update, rebooted but the display is {censored}ed up. have u remove the kext first and copied the needed one's first and after that rebooted?


What version of leopard are you using? Did you install the leopard graphics update then remove all AppleIntel* video kexts, then drop the files matching your device ID?

If you did this and still doesn't work, what is your device ID please? Can you boot into safe mode -x ?

#44
ktrust

ktrust

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
i'm on 10.5.2

but i think i made a mistake. I've rebooted after i installed the graphics update, before removing the intel kext

yes i can boot with -s, but don't know what kext to remove

btw my device id is 2792

#45
ktrust

ktrust

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Thank you very much!!! It's working now.

#46
flibblesan

flibblesan

    Lenovo hackbook guru

  • Members
  • PipPipPipPipPipPip
  • 469 posts
  • Gender:Male
  • Location:Nottingham, UK

Thank you very much!!! It's working now.


Sweet. Do you have full Quartz Extreme and Core Image?

#47
riws

riws

    InsanelyMac V.I.P.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 6,081 posts
flibblesan, you have EFI BL?

Only with 1.4.... FB it boots to Desktop, with 1.5... FB it just shows light blue color.

#48
flibblesan

flibblesan

    Lenovo hackbook guru

  • Members
  • PipPipPipPipPipPip
  • 469 posts
  • Gender:Male
  • Location:Nottingham, UK

flibblesan, you have EFI BL?

Only with 1.4.... FB it boots to Desktop, with 1.5... FB it just shows light blue color.


It appears so. I installed from Kalyway 10.5.2

#49
pezley

pezley

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
really appreciate the guide, shame im having massive problems. have followed the guide to perfection, but still getting a blue screen.

one question, why are there two lots of folders in your zip file for each device ID? one in gma900 and one in macos folder ? maybe im choosing the incorrecte version ? any advice would be highly helpful.

running this on a laptop if this makes any difference.

thanks

Firstly, thanks to Andy4life for putting his edited kexts online and telling us how he got it working. Thanks to this guy, I got it working on my desktop so I thought I would share my files. I have edited the latest Intel drivers with both my ID and Andy's ID which should cover everybody.

Quick guide:

1) Download and install Leopard Graphics Update (make sure you are running 10.5.2 at least). http://www.apple.com...csupdate10.html

IMPORTANT - DO NOT REBOOT! Remove all intel graphics kexts first then reboot.

2) Remove all intel graphic kexts from /System/Library/Extensions these are:

AppleIntelGMA950.kext
AppleIntelGMA950GA.plugin
AppleIntelGMA950GLDriver.bundle
AppleIntelGMA950VADriver.bundle
AppleIntelGMAX3100.kext
AppleIntelGMAX3100FB.kext
AppleIntelGMAX3100GA.plugin
AppleIntelGMAX3100GLDriver.bundle
AppleIntelGMAX3100VADriver.bundle
AppleIntelIntegratedFramebuffer.kext

3) Download GMA900 pack from http://www.megaupload.com/?d=HZ8M543A and drop the kexts for YOUR device ID into the extensions folder. Use kexthelper (supplied) as it's easier.

4) remove Extensions.mkext and reboot.

Included AppleIntelIntegratedFramebuffer.kext is verson 1.5.24.9 - this does not give me resolution change, but also does not give me artifacts. If you need resolution change, then you need version 1.4.20.28 which does allow resolution change, but has slight artifacts with heavy applications. You will find this in the folder "to enable resolution change"

Thought I would post a screengrab of it working on my system. I am now using the latest Intel kexts from the Leopard Graphics Update.



#50
flibblesan

flibblesan

    Lenovo hackbook guru

  • Members
  • PipPipPipPipPipPip
  • 469 posts
  • Gender:Male
  • Location:Nottingham, UK

really appreciate the guide, shame im having massive problems. have followed the guide to perfection, but still getting a blue screen.

one question, why are there two lots of folders in your zip file for each device ID? one in gma900 and one in macos folder ? maybe im choosing the incorrecte version ? any advice would be highly helpful.

running this on a laptop if this makes any difference.

thanks


What macos folder? Did you unzip this on Windows? I zipped them up on a mac, so I guess it's the hidden folder you can see. You need to use the files in the GMA900 folder, depending on which device ID you have. If you have a blue screen, use the alternative AppleIntelIntegratedFramebuffer.kext here http://flibblesan.co...GMA950.kext.zip - it might work for you.

I'm unable to test things on other computers. All I know is that these work for myself and a couple of others, but it's really dependent on your device ID etc.

#51
pezley

pezley

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
just re installing and ill let you know if it works. appreciated for the speedy reply. fair comment about the different types of hardware. i have checked the device ID, matches up ok.

#52
ktrust

ktrust

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
flibblesan, yes , everything is working well. thank you again. i've got full qe & ci.

the only thing that doesn't work is ical. it crashes when i open it, but it's not related with this topic.

#53
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,615 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets

Included AppleIntelIntegratedFramebuffer.kext is verson 1.5.24.9 - this does not give me resolution change, but also does not give me artifacts. If you need resolution change, then you need version 1.4.20.28 which does allow resolution change, but has slight artifacts with heavy applications. You will find this in the folder "to enable resolution change"

Weird, on my GMA950 I used GMA10.5.3 kexts (1.5.28.21) with AppleIntelIntegratedFramebuffer.kext 1.4.20.28, I have resolution change and no artifacts.

You are using AppleIntelIntegratedFramebuffer.kext from 10.5.2 update and GMA950 kexts from 10.5.2 also...

#54
flibblesan

flibblesan

    Lenovo hackbook guru

  • Members
  • PipPipPipPipPipPip
  • 469 posts
  • Gender:Male
  • Location:Nottingham, UK

Weird, on my GMA950 I used GMA10.5.3 kexts (1.5.28.21) with AppleIntelIntegratedFramebuffer.kext 1.4.20.28, I have resolution change and no artifacts.

You are using AppleIntelIntegratedFramebuffer.kext from 10.5.2 update and GMA950 kexts from 10.5.2 also...


I didn't realize that 10.5.3 updated the intel kexts. Something for me to look at then, they may work better.

#55
alejo_id

alejo_id

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Location:Bogot-Colombia

3) Download GMA900 pack from http://www.megaupload.com/?d=HZ8M543A and drop the kexts for YOUR device ID into the extensions folder. Use kexthelper (supplied) as it's easier.


please flibblesan, upload the GMA 900 pack to rapidshare, i can't download from megaupload :) :D :( i am in the middle of the installation...

#56
alejo_id

alejo_id

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Location:Bogot-Colombia
thanks fibblesan!!!! finally i can download the pack, and now i hace CI n QE!!!! :D:D:D:D:D:D:D:D:D:D:D:D

#57
Mascot

Mascot

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

Weird, on my GMA950 I used GMA10.5.3 kexts (1.5.28.21) with AppleIntelIntegratedFramebuffer.kext 1.4.20.28, I have resolution change and no artifacts.

You are using AppleIntelIntegratedFramebuffer.kext from 10.5.2 update and GMA950 kexts from 10.5.2 also...


Same here. I'm using the AppleIntelIntegratedFrameBuffer.kext from 10.5.0, though.
Edit: Scratch that, looks like the only place I get artifacts are in firefox in the input fields. No where else though.

#58
Andy4life

Andy4life

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
I'm only getting artifacts in text fields as well, so far the places i've noticed it are:

- Firefox
- iTunes (in the search field)
- When I right click a file --> Get Info and try to change the extension

#59
flibblesan

flibblesan

    Lenovo hackbook guru

  • Members
  • PipPipPipPipPipPip
  • 469 posts
  • Gender:Male
  • Location:Nottingham, UK
Ok. I've produces a quick pack using 10.5.3 kexts, with the AppleIntelIntegratedFramebuffer.kext that allows resolution change. You can find this earlier in the thread at http://forum.insanel...&...st&p=783029

#60
flibblesan

flibblesan

    Lenovo hackbook guru

  • Members
  • PipPipPipPipPipPip
  • 469 posts
  • Gender:Male
  • Location:Nottingham, UK
I've been trying to make an install package for these using PackageMaker, but the program keeps failing saying "Could not create temporary BOM" and Google brings up nothing useful.

Are there any other programs that can do this, that are better? I've tried Iceberg but it's hard to use.

Unless somebody else can make a package?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy