Jump to content

ATI Radeon HD pkg installers 10.5.x & 10.6


  • Please log in to reply
2377 replies to this topic

#101
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Hi, i will switch from NV 7600 GT to ATI 2600 XT 256 MB PCIe next week.

I have 10.5.3 installed

Are the ati 2600 dl pack with 10.5.3 drivers or are they older ?

Are there an solution by using an natit injext + EFI strings using orig. ATI driver (incl. all other opengl things ) ?

I used only Nvidia cards since osx86 (1,5 year, 10.4.9 up) , thats the reason for my questions.
Thanks

#102
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years

Hi, i will switch from NV 7600 GT to ATI 2600 XT 256 MB PCIe next week.

I have 10.5.3 installed

Are the ati 2600 dl pack with 10.5.3 drivers or are they older ?

Are there an solution by using an natit injext + EFI strings using orig. ATI driver (incl. all other opengl things ) ?

I used only Nvidia cards since osx86 (1,5 year, 10.4.9 up) , thats the reason for my questions.
Thanks



you can use both natit and EFI String for 2600xt but its all up to you :(

#103
kavalir

kavalir

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

more fixes are coming. my stomack been acting up :wacko:


hello, it seems like everyone with 3650, who performed 10.5.3 kalyway combo update, have white menus bug. leo4all and kalyway. I saw one post where someone with iatkos updated to 10.5.3 and everyhting was working.. so hope you will wind the way to fix it.. thanks for your good work!

#104
Danzo

Danzo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 6 posts
Thank you for creating the installers for all the various cards it is greatly appreciated. When I was attempting to download the driver package for the 2600XT Pcie I get this error from the hosting site "The quickkey you provided for file download was invalid. This is usually caused because the file is no longer stored on Mediafire. This occurs when the file is removed by the originating user or Mediafire." Could someone please upload a new file.
Thank you,
Danzo ;)

#105
phantom8

phantom8

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
To fix the white menu issue with 3650 & Kalyway 10.5.3 combo update, you can just install the 10.5.3 combo update first before installing 3650 drivers.

#106
kavalir

kavalir

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

To fix the white menu issue with 3650 & Kalyway 10.5.3 combo update, you can just install the 10.5.3 combo update first before installing 3650 drivers.


Hello.. It worked for you? I'm not sure, if I'm able to make whole reinstall;) .. any way to 'roll back', update, and then drivers ?

#107
Wardialer

Wardialer

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
9588 installer works great on my 2600XT. the fonts finally look right. bravo!
thanks to netkas and everyone involved!

now i just gotta find a sleep kernel and fix my restarting problems for 10.5.3

#108
madpeanuts

madpeanuts

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
id really like to shout out big props to Netkas and lastExile for all the support and effort helping people like me to get their drivers working. im another hd2600 (8591) lucky winner, before i had an intel gpu that got qe/ci in no time, it was great. now this one more of an effort, but a simple effort though, of digging for the info, installing some files and so on. i mean, the real work is putting it together, the extra mile is sharing it and caring for others. we all know anything is possible, especially if is just code, but only some have those skills and patience. anyways. i`ll be waiting patiently to get my ati working with full 3d acceleration, i know is work in progress, and that so many out there figured it out and got it working by themselves. im sure ill just have to click a couple times, maybe erase or overwritte a few files, and thats it... so thats why im thankful and so excited about this work. is funny that after waiting a couple of months to clear out my vista and backin up all my work so i can have the resource and time to try every install, i come to be in the waiting list for working hardware. keep up the great work and attitude!

#109
nekton

nekton

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
My 9588 HD2600XT is working fine and when I ran Software Update (not vanilla kernel), it saw a 2600XT graphics update from Apple. I guess this would screw the cat?

#110
boris99

boris99

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Has anyone tried the HD3450 yet? Am I right in understanding it's the same as the 3650?

#111
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years
3450 is not the same as 3650 its the same as 2400pro&xt but still having some problems with getting a picture on the screen

#112
animus_domini

animus_domini

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
  • Gender:Male
  • Location:Brazil

To fix the white menu issue with 3650 & Kalyway 10.5.3 combo update, you can just install the 10.5.3 combo update first before installing 3650 drivers.


1) Can anyone to confirm that procedure works?
2) I'm thinking to buy a saphire HD 3650 512MB/128 Bits... Is this card working flawless at least on 10.5.2 or need white menu fix?
3) About heating... Has HD 3650 that issue on 10.5.2 and 10.5.3?

Thanks in advance

#113
coccolino_dbro

coccolino_dbro

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:Targoviste, Romania
I got my 3650 working on 10.5.3 without the white menu bug:
1. installed iAtkos 2.0i
2. installed the driver package for my video card
3. installed the 10.5.3 update, but not Kalyway's. I used the Jas OsX86 10.5.3 Intel SSE3 Combo Update.

Updating didn't remove QE/CI etc... However, this combo made my system profiler crash, so I had to replace SPPlatformReporter.spreporter with the one from the iAtkos install dvd. And made booting time quite long (with Kalyway combo I didn't have this behaviour), but that's another issue, to be discussed elsewhere.

Attached Files



#114
animus_domini

animus_domini

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
  • Gender:Male
  • Location:Brazil
Thanks coccolino_dbro.

Do you know if your card have heat issue?
Did your card work flawless with 10.5.2 (QE/CI, DVI, Dual Head)?
And now, after update, still QE/CI, DVI, Dual Head working?

Thanks

Ps. Which is the brand of your video card?

#115
coccolino_dbro

coccolino_dbro

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:Targoviste, Romania
The card is a Sapphire; I don't know if it has overheating issues, but I'm running Leo all day long and i haven't noticed any weird behaviour (I guess this would be a sign of overheating?). The card's fan only has two wires, not three (as the controlled fans), and I'm guessing is working 100% all the time, keeping the gpu in certain limits.

I had QE/CI before and I still have after the update; as for DVI and DualHead I can't really say, because I have only one VGA monitor, and I'm using a dvi2vga adapter to connect it (the card has only 2 dvi connectors, no vga).

#116
animus_domini

animus_domini

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
  • Gender:Male
  • Location:Brazil
Thanks coccolino_dbro.


Did anyone test HD 3650 512MB DualHead on 10.5.2 or 10.5.3?
Did anyone notice HD 3650 512MB overheating issue on 10.5.2 or 10.5.3?

Thanks in advance

#117
animus_domini

animus_domini

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
  • Gender:Male
  • Location:Brazil
Hi all,

I am planing to buy a new video card tomorrow. I have some options, but I want a videocard with QE/CI, full resolution, DualHead. I don't want a card with overheating issues. I am not a gamer and power doesn't matter that much. For me is important a videocard to do daily work, photoshop, some video editing, web, watch HD movies and, if I can play some windows games, it will be a gift. I actually using kalyway 10.5.2, updated to 10.5.3, using Netkas method. I also want a card easy to configure, because I don't want mess my system with tons of trials and errors. Probably I am asking so much, but I will be very happy if anyone give some directions to reach my goals.

My options:
1) PCIe Sapphire HD 3650 512MB / 128 Bits
2)
PCIe Gigabyte HD 3850 512MB / 256 Bits
3)
PCIe Sapphire HD 3870 512MB / 256 Bits
4) PCIe MSI HD 2600XT 256MB / 128 Bits

Any advice will be appreciate.

Thanks in advance


#118
fburger

fburger

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Just wondering if there is a fix in progress for mobility HD cards.
I have a mobility HD2400 and would be glad to help the development in any way i can.

#119
nekton

nekton

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
animus_domini

I am using option 4 with a dual head setup on 10.5.3 running two DVI screens (no VGA adapters) and it is fine. Dl the 9588 2600XT drivers from here, install them and the card, fix permissions and don't look back.

#120
animus_domini

animus_domini

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
  • Gender:Male
  • Location:Brazil

animus_domini

I am using option 4 with a dual head setup on 10.5.3 running two DVI screens (no VGA adapters) and it is fine. Dl the 9588 2600XT drivers from here, install them and the card, fix permissions and don't look back.


Thanks, nekton





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy