Jump to content

[Release] Leo4VMware by ~pcwiz

504 posts in this topic

Recommended Posts

SUPPORT APPLE: Help Apple and buy a license for Leopard if you are going to use this!


EDUCATIONAL ONLY: Not to be used in a productive or commercial environment


NOTE: When this virtual machine is booting, if there is like a no smoking sign sort of thing (cross) over the Apple logo when booting, don't worry about it, its normal :)


VMware Server Note: To use this with VMware Server you need to do a minor tweak to the config file. Otherwise it gives you an error that it was created on a version of VMware with more features. Instructions for the tweak are at the bottom.

  • Intel SSE3 only (no SSE2 patch applied and no AMD decrypts)
  • This has now been confirmed working on VMware Fusion as well!
  • It is possible to get this to work with AMD and SSE2 but you have to do that yourself :)
  • This release is Leopard Flat Image + 10.5.2 Update + netkas 9.2.0 SpeedStep kernel + mac.nub SMBIOS with the necessary VMware tweaks
  • It comes in a ready to go directory that contains everything you need to boot and use it in VMware, just navigate to the config file and open it as a vitual machine in VMware
  • By default RAM is set to 1GB, adjust this if necessary
  • Ethernet does work apparently, but I didn't configure it by default in the release. Scroll down to the bottom of this post to get Ethernet configuration instructions
  • USB does not work, which is not a surprise seeing as it didn't work in Tiger on VMware either
  • Sound works partially, but its laggy and not practical at all
  • The default username is pcwiz and the admin password is pcwiz
  • Time Machine fix is not applied and Time Machine is not configured. I didn't think Time Machine is practical considering you can make VM snapshots in VMware, but if you want to use it apply the Time Machine fix from here (download it, put it into an ISO and mount) and configure another virtual hard drive and format it with Disk Utility and configure Time Machine to use the new disk
  • There is 8.3 of free space left on the disk for your use (add another virtual disk if you need more space)
  • The virtual CD-ROM is not configured to Connect at Power On because it slows boot. Once you are booted into Leopard, connect the virtual CD-ROM by right clicking the CD icon on the bottom right of the VMware window and clicking Connect. Use the Edit option in that same menu to configure drive and ISO settings
  • No QE/CI at the moment

Where to get it?


This is basically a preprepped virtual machine that can boot right out of the box, Leopard with no configuration or installation. Download a ZIP file [no links for you!] that contains a text file with links to download all 36 parts (3.55GB total). If you want to download all the same parts at the same time, there is a torrent floating around on Mininova called "~pcwiz's VMware Leopard Image". If you prefer to learn and do all the configuration and everything by yourself, there is a guide for this available here .

How to use it?


This is not just a VMware disk image, it contains the configuration files and everything you need to boot it right out of the box. Once you have unzipped the final product, it is a folder called Mac OS X Leopard. Go into VMware and open an existing virtual machine and go into the unzipped Mac OS X Leopard folder and select the FreeBSD 64 bit config file.



VMware Server Tweak

  • You must do this to make it work with VMware Server (tested with 1.0.5)
  • Open the Mac OS X Leopard folder and find the FreeBSD-64bit.vmx file
  • Open the file with Notepad or another basic text editor
  • Find the line where it says virtualHW.version = "6"
  • Change the "6" to "3" so it reads virtualHW.version = "3"
  • Save the file and open the virtual machine!
  • If it still gives you the error that it was created on a version of VMware with more features then do this
  • Open the config file again and change the virtualHW.version line to 4 so that it reads virtualHW.version = "4
  • Save it and try again."

Patching for AMD SSE3

  • You only need to do this if you have an AMD SSE3 processor (Intel works out of the box)
  • Firstly, you need to have a working Tiger VM (instructions here)
  • Mount the leopard.vmdk file from this package as a virtual disk in the Tiger VM
  • Boot the Tiger VM and you should have access to the Leopard drive
  • Download Marvin's AMD Utility here
  • Run it from the Tiger VM, for the "Volume/Directory to patch" choose your Leopard volume
  • Choose the "Patch all binaries" radio button and Patch
  • It will take a long time, but eventually it will be done
  • You should now be able to boot the Leopard VM properly
  • If it doesn't work, tap F8 while the Leopard VM is booting to get to the boot: prompt and type in -v and hit Enter.

Ethernet How-To

  • To get Ethernet working in Leopard on VMWare follow these instructions (its easy)
  • Back at the VM home screen, go to VM menu >> Settings
  • Click Add and from the dialog that comes up, choose Ethernet Adapter and click Next
  • Make sure Bridged is chosen and the Connect at power on box is checked and click Finish
  • Boot into your Leopard VM and go to System Preferences (in the Dock)
  • Click on the Network preference pane
  • It will say that a new interface (en0) has been detected, choose the Ethernet Adapter from the left pane
  • Assuming that your internet is auto configuring DHCP, just click the Apply button.
  • Even if it says Cable disconnected or not connected, ignore it, Ethernet will still work
  • It will pull up all your DNS info and everything automatically, close System Preferences
  • You should be able to use Apple Software Update and go on the net fine!

Ethernet Method 2

  • If it still doesn't work, here's another method to do it (make sure that you have an Ethernet adapter configured as Bridged and that you have rebooted the virtual machine after adding the adapter)
  • Go back to System Preferences and open the Network preferences again
  • Click on Ethernet from the left pane and at the bottom click the Assist Me button
  • In the resulting dialog box click the Assistant button
  • The Network Setup Assistant will start up, give the Location a name and click Continue
  • Choose the "I use a cable modem to connect to the Internet" option
  • Click Continue again, and then it will take a moment and tell you that you can't connect automatically and to enter some details
  • Without entering any details click Continue and click OK at the dialog box (this sort of "activates" the Ethernet)
  • Now click the Go Back button twice to get to the screen to choose a connection option
  • This time choose "I connect to my local area network (LAN)"
  • At the Ready to Connect screen click Continue and now it will give you a confirmation that you are connected
  • Click Done or whatever button and close System Preferences, Internet should be working

How to increase screen resolution

  • Because there are no video drivers for it, you can't just configure screen resolution from System Preferences but there is a manual way
  • Go here for instructions on how to do it manually.

Using Apple Software Update


  • You can use Apple Software Update to update Mac OS X (if you have a working Ethernet connection)
  • Before updating anything, take a snapshot of the virtual machine just in case something goes wrong
  • To do this, while your virtual machine is running, go to the VM menu >> Snapshot >> Take Snapshot
  • To open Software Update, go to the Apple menu and click Software update, it will scan for updates and it will list them
  • As of now, pretty much any update is OK, except the Time Machine update. DO NOT apply the Time Machine update (it installs a new kernel that will possibly mess up your install)
  • If anything goes wrong after an update, just restore your Snapshot (VM menu >> Snapshot >> Revert to snapshot)


  • If this VM doesn't boot properly or if it hangs at the Apple logo, the first step in troubleshooting is to find your errors. Right at the vmware splash screen, click inside the window and tap F8 as fast as you can. You eventually get to a boot: prompt. At the prompt enter -v and hit Enter, watch the messages and post up your errors or where it halts!
  • The next thing to do is to try an older kernel. Tap F8 to get to the boot: prompt again and type in mach_kernel.toh and hit Enter. See if this kernel boots the system properly.


Link to comment
Share on other sites

modified, I can't put up these in public. I plan to link to a text file that contains the download links. I'm PMing you with the links to the parts I've uploaded though :D




Yes thats what I mean. But I only tried 1 or 2 of the three methods available. Try and use this guide I wrote to get it to work:




I don't know if it will, but its worth a shot :) In the packaged release I've removed the ethernet adapter so you'll have to add a new ethernet virtual device from the VM >> Settings menu

Link to comment
Share on other sites

The full thing is not released yet. Its not a torrent, it'll be uploaded in parts to FileFactory. Its in 36 parts and 31 of 36 parts are done uploading. If you are interested in downloading the uploaded parts, PM me. When its all done downloading, I'll put the links in a text file, zip that text file, and upload it to Mediafire and then I will link to the Mediafire zip. To be in accordance of the forum rules for no direct download links ;)

Link to comment
Share on other sites

cool, I can try this on my intel system. you think it can work in vista?

Link to comment
Share on other sites

Hi ~pcwiz-thanx for your efforts. Did you try to run this baby within Fusion? It would be nice to run Leo server on Leopard-but with a working networkcard!!



Edit: Did you use MaxxussAMDPCNET.kext cause this kext works fine in Tiger 10.4.10 VM Fusion ?

Link to comment
Share on other sites



Yes, I did this entire thing on Vista :)




Nope, haven't tried :) Yeah like I said I didn't test Ethernet 100% extensively, but go ahead and try whatever you want on it, improve upon our works and shre with the community.


EDIT: Done uploading. A link to a zip with the links in it has been posted on the first post, bottom.

Link to comment
Share on other sites

Thanks for the upload and development.


I tried to dl from filefactory and it was :lol: slow and bought a premium account for 2 months and it is still slow as :censored2: .

When I am finished dl it, maybe I could upload it to rapidshare if ~pcwiz is ok with that, their mirrors are imho much faster.

Link to comment
Share on other sites



Sure go ahead :censored2: But I'm getting speeds of 180KBps from FileFactory which is more than enough for me. The only reason I didn't upload it to Rapidshare is because of the nasty download limits. So you download one 100MB file and you have to wait another 100 minutes to download the next part :lol:. But yeah, if you think it will help then go ahead and upload to Rapidshare :)


Also everyone, I had a rather interesting idea on how to get QE/CI for these VMs. I don't know if anyone has heard, but Apple has given out licenses to VMware and Parallels to virtualize Leopard Server. So assuming that it gets done, and that these virtual machines have drivers for QE/CI, then we could "borrow" whatever kext it is from VMware Fusion and load it into VMware Workstation. Worth a try once virtualizing Leopard Server is possible :)

Link to comment
Share on other sites



I'm getting 180KBps on a 4MBit line. Maybe your ISP is blocking ports or something.




That was left over from the first virtual disk that was created before I mounted the leopard.vmdk. Its only 1MB, might as well leave it alone :lol:

Link to comment
Share on other sites

You need an existing working Tiger VM. First go here and follow the steps to get Tiger working on VMware. Then, unzip the Mac OS X Leopard archive and the Mac OS X Leopard folder will be unzipped and there is a file called leopard.vmdk inside. Mount leopard.vmdk as an addition virtual disk in your Tiger VM so you have access to the Leopard drive using Tiger.


Go here to get Marvin's AMD Utility and run it from Tiger. Choose the Leopard volume as your Volume/Destination and choose the Patch all binaries option to patch. Then get out of Tiger, start up the Leopard virtual machine and it should be fine ;)

Link to comment
Share on other sites



Tell me if it works so I can put it in my guide ;)




Yup it would take 20-30 mins to boot. If it doesn't boot after an hour or so, boot in verbose to see whats stalling it

Link to comment
Share on other sites


  • Create New...