Jump to content

theStevo 4.0 Patch for the 775Dual-VSTA


121 posts in this topic

Recommended Posts

Announcing the release of theStevo 4.0 patch! After numerous delays, it is finally here and to the best of my knowledge working properly. Thanks to the Martin Luther King holiday I was finally able to finish it up.


I do not understand why, as a community, we are so concerned about ego. There is very little sharing of information regarding the production of data used. In my attempt to figure out how to modify the Leopard installer I have looked on the forums and requested help from the two main members who have already figured these problems out, all with no avail. Granted, in the end it is not a very difficult processes. However, with a lack of contiguous time to research and spending such time as I had chasing down some wrong leads, it was a long and drawn out journey.


It should not be this way. We should spend more time building hardware support and less time building our social standing. With this release, all development files and the process will be 'open sourced'. My goal is to provide a definitive guide, for this point in time, for people to develop their own installation discs based off of Kalyway's current installer (possibly applicable to iATKOS).


However, let me be perfectly clear that I have the utmost respect for Uphuck and Kalyway and they have the right to decide the information released regarding their works. I very much appreciate the fact that they work pro bono for the benefit of our community, I simply offer that there are more effective ways of interacting with the rest of the members. Note that I did not rename the disc, change the icons, or change any of the credit lines. They deserve our respect and thanks, both of them.


Please, don't go 'distro' happy with this. Diversity has a place, and so does consolidation. If a disc for your hardware doesn't exist, and you have thoroughly searched to verify that, create it. I do advise though, that you don't create discs just to put your name on something. Try to work with people that are working along the same line first. It helps newcomers understand what to use, making it easier to increase our numbers and therefore our chances of developing hardware support. I tried to talk to both Kalyway and Uphuck developers about 8237 support and have yet to see a response. Also, when you create your own disc you automatically get exponentially more questions that you may or may not be ready for. So, sometimes its best to collaborate and othertimes best to branch off.


About this version:


Q: Where is it?

A: Down by the BAY, where the watermelons grow...


Q: What can I apply the PPF to?

A: ONLY the Kalyway 10.5.1 Leopard installation disc.


Q: What about iATKOS?

A: Its about Leopard, not the install disc. Kalyway gives more diversity for use in other computers and I like it better, I will not be supporting iATKOS with this release. If it means enough to you, dive into creating a patch yourself; you have my material.


Q: But I HATE the orange background on finder!

A: View options -> background color -> change to white -> set as default.


Q: Is 4CoreDual-VSTA supported?

A: As far as I am aware you should be able to get a working SATA install with network and sound from this disc. HOWEVER, this version does not include UDMA support for the 4CoreDual-VSTA. I have received a kext file from a 4CoreDual-VSTA user (Thank you Lean) that has UDMA on SATA fully working and I will release an updated version that only 4CoreDual-VSTA users need download, however it will include 775Dual-VSTA support also. UDMA support can be achieve seperately from this install disc by replacing AppleVIAATA.kext or modifying it.


Q: Can I use EFI on the 775Dual-VSTA?

A: Yes, either GPT or MBR on their repective disk configurations.


Q: Why would I want to use GPT instead of MBR?

A: Slight performance gain. Makes you feel more like Steve Jobs. If you multi boot, its not worth it yet.


Q: Can I use the Vanilla kernel and do unmodified Apple updates?

A: No! Most likely that will never be available for this board. While conceivably possible through emulation calls, it would have to be specifically developed per non-vanilla-compatible board and will likely never be attempted.


Q: Does the network connection (VIA Rhine II) drop?

A: Possibly. I never had it happen until recently. Beats me what is up. Don't ask me yet, if I figure it out you'll see it somewhere.


Q: Wasn't this supposed to be theStevo 3.1?

A: Yeah, but I figured there was enough difference I should list it a whole new version, not just a new revision. Its based off a different disc, it doesn't require post patching, etc...


Q: What about support for the Dell E520, wasn't that apart of theStevo 3.0?

A: Indeed it was. However, Kalyway works 100% with a vanilla EFI install on the E520. Another reason for my preference of Kalyway. Simply put, it is my way of saying that I can verify to others that I had that type of computer and got Kalyway running 100%. With that in mind, this patch also 'supports' the Dell Dimension 8400 and possibly others to come.

The zip file contains a PPF that can be applied to Kalyway 10.5.1 with PPF-O-Matic. That is all that is necessary for creation of a working installer. The following guide is only for those who are curious how I did it.


The Guide:

Materials required:

  1. ISO of the disc to modify
  2. PackageMaker (From xCode or other sources)
  3. Installed Iceberg
  4. Working OS X install (Tiger or Leopard)

First, a brief overview of the concept of how the install works. Think of there being two distinct Operating Systems to modify. The first one is the live boot Operating System, rather like Ubuntu or Knoppix, that installs the Operating System that will reside on your hard drive and you will use. The live one is the easiest and most essential one to modify.

Step 1: the live install OS


If you have ever installed a kext by hand, this will be very familar.

  1. Mount the ISO
    sudo -s
     hdiutil attach -readwrite file/location.iso -owners on

  2. Add the kext files to the mounted disc in /volumes/disc_name/system/library/extensions . You can drag and drop them in finder.
  3. Set proper permissions.
    chown -R root:wheel /volumes/disc_name/system/library/extensions
     chmod -R 755 /volumes/disc_name/system/library/extensions

Now, that is all you will need to boot from the disc and have it recognize your hardware. The kexts you added will NOT be transfered to the hard drive but the OS X files will. If you are adding a kext for your ATA controller, the system will not boot after the install. However, you can add these kexts back manually with only using the disc (no need for access from a separate installation) by booting from the disc again and copying the kexts you added to the hard drive using the terminal. We won't discuss that, because step two exists to make that unnecessary.


Step 2: the installed OS


This is the more complicated of the two steps. It involves creating an installer package that will ultimately place the kexts in the extensions folder.


Part A: Creating the installer package


For the purposes of this guide we will use Iceberg to create the install packages. The reason being that it is more flexible to use and easier to create the packages needed for installation. PackageMaker in xCode seems very slick, but it likes to create mpkgs with separate pkgs for each file and it seemed to me that it created problems with the installation.

  1. If you are adding kext files that do not have versions by the same name in the extensions folder already (like VIARhine.kext, Apple doesn't have that by default), then you can drag and drop these extensions into the /system/library/extensions folder inside the files section of your installer project.
  2. If you are adding kext files that do have versions by the same name in the extensions folder already (like AppleHDA.kext), then create a folder inside of /system/library/tempfile in the file section and drag and drop your extensions into there.
  3. Add a postflight script in the scripts section of the project like 'postkextmove' given in the development folder. Modify 'postkextmove' as per the name of your folder you created in tempfile and the name of your kext. Tip: use TextWrangler for editing that file.
  4. In the settings section change the project to requiring root authentication and requiring logout.
  5. Take note of the package name and identifier, change them to be what you wish.
  6. Build package
  7. The ISO should be mounted as readwrite as describe above, then copy the built package into /system/installation/packages of the ISO.
  8. Fix permissions on /system/installation/packages of the ISO.
    chown -R root:wheel /volumes/disc_name/system/installation/packages
     chmod -R 755 /volumes/disc_name/system/installation/packages

The concept: Many things are happening during the install. OSInstall.mpkg calls the install processes of all selected .pkgs and then finishes its own processes at the end. When we start adding more and more packages in addition to the ones that Apple gives us by default, it increases the possibility that any changes directly written into the /system/library/extensions will be overwritten before the installation is over. Therefore we create a folder inside of tempfile, which itself is a creation of Kalyway for the same purpose, so that we can install the kext files and then move them into place at the end of OSInstall's run through a postflight in the package we create. Regardless of when the main install is done inside of OSInstall's run, the postflights are all executed at the end in the same order that the installs were executed. The installer puts the kexts in tempfile/thestevo then the other installers run. At the end of OSInstall.mpkg the postflights start to run and our installer first removes the existing files from /system/library/extensions and copies our installed ones from tempfile/thestevo. Removing the existing ones is necessary because cp will not overwrite files with root:wheel ownership.


Part B: Add to Install Checklist


This requires editing OSInstall.mpkg. The way I did it will be as follows, I'm sure there is an easier way, but I didn't use it. Feel free to let me know if it should be different.

  1. Copy OSInstall.mpkg to some place to work with it (e.g. desktop)
  2. Open OSInstall.mpkg in Flat Package Editor (Inside of PackageMaker, will show up on 'Open with' list after you launch it once through the menu command inside PackageMaker)
  3. Copy 'Distribution' from inside Flat Package Editor to some place to work with it.
  4. Open 'Distribution' in TextWrangler.
  5. Use the find command to find every instance of SSE2. Copy every line, or set of lines, pertaining to SSE2 and modify the references as per what you set the package settings to before you built it.
  6. Double check to make sure that every SSE2 reference has a corresponding one for your package and that it has been properly changed to match what your installer package settings are.
  7. Save the file and fix the permissions. Chown and Chmod it like before.
  8. Delete the 'Distribution' file that is inside of the Flat Package Editor.
  9. Copy the 'Distribution' that you edited into Flat Package Editor.
  10. Save OSInstall.mpkg in the Flat Package Editor.
  11. Copy OSInstall.mpkg into the /system/installation/packages folder of the ISO.
  12. Fix permissions on /system/installation/packages of the ISO.
    chown -R root:wheel /volumes/disc_name/system/installation/packages
     chmod -R 755 /volumes/disc_name/system/installation/packages

Concept: SSE2 is an item that is on the main level of the packages list. This process simply duplicates the entries and uses them as a template to fill your own information into. It helps ensure that everything is correctly entered.


Samples of all changes can be seen by the files in the 'Development' folder. This guide will be refined, input welcomed.




* MD5s are in a file inside the 'Development' folder.

* Please seed!

* Please report if it works! A simple 'It works' helps me know what to think when somebody tells me it didn't work. I need to know whether my patch is bad or their setup is wrong. If I don't get feedback, I can't help others.


Remember to drop by the 775Dual-VSTA wiki! Its newly revised and unlocked so that others can make changes too!

Link to comment
Share on other sites

hi StevoThanks a lot 4 your work, it is v much appreciated.a question: can i just simply use ppf-0-matic to integrate your patch?I changed the appleviaata.kext and modified it by adding 0x05911106, then created a dvd, but i won't boot!Did it by creting a n image on tiger of kalyway, opened it, modify the necessary string, then burned the dmg back on dvv with toast.Such a pain, can't get sata to work, did a clone of tiger 10.4.11, but no luck! blinking cursor.Sorry if i am a bit confused, but i am a bit of a noob on mac os x, and can't understand your above steps, a bit difficult.

Saw it few minutes ago - loaded and installed. Great. Now my Xbench Score runs up to about 130. Before only 85 in caus of the slow ide. Now i runs on my Sata. Big - big thanks!
Sorry Nadeo, can u read my post, hope u can give me some help!Thanks
Link to comment
Share on other sites

The guide for making the DVD yourself is only for those who want to know how to do it. The PPF is included along with the development files.


You can use PPF-O-Matic to apply the PPF to Kalyway, and that is all that is necessary.

Link to comment
Share on other sites

The guide for making the DVD yourself is only for those who want to know how to do it. The PPF is included along with the development files.


You can use PPF-O-Matic to apply the PPF to Kalyway, and that is all that is necessary.




You deserve a prize! Hope the patch will work for me.


Thanks a lot

Link to comment
Share on other sites

Nice work, thank you.

I have a 4coredual-vsta. I had everything working (except wireless), but drives were ide only. Now I made a major upgrade to the machine: a new ati hd 2600 xt, new&faster&more ram, fat sata drive and some other things...So now I start caring for sata, which does NOT work by now. Could you post or link that VERY interesting UDMA-SATA kext or do you have to work on it first?


Regarding Leo dropping connections, that's something known to (official) mac users. I had it on my macbook since Leo, but the wireless driver sucked even with Tiger. There is probably some sort of bug or pseudo-bug somewhere, but I succeeded in making things better at least. There's a sort of tcp enhancement aka rfc 1323 aka dynamic tcp scaling (or something like that). Without getting too technical, those having connection dropping/freezing problems - specially when there are A LOT of connections open (read P2P but not only) - could try creating a file in /etc, calling it sysctl.conf and putting the following inside:





Then restart and...maybe...

Last note: I suspect it might be a router problem also, which handle bigger tcp windows differently. The proposed solution helps by keeping those windows at the old standard size. Google rfc1323 if you need more details.


Sorry if this is off topic somehow, but I answered to 1. the connection dropping thing 2. the better info sharing thing :P



Link to comment
Share on other sites



Network, sound, work perfectly, only issue is that leo does not recognise my belkin usb hub 2.0, strange.


Thanks a lot Stevo, ppf-o-matic did not work on leopard, but i used the win version and after patched i burned the dvd with ultraiso Sata, sound, network are with your patch auto installed.


First class!


Asrock 4coredual-vsta

Pentium D 805 (>3.33ghz)

2gb ddr2 667mhz

2x 80gb sata hdd (no raid)

Pny 7600gt 256mb

Link to comment
Share on other sites

Mouse tearing is a problem with the graphics card (driver) not the motherboard. However, to specifically answer your question; no, I have never had mouse tearing with Leopard on the 775Dual-VSTA through all my reinstalls and two nVidia graphics cards.



Link to comment
Share on other sites

I understood from some other posts around the forum that your patch has solved the connection dropping problem. Is that so? - and if so, is there any way I can download just that one patch, or any of your patches seperatly for that matter? I've already installed Kalyway and got my rig running fine, except for the network connection and don't feel like going through the hassle of having to burn another DVD and install the whole thing over again.


Appreciate it

Link to comment
Share on other sites

Thanks Stevo,It is such a pain, but i can live with it, no problems.now i got a new issue.......network, connection dropping, no internet. In the network settings once the connection to internet stops, you can see on tcp the 'self-assigned ip', tried manually insert my ip, but no luck.Any idea, maybe i have to add that ip (192.168.0.x) to DNS settings?Thanks in advance.By the way,i have a 4coredual-vsta mb.PS. i am typing form a Leopard where i have manually installed the viarhine.kext. B4 using your patch i had to press f8 and type -f for the kext to load, now....not anymore. Only difference is that i have no conn dropping here (40gb ide hdd).any idea?

Link to comment
Share on other sites

Guys, I'm sorry, but I don't know what the connection dropping thing is about; as I said in the first post. I did numerous reinstalls and it was there sometimes, and other times it was fine. The only thing I know is it looks to be related to heavy traffic.


I don't really think you can say that my patch solves the problem, because I've had it before in the installs I did to test my patch. I think it is intermittent, and I'm not sure what it is a result of in the install. When I have time, I'll look into it.


However, if you do feel compelled to somehow do something: The kext I've used is the same one I've always used. You can find it in the development folder in kexts and install it manually if you wish. It shouldn't bring you any different results because if it works at all you are most likely using the same kext right now.


I'm sorry, I just truly do not know. I don't have the time to explore the issue right now.



Link to comment
Share on other sites

hi guys,


just installed viarhine.kext from macdotnub 10.4.10 tiger dvd, and it made a diference. Only things, i have to again press f8 and then type -f to load the kext otherwise it won't work (error, kext not installed properly).


Maybe you Stevo, know what to do. I think i have to type something in the terminal for the kext to be installed properly.......hope you know what.......i am sure you know.


Thanks mate.

Link to comment
Share on other sites

Ciao Stevo,


everything worked for me with your patch on a asrock 4coredual -vsta on the first install on a sata hard disk...thank you for your effort.

Great work, i'am looking forward for your specific package for the 4corecore.

Ciao e grazie



Link to comment
Share on other sites

Litania, I don't know. Sounds like the system isn't able to properly create the mkext file and therefore requires a rebuild of the cache every time. You could try putting -f in boot flags in boot.plist, that way it would at least look the same as if it was perfect, it will just take a little longer to boot.


Friestok, thanks for the report. Good to hear.


I need to make a clarification that was just brought to my attention.


The ASRock 775Dual-VSTA and the 4CoreDual-VSTA have the same SATA controller, the 8237A. The 4CoreDual-SATA and revision 2 have the 8237S. I thought that the 4CoreDual-VSTAs had the 8237A also, so if I told you that: my bad, I apologize. I am working with user lean to work out 4CoreDual-VSTA issues.


However what would help me the most:


I NEED reports from 4CoreDual-VSTA, 4CoreDual-SATA, and 4CoreDual-SATA R2 owners on the following questions.


1. What board do you have of the three. (Know for absolute sure! Give full board name as listed above!)

2. Does my patch let the installer find the SATA drives?

3. Is UDMA enabled on IDE drives? (Easiest way to tell is run an xBench on an IDE drive and if the disc results just crawl you'll know its off)

4. Additional info?


Theoretically the 4CoreDual-VSTA should work EXACTLY the same as the 775, but it doesn't appear to be that way. Even though lean has provided me with a working kext, I think that if we can gather some information as a community about why they behave different we'll be better off.




Edit: UDMA for IDE only.

Link to comment
Share on other sites

Hi Stevo,My mb is 4coredual-vsta, i don't think is the R2 or sata as they came out much later (mine is nearly 2 years old).


On the box it says 4coredual-vsta/a/asr.


Using your patch embedded to the kalyway dvd leo installer makes the sata being recognised (i have 2, and 1 is sata2).


about the udma, below are the results of xbench disc test only:


Results 58.78


System Info Xbench Version 1.3

System Version 10.5.1 (9B18) Physical RAM 2048 MB

Model Mac Pro

Drive Type WDC WD800JD-75JNA0 WDC WD800JD-75JNA0

Disk Test 58.78

Sequential 90.90

Uncached Write 83.28

51.14 MB/sec [4K blocks]

Uncached Write 95.38

53.97 MB/sec [256K blocks]

Uncached Read 79.57 23.29 MB/sec [4K blocks]

Uncached Read 111.80 56.19 MB/sec [256K blocks]

Random 43.43

Uncached Write 15.54 1.65 MB/sec [4K blocks]

Uncached Write 107.28 34.34 MB/sec [256K blocks]

Uncached Read 92.79 0.66 MB/sec [4K blocks]

Uncached Read 130.73 24.26 MB/sec [256K blocks]


Thanks a lot.


by the way,


What about that com.apple.network.identification.plist in system configuration folder? Has it anything to do with the network loss?


Anyway, stevo, when u say boot.plist, r u telking about com.apple.boot.plist ? And when i'm there, where to add the -f?


Thanks 4 patience and help!

Link to comment
Share on other sites

i have a 4coredual-sata2 board. <br /><br />tried patching my kalyway dvd (made an image using toast since i lost my .iso to an hd crash and patched that). burned the dvd and re-installed kalyway. the 775 addition to the installer customize menu did not show up. i guess the patch didn't work. have repatched it and checked with pacifist to see if the packages made it to the installer. will report soon if it works.<br /><br />



edit: typo

Link to comment
Share on other sites

I kind of solved the connection dropping thing on my 4CoreDual-Vsta. Part of the solution is doing what I explained a few posts above (though no one seems to care?), the rest was enabling full duplex in the ethernet tab - for unknown reasons it was set to half duplex. Half duplex means causing a LOT of collisions which then cause that strange interupt() Tx still on error message by ViaRhine. And yes, it's interupt with 1 r ;) . Have a look in your logs if that's happening on your machine also. It's still quiet slow, but didn't drop since. I installed Leo on a SATA drive, so patching worked and sata works too. Regarding the details and udma, I'll post them later, but xbench looks similar or even better than litania's if I remember correctly. Isn't there a better way to tell about udma??



Link to comment
Share on other sites

I'm sorry, I should have clarified. UDMA is only for IDE. SATA uses another type of DMA (Direct Memory Access) so I need the xBench on any UDMA compatible IDE drive (which includes most anything fairly recent).


Litania, when I referred boot.plist I meant /Library/Preferences/SystemConfiguration/com.apple.boot.plist

You should see this:

<key>Kernel Flags</key><string></string>

Just add the boot flags in the middle of <string></string>.


Ricx, good work. I tried putting it at full duplex out of curiosity a couple times, but I never gave much mind to the results. Now that I think of it, I don't remember it dropping when fully duplexed. However, if I remember correctly the performance is worse when fully duplexed.


And as for checking UDMA, there is a way to actually see it. If you open IORegistryExplorer under the ATA controller you will see a reference to UDMA mode if it is on, if not it should be unknown.



Link to comment
Share on other sites

Something I don't quite understand.

I only have SATA hard drives, and 1 IDE DVD drive. Do I need an IDE drive to install?


That is, I've tried installing 10.4.8 to no avail because of a lack of IDE drives. Does the 10.5.1 kalyway finally allow installation on SATA? The 10.4.8 disc didn't even want to recognize any SATA drives whatsoever.


much obliged,


Link to comment
Share on other sites


  • Create New...