Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
AOI Photo

OS 9.2 Where to get it

29 posts in this topic

Recommended Posts

Anyone have any way of getting this so I can install on and get working three old G3 Imacs.

 

I bought them and got home to find my os9 disc is unreadable.

 

Does anyone know of any way to get ahold of 9.2 ?

 

I just need it so I can then install the firmware update, and osX.

 

If anyone has either a link, or knows any other way. I would be eternally grateful, more importantly so would my four year old son who Is expecting his computer to be working.

 

Please, Pretty please, pretty pretty please.

Share this post


Link to post
Share on other sites

I had to do the same thing last week on my G4.

 

There are many torrent sites where you can find it, but I used the newgroups which was much faster.

 

Work of caution: There are many different copies of OS 9. Make sure you get one that is bootable, works on all machines and is not just for installing Classic 9 in OS X.

Share this post


Link to post
Share on other sites

I'll have to try the newsgroups, wow haven't used usenet in years.

 

Apparently you have to use 9.2 for these imacs.

I found an earlier version :)

I found 9.2 on the green demon, but i'm not a member.

 

Everywhere else I found it there are 0 seeders.

 

Well maybe it's off to usenet I go.

Share this post


Link to post
Share on other sites

The bootable version I found was 9.1

 

I think you only need 9.2 for classic in OS X.

 

According to Mactracker, most G3s can use Mac OS 8.0 to OS X 10.2.8 except for the Blue and White G3 which can use Mac OS 8.5.1 to the most current OS X.

Share this post


Link to post
Share on other sites

Yeah guess it is 9.1 I need.

Irritatingly I have 9.0.4 (9.1 is required)

I have the upgrades to 9.1 and 9.2

I just can't install anything till I get 9.1 or 9.2

I found a 9.1 torrent, getting 1kps right now, estimated time of about a week :jester:

Guess I'll keep hunting.

I have a friend with a decent newsserver account. I'll ask him to keep an eye out too.

Thanks

Share this post


Link to post
Share on other sites
It's on the demon, version 9.2.2

I think AOI Photo solved the problem already anyways, but for reference for others:

 

Are you sure that isn't that 9.2.2 Classic installer?

 

Using that and removing the classic support files was a no go for me. Although it would show up in startup disk, it would not boot into it directly.

(Which is needed for firmware updating.)

 

I had to track down a bootable OS 9 CD.

Share this post


Link to post
Share on other sites

Um, I think so. Here's the description:

Not machine specific!

can be used on all machines (i think)

english version

latest os version with fixes for usb cevices ....

no further desribtion needet!

 

Ps: for old cd drives its better to burn it with low speed and dont open the dmg on osx before you burn it!!

 

I can't test it because I'm on an Intel Mac and sheepshaver runs max 9.0.4, but from what they say, I'm pretty sure it's bootable.

Share this post


Link to post
Share on other sites

First of all, newer G3s can run all the versions of OS X up to 10.4. 9.2 is available on a bunch of torrent sites. You shouldn't have trouble finding it. Yeah, PearPC RUNS OS X, PearPC doesn't run UNDER OS X. PearPC can run any OS for PowerPC processors.

Share this post


Link to post
Share on other sites

PearPC can run under OS X, I remember seeing a screenshot, but haven't been able to locate it again :)

 

and it will deffinately run 9.22

Share this post


Link to post
Share on other sites
PearPC can run under OS X, I remember seeing a screenshot, but haven't been able to locate it again :)

 

and it will deffinately run 9.22

Yeah, but the point was to get it to run a firmware update...updating the firmware through a VM is impossible

Share this post


Link to post
Share on other sites
Oh yeah maybe you can run PearPC under OS X using the Linux port.

 

What? The problem is if he doesn't natively run OS 9 on his iMac he can't install the latest firmware update needed for Mac OS X 10.2 or later, without this firmware update all hell breaks loose.

Share this post


Link to post
Share on other sites

It wasn't an answer to the problem, just a thought about running PearPC UNDER OSX. And the answer is No, you can't install firmware updates through PearPC.

 

The easiest way is to DL 9.2 via torrent, install it, install the firmware and format the drive and install OS X. I wouldn't feel any guilt in using a pirated 9.2 for a couple minutes only.

Share this post


Link to post
Share on other sites
It wasn't an answer to the problem, just a thought about running PearPC UNDER OSX. And the answer is No, you can't install firmware updates through PearPC.

He's just saying you awoke a thread after several months to basically repeat what I said in post #4 :dev:

 

The easiest way is to DL 9.2 via torrent, install it, install the firmware and format the drive and install OS X. I wouldn't feel any guilt in using a pirated 9.2 for a couple minutes only.

This was established from the beginning.

The issues are that there are several version on torrents sites and not all work with every mac and that his download speeds are very bad.

 

matt_olsen, if by chance you don't have it already, PM me.

Share this post


Link to post
Share on other sites

*Repeated for about the third time*

 

Emulation will not work if your purpose is to install a firmware update. Its beyond the scope of power of VMs. The only way to accomplish this is to get a copy of 9.2, install it temporarily and install the firmware update.

 

Although I'm curious, what is the OS that the iMacs are running right now? If they are running something old like OS 8 or a old version of OS 9, then they are probably not suited for OS X anyway.

Share this post


Link to post
Share on other sites

Im truly interested in get mac os 9, i need to update my G4 Firmware, and i need the stupid mac os 9... plase anyone can give any clue for searching the link? :P

Share this post


Link to post
Share on other sites
Im truly interested in get mac os 9, i need to update my G4 Firmware, and i need the stupid mac os 9... plase anyone can give any clue for searching the link? :D

 

If you are part of Revolutiontt.net, I will upload it for you...

 

Let me know...

Share this post


Link to post
Share on other sites

I was going to upload it to btjunke.org, but there are already a few copies up.

 

Search "mac os 9"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Baio77 per me ciò che hai scritto è abbastanza "arabo" non ho capito nulla... comunque mi sono rivolto prevalentemente a questo forum per sistemare delle cose che non funzionavano e molto gentilmente Gengik me le ha sistemate, facendo lui però... io ho solo capito che l'impostazione per la grafica non va messa perché crea fastidiosi sfarfallii all'interno delle applicazioni nonché al finder nella parte superiore a sinistra (se leggi i post precedenti trovi le descrizioni)... stop sono riuscito a risolvere solo questa cosa da me leggendo anche in altri forum  proverò il tuo config.plist pulito e farò sapere. Grazie dell'aiuto
    •   Thank you Baio77. Here is my CLOVER folder and the Hack info. 
            For Some Reason I can't upload my CLOVER folder. But here you can download...
      https://www.dropbox.com/s/vjprxs1idtj9pt7/CLOVER.zip?dl=0     Thank you again!!!   HackInfo_Report.zip
    • The brightness is NOT from Sierra, in my signature you find tools with which to give info on your system .....
      Post Hack Info and the clover folder ......
      Only in this way can I help you ......
    • Few more minutes to go before going live again with https://OSXLatitude.com
          So you can lock this topic again @Allan Hopefully for a bit longer than a couple of weeks this time hehe.
    • ok, I am having a weird glitch with my Primary bios after modding it myself. can I get some help getting a Clean osmosis modded (for High Sierra and beyond) Bios Image?   https://www.gigabyte.com/us/Motherboard/GA-Z87X-UD5-TH-rev-1x#support-dl   the version I have always stuck with was F4, because the F5d.  I use a custom iMac 14,2 configuration that has been stable, the issues I have with stability come from not being able to get Access to the Bios, and prior to my attempt to mod it has been stable with up to High Sierra using clover, and up to Sierra with my very very old Ozmosis 894m F4 rom. I am not opposed to installing Ozmosis on the EFI Partition, But Gigabyte locked the Bios loading .efi Files, there is no shell to Force it to load HFS+ or APFS drivers.   so what I am asking for is assistance ether unlocking a Shell for my Bios, or getting a bios with the APFS, HFS+, and Ozmosis related files in it.   thanks again for everyones assistance. HBP


×