Jump to content

Instalación macOS Ventura Beta 1


Derty
 Share

94 posts in this topic

Recommended Posts

Bueno, pues he probado la 6600 en el i5, y es peor que la 6650XT, literalmente es imposible llegar al escritorio en ventura, de ningúna manera arranca, En Monterey si, pero ventura nadita..

 

He probado a instalar de nuevo e instalar instala perfectamente, pero cuando llega al ultimo reinicio para llegar a la pantalla de configuración se reinicia automáticamente antes de dar imagen en pantalla....

 

Un desastre jajajaja 😆....  

 

Ni con el DSDT de Maldon ni sus EFIs para alder lake, nada funciona en ventura en ese equipo y una RX6600... y con la 6650XT si que funciona pero sin nada de DRM....

 

 

El que va muy bien es el portátil Lenovo 520s de la firma.... dentro de sus posibilidades pues e un i3 muy bajo de gama y con solo un banco de memoria ram asi que aun por encima trabaja en sigue Channel.....

 

funciona el encoder, y hasta el wifi intel con el ultimo Kext para ello... pero como siempre tiene que fallar algo, el trackpad no funciona en Ventura 😁

 

 

GJPnbse.png

 

Un Saludooteee

 

 

Edited by PoMpIs
  • Like 1
Link to comment
Share on other sites

@miliuco @Derty  

 

Conseguido DRM a tope con la RX 6600, he descubierto que hay ya revisiones nuevas de RX6600, la mia es algo rara,  no sale listada ni en la base de datos de GPUz ni en Techpowerup, funciono siempre bien en Monterey, incluso en el Ryzentosh con monterey va perfecta sin hacer nada, pero ahora en Ventura ya no es tan fácil y cuando carga el sistema da pantalla en negro...( le esta pasando a mas gente )

 

Le he solucionado en el DSDT después de mogollón de pruebas... con esta RX6600 o pongo lo siguiente o en Ventura no se ve el escritorio:

 

Device (PEGP)
                        {
                            Name (_ADR, Zero)  // _ADR: Address
                            Name (_SUN, One)  // _SUN: Slot User Number
                            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                            {
                                Local0 = Package (0x14)
                                    {
                                        "model", 
                                        Buffer (0x13)
                                        {
                                            "AMD Radeon RX 6600"
                                        }, 

                                        "ATY,FamilyName", 
                                        Buffer (0x13)
                                        {
                                            "AMD Radeon RX 6600"
                                        }, 

                                        "ATY,DeviceName", 
                                        Buffer (One)
                                        {
                                             0x00                                             // .
                                        }, 

                                        "@0,name", 
                                        Buffer (0x0C)
                                        {
                                            "ATY,Henbury"
                                        }, 

                                        "@1,name", 
                                        Buffer (0x0C)
                                        {
                                            "ATY,Henbury"
                                        }, 

                                        "@2,name", 
                                        Buffer (0x0C)
                                        {
                                            "ATY,Henbury"
                                        }, 

                                        "@3,name", 
                                        Buffer (0x0C)
                                        {
                                            "ATY,Henbury"
                                        }, 

                                        "device_type", 
                                        Buffer (0x12)
                                        {
                                            "ATY,HenburyParent"
                                        }, 

                                        "device-id", 
                                        Buffer (0x04)
                                        {
                                             0xFF, 0x73, 0x00, 0x00                           // .s..
                                        }, 

                                        "hda-gfx", 
                                        Buffer (0x0A)
                                        {
                                            "onboard-1"
                                        }
                                    }
                                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                                Return (Local0)
                            }
                        }

                        Device (HDAU)
                        {
                            Name (_ADR, One)  // _ADR: Address
                            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                            {
                                If ((Arg2 == Zero))
                                {
                                    Return (Buffer (One)
                                    {
                                         0x03                                             // .
                                    })
                                }

                                Return (Package (0x0A)
                                {
                                    "AAPL,slot-name", 
                                    "Integrado", 
                                    "name", 
                                    "HDMI Controller", 
                                    "Integrado", 
                                    Buffer (One)
                                    {
                                         0x00                                             // .
                                    }, 

                                    "model", 
                                    Buffer (0x1A)
                                    {
                                        "AMD HDMI Audio Controller"
                                    }, 

                                    "device_type", 
                                    Buffer (0x10)
                                    {
                                        "HDMI Controller"
                                    }
                                })
                            }
                        }
                    }
                }
            }

 

Poco mas y tengo que hacer el pino puente a una mano, la madre que parió a esta GPU y a MacOS ventura...

 

Pero ha merecido la pena, app TV a full, app Amazon video a full, encoder y decode a full en Ventura, ahora si que da gusto... no podía quedarme con esa espinita ahí jodiendome 😅..

 

lXhISB8.png

 

Ahi lo esta reproduciendo appleTV y Netflix en safari:

 

uOWAXGM.png

 

Un Saludootee compis :frantics:

 

 

Edited by PoMpIs
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

@PoMpIs

Mi RX 6600 tiene el mismo device-id, 73FF, y con SMBIOS de iMac no tengo DRM en Safari aunque puedo ver TV app con el argumento de arranque unfairgva=yes. Voy a probar tu DSDT a ver si también consigo DRM en Safari. Ya te comentaré.

  • Like 1
Link to comment
Share on other sites

@miliuco Da igual el device-id, eso es igual en todas las RX6600/XT, lo que cambia es la revisión, y tienen otra bios... tuve varias RX6600, y las primeras del año pasado no hay que hacer nada, solo necesitan el flag agdpmod=pikera e unfairgva=1  ( este ultimo para el DRM ) ...  Pero la que yo tengo tiene una bios rara, ya el GPUz no la marca en su base de datos, supongo que una bios muy nueva y cambia el ID del subsistema creo que es..... Tampoco puedo meter una bios aterior porque el amdvbflash dice que no coincide el SSID del chip ( cosa que es cierta ).. puedo flashearla con el programador SPI, pero no tengo un Dump de una mas antigua.

 

La inyección que puse es en el DSDT, no es un SSDT.... si quieres te paso el DSDT¿?....

 

De todos modos sigo haciendo mas pruebas en un SSD aparte, porque el apaño funciona bien, y bueno, menos es nada, pero me gustaría que funcionara igual que lo hace una RX6600 de las primeras la verdad, sin tener que parchar nada..

 

Un saludooo :)  

Link to comment
Share on other sites

@PoMpIs

No subas el DSDT, sólo por si era un SSDT independiente. De todas maneras puedo añadir código al tuyo para que sea un SSDT estándar. Gracias.

Mi RX 6600 tiene device-id 73FF, vendor 1002, revisión 00C7, subsistema 1DA2, revisión de la ROM 113-2451LMH-U03. 

 

  • Like 1
Link to comment
Share on other sites

Yo me voy a volver loco con MacOS Ventura jajajaj 😆 ...

 

Al final he flasheado una bios a la GPU con el programador SPI,... es una Sapphire RX6600....

 

Ahora bien, en Monterey una maravilla, esto chuta sin hacer nada.... ha cambiado el SSID y bien, pero yo tengo un problema muy gordo con esta plataforma Alder Laker, no se lleva bien con estas GPUs, porque vienen capadas a PCIe X8 4.0, y ahora en Ventura, no hay manera de que cargue el escritorio, se queda siempre la pantalla en negro o se reinicia de golpe así sin mas... un desastre..

 

Ahora tengo los mismos IDs que tu, que es la bios antigua, pero sigue siendo diferente la versión de la ROM: 113-2447LHS-UDB  

 

Con la 6650XT no tengo ese problema de reinicio o pantalla en negro, pero quedo sin DRM :( .. 

 

Seguire indagando, a ver si al final doy con algo compatible sin parches

 

  • Like 1
Link to comment
Share on other sites

He podido cazar el Panic que da sin el parche en el DSDT en Ventura:

 

{"bug_type":"210","timestamp":"2022-06-16 13:19:06.00 +0200","os_version":"macOS 13.0 (22A5266r)","roots_installed":0,"incident_id":"E18DD537-6EC8-4128-A5E5-1ACDB6A8CE80"}
{"macOSProcessedStackshotData":"bm8gb24gZGlzayBwYW5pYyBzdGFja3Nob3QgZm91bmQgaW4gY29yZWZpbGU=","macOSPanicString":"panic(cpu 0 caller 0xffffff7fab5862a8): \"[3:0:0][PPLIB] Failed to send PPLIB IRI to Accelerator. TTL Error Message: {15711515958:[3:0:0] Error SW_IP_CLIENT_ID__GC: event_id=0xc00c0401 event_info:type=3 hw_id=0 event_specific_tag=0x0 pData=0 data_size=0 }{20747748094:[3:0:0] Error PSP: event_id=0x140401 event_info:type=3 hw_id=0 event_specific_tag=0x3 pData=0 data_size=0 [FW] psp_cmd_km_fence_wait: fence timed out \n}{20747758917:[3:0:0] Error PSP: event_id=0x4010020d event_info:type=3 hw_id=0 event_specific_tag=0x2 pData=0 data_size=0 [FW] psp_asd_load: failed due to CMD submission failure \n}{20858509600:[3:0:0] TTL Even.\n\" @AmdRadeonController.cpp:2001\nPanicked task 0xffffff86ae63f988: 10 threads: pid 226: WindowServer\nBacktrace (CPU 0), panicked thread: 0xffffff8b77e6f4e0, Frame : Return Address\n0xffffffd5283db500 : 0xffffff801e5323dd \n0xffffffd5283db550 : 0xffffff801e69ab56 \n0xffffffd5283db590 : 0xffffff801e689df0 \n0xffffffd5283db5e0 : 0xffffff801e4cd951 \n0xffffffd5283db600 : 0xffffff801e5326bd \n0xffffffd5283db6f0 : 0xffffff801e531d69 \n0xffffffd5283db750 : 0xffffff801ed1613b \n0xffffffd5283db840 : 0xffffff7fab5862a8 \n0xffffffd5283db950 : 0xffffff7fab547fc9 \n0xffffffd5283db990 : 0xffffff7fab585146 \n0xffffffd5283db9e0 : 0xffffff7fab54c870 \n0xffffffd5283dba40 : 0xffffff7fb43cacf9 \n0xffffffd5283dbad0 : 0xffffff7fab54c7fc \n0xffffffd5283dbaf0 : 0xffffff7fb43c0f0e \n0xffffffd5283dbb80 : 0xffffff801ec177dc \n0xffffffd5283dbbe0 : 0xffffff801ec87dd7 \n0xffffffd5283dbc50 : 0xffffff801e641257 \n0xffffffd5283dbca0 : 0xffffff801e50a806 \n0xffffffd5283dbd50 : 0xffffff801e523218 \n0xffffffd5283dbdc0 : 0xffffff801e52393a \n0xffffffd5283dbef0 : 0xffffff801e66cd4a \n0xffffffd5283dbfa0 : 0xffffff801e4cddb6 \n      Kernel Extensions in backtrace:\n         com.apple.iokit.IOGraphicsFamily(597.0)[1418696D-9CF9-3249-B6B4-CA695BF037F6]@0xffffff7fb43b0000->0xffffff7fb43defff\n            dependency: com.apple.iokit.IOPCIFamily(2.9)[98643CEB-CCC7-3DA8-B1DE-0C82D4D28F2B]@0xffffff8020ffc000->0xffffff802102afff\n         com.apple.kext.AMDRadeonX6000Framebuffer(4.0.9)[97BFB693-7A25-3C1D-A3B4-B33F335DA4F1]@0xffffff7fab537000->0xffffff7fab7c0fff\n            dependency: com.apple.AppleGraphicsDeviceControl(7.1.14)[B3BE5F58-0040-3606-907A-FFE6385C38C1]@0xffffff7fb330a000->0xffffff7fb330dfff\n            dependency: com.apple.iokit.IOACPIFamily(1.4)[62C52EB0-4D0B-3A00-B4B0-A1841EA15AB4]@0xffffff8020b8c000->0xffffff8020b8dfff\n            dependency: com.apple.iokit.IOGraphicsFamily(597)[1418696D-9CF9-3249-B6B4-CA695BF037F6]@0xffffff7fb43b0000->0xffffff7fb43defff\n            dependency: com.apple.iokit.IOPCIFamily(2.9)[98643CEB-CCC7-3DA8-B1DE-0C82D4D28F2B]@0xffffff8020ffc000->0xffffff802102afff\n\nProcess name corresponding to current thread (0xffffff8b77e6f4e0): WindowServer\nBoot args: -v agdpmod=pikera unfairgva=1\n\nMac OS version:\n22A5266r\n\nKernel version:\nDarwin Kernel Version 22.0.0: Tue May 24 20:31:35 PDT 2022; root:xnu-8792.0.50.111.3~5\/RELEASE_X86_64\nKernel UUID: 198748B0-2858-345A-957A-45C9ACB4C2F2\nroots installed: 0\nKernelCache slide: 0x000000001e200000\nKernelCache base:  0xffffff801e400000\nKernel slide:      0x000000001e210000\nKernel text base:  0xffffff801e410000\n__HIB  text base: 0xffffff801e300000\nSystem model name: iMacPro1,1 (Mac-7BA5B2D9E42DDD94)\nSystem shutdown begun: NO\nPanic diags file available: YES (0x0)\nHibernation exit count: 0\n\nSystem uptime in nanoseconds: 21309811186\nLast Sleep:           absolute           base_tsc          base_nano\n  Uptime  : 0x00000004f629eb48\n  Sleep   : 0x0000000000000000 0x0000000000000000 0x0000000000000000\n  Wake    : 0x0000000000000000 0x0000000c2d8ed6cc 0x0000000000000000\nCompressor Info: 0% of compressed pages limit (OK) and 0% of segments limit (OK) with 0 swapfiles and OK swap space\nZone info:\n  Zone map: 0xffffff8044385000 - 0xffffffa044385000\n  . PGZ   : 0xffffff8044385000 - 0xffffff8048386000\n  . VM    : 0xffffff8048386000 - 0xffffff85146b9000\n  . RO    : 0xffffff85146b9000 - 0xffffff86add1f000\n  . GEN0  : 0xffffff86add1f000 - 0xffffff8b7a052000\n  . GEN1  : 0xffffff8b7a052000 - 0xffffff9046385000\n  . GEN2  : 0xffffff9046385000 - 0xffffff95126b8000\n  . GEN3  : 0xffffff95126b8000 - 0xffffff99de9eb000\n  . DATA  : 0xffffff99de9eb000 - 0xffffffa044385000\n  Metadata: 0xffffffca85550000 - 0xffffffcaa5550000\n  Bitmaps : 0xffffffcaa5550000 - 0xffffffcab1550000\n\n\n\n"}

 

y eso con la bios mas antigua, algo raro tiene mi equipo con estas GPUs y Ventura..... lo bonito es que así funciona todo... no se si cambiando a MacPro7,1 iría mejor... pero ya me empiezo a quedar sin ideas :(

 

Woc0O15.png

 

Vyqjd5K.png

Edited by PoMpIs
  • Like 1
Link to comment
Share on other sites

@miliuco Tiens el GPUz a mano??  podrías hacerme el favor de sacar una copia de la bios de tu GPU y pasármela ?? .... he probado varias bios y empiezo a creer que es cosa del propio diseño interno de esta RX6600.. la he probado en otro equipos que funcionan a la perfección, y con esta sucede lo mismo que en mi i5, no acaban de cargar el escritorio, lo hace una vez de 15 intentos... eso si, cuando lo hace funciona todo a full... cosa rarísima....

 

Y en monterey no da ningún tipo de problema esta GPU, ni la 6650XT tampoco, esta ultima ya ves que funciona de maravilla en Ventura, pero sin DRM :( ...

 

Todos los que he visto con DRM a full en ventura son con GPUs anteriores, como las 5xxx ..

 

Un Saludo

Link to comment
Share on other sites

Con las versiones actuales de OpenCore y extensiones (17 de junio) ya puedo instalar y utilizar Ventura con la misma EFI que uso en Monterey. Al principio necesité una EFI que preparó @Stefanalmare y unos ajustes de @Cyberdevs pero con ayuda de @eSaF y del trabajo de Acidanthera he podido volver a mi EFI habitual. Todo el hardware parece funcionar bien aunque ya habéis visto que Ventura tiene algunas pegas pero en general también puedo decir que es sorprendente lo bien que va para ser una versión tan temprana.

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

@miliuco muchísimas gracias, mi 6600 es el mismo modelo que la tuya, pero con una bios nueva que como dije no sale ni en la base de datos de techpowerup……. 
 

ahora arranca en ventura peeeero.. necesito el parche del DSDT en ventura sino no da vídeo…. 
 

pero ahora he descubierto más problemas en ventura…  que te contaré después que estoy escribiendo desde el iPad y no es lo mismo que desde el ordenador jajaja

 

EDITO:    Aqui estoy desde ventura con la 6600 y ful decoder, funciona todo, app TV app Amazon, Netflix en safari Disney+ HBO, todo...

 

wHKgmpF.png

 

Pero no se el porque, al usar esta Rx6600, petan los USBs de esta placa en Ventura, en Monterey todo bien, pero en ventura no me sirve el mapeo de USBs.... de ahí que muchas veces que reinicio no llega al escritorio porque se apaga el equipo a lo bestia como si lo desenchufara de la corriente....  

 

Esto no es nuevo para mi, porque eso lo hacia aleatoriamente en windows con una RTX3080... pero muy poco, a lo mejor una vez a la semana... .pero en macOS dependiendo de la GPU que uses se apaga al entrar al escritorio... con la RX6650XT no sucede eso.... puedo usar la misma EFI para Monterey y Ventura sin problemas...

 

De todos modos esta paca Asus b660 "casi no tiene USBs", es decir, son HUBs internos Asmedia 107x lleva 4 creo.. y eso es una mierda, dan mucho por saco...

 

Fijaros la de Hubs Asmedia que tiene:

 

zcUEZep.png

 

Y uno lo tengo apagado en bios......  

 

Esos HUBs ineternos con MacOS Ventura se vuelven locos al reiniciar, y es cuando al volver a arrancar se apaga el PC a lo loco.....  lo extraño es que eso no sucede con la RX6650XT... solo que con esta ultima no hay DRM era Ventura ni ningún tipo de encoder decoder....

 

En fin, que el problema esta en   PLACA/BIOS/Tipo de GPU que se use/Mapear USBs------  cosa que es casi imposible con tanto HUB interno, tengo USBMap que hice en windows que funciona muy bien usando la RX6650XT, con esta GPU no va.... 

 

Un Saludooo 

 

 

 

 

Edited by PoMpIs
  • Thanks 1
  • Sad 1
Link to comment
Share on other sites

aqui también al final funciona en safari netflix y demás, con los últimos kexts compilados, el opencore de ayer, imacpro 1.1 y la inyección de la rx6600xt....

 

 

  • Like 1
Link to comment
Share on other sites

@miliuco  Pues después de pelearme mucho con el i5 y la RX6600, he logrado hacer funcionar el conjunto a full en Ventura....

 

Lo asombroso es que funciona todo, solo con tener en el DSDT ATY,Henbury  mas un Fake-ID 73E0 con eso mi RX6600 funciona bien, no necesito ni WEG ni agdpmod=pikera ni unfairgva=1 nada... funciona Netflix en safari, appTV, app Amazon prime, audio por DP/HDMI etc....  y el resto del equipo igual, funciona el reposo, los usbs, vamos todo....  no tengo nada de nada en boot-args ni siquiera necesito AppleALC ni kext para la red i225v

 

jMLiRWF.png

 

A veces los fallos son por exceso de cosas 😄

 

Un Saludootee 

 

 

  • Like 1
Link to comment
Share on other sites

2 minutes ago, miliuco said:

@PoMpIs

Enhorabuena!!! Ese código para la gráfica que tienes en el DSDT se puede portar a SSDT independiente sin excesivo trabajo? Para probarlo por separado. 

 

El código te lo dejo aquí pero yo de SSDTs ando perdido...  voy a ponerme a mapear los USBs desde la propia tabla SSDT extraída de la bios con el tutorial que tiene 5T33Z0 pero va ser una ardua tarea 😆 

 



Device (PEGP)
                {
                    Name (_ADR, Zero)  // _ADR: Address
                    Device (EGP1)
                    {
                        Name (_ADR, Zero)  // _ADR: Address
                        Device (PEGP)
                        {
                            Name (_ADR, Zero)  // _ADR: Address
                            Name (_SUN, One)  // _SUN: Slot User Number
                            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                            {
                                Local0 = Package (0x10)
                                    {
                                        "model", 
                                        Buffer (0x17)
                                        {
                                            "Sapphire Radeon RX6600"
                                        }, 

                                        "ATY,FamilyName", 
                                        Buffer (0x17)
                                        {
                                            "Sapphire Radeon RX6600"
                                        }, 

                                        "ATY,DeviceName", 
                                        Buffer (One)
                                        {
                                             0x00                                            
                                        }, 

                                        "device-id", 
                                        Buffer (0x04)
                                        {
                                             0xE0, 0x73, 0x00, 0x00                           
                                        }, 

                                        "@0,name", 
                                        Buffer (0x0C)
                                        {
                                            "ATY,Henbury"
                                        }, 

                                        "@1,name", 
                                        Buffer (0x0C)
                                        {
                                            "ATY,Henbury"
                                        }, 

                                        "@2,name", 
                                        Buffer (0x0C)
                                        {
                                            "ATY,Henbury"
                                        }, 

                                        "@3,name", 
                                        Buffer (0x0C)
                                        {
                                            "ATY,Henbury"
                                        }
                                    }
                                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                                Return (Local0)
                            }
                        }

                        Device (HDAU)
                        {
                            Name (_ADR, One)  // _ADR: Address
                            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                            {
                                If ((Arg2 == Zero))
                                {
                                    Return (Buffer (One)
                                    {
                                         0x03                                             // .
                                    })
                                }

                                Return (Package (0x0A)
                                {
                                    "AAPL,slot-name", 
                                    "Integrado", 
                                    "name", 
                                    "HDMI Controller", 
                                    "Integrado", 
                                    Buffer (One)
                                    {
                                         0x00                                             // .
                                    }, 

                                    "model", 
                                    Buffer (0x1A)
                                    {
                                        "AMD HDMI Audio Controller"
                                    }, 

                                    "device_type", 
                                    Buffer (0x10)
                                    {
                                        "HDMI Controller"
                                    }
                                })
                            }
                        }
                    }
                }
            }

[/CODE]

 

Eso yo no sabría portarlo a SSDT....

  • Thanks 2
Link to comment
Share on other sites

Yo como soy un trasto sin remedio, pues sigo haciendo pruebas en otro SSD 😁 ...

 

Que con SMBios de MacPro7,1 funciona solo con inyectarle ATY,Henbury y nada mas, no se necesita agdpmod=pikera ni unfairgva=1 .... simplemente funciona...🤷‍♂️

 

CLonA1B.png

 

Mañana me llega una RX6800XT, así que la probaremos en Ventura a ver como va.. 👍

Edited by PoMpIs
  • Thanks 1
Link to comment
Share on other sites

Hola @PoMpIs, te veo ahí a fuego chachareando a tope ...

 

Un par de preguntas:

 

¿Como te va la Asus b660 con Ventura? Sigo pensando en pillar la b660-g, pero los comentarios sobre fallos con USBs con tu placa y demás me están parando un poquitín ...

 

¿La bios de la 6600 que te está dando guerra es la original o tu la actualizaste?

 

Muchas gracias y a disfrutar¡¡¡

  • Like 1
Link to comment
Share on other sites

24 minutes ago, DocXavier said:

Hola @PoMpIs, te veo ahí a fuego chachareando a tope ...

 

Un par de preguntas:

 

¿Como te va la Asus b660 con Ventura? Sigo pensando en pillar la b660-g, pero los comentarios sobre fallos con USBs con tu placa y demás me están parando un poquitín ...

 

¿La bios de la 6600 que te está dando guerra es la original o tu la actualizaste?

 

Muchas gracias y a disfrutar¡¡¡

 

Lo de cacharrear es ya de costumbre, solo que no me pasaba tanto por este foro, porque matarse a afinar un hackintosh para cambiarlo en menos de un mes es tontería... en 2015 deje de tratar con OSX, pero empecé en el año 2006, cuando se pasaron a intel 😄...

 

Al lio...

 

La placa bien, yo le he pillado cariño al cacharro este, el i5 es una locura lo que rinde con overclock, tiene chispa, en single core rinde lo mismo a igual frecuencia que un i9...

 

La placa no es que dea problemas con los USB, es que ya lo dije por ahí mas atrás, NO tiene realmente USBs como tal , lo que han hecho es meter HUBs internos Asmedia 107x, que no lo veo mal, pero es que han metido 4, no me jodas, eso se le va la pinza hasta al windows con tanto HUB interno.... 

 

probablemente la placa que tu dices no tenga tantos, o igual si, porque es un clon de la mía pero en M-ATX.... 

 

Pero se pueden mapear desde windows, ( o desde SSDT cosa mas difícil, estoy probando ) y con un simple USBMap.kext ya va bien, no necesitas ni XHCI-Unsuported ni USBInyectall .... y como esta placa tiene el audio integrado por USB no necesitas tampoco AppleALC, y la red i225v es la V.3 y va sin kext también,...  es que realmente pocos Kext necesito mira:

 

2Akxu8A.png

 

La bios de la GPU creo que da igual, lo que le hacia producir pánicos es no ponerle ATY,Henbury  cuando empecé, y usar agdpmod=pikera y unfairgva=1 ... eso en mi aparato hace que en Ventura el sistema pete aleatoriamente tanto por GPU como por los USBs, depende por donde se le dea....

 

Ahora desde ayer, esto va estable y funcional, ni un detalle en Ventura, todo funciona, reinicio y se reinicia, apago y se apaga, lo enciendo, y se enciende 😆, y el reposo igual, lo dejo y a los 10 minutejos se pone a dormir, llego y le todo el ratón o teclado o el Magic trackpad y se despierta al instante, ASI SI!! jajajjaa

 

Otra cosita ( en mi caso ) es que si quiero tener el reposo operativo y que se pueda despertar desde el teclado o ratón.. tengo que matar uno de los HUBs Asmedia, eso es asi, incluso en Monetrey, ese HUB MacOS no lo quiere....  si se quiere dejar ese HUB activo hay que quitar en DSDT que se despierte del reposo cuando tocas el teclado o ratón, y solo se despierta si le das al botón de encendido.. no esta mal pero a mi no me gusta, y como esos puertos traseros de ese HUB cabroncete no me hacen falta, pues lo quito y punto, y asi puedo usar el reposo como debe ser...

 

Son estos puertos los que se apagan desactivando el HUB ese que no le gusta a MacOS:

 

zHks4wY.jpg

 

 

 

 

Edited by PoMpIs
  • Like 1
Link to comment
Share on other sites

Muchas gracias @PoMpIs por esta info tan Clarita, eres grande compi ...

 

Pues he estado mirando por ahí algunas reviews de la b660-g y he visto una foto de un chip Asmedia ... y me da pereza. Parece un clon de la tuya "algo" venida a menos y parece que heredando (no se si todos) los HUBs con el AS-xxx.

 

La verdad es que me mola mucho lo de poder darle caña a un micro con el BCLK, pero por el precio que tiene, el estupendo Asmedia, solo 2 M2 ... No se .... Pensaba aprovechar la caja donde tengo mi bicho actual con el factor mATX y me gusta el chip de audio (mi placa Z97 ha dejado ahí el listón muy alto). 

 

Joder, tampoco tengo mucho tiempo y quisiera renovar el Halcón Milenario por algo mas acorde con los tiempos, después de ocho añitos ya está bien 🤣, pero con una instalación probada y estable si fuera posible ... y que me dure hasta que Apple nos separe ¡¡¡

 

He visto por los foros alguna instalación en Gigabyte z690 Gaming X que no tiene mala pinta, juntándolo con un 12600K, a ver que podría salir de ahí ... ¿Como lo ves?

 

Oye, gracias de nuevo por tu ayuda, y ya me contarás como haces para cambiar de hacki cada mes¡¡¡ Ya me gustaría a mi ... jajajajaja

 

 

 

 

 

 

 

 

  • Like 1
Link to comment
Share on other sites

@DocXavier  Hombre si puedes, si, mejor z690 donde va parar, y menos lio, hacer OC por BCLK es mas complicadillo que tener un micro K...

 

Yo tuve una Hero z690 mas un 12900k, y con un DSDT de MaLdon, aquello era una virguería.... con esa no tenia que matar ningún puerto USB funcionaba todo sin mucha complicación..

 

Si quieres una gigabyte z690, pilla una que coincida con las Build de MaLd0n, con eso es ir a tiro fijo, lo tienes todo hecho jajaja...

 

Yo ya cambio menos, pero hasta que empezó la pandemia eso era un no parar, ademas como llevo muchos años trasteando y comprando y vendiendo hardware, siempre acabas conociendo gente, y conozco a varios que hacen reviews y me mandan los cacharros para probar, otros ya me los quedo por un módico precio etc... y asi es como iba cambiando cada poco tiempo... mismamente de Alder Lake, he tenido la Hero z690, una Aorus z690 Master, las B660F gaming actual, un cleron g6900, un i3 12100F, dos i5 12400f, dos i7 12700KF, un 12900k y un 12900KF... 

 

Pero este i5 mas la B660 como siga siendo compatible con MacOS me lo quedo hasta que no se pueda instalar mas sistemas Apple en el...  yo en MacOS no hago nada que consuma muchos recursos, por eso que tener este sistema en un i9 o i7 en mi caso es un desperdicio... cuando tengo un i9 o i7 prácticamente lo uso con windows y le sacamos algo de partido en casa usándolo para juegos...

 

@miliuco De este hardware ya sabia mas o menos como era, lo que no me esperaba es el tema de los HUBs USB, debe ser la primera placa que veo semejante cosa de HUBs internos la verdad.... Lo vi cuando empecé a mapear los puertos, ponía el pendrive y siempre me salía que era el mismo puerto, y me extrañaba, hasta que descubrí que son HUBs, esos 4 puertos azules del panel trasero para MacOS es un solo puerto 😆, y claro revientan el reposo ... los dos cabezales internos USB 2.0 que pongo el bluetooth en uno de ellos, lo mismo, si apago uno se apaga el otro, van también por HUB interno, el USB del frontal lo mismo que es SS01  da igual si pongo el pendrive en una u otra salida, pues va al HUB también y el pendrive es siempre SS01.... un lio de la leche..

 

Pero si sigue funcionando así, va ser mi hackintosh el resto de sus días... 

 

A ver que sucede mañana cuando ponga la RX6800XT, esperemos que no se vaya todo a tomar por c***** 😄 

 

Que por cierto las 6800XT son nativas?? o hay que usar un Device-id especifico??? 

 

PosData: Ya he estudiado el tema de mapear los USB en la tabla ACPI... por hoy lo dejo, que me voy al sobre, que sino mañana estoy reventado, pero creo que ya he conseguido mi template.. solo falta asignar el tipo de puerto.. que eso creo que lo controlo... gracias al tutorial de 5T33Z0 ... Solo que a mi me sobraba el tema de que funcionen unos puertos en Mac y otros en Windows, eso no lo necesitaba, pues yo windows no lo arranco desde OpenCore, cuando quiero arrancar windows pulso F8 para seleccionar el disco y punto... pero si no me lo explican no se hacerlo solo para MacOS y quitarle código jajajaja

 

Pero es la mar de adictivo esto bufff..

 

Por si quieres hecharle un ojo, aunque obviamente solo vale para mi placa 

SSDT-8-xh_adls3.aml.zip

 

 

Edited by PoMpIs
  • Like 1
Link to comment
Share on other sites

14 hours ago, miliuco said:

@PoMpIs

6800 XT en teoría sólo necesita agdpmog=pikera pero con el código ACPI que tú preparas puede ser que no necesites ni siquiera eso. 

 

Pues no me va llegar hoy, me han cambiado la entrega para mañana.... esta mal el tema transportes 🤷‍♂️ ...

 

Pero lo que os quería decir.... Las RX6600 dan tan poco puntuación en Ventura porque al usar ATY,Henbury la gráfica se ancla a unas frecuencias bajísimas....

 

La mia aun haciéndola currar codificando video, no llega casi a superar nunca 1Ghz, cuando en Monterey sin ATY,Henbury llega a mas de 2Ghz igual que en windows

 

qRsoh6a.png

 

De todos modos tenemos que tener en cuenta que es una beta, pero hay algo en los drivers que no le gustan mucho estas RX6600 a Ventura, van a medio gas... que en MacOS en uso normal casi no lo notamos, pero si que pierde bastante rendimiento, deberíamos poder usarla igual que en Monterey pero es imposible, he probado de todo y sin ATY,Henbury da siempre pantalla negra al cargar el escritorio.... 

 

Probablemente no suceda esto cuando lanzen mas versiones o incluso la versión final, pero si es el caso y hay que usar ATY,Henbury para siempre estas RX6600 ya se las cargan los de apple..

 

 

  • Like 1
Link to comment
Share on other sites

 Share

×
×
  • Create New...