Jump to content

Post YOUR instructions....


60 posts in this topic

Recommended Posts

10.4.8 JAS Image, GeForce 7600 GS

First I should do is to disable USB latency in BIOS, without doing it install was too slow. After install I was able to boot in Safe mode only, it was caused by my Graphics card, so I had to edit my /System/Library/Extensions/GeForce.kext/Contents/Info.plist string with


<string>some text</string>

right like this



0392 is my devise ID and 10de is vendetor ID. For your graphics card it can be found "System information" utility.

So it works fine in native mode now, just like a real mac :)

Edited by JasT
Link to comment
Share on other sites

Some people are probably wondering HOW to edit the .plist files, theres a lot of "edit the plist" but not a lot of "you edit the plist by..." so I'll make the lives easier for the people who cant figure it out without having to use terminal.


- Navigate to your extentions folder (system>library>extentions)


- Find the .kext files you need to edit (they were previously mentioned above), right click or ctrl+click them and choose "Show package contents."


- This will open a new window, find the .plist file and copy it to the desktop and leave the window open.


- Open the .plist file on the desktop, choose textedit as the program to open it.


- In text edit find the text that looks like:

<string>0x****10de;a bunch of other numbers and letters</string>


- Replace the *'s (they will be numbers in the plist) with your graphics ID (find this by going "about this mac> more info> graphics/displays"). My gf6800 ID was 0041, so my string looked like 0x004110de


- Delete the rest of the {censored} after the 10de up to the closed string tag and save


- Replace the plist on the desktop with the plist in the original .kext that you openned, you will have to authorize with your pw.

Edited by idividebyzero
Link to comment
Share on other sites

most instructions are for 256mb cards.


for a 512mb card you need to install the NVidiaEFI.kext made for 512mb cards in addition to any other kext.

that can be found in _np's toolbox over at macvidia.com (more info and instructions can be found there also)

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...


First of all, I'd like to point out that I take absolutely no credit for the following tutorial, all material was copied from this and some other forums and my "discoveries" may be attributed to common sense... I'd like to appologize to those who aren't getting their due citations, but I'm just plain lazzy :), if you find this post you may claim your thread for recognition...


I have come to notice that many people are still experiencing problems like "black screen" or "no QE/CI", particularly with agp and nvidia geforceFX series, and a lot of tutorials with magical sequences that should make it all work, working for some and not for others...


So here's what I found out after looking into it a bit, this should work with all:


0- First of all, you must be running a 10.4.8 system on 8.8.1 kernel for it to work, and Semthex Beta 9 DOES WORK...


1- NVDA display randomly fails in every install I've made on every machine, including those with QE/CI enabled... The reason only people without QE/CI report it is because only they notice it :) So that is not a problem...


2- The problem lies in the .kexts, they MUST ALL HAVE THE SAME VERSION NUMBER IN ORDER FOR THEM TO WORK, dates don't matter...


These include:


- ALL Geforce kexts (there are 6 of them), ALL NVDA kexts (there are 5 of them) and AppleIntelIntegratedFramebuffer.kext must be version " (8.6.0f1)"


- IOGRAPHICSFAMILY.kext and IONDRVsupport.kext must be version "1.4.4" (sugestive, right?)


- IOPCIFAMILY.kext doesn't have much to do with loading the driver, but it would be best to have version "2.1" for AGP sake...


- You can check the version by right clicking on the kext and choosing "get info", the 4th down from top to bottom... it is displayed right above the collour tabs...


- You can find most of these kexts in the official intel 10.4.8 update, open it with pacifist and expand it to your desktop (there are tutorials on this page who teaches how to do this...), you might also try downloading them from other sources :whistle::)


3- Do not delete any unnecessary kexts before 1st boot, some drivers need to ping all plugins to discover they don't work, I don't know if this is the case, but...


4- You need to correctly modify NVDAResman.kext, Geforce.kext and NVDAVxxHAL.kext with your DEVICE ID, like so, othrwise it will hang:





being 0x0322 my DEV ID and 10de my Vendor ID (Nvidia), put yours over where mine is, DO NOT DELETE THE REST

you can find yours in the upper left apple, about this mac, more info, display...


YOU MUST EDIT NVDAResman.kext, Geforce.kext and NVDAVxxHAL.kext, being xx your arquitecture (20, 30, 40...) exactly this same way...


Do this by right clicking the .kext, clicking "show package contents" and find info.plist


typing in Terminal:


sudo -nano -w , and drag the info.plist to the terminal and press "enter" in terminal, this should open it for edditing (after you put your password in...)

After finnished, press "ctrl-o", "enter" and "ctr-x"




7- Drag your Titan/Natit to "System/library/extensions" folder


6- Install and correct permissions:


Go to Terminal and copy this:


sudo chown -R root:wheel /System/Library/Extensions/GeForce.kext

sudo chmod -R 755 /System/Library/Extensions/GeForce.kext

sudo chown -R root:wheel /System/Library/Extensions/NVDARESMAN.KEXT

sudo chmod -R 755 /System/Library/Extensions/NVDARESMAN.KEXT

sudo chown -R root:wheel /System/Library/Extensions/NVDANV30Hal.kext

sudo chmod -R 755 /System/Library/Extensions/NVDANV30Hal.kext

sudo chown -R root:wheel /System/Library/Extensions/Titan.kext

sudo chmod -R 755 /System/Library/Extensions/Titan.kext

sudo chown -R root:wheel /System/Library/Extensions/IOGraphicsFamily.kext

sudo chmod -R 755 /System/Library/Extensions/IOGraphicsFamily.kext

sudo chown -R root:wheel /System/Library/Extensions/IOPCIFamily.kext

sudo chmod -R 755 /System/Library/Extensions/IOPCIFamily.kext

sudo chown -R root:wheel /System/Library/Extensions/IONDRVSupport.kext

sudo chmod -R 755 /System/Library/Extensions/IONDRVSupport.kext

sudo chown -R root:wheel /System/Library/Extensions/AppleIntelIntegratedFramebuffer.kext

sudo chmod -R 755 /System/Library/Extensions/AppleIntelIntegratedFramebuffer.kext

sudo chown -R root:wheel /System/Library/Extensions/AppleSMBIOS.kext

sudo chmod -R 755 /System/Library/Extensions/AppleSMBIOS.kext

sudo chown -R root:wheel /System/Library/Extensions/GeForce2MXGLDriver.bundle

sudo chmod -R 755 /System/Library/Extensions/GeForce2MXGLDriver.bundle

sudo chown -R root:wheel /System/Library/Extensions/GeForce3GLDriver.bundle

sudo chmod -R 755 /System/Library/Extensions/GeForce3GLDriver.bundle

sudo chown -R root:wheel /System/Library/Extensions/GeForceFXGLDriver.bundle

sudo chmod -R 755 /System/Library/Extensions/GeForceFXGLDriver.bundle

sudo chown -R root:wheel /System/Library/Extensions/GeForceGA.plugin

sudo chmod -R 755 /System/Library/Extensions/GeForceGA.plugin

sudo chown -R root:wheel /System/Library/Extensions/GeForceVADriver.bundle

sudo chmod -R 755 /System/Library/Extensions/GeForceVADriver.bundle

sudo rm -f /System/Library/Extensions.mkext

sudo rm -f /System/Library/Extensions.kextcache

diskutil repairpermissions /


This takes a bit, after this reboot and all should be good... if not, replace existing opengl.framework in "System/Library/Frameworks" with that of 10.4.8 oficial update (it should already be so, though...), about 13,4mb... repair permissions and reboot again.


It could also be because of appleSMBIOS.kext, you'll then need to find paulicat's version on the net somewhere (don't know how it boot without it, but you never know...)


Now for AGP users there is a bit more:


After 1st reboot, you can tray to make your performance better by getting AGPGART.kext...

It works if you motherboard is compatible, mainly AMD64 for now...

Just download it, drag it to the same extensions folder and type in terminal. giving your password when asked:


sudo chown -R root:wheel /System/Library/Extensions/Agpgart.kext

sudo chmod -R 755 /System/Library/Extensions/agpgart.kext

sudo rm -f /System/Library/Extensions.mkext

sudo rm -f /System/Library/Extensions.kextcache

diskutil repairpermissions /


And reboot, you should have agp detected... If not, try a different version.


Latest for now is 2.2... it works better for a few intel motherboards, but lost a bit of AMD64 compatability (so I've been told...)

If your AMD64 and it doesn't work, try version 2.1... Any earlier version requires older IOPCIFAMILY.kext versions, and you may loose QE/CI (no offense in trying...)


After that you can try to enable QE2D and Disable Beamsync (good for LCD, tearing in CRT), look for Quartzsimple in search bar (yess, search bar goood...)


That's all I have, got it working 100% in every computer i tried with this, hope it works for all...


Mac OS X as only installed OS!




A bit confused here...have a 7600GS EVGA, will get the id, fine.


But others posted they ran the Nativ Black Apple 1.0 package and where up and running after two boots, at least that is what two in this thread have said. Had they also done what you have said to do here?


I would like dual display, but one thing at a time, want to get the 256 mb GPU working for Final Cut and maybe some games.



Link to comment
Share on other sites

Hello, I've already installed OSX 10.4.8 in my pc, it runs perfect but I can't change the screen resolution, 1024x768 is the maximum and the only one, how can I fix it. Thankyou all.



I think you will need to read through some of the threads, for starters though, posting your computer specs and graphic card is a start. LOL

Link to comment
Share on other sites

  • 4 weeks later...

QE/CI working with Winfast A360, Nvidia FX 5700 512MB, deviceID 0342


This machine:


mobo: MSI 6398E rev1

cpu: 2.4GHZ celeron, socket 478

gfx: Winfast A360, FX5700 512MB. ID 0342

net: onboard did not work, plugged a realtek compatible pci

sound: onboard AC97, working out of the box


iso: JaS 10.4.8 AMD Intel SSE2 SSE3.Defiant diskutil fix.iso


I installed during the initial installation the intel stuff, the boot menue fix and the nvidia (nv40) drivers.


Then I went through the description of post #2.


1. remove AGPGart.kext, NVDAV10HAL.kext, NVDAV20HAL.kext, NVDAV40HAL.kext

2. place your deviceID in NVDAResman.kext, Geforce.kext and NVDAV30HAL.kext

->I just changed the string where it was neccassary, e.g.








and left ANYTHING else like it was.


3. repair permissions

4. reboot


The use of AGPGart.kext resulted in a blank black screen with mousepointer.

Performance is 100% usable for a living room PC, p2p, video, itunes, pictures... everything fine now.


@ seclusion

trigger F8 during boot and type"-s" for boot option, welcome to shell


Thanks and credits to all involved !



Link to comment
Share on other sites

Well after weeks of testing, ok. one week, but it was almost 8 days a week, 25 hours a day kind of thing... :(


I took Diabolics advice and got the card he used, a XFX Geforce 7300 GT, Dual DVI and used DVU.VGA adapters on both.


The Graphic card was purchased HERE!!!!!!! Thanks God andDiabolic! :-)




Dual Screens in action:





I also sold the 7600 GS so made most of my money back, the blessing also was that the new card is a LARGE heat sink, no fan, and while it may not be as strong as the 7600, it

a) Should be equal to at least powerbook pro macs (which by the way you can do a lot of REALTIME EDITING in FCP without RENDERING and


b)since it has no fan is perfect for audio use. In XP, I am sure it can overclock. Besides, this is the closest card to what ships in the MAC PRO and down the road I can always get the higher end ATI Card that APPLE offers...


I used Natit 1.0 and Natit Dual V0 02 which I am attaching. Why? Well, there are so many files all over the place, why not put them in a spot where you know it will work for a certain card. PS. If someone else ends up buying a card their, PM me, as I would like to know if it helped you too.


Link to comment
Share on other sites

  • 2 weeks later...

Installation / Configuration Instructions:

HP Pavilion zd7000 (nvidia fx5700) devid: 0x0347



OS Installed using JaS 10.4.8 AMD Intel Patched.

(Printer, Font, and Translations are personal choices)

  • Chose Patch option according to processor (Intel)
  • Chose Natit NV40 (Nvidia)

After installation progress through account creation. In this case, desktop was 1680x1050x32 without CI/QE enabled.

Proceed to open a terminal to perform the following changes:


(in terminal)


sudo -s <press enter>

Type password <press enter>


at this point, create a backup dir for kexts as a precaution

Example: mkdir /Users/youraccount/nvbackup


Now, copy the following kexts to your backup -

cp /System/Library/Extensions/AGPGart.kext /Users/youraccount/nvbackup

cp /System/Library/Extensions/NVDA* /Users/youraccount/nvbackup

this will copy all of your related kexts to the nvbackup directory. Before you proceed, check the directory to ensure

that they are backed up. I know most of you wont, but I have to mention it. :(


Once you have backed up your files, it is time to remove several kexts and edit some others.


Using the information in system profiler, verify the devid of your video card. In this case 0x0347


NVIDIA GeForce FX Go5700:


Chipset Model: NVIDIA GeForce FX Go5700

Type: Display

Bus: PCI

VRAM (Total): 128 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x0347

Revision ID: 0x00a1



Resolution: 1680 x 1050

Depth: 32-bit Color

Core Image: Supported

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Supported


Status: No display connected


Notice that CI and QE are enabled in this sample - post fix.


back in terminal again:


cd /System/Library/Extensions/

rm -R AGPGart.kext

rm -R NVDANV10Hal.kext

rm -R NVDANV20Hal.kext

rm -R NVDANV40Hal.kext


Now we will edit the remaining needed files. It helps if you know vi for this. I know other options exist, just a suggestion.

In each of the files, you will replace the devid with your devid.







(each command is simply the command to start the edit process. You must edit and save the file after each change)

vi /System/Library/Extensions/Geforce.kext/Contents/Info.plist

vi /System/Library/Extensions/NVDAResman.kext/Contents/Info.plist

vi /System/Library/Extensions/NVDANV30Hal.kext/Contents/Info.plist


Once you have completed the above steps, you need to repair permissions and reboot the system.


diskutil repairpermissions /




Good Luck!!


I hope this helps out - BTW Post any issues and I'll try to help out.


Thanks to everyone that has posted valuable files, tutorials, and assistance to the community. There are too many to name.



Link to comment
Share on other sites

  • 4 weeks later...

Thanks to Spanakorizo's guide I finally got QE and CI working on my system. With my AGP Evga 7600GS.

It helped when I deleted AGPGart.kext also. 1st time I rebooted after that, my screen was really narrow, next time my screen was upside down haha. but I got into system preferences | displays | and clicked on 'detect display' i believe and it corrected the upside down problem. so now i can run virute desktop with effects :thumbsup_anim:. still have to test movies and going to install WoW. Thanks again guys. good work. nice walk throughs for nubs like me. :hysterical:


JaS 10.4.8

Intel P4 2.53


MSI 845E-Max


Link to comment
Share on other sites

  • 1 month later...

nvidia Quadro FX 1000, Asus K8V-MX-S motherboard (VIA K8M800/VT8237 chipset) AMD64 Sempron 2800.


i installed uphuck 1.4a, and chose natit .2 in the installer. worked great, had resolutions and dual monitor right away. after that i put my graphic card device id into GeForce.kext, NVDANV30Hal.kext, and NVDAResman.kext Info.plist, and removed the other NVDANVxxHal.kexts. then i had quartz extreme and core image.


i also chose agpgart 2.1, which improved performance hugely. that's it!!


it was much easier than the first time, when i used Jas 10.4.8 w. ppf1 & 2. - at first i couldn't even boot, got a kernel panic/restart in six languages screen. went in single user mode and deleted some geforce kext i think, can't remember which, sorry. then i could boot but only with 1024x768. installed natit, a bunch of geforce kexts, and did some info.plist editing. could get dual screens and different resolutions, but no qe/ci, and performance was extremely poor. adding agpgart only gave a black screen.


the main trick (thanks to toadman!) was to get the correct version numbers on all the kexts and bundles. here's what i'm using, i found them in the "backed up extensions folder". note: these work with the Quadro FX 1000 nvidia card, if you have a different card, you might need different versions of the kexts and bundles. [note: the later versions that come with uphuck 1.4a worked fine, i didn't have to change anything, just put the id in]


NVDANV30Hal.kext (8.6.0f1)

NVDAResman.kext (8.6.0f1)

GeForce.kext (8.6.0f1)

GeForce2MXGLDriver.bundle (8.5.0f2)

GeForce3GLDriver.bundle (8.5.0f2)

GeForceFXGLDriver.bundle (8.6.0f1)

GeForceGA.plugin (8.6.0f1)

GeForceVADriver.bundle (8.6.0f1)


plus, natit dual 0.2


i put my quadro fx device id in the first three (kexts) Info.plist files (but not in natit kext). just "0x030910de" and no ffffffff or whatever. changed the permissions and all that stuff, and viola! :( (<--this is me playing a viola) i had dual monitors and qe/ci.


then after that i put in agpgart 2.1 (not 2.2, it didn't do anything) and my benchmarks went up more than double! i now have no problem eg. watching HD (1280x720) movies full screen, even wmvs - something i can't do on my g4 powerbook!


hope this helps someone, i sure wish someone told me this a month ago!


here's my xbench results:


Results 72.11

System Info

Xbench Version 1.3

System Version 10.4.8 (8L2127)

Physical RAM 768 MB

Model ADP2,1

Drive Type ST3802110A

CPU Test 54.76

GCD Loop 87.96 4.64 Mops/sec

Floating Point Basic 66.81 1.59 Gflop/sec

vecLib FFT 33.23 1.10 Gflop/sec

Floating Point Library 60.16 10.48 Mops/sec

Thread Test 61.03

Computation 39.85 807.20 Kops/sec, 4 threads

Lock Contention 130.29 5.60 Mlocks/sec, 4 threads

Memory Test 65.79

System 59.22

Allocate 126.65 465.09 Kalloc/sec

Fill 44.19 2148.76 MB/sec

Copy 49.66 1025.67 MB/sec

Stream 74.00

Copy 70.38 1453.75 MB/sec

Scale 70.43 1455.01 MB/sec

Add 78.11 1663.84 MB/sec

Triad 77.84 1665.27 MB/sec

Quartz Graphics Test 79.86

Line 71.25 4.74 Klines/sec [50% alpha]

Rectangle 96.22 28.73 Krects/sec [50% alpha]

Circle 91.27 7.44 Kcircles/sec [50% alpha]

Bezier 82.69 2.09 Kbeziers/sec [50% alpha]

Text 66.06 4.13 Kchars/sec

OpenGL Graphics Test 94.53

Spinning Squares 94.53 119.91 frames/sec

User Interface Test 97.50

Elements 97.50 447.49 refresh/sec

Link to comment
Share on other sites

  • 3 weeks later...


ok listen

1st of all go to system/extensions folder and DELETE ALL nvidia and geforce kexts etc

for example : Geforce.kext : DELETE IT


now download this rar i 've made that inside are only the neccesary kexts i used to load nvidia


extract everything and paste all the files inside this rar to EXTENSIONS folder

(dont extract the file CONSOLE COMMANDS.txt ! )







you must do this with nano in the terminal and when you finish save the changes


now open terminal

type: sudo -s

enter your password

now copy/paste all this text to terminal (in 1 line)




sudo chown -R root:wheel /System/Library/Extensions/GeForce.kext ;

sudo chmod -R 755 /System/Library/Extensions/GeForce.kext

sudo chown -R root:wheel /System/Library/Extensions/NVDARESMAN.KEXT ;

sudo chmod -R 755 /System/Library/Extensions/NVDARESMAN.KEXT

sudo chown -R root:wheel /System/Library/Extensions/NVDANV40Hal.kext ;

sudo chmod -R 755 /System/Library/Extensions/NVDANV40Hal.kext

sudo chown -R root:wheel /System/Library/Extensions/Natit.kext ;

sudo chmod -R 755 /System/Library/Extensions/Natit.kext

sudo chown -R root:wheel /System/Library/Extensions/AGPGart.kext ;

sudo chmod -R 755 /System/Library/Extensions/AGPGart.kext

sudo chown -R root:wheel /System/Library/Extensions/GeForce2MXGLDriver.bundle ;

sudo chmod -R 755 /System/Library/Extensions/GeForce2MXGLDriver.bundle

sudo chown -R root:wheel /System/Library/Extensions/GeForce3GLDriver.bundle ;

sudo chmod -R 755 /System/Library/Extensions/GeForce3GLDriver.bundle

sudo chown -R root:wheel /System/Library/Extensions/GeForceFXGLDriver.bundle ;

sudo chmod -R 755 /System/Library/Extensions/GeForceFXGLDriver.bundle

sudo chown -R root:wheel /System/Library/Extensions/GeForceGA.plugin ;

sudo chmod -R 755 /System/Library/Extensions/GeForceGA.plugin

sudo chown -R root:wheel /System/Library/Extensions/GeForceVADriver.bundle ;

sudo chmod -R 755 /System/Library/Extensions/GeForceVADriver.bundle

sudo rm -f /System/Library/Extensions.mkext

sudo rm -f /System/Library/Extensions.kextcache

diskutil repairpermissions /




now press enter at terminal

w8 for some seconds

type: reboot

if you did everything correctly after reboot you must have qe/ci

i've made easy for you the most serious part at terminal in one copy/paste

but you must also modify CORRECTLY the 3 kexts ,its very important also

plz dont ask me "what is devID,where can i find it?...how do i insert my devID etc etc"

im trying to help but there are answers for those common questions everywhere in forum!

hope this helps


A big big thanks to you spanakorizo, Slap on the back and all that. For a clear "Of What To Do".

And producing the rar file which was of great help. It took a long time to find your info but I guess the trick is to never give up looking, The Fix Is Out There.


I did not have to make any changes to the .kext as your card is the same (PNY 7600GS, 256mb) I did have to delete the AGPGART.kext and Wow, OMG it all worked just as you said it would.


Again Thanks.......


OSX 10.4.9 (Combo update with Koolkal latest kernel)

MSI 865PE Neo 2-V

Intel ICH5 Chipset

PNY Nvidia 7600GS, 256mb

Link to comment
Share on other sites



I have nVidia 6200 with VGA and DVI outs... Two monitors Benq 22" (VGA) and SyncMaster (DVI)... Have installed Natit Dual v2.0...


On Benq have QE/CI enabled... 1680x1050.... BUT..!!!!


The II monitor is not working (not recognised.... It have parts of main desktop sqares all over it.



Chipset Model: GeForce 6200

Type: Display

Bus: PCI

VRAM (Total): 128 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x0221

Revision ID: 0x00a1


BenQ FP222W:

Resolution: 1680 x 1050 @ 60 Hz

Depth: 32-bit Color

Core Image: Supported

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Supported

Rotation: Supported


Status: No display connected


How to enable II monitor and Extended desktop..?

With Natit Dual V1.0 on smaller resolution (1024x768) have same picture on both monitors...?

Link to comment
Share on other sites

Thanks spanakorizo, hopefully your guide has taken me beyond randomly but constantly reoccurring kernel panics at startup. Looking good after a few startups.


For the GeForece GO 7600 in my Toshiba Satellite P100-103 the magic line is as follows:




retrieved from my Windows Driver's .inf.


I deleted all the other strings in there in all three kexts.





Link to comment
Share on other sites

hi im new to the whole osx thing


i have installed 10.4.8 jas version osx and cannot get my graphics card working properly


i have a 7600gt agp




I've also got an XFx 7600GT AGP with 256MB, also, and have spent 4-5 hours trying in vain to get the card to work with Natit, Titan, etc. I've read a ton of posts about this, and have tried numerous things, with no luck. If someone could post some detailed instructions for getting this card to work with 10.48. JaS, I would be extremely greatful. Thanks!

Link to comment
Share on other sites

Hi guys and gals i have

biostar PT880 pro A7

intel 775 HT 3.06ghz

1.5GB memory DDR2

onboard lan realtek VT8237 works with viahine patch

onboard sound works out the box

sata works out the box

nvidia 7300LE 256MB

about that nvidia 7300LE it only works without the Titan and Natit. I can use a GeForce FX5200 128MB card and works fine. But I need it to work with my 7300LE, I have try natit edited->natit uni1.0->natit dual not-thing on my montior the system seem to be working but no screen display.

Any help will be greatful

Link to comment
Share on other sites


  • Create New...