Jump to content
kamyar1979

AMD 7750 (7770, 7xxxx) fixture for Mojave

3 posts in this topic

Recommended Posts

I have bought a 2nd hand AMD Radeon 7750 to fix my Mojave installation problems. Although the Vendor/Device Id is in AMD7000Controller.Kext, I get a black screen and with some changes a yellow screen. I can not find any useful information to fix that. All information are for High Sierra and older macOS versions. Is there any fix to resolve that? What if I buy an RX 650 for example?

Edited by kamyar1979

Share this post


Link to post
Share on other sites
Advertisement

Hi @kamyar1979 and welcome to insanelymac.com :)

Please update your signature with your hardware specs so we can help you easier.

 

There are several ways to resolve the black screen issue on AMD GPUs. The procedure is the same for High Sierra and Mojave.

1. Use RadeonDeInint=true injection in the config.plist under the Graphics Section. You might also need to set InjectATI=true as well, test with and without InjectATI=true and see if that helps.

2. Use the AGDP patch in the config.plist under the kernel and Kext patches:

  • Name: com.apple.driver.AppleGraphicsDevicePolicy
  • Find: BA050000 00
  • Replace: BA000000 00
  • Comment: Disable board-id check to prevent no signal © lvs1974, Pike R. Alpha, vit9696

3. Using WhateverGreen.kext and Lilu.kext which should be placed inside the /EFI/Clover/kexts/Other. If you are going to use these kext files you shouldn't use InjectAti=True and you should not Inject the Framebuffer in the config.plist.

 

4. Using a SSDT for your GPU.

The RX 560 (Which I assume is what you mean by saying RX 650) should work OOB because it has the native support in macOS 10.12.6 and newer.

 

There are several reports on people having issues activating their 7750/7770 GPUs in High Sierra and probably Mojave.

 

 

Good luck.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gk12345
      hello to everyone, i managed to install mojave on my asus ux303ub with i5 cpu and now sleep does not work when i press sleep display turns black and pc stays on and then i have to force shut down by holding power button in order to restart pc ,by the way i used the clover folder from a guide on the internet, any help would be appreciated, thanks
    • By Bahaa
      Need help here
      My graphic card is detached 7mb
      and I try a lot of solution and no one work 
      can any one help
       

    • By Gracie
      Hello, insanely kind people! 
      I had full working Speedstep on my system with El Capitan, but after installing Mojave i cant make it working again!
      Help me please. Actually system is working only with NullCPUPowerManagement.kext. As soon as i remove it from Extensions directory i've got kernel panic at the boot.
      I tried to put SSDT.aml from my previous ElCapitan clover, tried to make new by different utilities, but still no luck.

      My system is:
      Pentium G3258
      Asus Z97-K USB 3.1
      Nvidia GTX 670


      i''m attaching my new clover.plist of Mojave and old El Capitan one, which makes Speedstep fully working and overclocking my little Pentium from 3.2 to 4.5GHz. Now i see huge speed loss without SpeedStep on Mojave  Please help, anybody! Also im attaching my working SSDT.aml from El Capitan.
      El Capitan SSDT.aml
      El Capitan config.plist
      Mojave config.plist
    • By guitar201
      I’m currently getting around 30seconds on the brucex test and think I can do better.   Ive tried disabling dgpu in the bios and enabled to no availe.  Currently running 10.14.3 with corps dsdt script.  
       
      System is a:
       
      ​
       
      Core i5-8400 / Gigabyte Z370 SLI XP mobo
       
       
      Vega 64
       
       
      GC-Alpine Ridge Thunderbolt 3 card
       
       
      [https://pastebin.com/W3PVZCxh](https://pastebin.com/W3PVZCxh) My Config.plist
       
       
       
      [https://imgur.com/a/KZ9qgop](https://imgur.com/a/KZ9qgop) Contents of my EFI folder
       
      Any suggestions is appreciated.  Thanks. 
    • By End3rPower50
      Hi, is Qualcomm Atheros AR956x compatible with MacOS Mojave 10.14.3?
×