Jump to content

Versions bêtas : OS X 10.11


194 posts in this topic

Recommended Posts

donc nous voici !   ^_^

 

la WWDC finie, Apple mets à disposition des développeurs la première DP de OS X Yosemite 2.0 El Capitan.

 

elle a été estampillée build 15A178w

 

OS X v10.11 Developer Preview Build 15A178w.png

  • Like 3

Bon, ben, les 6Go sont là, yapuka... On va tester l'installation de la bête sur le bon vieux Dell Latitude D630.

  • Like 2

Je tente désespérément avec Clover sur le D830 mais je tombe systématiquement sur un still waiting for root device :wacko: alors que mon EFI/Clover est strictement le même. J'ai essayé avec la version 3215 puis la 3200, en ne laissant que FakeSMC et même sans DSDT mais pareil :no:

 

Le dmg n'est pas en cause, je suis en train d'installer sur ma GA-H97-HD3 sans problème. À noter que la méthode restauration BaseSystem ne marchait pas mais que celle du create-install-media oui :huh: !

  • Like 1

Pour l'instant, sur Dell Latitude D, je ne connais qu'une réussite par upgrade via Clover sur une installation Mav/Yos existante.

Ah !

 

Je te confirme que c'est possible sur le D830 en clean install. Je l'ai fait y a pas si longtemps pour passer en full GPT sur mon SSD et mon SATA (OS X 10.10.3 sur SSD et Win 8.1 + Mint sur SATA) via Clover. Du coup, j'ai même pu installer tous les OS en mode UEFI !

 

Bref, rien de sorcier, j'ai juste mis la DSDT où il fallait et les kexts aussi et ça s'est installé sans soucis :D.

moi, il ne veut rien savoir  :(

 

et pourtant, ma vielle p5kpl-am passe très bien sous OS X

 

que ce soit avec la méthode standard ou avec createinstallmedia, impossible de passer la séquence d'amorçage

 

quelque soit les flags, rien n'y fait.

Idem, je n'arrive à dépasser Missing Bluetooh Controller. Ensuite c'est still waiting for root device et ce même avec rootless=0, le masque DSDT à 0x00000000 et nv_disable=1…

 

Je comprend pas :wallbash:

 

Je suppose que Chameleon n'y changera rien ?

  • Like 1

En fait, je me demande si tout ça n'est pas lié à l'USB2 de nos vieilles guimbardes… Dans les Release notes que tu mentionnes ici, il est dit ceci :

 

 

USB
Known Issues

    USB storage devices, including internal SD card readers, may become unavailable after system sleep and require either re-plug or restart to recover.

    USB input devices may become non-functional on some Macs after several days.

    USB 1.0, 1.1 and older 2.0 devices may not function.

 

Or il se trouve que ça pourrait bien être la cause de mon still waiting for root device mais ça expliquerait également pourquoi ma clé USB d'install n'est pas vue par El Capitan une fois arrivé sur le bureau et pourquoi ma souris USB sans fil n'est pas reconnue non plus.

 

Car oui, j'ai finalement pu "accéder" à El Capitan sur le D830 en passant par mon autre Hack Gigabyte H97-HD3 et en l'installant sur un DD 2.5" sata connecté en USB que j'ai reconnecté ensuite. Pour la blague, je n'ai jamais réussi à rebooter sur la H97-HD3 pour refaire une install :hysterical: !

 

Bref, c'est vraiment cracra comme méthode mais visiblement, c'est la seule méthode possible pour l'instant…

  • Like 1

Moi jai réussie a booté et installer  ( avec un adapteur USB 2 relier sur le port USB 3  )  sur mon Laptop et mon PC

seulement qu'avec ce config.plist. C'est un vieux config de ML que jai

depuis longtemps et j'ai ajouter  

kext-dev-mode=1 rootless=0

 

Ensuite du coup installer tu peut changer le config sans problèmes

si sa peut aider ?

  • Like 1

En fait, je me demande si tout ça n'est pas lié à l'USB2 de nos vieilles guimbardes… Dans les Release notes que tu mentionnes ici, il est dit ceci :

 

c'est assez drôle de la part d'Apple de dire que parmi les Mac supportés par cette bêta figure (en premier) iMac 2007, sachant que ce dernier embarque 5 ports USB 2.0 et ensuite de dire qu'il se pourrait que des précédentes versions d'USB pourraient ne pas fonctionner.   :rofl:

 

person, je pense que le problème est ailleurs... je n'ai pas encore eu la possibilité de tester la dernière version de Clover supposée supporter El Capitan.

 

si j'utilise la méthode standard, je m'arrête au bla bla : 255 et ce malgré rootless=0 ( et kext-dev-mode=1, au passage  :)  ) 

 

mais si j'utilise la méthode createinstallmedia, j'arrive (avec du mal) sur l'écran noir et la pomme blanche et là plus rien, il reste figé (en même temps, je n'ai pas essayé de le laisser comme ça pendant longtemps, histoire de voir s'il n'allait pas basculer sur l'écran d'installation)

 

démarrer avec -x me donne un KP puis un redémarrage... avec cache ou sans, aucun changement...   :(

c'est assez drôle de la part d'Apple de dire que parmi les Mac supportés par cette bêta figure (en premier) iMac 2007, sachant que ce dernier embarque 5 ports USB 2.0 et ensuite de dire qu'il se pourrait que des précédentes versions d'USB pourraient ne pas fonctionner.

Issue usb 2:

it looks like usb now works little different. in IOUSBHostFamily.kext-->AppleUSBEHCIPCI.kext-->info.plist every mac usb is identified ... as my example imac11,1 EHC1 and EHC2 so i changed name in DSDT

 

...

 

now usb 2 is working. mouse and keyboard started to work on reboot.

Il semblerait que CHAQUE identifiant USB des machines Apple soit référencé ... un bon DSDT et ça semble passer ... à confirmer
  • Like 1

oui j'a vu ça mais je pense que cela concerne plus les cartes mères embarquant usb3 et usb2

 

pour te dire, ma p5kpl-am n'a même pas besoin de dsdt et ça depuis Lion, je crois.

 

regarde le poste plus bas... lui il a carrément une ga-g31m-es2c et il n'a pas eu de gros souci

 

après, est-ce qu'il utilise un dsdt, je ne saurais te le dire.

 

mais merci comme quand-même pour ton conseil   ;)

 

 

EDIT:

 

j'avais donc raison... le problème de usb2 ne concerne pas les anciennes configurations (du moins celles à base de ICH7)

 

la version 3224 de Clover boot sans souci, par contre uniquement avec la méthode standard... la méthode createinstallmedia ne me laisse pas charger FakeSMC correctement même en essayant de le charger manuellement en démarrant avec -s et ensuite /sbin/mount -uw /... il me dit "media is locked"

Edited by fantomas1

J'ai tenté d'upgrader une partition Mavericks dupliquée de mon Dell Latitude E6220 (une bébète standard et toute simple en SandyBridge i5-2520M avec HD3000 supporté OOB) en double cliquant simplement sur l'app Install 10.11. Ca bosse quelque (court) temps puis propose le redémarrage. Je démarre alors depuis une clé USB en Clover v3215 et je choisis la partition d'installation d'OS X (cachée) qui est listée parmi les partitions existantes. Et ben, je n'ai pas réussit à démarrer le foutu bouzin, ça bloque après les messages Bluetooth et d'initialisation de la carte LAN.

 

En mode sans échec, c'est comme pour Fantomas, l'ordi redémarre inopinément.

 

Je réessaye ce soir avec ce Clover v3224.

 

Je l'aurais, un jour je l'aurais...

post-851564-0-47214500-1433948181.jpg

  • Like 1

donc comme dit dans mon poste précédent, Clover 3224 boot ma clé usb sans souci

 

par contre, le gros souci c'est qu'une fois choisi la langue d'installation, il ne bascule pas sur la fenêtre d'installation mais sur Utilitaire OS X   :surprised:

 

du coup, impossible d'installer OS X     :lol:

 

et comme un nanar, j'ai supprimé ma partition Yos avec tous mes fichiers  

 

applaudir-bravo.gif

Capture d’écran 2015-06-10 Ã  17.18.44.png

En ce qui concerne les Latitude Dxxx, je pense que le soucis vient des DSDT. Je ne vois pas d'autre explication pour cette histoire de still waiting for root device et les problèmes de reconnaissance des périphériques USB…

 

La version 3224 de Clover ne change rien à l'affaire.

 

Par ailleurs, j'ai remarqué des résultats variables selon que les kexts sont dans 10.10 ou 10.11. Sur la partition El Capitan installée, les kexts ne se chargent pas si ils sont dans 10.10 mais pas de problème si ils sont dans 10.11. Idem pour la clé d'install. Mais sur la Gigabyte GA-H97-HD3, pas de problème s'ils sont dans 10.10.

 

Enfin j'ai tellement essayé de trucs que je ne sais pas vraiment si c'est la version de Clover qui veut ça, la méthode de création de la clé ou autre chose…

  • Like 1

il est vrai que c'est assez aléatoire  

 

on a du mal à trouver LE truc

 

je veux dire, la méthode reste la même, seulement pour différentes raisons, un coup ça marche, un coup non

 

7386.gif

Install en cours avec Osmosis, DSDT patché dont USB3 pour carte Z77-DS3H.

 

Création clef USB avec la méthode createusbmedia.

Il a fallu mettre ma clef usb dans un port USB3, sinon still waiting for root.

Idem pour clavier ne fonctionne pas sur USB2.

 

Fred

donc comme dit dans mon poste précédent, Clover 3224 boot ma clé usb sans souci

 

par contre, le gros souci c'est qu'une fois choisi la langue d'installation, il ne bascule pas sur la fenêtre d'installation mais sur Utilitaire OS X   :surprised:

 

du coup, impossible d'installer OS X     :lol:

 

bon, j'ai trouvé le souci... en faite, pour une raison qui m'est encore inconnue, le dossier Packages a été copié sur la racine de la clé usb et non dans System/Installation

 

une fois à sa place, j'ai aussi tôt basculé sur la fenêtre de l’installation et tout s'est très bien passé.

 

donc, encore une fois les anciennes configurations à base de ICH7 sont toujours d'actualité.  ^_^

 

finalement, ce n'était qu'une question d'avoir la bonne version de Clover (en ce qui me concerne)

×
×
  • Create New...