Jump to content
estampador26

Plz Plz HELP, EVGA NVIDIA GEFORCE GT 610 2GB Black Screen After Install 10.9

16 posts in this topic

Recommended Posts

Hello.... I really really I would appreciate all your help...

 

My System is Ok, Mavericks install perfecto, everything works great, but Video...

 

I Purchaced a EVGA NVIDIA GEFORCE GT 610 2GB DDR3, Because I read on OSX86wiki that runs OBB,

but Nothing... I have already 3 days trying and Nothing... I tried all boot flags...

 

the only ways the OS Start is with  NV_DISABLE=1...

 

all others boot flags are useless...

 

I really would appreciate all the help you could gave me...

 

mail:   estampador26@gmail.com

 

Thanks...

 

Share this post


Link to post
Share on other sites
Advertisement

What bootloader are you using? Make sure you have graphics injection disabled.

In Chameleon use

GraphicsEnabler=No

and Clover use

<key>Inject</key>
<dict>
<key>NVidia</key>
<false/>
</dict>

Share this post


Link to post
Share on other sites

Well... first its Nerish Distro... in my first hackintosh all works well, its an old pentium D 2.5ghz with XFX 9800 GT 512dd3 and always is obb..

 

but this second machine, all works well, except video... 

 

I try first chameleon, then, I just re install with clover, and nothing... the System boot ok But just with NV_DISABLE=1... even without install yet the [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]...

 

and the OS detect de graphics card fast, it says EVGA GeForce T 610 2gb...

 

I also tried thoses boot flags,  graphicsenabler=Yes and No, PciRootUID=1, or 0... and Nothing....

 

Another thing... about an hour ago, I tried Yosemite.. and the same situation.. it boots ok, but just with NV_DISABLE=1... 

 

and This Graphics Card is brand new, Bought 3 days ago..

 

Any Idea..??

 

I Really really Really would appreciate all the help...

Share this post


Link to post
Share on other sites

When you have the graphicsenabler=Yes and GraphicsEnabler=Yes is 2 different thing, typo is not allow with the chameleon bootloader which mean when you type w/o capital is nothing to chameleon boot.

About PciRoot=1 or more, my dell xps 410 is 4, about 0 is not require because it is default

So you can try the value PciRoot=?

With ?=1,2,3,4,5

When you try to find the rigth boot flag, dont include all in one unless you are sure it is work for you machine.

You could try -x to see the osx see it or not.

Share this post


Link to post
Share on other sites

ok first thanks for keep answering...

 

you are right, I usually use capitals like GraphicsEnabler=Yes... but I think in middle of all this hundres of trying I must forgot in some times the Capitals...

 

another thing... when I use  -v  -x   its the same, the system start to load, but when should gime me the mac logo or desktop, it turn off the monitor.,.. and goes black again.... 

 

Right now I going to reboot and try with correct capitals to see what happen.. and I let you know..

 

and something that I notice a few hours ago, when I installed mavericks [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url],, after reboot, with nv_disable=1 of course, the detect graphics card change from my Evga to some generic... so I re install again, 

 

right now.. here is working normal, but load with nv_disable.... 

 

 

Bytheway, excuse the english... 

Share this post


Link to post
Share on other sites

OK I get it....  Im trying right now with PciRoot=...

 

I could see that using -x it loads everything.. and when it reach NVDAGF100HAL it turns the screen to gray and then Black... 

 

My Motheboard its a ASUS P8Z68 -V -LE


Well my friend... until now, nothing... I've been using PciRoot=1, later... 2, 3, 4, 5, 6 ,7,... but keep getting Gray Screen (usually after this I get Mac OS desktop) and then Black Screen and monitor goes off...

 

Im thinking in reinstall again.. this time, with Chamaleon Bootloader... and again.. try everything PciRoot again...

 

the thing is that in OSx86Wiki, says that this card works OBB... and I read in other forum, someone that build a setup using the same EVGA GT 610 2Gb card and says that works OBB too...

 

so... its frustating.. 

Share this post


Link to post
Share on other sites

GraphicsEnabler=Yes is required if using Chameleon Bootloader. 

 

Also boot in with the disabler flag and install the Nvidia Retail drivers. After so boot with GraphicsEnabler=Yes and the Nvidia Retail Driver Bootflag. 

Share this post


Link to post
Share on other sites

You don't have to reinstall osx, it is not neccesary, it is just need to firgure to loadnvidia kext correctly, if you said that, some thing is related to graphics enabler is no is active, with the gt610 is needed as graphics enable is yes.

Boot in safemode, run drawin dumper, zip it and attach here, some other menbaer can take q look and can tell youwhat you need.

The card is work obo, it is just not inject the wrong flag.

Share this post


Link to post
Share on other sites

well.... After knowing that nerish is corrupted and banned here... I download Mavericks Retail, but not from Apple Store, because it says is not available... not in the country im right now, and either changing country store.... so, I get it from torrent but one is untouched...

 

then, I copy the Install OS Mavericks to Applications folder..

I tried the Method of Apple through terminal, but always have an error, that says command not recognize, something like that...

 

so, I make the Usb Installer with [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]...

 

I install the OS Again, (I can see the differences with nerish, so its not the same)...But..

 

Again... to be able to boot, (Before Install [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]) I must choose USB again, and then select HDD, and Use nv_disable=1... otherwise I get the same... Black Screen monitor off...

 

I install [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] setting the flag GraphicsEnabler=Yes...  Reboot.... and... again... 

 

then, Installed Web Nvdia Graphics, I choose, and reboot... it says NVDAStarup:Web, and keep.. then, Gray Screen, then Black and that it is..

 

I must Work... this night I will upload Pics of my Screen and other data so you could see...

Share this post


Link to post
Share on other sites

Yes my friend, but it is because the method that you guys gimme, only works to make USB Yosemite... and works fine... but, for Mavericks, I keep getting error or syntaxis or something like that... and I see and check every single character in the terminal and all was ok... but not work, not run and make the usb installer...

 

I dint know that there was some Installation Methods that are banned...  

 

The thing is that i'm stuck then...because, the OS isn't available from apple store, it says in US Store is, and when I change country to US, says isn't longer available... so.... 

Share this post


Link to post
Share on other sites

Well.... this is how are thing at this point...

 

I did a Fresh Clean Retail Install of Mv.... But.... with internal graphics.. Intel HD3000... all work well.. except Not Aceleration... I did follow a guide in Rampage Dev Site... but still, not acceleration...

 

So... I set PciExpress Graphics first again... the Famous and tedious EVGA NVIDIA GEFORCE GT 610 2GB DDR3..

 

and now... I can't Reach the Installation menu without nv_disable=1... 

 

the same happens with the Yosemite Instalation guide here in this forum... I follow every single step but also, I can't reach Install menu without nv_disable=1... 

 

 

Using this flag... Im able to install everything and boot OS, and keep installing wifi, printers, etc.... but, as soon as I remove this flag... the system goes to Black Screen... in both cases... Yosemite and 10.9....

 

I really appreciate your help... specially those who respond to me... but... I don't now... 

 

If I use my old XFX Geforce 9800GT 512 DDR3... I don't have any problem... this card works OBB and flawless... but this card if from this machine (First Build)... so....

 

I know is tedious when someone keep coming back with the same problem over and over and over... but... You guys are the expert... 

Share this post


Link to post
Share on other sites

old thread, but the problem still occurs. I use the GT 610 successfully. I used chameleon rev 2538, then installed the NVidia drivers and Cuda. works great in Mavericks and even ML, but no love yet in SL. be nice if we got some support from NVIDIA. For all the money I have thrown their way over the years. No love there either.  My Mavericks boot.plist as follows (amd on asrock alivesata2 with geforce gt 160)

NVDAGF100Hal 8.26.28 310.40.55b01  (i hope that will help you find my driver version, i have too many downloaded) the "skip" flags are just to help speed things along, works without them. The lack of GraphicsEnabler flag defaults to Yes as far as I know?? try either way

<key>EthernetBuiltIn</key>
    <string>Yes</string>
    <key>Graphics Mode</key>
    <string>1024x768x32</string>
    <key>Kernel</key>
    <string>mach_kernel</string>
    <key>Kernel Flags</key>
    <string>-f cpus=1 npci=0x3000 busratio=12</string>
    <key>SkipAtiGfx</key>
    <string>Yes</string>
    <key>SkipIntelGfx</key>
    <string>Yes</string>
    <key>Timeout</key>
    <string>8</string>
    <key>UseKernelCache</key>
    <string>Yes</string>

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By skrypious
      Hi,
      I have been using my hackintosh for a while without any problems, until my monitor is replaced with a new one... Previously I was using 2 monitors connected via HDMI + DVI, now - with new one, I am using HDMI + DP, and my hackintosh stopped working. On every boot, everything I see is black screen... When I connect only one monitor (via HDMI or DP) - everything works fine.
      I have tried many things: 
      - CSM off / on 
      - PEG + iGPU (64MB/128MB) / only PEG 
      - SSDT patching / DeviceProperties patch 
      - VBIOS reflash 
      - BIOS reflash 
      - Changing cables 
      - Resetting NVRAM
      - Changing SMBIOS
      Nothing helps…
      Fun fact - for 2 days everything was ok, the black screen problem appeared suddenly... So I am writing this post, maybe someone more knowledgeable will be able to help me
      Hardware: 
      - Intel Core i5 4690k 3,5GHz (overclocked to 4,4GHz) 
      - MSI Z97 Gaming 3 
      - MSI Radeon R9 390 8GB 
      - Kingston 16GB DDR3
      Software: 
      - macOS Big Sur 
      - Dual boot with Windows 10
      Screens: 
      - Acer VG272U 2560x1440@170Hz (connected via DP 1.4)
      - LG 23MP48 1920x1080@60 (connected via HDMI 2.0)

      Hackintosh: 
      - OpenCore 0.6.3 
      - iMac15,1 
      - Full EFI: https://drive.google.com/file/d/1eul7SnOEunfJOxBGD3Ygcmkc9f80DrlN/view?usp=sharing
      BIOS: 
      - UEFI Boot Mode 
      - CFG Lock and VT-D are disabled 
      - iGPU is disabled right now, but it doesn't make any difference somehow in this situation. iGPU is HD4600
      More Info: 
      - I have SSDT patch in my ACPI folder, which works fine - R9 390 works pretty fast, but I have never edited AMD8000Controller - is it required? 
      - I also have all needed kexts (AppleALC, AetherosE2200Ethernet, Lilu, VirtualSMC, WhateverGreen) 
      - if I made linguistic mistakes somewhere - forgive me, I don't use English every day
    • By b2550
      Currently my install is 100% working except that so far I have only been able to get one of my 1080p monitors working with a MiniDP to HDMI cable. I currently am getting a second MiniDP to HDMI cable but for now I am stuck with a DVI to HDMI cable.

      The monitor that is working is plugged in via the MiniDP to HDMI. The monitor that isn't working is using the DVI cable. However I also tried switching it to HDMI to HDMI which had the same result. The monitor wakes up but it's black. However for whatever reason, both monitors are still recognized in system preferences and hackintool.

      I know all my cables are good and work because I updated from an install of El Capitan (which I still have on it's original SSD just in case this install fails) as well as a Windows install. Both monitors worked fine on El Capitan for literally years. El Capitan is just too old now and I need to update to keep up with software updates.

      Problem reporting files should provide needed info about how I've configured this install. Build is in my signature.
      debug_22725.zip
×