Jump to content

ASUS Zenbook Prime UX31A-DB51 Ultrabook - fixes, mods, tweaks, etc


1,056 posts in this topic

Recommended Posts

Could somebody post it for me in https://www.tonymacx86.com/forums/sierra-laptop-support.188/ ?
I somehow not understandably got banned there because of some signature rules, I do not understand.

After macOS upgrade from 10.12.5 to 10.12.6, I can not boot macOS again.

It hangs here see the screenshots below.

Attached is EFI folder as created by FAQ - Problem Reporting" files.

My notebook is:
ASUS ZENBOOK UX32VD-R4010P, Intel i7-3517U, 10GB RAM, 2x256SSD, NV 620m: ASUS ZENBOOK UX32VD-R4010P, Mainboard model: UX32VDA, Northbridge: Intel Ivy Bridge rev. 09, Intel® Core i7-3517U CPU @ 1.90GHz, Southbridge: Intel HM77 rev. 04, Intel® HD Graphics 4000, NVIDIA GeForce GT 620M, 1920 x 1080, BIOS UX32VDA.203: OS X 10.12.6/10.11.2/10.9.5/Ubuntu/Win10

I described issue here with user name @pavn there also.
http://www.insanelymac.com/forum/topic/283038-asus-zenbook-prime-ux31a-db51-ultrabook-fixes-mods-tweaks-etc/?p=2551285

EFI.zip

post-51549-0-87950700-1513377207_thumb.jpeg

post-51549-0-88339600-1513377228_thumb.jpeg

post-51549-0-48151500-1513377248_thumb.jpeg

Did you try with Danieleds DSDT ?

I beilieve he was able to disable the Nvidea discrete card:

[RehabMan's Guide] Disabling discrete graphics in dual-GPU laptops

 

One issue I had with El Capitan is that it suddenly stopped working after an unexpected reboot. I thought it was linked to something I did. After hours trying to fix it, I ended up reinstalling everything following the exact same steps and it worked. My guess is that one boot file got corrupted.

 

My recommendation, again, would be: going directly for High Sierra might be an easier path.

Good luck.

  • 2 weeks later...

Ok. I was able to get my Sierra to boot again!

 

And also created spoofed SSDT.aml to be able to boot High Sierra Installer.

 

But before update of my Sierra to High Sierra, I would like to make the most from Sierra via hotpatching first.

 

Any advice where to start?

  • 8 months later...

MOJAVE : Zenbook Ux31 successfully installed to 10.14 beta 8

Installed to an external HDD (apfs format)

 

instructions

1. Update Clover r4644 and Clover configurator.
2. Lilu_version 1.2.6 https://github.com/vit9696/Lilu/releases
3. AppleALC version 1.3.1 https://github.com/vit9696/AppleALC/releases
4. Update apfs.efi https://www.tonymacx86.com/threads/macos-10-13-6-update.255911/
Then Clear cache and reboot
5. touch /System/Library/Extensions/ && kextcache -Boot -U /
 
After reboot
6. Download Mojave 10.14 public beta 8
7. Launch Mojave Install from Application directory
8. Select external HDD (apfs format)
9. At Clover boot, HDD appears with both MacOS (Mojave) and Recovery partition (Mohave)
10. Continue boot to MacOS (Mojave) and you are done !
 
Atheros AR9285 no longer supported
Copy AirPortAtheros4xxx.kext to /System/Library from High Sierra to get wifi working.
 

Everything works : Wifi, Sound etc...

 

×
×
  • Create New...