Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


[Working Install GM] GA-Z77X-UD5H + Ivy Bridge i7-3770 + HD4000(QE/CI)

16 posts in this topic

Recommended Posts

Hey peeps,


I've recently upgraded my pc with the idea that I will create a hackintosh that runs Mountain Lion, and have tried to buy compatible hardware. With the Mountain Lion release date soon, I guess I could have waited another 10 days or so to find out exactly what would work. But I'm inpatient.


After reading around, I determined that the Gigabyte GA-Z77X-UD5H would be a pretty compatible motherboard (Doesn't even need a DSDT for sleep/reboot etc) along with the new Ivy Bridge i7 3770 (And integrated Intel HD4000 graphics). I will run it with the HD4000 to begin with, but I would like to upgrade and get a supported graphics card for my three monitors.


So here's my base components:


- GA-Z77X-UD5H

- i7 3770

- 16GB G-Skill 1600 ram

- 120GB Vertex 3 SSD




I found this great guide by Lofen here that I pretty much followed.


1. Download the MtnLion Installer Kit ver 1.0.zip from here

2. Open the mkboot script and uncomment the Realtek ALC889a installation, Power Management plist, AppleRTCpatch.txt, and the Realtek NIC pkg

3. Open the finalize script and uncomment the same things as above.

4. Copy the install folder to your desktop, along with the installESD.dmg (From the ML app/download)

5. Format your 8GB+ USB/HDD to GUID, HFS+ and name it 'ML'

6. Open a terminal at your desktop and run 'sudo install/mkboot /Volumes/ML' and watch the show/make a cup of tea, this amazing script will do all the work (20 minutes or so)

​7. Once that completed successfully, boot it and the Mac OSX Mountain Lion installer should appear, follow the instructions and install

8. Once complete, restart and boot off of the install USB/HDD again, we need to open terminal and run the './finalize' command to install the bootloader+extras on the main

9. With a little luck, we should be booting into a fresh installation of Mountain Lion!


At this point, it will look a bit {censored}, No Sound, No HD4000 acceleration, No network. But not to fear.


Network + Sound


Pretty simple, probably not the best way to do it, but I downloaded the latest Multi Be ast (4.6.1) and check the following:





Full QE/CI HD4000 Support


I found this awesome thread by proteinshake that describes a way to get the HD4000 working properly here. I'm sure you can play around with DSDT's or some other method, but I managed to create myself an EFI String that I put in my org.chameleon.Boot.plist's device-properties.


This excellent post details on how to find your own EFI String OR you could try the one I generated (same as someone else's in that thread)





The Problems


- The sound quality is average, no DD/DTS streams out of Optical, only stereo. Front and rear mic's work, two outputs on the back work (and a line in?) as well as Optical Out.

If anyone has a better method of getting the Realtek 898 to work, please comment!


- I've only managed to get one display running off of the HD4000 so far. UPDATE: (I've now added an ATI5850 and can run two off the card, and one off of the internal HD4000, the HD5850 was plug and play, worked OTB)


- Forward and Back buttons on my mouse don't work! (Razer DeathAdder) Help!?1




Hope this helps someone, and no doubt, in the next month or so more things will become working as more people get Mountain Lion when it gets released.




1. Fixed this by installing the OSX Razer driver and assigning the CMD+[, CMD+] keyboard hotkeys to each mouse button.

Share this post

Link to post
Share on other sites

what file size should I expect the USB drive to use? When I do this method it's only using about 1.6GB and the install fails.


Could someone also re-up the installer? I may have a corrupt download. Thanks!

Share this post

Link to post
Share on other sites

My usb HDD has about 5.02GB being used. So yeah, something sounds dodge with your install.


You could do it manually by restoring the installESD.dmg and installing charmeleon to the drive.

Share this post

Link to post
Share on other sites

Also tried to fix the HD4000 on my GA-Z68X-UD3H in combination with my 3770K but no Qe/Ci.. Are there any additional kexts I must use? I've got the default kexts installed who came up with 10.8 for the HD4000. Also setup my '<key>device-properties</key>'.. See my plist. Do I make any mistake on it..?



<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">


<key> GenerateCStates</key>


<key>Boot Graphics</key>










<key>Graphics Mode</key>
















Share this post

Link to post
Share on other sites

Hi, it seem the John Cash guide that Lofen linked too has been removed as it may have linked to apps created by another x86 site.


Are you able to post the files to a drop box folder or something, im really keen to build a brand new hacky and the specs looked VERY promising :)


thank you!



Share this post

Link to post
Share on other sites

I too have the GA-Z77X-UD5H and would like John Cash's information and possibly the supporting files for installing Mt. Lion 10.8. I have not found installation anywhere else for 10.8 that includes support for Ivy Bridge. I have successfully installed 10.7.4 with Bridgehelper but 10.8 is what I am trying to get working with the i7 3770 CPU.

Share this post

Link to post
Share on other sites

If anyone has a better method of getting the Realtek 898 to work, please comment!

Forward and Back buttons on my mouse don't work! (Razer DeathAdder) Help!?


I have Intel motherboard with same codec, i used voodoohda and in sound settings it shows all the ports, even hdmi.

Will try with my DeathAdder when i get time.


Does ML have native ivy bridge support? I mean does the vanilla mach_kernel in the ML image work to boot your i7 3770?


Yes. It also has Intel USB 3.0.

Share this post

Link to post
Share on other sites

Sorry I've not replied to anyone. It seems that the

John Cash's post has been removed..


I've uploaded the files to dropbox, with my modifications. So this works for the same hardware as mine.




Copy the 'install' dir to your desktop, and also copy the 'installESD.dmg' to your desktop and run 'install/mkboot /Volumes/-volumetoinstallML'

Share this post

Link to post
Share on other sites

Very useful guide, thanks.


One question: does firewire work out of the box? Or, if not: is there a driver to make it work?


I'm in doubt whether to choose this board or the cheaper DS3H plus firewire card with Texas Instruments chipset. I don't need a highend overclocker board but if you consider the price for the card and the better build quality and better cooling of the UD5H it might be the better choice.

Share this post

Link to post
Share on other sites

I copied the 'install'-folder and the InstallESD.dmg to the desktop.


When i paste 'install/mkboot /Volumes/-volumetoinstallML' into terminal, terminal responds: -bash: install/mkboot: No such file or directory.


That can be fixed by dragging the 'mkboot'-script on the terminal-window, hitting space and pasting '/Volumes/-volumetoinstallML' in the same line.


Now terminal seems to find the 'mkboot'-script but not the InstallESD.dmg. It responds:

InstallESD.dmg: No such file

Usage: mkboot ‹Target volume›


I tried this under 10.7.4, booted from a USB 3.0 hd.


The terminal and me, a sad story.


Edit: found this in lofen's thread (http://www.insanelym...howtopic=280420):


It looks like the error is caused by being in the wrong directory. Make sure you copied the "install" folder and "InstallESD.dmg" file to the desktop, or at least put them in the same directory. Then in terminal, you want to go to where you put them. Assuming the files are in your Desktop directory, in Terminal I did the following:


~$ cd Desktop/

~/Desktop$ ls

InstallESD.dmg My Boot Camp install

~/Desktop$ sudo install/mkboot /Volumes/USB




He named the install stick USB instead of ML.

He said that firewire works out of the box.


Looks a little bit frightening but I will try tomorrow.


edit2: worked for me, install stick done.

Share this post

Link to post
Share on other sites



I have GA-Z77X-UD5H, Ivy Bridge i7-3770K and only Intel HD 4000. I generate EFI string but i don't know how set org.chameleon.Boot.plist. Can You please post your org.chameleon.Boot.plist? Because my generated EFI string is same as yours. I'm beginner and this is my first Hackintosh Build. Thank You.

Share this post

Link to post
Share on other sites

Hi All


I'm a relative newbie by comparision to most - though I think I do have a decent grasp of the fundamentals.

I need some help please ........


I've followed this excellent install to the letter and everything went very smoothly once I had commented the graphic card port line to 0.


mkboot, install all go perfectly as per the guide.

After install i reboot the USB stick and execute the finalize command.

Everything reports completed ok - however, I'm not able to boot OSX from the hard drive at all.

It appears the bootloader is not installed.

The error I get is ....









when i start the machine i hit f12 and my WD drive is shown twice - once as a UEFI device and once as P3

The above error occurs when i choose P3.

If I choose the UEFI version i get a message telling me to insert a bootable media into the relevant drive.


Ive reformatted the WD hard drive each time ive tried the install so its always clean. Every time i get the same result.


On about the seventh attempt, I booted from the USB and chose the WD installation to boot and ML started fine and I was able to do first time setup etc and all looked great. However when i looked in the finder i couldnt see the WD drive that i launched OSX from, only the USB drive.

So far I havent been able to replicate this - however at least I know that the OS will run.


I would really appreciate any guidance to help me solve what appears to this newbie to be the bootloader not installing on the WD hard drive diring the finalize routine. I havent edited any scripts at all so they are as they came in the original zip.


My equipment is


GTX 550 ti 1024

2x4 GB twinmos ddr3 ram


WD green 1 Tb HD SATA


Thanks guys

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.