Jump to content

[HELP] Mac OS X Lion on AMD - Niresh 10.7.3 V2


12 posts in this topic

Recommended Posts

"I have successfully installed Mac OS X Leopard 10.5.2 - Kalyway on my HP 520 Notebook. It is running stable and good."

"I will post about my experience soon. I am still experimenting with it. :)"


This is about getting Mac OS X Lion up and running on an AMD Desktop.


I have chosen Niresh's Distribution for my install. But I am sure that the procedure as well as the problems faced by everyone will be the same. So let's work it out.


My Configuration:


Motherboard: ASUS M4A88T-M-LE [ 880G Chipset ]

Processor: AMD Phenom II X4 955 [ Black Edition ]

Graphics: ATI Radeon HD 5670 [ 1GB GDDR5 ]

RAM: Corsair Vengeance 2 x 4GB




1. SATA Mode changed to AHCI from IDE

This is for people facing
Still waiting for root device
error. Changing SATA mode to AHCI corrects it.


2. Took out a RAM

Hackintosh has problems with Dual Channels most of the time


3. Suspend mode changed to S3 from AUTO

I am not sure about this. I was reading about a successful AMD installation with this configuration. But I saw no difference yet.


4. Booted from DVD with Boot: "Kernel Cache"=\amd arch=i386 -v

Successfull discovery of all 4 cores of the CPU and 4GB RAM.


5. And this is where I get Stuck:

USBMSC Identifier (non unique): 000000264001 0x424 0x4060 0x182

USBF: 54.274 AppleUSBOHCI [0x7fdb800] :: CheckSleepCapability - controller will be unloaded across sleep

Check screenshot for details of the error message with complete install log.




Requesting assistance with these issues. Kindly post your problems with installing Mac OS X Lion on AMD in this thread.



Edited by PookyMacMan
Please, no warez links and no misleading titles.
Link to comment
Share on other sites

  • 2 weeks later...

You and I are in the same boat. However I can get a few steps further than you have gotten. Unfortunately I cannot get any of my test systems to boot into the Niresesh OS.


Here are the system's that I tried on without success:


System 1

Gigabyte GA-MA790GP-UD4H

X6 1090t CPU

Gigabyte 550Ti Video Card

4 GB Crucial DDR2 Ram

WD 320GB Blue HDD


System 2

Biostar A780L

X3 720 (Unlocked to X4 20)

2 GB Generic HP DDR2 Ram

XFX 9800 GT

WD 320GB Blue HDD



This system below allowed me to install Niresh's OSX 10.7.3 to my surprise!!

Your following command(s) allowed me to get to the installer. Without your help I was dead in the water. I tried your command on the machines listed above but the system below is the only one it worked on.


"Kernel Cache"=\amd arch=i386 -v


Gigabyte 970A-UD3H

FX-8150(OC'd to 4.0)

8GB Kingston Hyper DDR3 1333 Ram

Radeon x2400 Video Card (old but this system mainly transcodes videos)

WD 320GB Blue HDD


Here are 2 short videos of what I get when I try and boot into the OS. I am working on adding more content to the site so a few of the pages might be blank or very low on information at this time.


I could get to the Mac install screen just fine with this one and even go into disk utility and partition drives and everything. Even though I could install the OS I cannot boot into 10.7.3 though. I took the hard drive and flash drive out that I am using as a boot drive and tried them both on systems 1 and 2 but cannot get either of them to boot into the OS. I tried multiple commands but none of them worked. Here are the commands that I tried but all of them failed to boot into the Operating system.



PCIRootUID=1 -x



Ironically the second system (the Biostar motherboard system) is the one that I have Snow Leopard installed onto a different HDD. In order for me to get everything working on that system I had to use an XFX 9800 GT Video card along with a Creative Soundblaster sound card to get it working perfectly. Check this page to see what exactly I used to get it working without a hitch.


There recently has been a posting here about Niresh's 10.7.3. It is in Portugese but can be translated through Google Chrome. I have tried it with all the commands in numerous orders but I cannot get it to work on the Gigabyte 970 board. I have tried a lot of the different commands listed below in different orders on the Biostar board but none of them work either.



DSDT=0 that's a zero that I am using and not an O as in ohhhh


Drop SSDT=Yes


At the top of the bios screen of the Gigabyte 970 it says its an ATOM bios so I also tried all of the commands above using. "Kernel Cache"=\atom -v None of any of this worked either. The last line of code I see says:


Setting Legacy USB controller off on controller [1002:4396]


Then the system reboots. I have tried to turn off the USB 3.0 controllers in the BIOS but that changes nothing.

Link to comment
Share on other sites

This site has a guide to add the AMD Kernel to an installation. The site is in Portugese, which I don't speak or read, so its instructions don't help me. Anyone here understand what the author is talking about. I have the Lion app from the app store and I have Niresh's version also. Has anyone successfully installed Lion on an AMD Machine??? If so any and all assistance to us who have not would be greatly appreciated.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Yea the same problem :)


Used "Kernel Cache"=\amd arch=i386 -v busratio=16 cpus=4

Everything all right but then stucked on USBF


Really dont know what to do to resolve this :/

I try to disable USB3 in Bios

I try -legacy with panic


Also posted here: http://www.insanelymac.com/forum/index.php?showtopic=279291

Also googled here: http://www.osx86.net/10-7-lion/15507-stuck-some-usbf.html

Also screen here: http://db.tt/rxrwxmmr


Thx for any reply :(

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
  • 2 months later...

Hi, I'm running 10.7.3 . My system is Asus m4a89gtd,AMDFX6100, radeon HD6850 4gb mem.

Runs pretty good so far.. I boot with cpu=1 busratio=20 PCIRootUID=1 npci=0x2000 and UserKernelCache=No.

Finder works in 64 bit !!

I used iatkos with this guide : http://www.insanelymac.com/forum/topic/278181-amd-1073-guide-experimental-only/


The only thing that causes trouble that I can't use 32bit apps they crash when launched

Link to comment
Share on other sites


  • Create New...