Jump to content

[Guide] Installing Lion on Sandy Bridge Dell XPS L502x


73 posts in this topic

Recommended Posts



Installing and Dual boot Lion and Windows on Dell XPS L502x




This guide is created with the attempt of assisting any newcomers wanting to install OS X 10.7 on there Dell L502X Sandy Bridge system. This guide is mostly done, I will be updating where clarification is needed


First off this guide couldn't have been possibile without the two pioneers DoiX and Wen1 in the orignal guide (Which is currently still active with discussion for help and development). All credits go to DoiX for the DSDT, SSDT creation, Package creator and help for just about perfecting this system. Now let's begin:


My System:

CPU: Intel Core i7 2630QM

GPU: Nvidia 525m


Monitor: 1920x1080

Sound: ALC 665

WIFI: Intel Centrino Wireless-n 1030 (Replaced with DW1510. Works perfectly out of box)


What works:

Native resolution via Intel HD 300 graphics

Sound (with some EQ help from Boom program)

Proper CPU detection

Wired Network


Native Power management

Speedstepping for Sandy Bridge Processors

Display ports (except HDMI)


What Doesn't:

Wifi (Install a DW1510 from amazon or ebay. It works out of box)

Nvidia Graphics (Due to BIOS lock which makes it impossible to power the card without a modified BIOS or injector Kext)

USB sleep on the 3.0 ports and a couple other minor glitches

Trackpad 3 and four finger gestures (Hardware limitation)



iAtkos L1 (Google it)

A USB drive with MBR partition table or blank DVD

Blank CD

Latest RBootLE & [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] from Tonymacx86

A running MAC (if your going to try creating a bootable USB disk)

CPU busratio value. You can find yours out here. Mine is 20 so that is what I'll use throughout the guide

DoiX's Package Installer

L502x Pack files (Only use if the package installer gives you problems. This pack is basically is a back up set of files. DSDT and smbios are outdated. However, the essential kexts will be enough to get you running. You can update afterwards)



If your looking to Dual boot OSX and Windows with a data partition to keep the data synced between them:

1) Use the Windows 7 installation disk to delete any current partitions on your machine (leaving you with a blank disk) and reinstall Windows on a 40- 50GB partition depending on your needs

*If you already have Windows installed you can try to shrink your drive to size needed using the disk manager. If disk manager won't let you, then its easiest to just wipe your hard drive and start fresh. If that isn't an option, using Gparted will easily get the job done but it takes a while to move your data across the disk

**** A preemptive measure to make fixing a future bootloader issue easier is, after installing windows, reboot the install CD and delete the 100 MB System partition. Then repair Windows to reinstall the bootloader to the Windows 7 partition. What this does is put the bootloader on the Windows 7 drive to streamline the dual boot process and make repairing the bootloader in the future, easier.

2) Create an unformatted partition for your data (If the disk manager makes this partition a logical drive its ok. But the Windows and OS X drives must be primary drives). We will format them to HFS+ during the installation process

3) Create an un-formatted 55GB partition for OS X at the end of the disk so that if you end up not using it, you can easily delete this and easily regain the disk space

4) Decide what formatting you want to use for the data drive:


For Windows being primary: I'd format the data partition to NTFS and install Tuxera for OS X

For OSX being primary: I'd format the data partition to HFS+ and install Paragon ntfs+ (Macdrive is another suitable option but I've run into issues with it)

For the debate on EXFat (Supported natively on both OS's) I've found this information to help compare the different formats and see the disadvantages of EXfat


Installation Process:

1) Use an working OS X machine to restore the iAtkos DMG to the USB drive in disk utility

1a) If you find the USB method doesn't work, restore the DMG in OS X or in windows using Transmac. While this method is safer and virtually bug free, it takes significantly longer to go through the install process

2) Burn/Restore RbootLE to a CD

3) Restart your computer and boot from the USB drive (Make sure no other devices are connected, and the USB drive is connected to the USB 2.0 port which is on the right side). If you get into the iatkos boatloader, type:

-v -f GraphicsEnabler=No cpus=1 busratio=20

If you get a "Missing operating system" error go to 3a

3a) If booting from USB drive doesn't work, you can try to use the RBootLE boot loader to try and boot from the USB. If that doesn't work try 3b

3b) Boot with a burn copy of iAtkos and boot the USB drive with -v -f GraphicsEnabler=No cpus=1 busratio=20

3c) If for some reason iAtkos still doesn't boot, just use the DVD to boot with mentioned flags

4) Accept the terms of use and now at the disk screen go to utilities and choose disk utility, select the partition you want to format and click the erase tab. Format the OS X partition to HFS+ journaled and name it "OS X". If your using a data partition, go ahead and format that partition to the same

5) Exit out of the Disk Utility app. Now select the appropiate partition to install and click customize. select the following options:



6) If you managed to get the USB drive to work, the install process should take about 10 minutes. If using a DVD, the process could take about 45 minutes to an hour

7) Go ahead and insert your RBootLE CD and reboot

8) You now have two options to get through the Lion Setup assistant process. This is tricky cause if you boot lion at this point, the intel graphics aren't fully working and the screen will be cut in half till you install the right DSDT:

8a) Boot windows and install Macdrive. From there use the L502X pack provided above to use the DSDT you need (Full HD DSDT is for a 1920x1200 screen and the HD DSDT is for the lower resolutions) and copy that respective DSDT to /OS X Partition Name/Extra Now . Now reboot using RBootLE and use the following boot arguments:

-v GraphicsEnabler=no busratio=20 cpus=1

you should have Intel Graphics working with Native resolution, your usb 2.0 port recognized. Continue the install process

8b) If you don't have Windows installed, you will have to boot with RbootLE with

-v GraphicsEnabler=no busratio=20 cpus=1

. The install process will be difficult but you can navigate through the set up screens if you guess the location of the button you need to press.

9) Once at the desktop you need to install kexts needed to boot OS X without the RbootLE CD:

9a) Use DoiX's package installer to install the kexts and the necessary files

9b) Use the L502X zip file, run kext Wizard to install the kexts in the "Kexts" folder

**DoiX's package is easier to use, however, if you should have an issue use the kexts from the pack.

**If you pre copied your DSDT to the OS X partition, you'll want to update it with the latest one from the package

10) What to choose in the package:

A) System Definitions: the i5 processors should choose the 8,1 system defintion, i7 processors should choose the 8,2

B) DSDT: If you own a 1920 x 1200 display choose the Full HD DSDT, otherwise choose the HD DSDT

C) Speedstepper: Choose the AICPUPM version that corresponds to the OS your running (Should be 10.7.1 after fresh install). As for which SSDT to use, check the explanation below (There should be a succint explanation in the package itself)








-9TS-SSDT.aml.zip uses 9 turbo states like real MBP 8,2 that allows your CPU to reach its max (2.9GHz) but if you are a heavy user like myself rendering and other stuff, this version is not good if you care of your laptops life span because it automatically goes to the max. Keeping it under heavy load most of the time heats up the CPU to 80ºC with no cooler pad. (Also included in pack)



-3TS-SSDT.aml.zip uses 3 turbo states, so your CPU doesn't go to it's max TS (2.9GHz) unless there is a hard core application demanding it so the CPU heats up to only around 60-65ºC (which is better than on windows either way). The CPU will run under average conditions with a TS of 24-26 unlike the 9TS version which would go to 2.9 even from opening youtube. (Also included in pack)


*** After install you'll get errors saying the extensions were improperly installed, this is ok. Just click out of them for now

11) Copy the "org.chameleon.Boot" from /extra to the desktop, edit the key that says "UseKernelCache" and change no to yes. Copy the file back to the extra folder

12) Find NullCPU Powermanagement in S/L/E/ and delete NullCPUPowerManagemnt

13) After the install run Kext Utility and after thats finished, repair permissions with disk utility

14) Reboot OS X. It should boot normally now with the CD or any arguments

15) Run Mulitbeast and select the following options: post-298881-1322110613_thumb.png


16) Run Kext Utility and Disk Utility and then reboot

17) Install the 10.7.2 Combo Update but DON'T REBOOT YET

18) Open back up the package and reselect the audio kexts and select the 10.7.2 AICPUPM this time.

19) Run Kext utility and disk utility. Reboot, and now you should be updated with everything working



1) Data Partition: For those using a data partition follow this guide to move your user folder over to your data partition: http://chris.pirillo.com/how-to-move-the-h...n-os-x-and-why/ reboot after

2) Audio: Search for the XPS_ALC665.kext in /System/Library/Extensions/. Right click on it, and select show contents. Click through the folders till you find a info.plist. Replace that info.plist with the one in the pack. Credits for this solution go to Whitegerry. For those who want specifics of the altered plist:

To fix the heavy bass you need to remove the node:




HDA Platform Resource > Layouts > PathMapRef > IntSpeaker > SignalProcessin

3) Mouse: Install Steermouse to customize your mouse, run Kext Utility and Disk Utility and reboot

4) Software Updates: Use software update to update the system with any App updates (Don't update the OS)

5) iCloud: Insert your account information into iCloud settings in Preferences after the 10.7.2 update



1) Recommended software

A) Hyperdock- Customize dock with Windows 7 previews, aero snap window

B) BetterTouchTool- Customize Keyboard shortcuts post-298881-1322110627_thumb.png


C) Google Chrome- Better browser

D) Rdio/Spotify- Streaming media

E) iLife- almost required

2) Making Windows the default boot partition:

The easiest solution is to edit the chamelon boot plist.

open a terminal and type in

diskutil list

and hit enter

This gives you the hard drive device and partition id for your win 7 partition.

Note also the "Label" name if it has one - if it doesn't, you can boot windows and use disk manager to give it a name.


open your com.apple.boot.plist (or org.chameleon.boot.plist) and add the following key


<key>Default Partition</key>



where x = your hard drive id and y = your win7 partition


3) To hide your data partition you need to go back into Diskutil in terminal and take the x and y values for the data partition and add this to the plist:


<key>Hide Partition</key>



4) Dualbooting with the Windows 7 bootloader: be warned this way is theoretical and I haven't tested it

(To use this method make sure you have the RBootLE CD handy)

When you install Lion, run the show all files program and look at the root of your OSX drive. Remove the boot file by putting it on your desktop. Reboot, and windows should auto boot know that you've taken OSX out of the picture.(This method is the only way I got windows to recognize the bootloader) run the easyBCD program and reinstall windows boot loader, and then add OSX to windows boot loader. You should then be able to boot with the RBootLE cd and put the boot file back into the root of the drive and theoretically have dual boot windows boot loader




1) I rebooted and got a kernel panic: This is probably the most vague problem. Reasons vary from not rebuilding kext cache with next utility, to an improper kext installation. I have encountered a couple of Kernel Panics on reboot, and for some strange reason, just trying to boot again made them go away and they never returned


2) I booted and get a Kernel Panic after a minute or two of using OS X. I can't rebuild next caches or repair disk permissions: The most common problem causing this is a bad kernel cache. Reboot with "UseKernelCache=No" and rebuild caches in kext utility and repair permissions in disk utility


3) I can't repair Disk permissions: Boot the usb drive using chimera on your HD with the options

-v GraphicsEnabler=no busratio=20 cpus=1

Go to disk utility, verify disk and repair permissions and reboot


4) In console you find a message spamming your log saying: "com.apple.kextd[10] Can't create kext cache under / - owner not root.": Open up terminal and type:

sudo chown root:admin /


5) The package incorrectly patched my AICPUPM: Run this code in terminal

Go to the speed stepper folder in the pack and find the Speedstepper file. Now open up another finder window and go to "/System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS" Now open up a terminal window and type

Sudo Drag speed stepper file in the command and then space and drag the AppleIntelCPUPowerManagement file after it


sudo Users/Austin/Desktop/l502x Lion pack/Speedstepper/speed_stepper_lion_1072 /System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement

. press enter, type your password and it should say patching complete. Now copy the 3SSDT (Look at the bottom of the thread for clarification on the differences in the SSDT's) to the root of OSX drive and rename it to SSDT.aml Lastly, go to "System/Library/Extensions" and delete nullCPUPowerManagement


6)Bootloader issues: You get a "Missing operating system" error when trying to boot Windows

To Solve this issue you need to boot into OS X and run the "show all files" app (You can find it in [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] from Tonymac). After that go to the root of the OSX directory and move the file named boot to the desktop (Be warned you'll need the RBootLE disk handy once you do this). After that go into the Windows installer disk and run automatic repairs to repair the bootloader. Reboot and Windows should automatically load. If so then reboot and this time boot from the RBootLE CD and when your back in OS X replace your boot file back in the root of the drive

*For information purposes, as you should never need them, the manual commands to repair the Windows 7 bootloader are: "Bootrec /fixmbr" "Bootrec /fixboot" "Bootrec /RebuildBCD"


7) Audio issues: More than likely you improperly installed the Audio kexts. They are quarky, I always had to have the latest chimera for them to work for me. So update chimera, reinstall the 3 audio kext from the pack (IOAudio, AppleHDA, Dell_XPS) and be sure to run kext utility and then repair permissions with disk utility

  • Like 3
Link to comment
Share on other sites

  • 2 weeks later...

Hi - I followed the guide posted in another forum (probably you!) and have most things working. However after step 13 the internal keyboard and touchpad stop working. Here is my kextstat. Any help would be appreciated.



Index Refs Address Size Wired Name (Version) <Linked Against>

1 58 0xffffff7f80741000 0x683c 0x683c com.apple.kpi.bsd (11.2.0)

2 6 0xffffff7f808f5000 0x3d0 0x3d0 com.apple.kpi.dsep (11.2.0)

3 87 0xffffff7f807a4000 0x1b9d8 0x1b9d8 com.apple.kpi.iokit (11.2.0)

4 92 0xffffff7f8072e000 0x9b54 0x9b54 com.apple.kpi.libkern (11.2.0)

5 78 0xffffff7f80740000 0x88c 0x88c com.apple.kpi.mach (11.2.0)

6 27 0xffffff7f80738000 0x4938 0x4938 com.apple.kpi.private (11.2.0)

7 50 0xffffff7f8073d000 0x22a0 0x22a0 com.apple.kpi.unsupported (11.2.0)

8 15 0xffffff7f808e3000 0x7000 0x7000 com.apple.iokit.IOACPIFamily (1.4) <7 6 4 3>

9 22 0xffffff7f80976000 0x1e000 0x1e000 com.apple.iokit.IOPCIFamily (2.6.7) <7 6 5 4 3>

10 2 0xffffff7f81eca000 0x55000 0x55000 com.apple.driver.AppleACPIPlatform (1.3.5) <9 8 7 6 5 4 3>

11 0 0xffffff7f80a65000 0x2000 0x2000 org.tgwbd.driver.NullCPUPowerManagement (1.0.0d2) <7 4 3>

12 1 0xffffff7f81289000 0xc000 0xc000 com.apple.driver.AppleKeyStore (28.18) <7 6 5 4 3 1>

13 8 0xffffff7f807eb000 0x25000 0x25000 com.apple.iokit.IOStorageFamily (1.7) <7 6 5 4 3 1>

14 0 0xffffff7f814e0000 0x19000 0x19000 com.apple.driver.DiskImages (331) <13 7 6 5 4 3 1>

15 0 0xffffff7f81c3c000 0x2a000 0x2a000 com.apple.driver.AppleIntelCPUPowerManagement (167.0.0) <7 6 5 4 3 1>

16 0 0xffffff7f808f6000 0x3000 0x3000 com.apple.security.TMSafetyNet (7) <7 6 5 4 2 1>

17 2 0xffffff7f80938000 0x4000 0x4000 com.apple.kext.AppleMatch (1.0.0d1) <4 1>

18 1 0xffffff7f8093c000 0x11000 0x11000 com.apple.security.sandbox (165.3) <17 7 6 5 4 3 2 1>

19 0 0xffffff7f809d0000 0x5000 0x5000 com.apple.security.quarantine (1) <18 17 7 6 5 4 2 1>

20 0 0xffffff7f82156000 0x8000 0x8000 com.apple.nke.applicationfirewall (3.2.30) <7 6 5 4 3 1>

21 0 0xffffff7f81ea7000 0x3000 0x3000 com.apple.driver.AppleAPIC (1.5) <4 3>

22 0 0xffffff7f81a44000 0x4000 0x4000 com.apple.driver.AppleSMBIOS (1.7) <7 4 3>

23 0 0xffffff7f81c74000 0x3000 0x3000 com.apple.driver.AppleHPET (1.6) <8 7 5 4 3>

25 0 0xffffff7f81a5e000 0x7000 0x7000 com.apple.driver.AppleRTC (1.4) <8 5 4 3 1>

26 1 0xffffff7f81462000 0x4000 0x4000 com.apple.iokit.IOSMBusFamily (1.1) <5 4 3>

27 0 0xffffff7f81f1f000 0x6000 0x6000 com.apple.driver.AppleACPIEC (1.3.5) <26 10 8 5 4 3>

28 0 0xffffff7f81f2d000 0x3000 0x3000 com.yourcompany.driver.AppleACPIPS2Nub (1.0.0d1) <8 7 5 4 3 1>

29 2 0xffffff7f81295000 0x6b000 0x6b000 com.apple.iokit.IOHIDFamily (1.7.1) <12 7 6 5 4 3 2 1>

30 0 0xffffff7f81f27000 0x4000 0x4000 com.apple.driver.AppleACPIButtons (1.3.5) <29 10 8 7 6 5 4 3 1>

31 1 0xffffff7f81261000 0x7000 0x7000 org.netkas.FakeSMC (3.1.0) <8 7 5 4 3>

32 1 0xffffff7f81e87000 0x4000 0x4000 com.apple.driver.AppleEFIRuntime (1.5.0) <7 6 5 4 3>

33 11 0xffffff7f809f3000 0x4f000 0x4f000 com.apple.iokit.IOUSBFamily (4.5.3) <9 7 5 4 3 1>

34 0 0xffffff7f81357000 0x17000 0x17000 com.apple.driver.AppleUSBEHCI (4.5.0) <33 9 7 5 4 3 1>

35 0 0xffffff7f81aaa000 0x8000 0x8000 com.apple.driver.ApplePS2Controller (1.1.5) <7 5 4 3 1>

36 3 0xffffff7f8165b000 0xa000 0xa000 com.apple.iokit.IOAHCIFamily (2.0.7) <5 4 3 1>

37 0 0xffffff7f81eab000 0x18000 0x18000 com.apple.driver.AppleAHCIPort (2.2.0) <36 9 5 4 3 1>

38 0 0xffffff7f81e8b000 0x7000 0x7000 com.apple.driver.AppleEFINVRAM (1.5.0) <32 7 5 4 3>

39 0 0xffffff7f80a42000 0x1e000 0x1e000 com.LaCie.driver.PXHCD (1.0.7) <33 9 7 5 4 3>

40 2 0xffffff7f8094d000 0x29000 0x29000 com.apple.iokit.IONetworkingFamily (2.0) <7 6 5 4 3 1>

41 0 0xffffff7f80994000 0x34000 0x34000 com.lnx2mac.driver.RealtekRTL81xx (0.0.90) <40 9 5 4 3 1>

42 0 0xffffff7f81286000 0x3000 0x3000 com.apple.iokit.IOUSBUserClient (4.5.3) <33 7 5 4 3 1>

43 0 0xffffff7f81342000 0x11000 0x11000 com.apple.driver.AppleUSBHub (4.5.0) <33 5 4 3 1>

44 0 0xffffff7f818e6000 0x9000 0x9000 com.apple.BootCache (33) <7 6 5 4 3 1>

45 0 0xffffff7f81e79000 0x5000 0x5000 com.apple.AppleFSCompression.AppleFSCompressionTypeZlib (1.0.0d1) <6 4 3 2 1>

46 0 0xffffff7f81e80000 0x5000 0x5000 com.apple.AppleFSCompression.AppleFSCompressionTypeDataless (1.0.0d1) <7 6 4 3 2 1>

47 0 0xffffff7f81671000 0x15000 0x15000 com.apple.iokit.IOAHCIBlockStorage (2.0.1) <36 13 5 4 3 1>

48 3 0xffffff7f807c0000 0x2b000 0x2b000 com.apple.iokit.IOSCSIArchitectureModelFamily (3.0.1) <5 4 3 1>

49 0 0xffffff7f81665000 0xc000 0xc000 com.apple.iokit.IOAHCISerialATAPI (2.0.1) <48 36 5 4 3 1>

50 0 0xffffff7f81949000 0x4000 0x4000 com.apple.driver.XsanFilter (403) <13 5 4 3 1>

51 0 0xffffff7f81466000 0x7000 0x7000 com.apple.iokit.SCSITaskUserClient (3.0.1) <48 13 5 4 3 1>

52 3 0xffffff7f8146f000 0xd000 0xd000 com.apple.iokit.IOCDStorageFamily (1.7) <13 5 4 3 1>

53 2 0xffffff7f8147c000 0xb000 0xb000 com.apple.iokit.IODVDStorageFamily (1.7) <52 13 5 4 3 1>

54 1 0xffffff7f81487000 0xa000 0xa000 com.apple.iokit.IOBDStorageFamily (1.6) <53 52 13 5 4 3 1>

55 0 0xffffff7f81491000 0x1a000 0x1a000 com.apple.iokit.IOSCSIMultimediaCommandsDevice (3.0.1) <54 53 52 48 13 5 4 3 1>

56 0 0xffffff7f81308000 0x6000 0x6000 com.apple.driver.AppleUSBComposite (3.9.0) <33 4 3 1>

57 2 0xffffff7f81555000 0x75000 0x75000 com.apple.iokit.IOBluetoothFamily (4.0.1f4) <7 5 4 3 1>

58 0 0xffffff7f815ea000 0xe000 0xe000 com.apple.driver.AppleUSBBluetoothHCIController (4.0.1f4) <57 33 7 5 4 3>

61 0 0xffffff7f808ea000 0x6000 0x6000 com.superhai.driver.VoodooBattery (1.3.3) <8 5 4 3>

62 14 0xffffff7f80a69000 0x38000 0x38000 com.apple.iokit.IOGraphicsFamily (2.3.2) <9 7 5 4 3>

63 0 0xffffff7f81aff000 0x3a000 0x3a000 com.apple.driver.AppleIntelSNBGraphicsFB (7.1.2) <62 9 8 7 6 5 4 3 1>

64 9 0xffffff7f80aa1000 0x12000 0x12000 com.apple.iokit.IONDRVSupport (2.3.2) <62 9 7 5 4 3>

65 2 0xffffff7f80ab3000 0x2da000 0x2da000 com.apple.NVDAResman (7.1.2) <64 62 9 5 4 3 1>

66 0 0xffffff7f80d8d000 0x4d4000 0x4d4000 com.apple.nvidia.nvGF100hal (7.1.2) <65 4 3>

67 0 0xffffff7f81757000 0xc0000 0xc0000 com.apple.GeForce (7.1.2) <65 64 62 9 7 6 5 4 3 1>

68 0 0xffffff7f813a2000 0x3000 0x3000 com.apple.driver.AppleUSBCDC (4.1.15) <33 4 3>

69 1 0xffffff7f81e4c000 0x3000 0x3000 com.apple.driver.AppleBacklightExpert (1.0.3) <64 62 9 5 4 3>

70 0 0xffffff7f81ea1000 0x5000 0x5000 com.apple.driver.AppleBacklight (170.1.9) <69 64 62 9 5 4 3>

71 1 0xffffff7f81e3a000 0x3000 0x3000 com.apple.driver.AppleGraphicsControl (3.0.16) <64 62 9 8 7 5 4 3 1>

73 0 0xffffff7f81af8000 0x3000 0x3000 com.apple.driver.AppleLPC (1.5.3) <9 5 4 3>

75 1 0xffffff7f814ab000 0x13000 0x13000 com.apple.driver.IOPlatformPluginFamily (4.7.5d4) <8 7 6 5 4 3>

76 2 0xffffff7f814be000 0xc000 0xc000 com.apple.driver.AppleSMC (3.1.1d8) <8 7 5 4 3>

77 0 0xffffff7f814ca000 0x11000 0x11000 com.apple.driver.ACPI_SMC_PlatformPlugin (4.7.5d4) <76 75 9 8 7 6 5 4 3>

78 0 0xffffff7f81e3d000 0xf000 0xf000 com.apple.driver.ApplePolicyControl (3.0.16) <71 64 62 9 8 7 5 4 3 1>

79 2 0xffffff7f818f0000 0x6000 0x6000 com.apple.kext.OSvKernDSPLib (1.3) <5 4>

80 3 0xffffff7f818f6000 0x46000 0x46000 com.apple.iokit.IOAudioFamily (1.7.2fc1) <79 5 4 3 1>

81 0 0xffffff7f8193c000 0x4000 0x4000 com.apple.driver.AudioIPCDriver (1.2.1) <80 5 4 3 1>

82 2 0xffffff7f81c8d000 0xc000 0xc000 com.apple.iokit.IOHDAFamily (1.7.9a4) <5 4 3 1>

83 1 0xffffff7f81c9f000 0x18000 0x18000 com.apple.driver.AppleHDAController (1.7.9a4) <82 62 9 5 4 3 1>

84 0 0xffffff7f8184a000 0x5000 0x5000 com.apple.Dont_Steal_Mac_OS_X (7.0.0) <76 7 4 3 1>

87 3 0xffffff7f81381000 0xe000 0xe000 com.apple.iokit.IOSerialFamily (10.0.5) <7 6 5 4 3 1>

88 0 0xffffff7f815dc000 0xe000 0xe000 com.apple.iokit.IOBluetoothSerialManager (4.0.1f4) <87 7 5 4 3 1>

89 0 0xffffff7f81443000 0x12000 0x12000 com.apple.iokit.IOSurface (80.0) <7 5 4 3 1>

90 0 0xffffff7f8126c000 0x6000 0x6000 com.apple.iokit.IOUserEthernet (1.0.0d1) <40 6 5 4 3 1>

91 0 0xffffff7f81268000 0x3000 0x3000 org.mozodojo.IntelThermal (1.0.0d1) <31 7 5 4 3>

92 0 0xffffff7f81b39000 0xe0000 0xe0000 com.apple.driver.AppleIntelHD3000Graphics (7.1.2) <64 62 9 7 5 4 3 1>

93 0 0xffffff7f81ac9000 0xa000 0xa000 com.apple.driver.AppleMCCSControl (1.0.26) <62 9 7 5 4 3 1>

94 0 0xffffff7f81950000 0x5000 0x5000 com.apple.driver.AppleUpstreamUserClient (3.5.9) <62 9 8 7 5 4 3 1>

96 2 0xffffff7f80748000 0x57000 0x57000 com.apple.filesystems.ntfs (3.8) <7 6 5 4 1>

97 0 0xffffff7f81377000 0x3000 0x3000 com.apple.driver.AppleUSBCDCWCM (4.1.15) <33 4 3>

98 1 0xffffff7f81cb7000 0xa5000 0xa5000 com.apple.driver.DspFuncLib (1.7.9a4) <80 79 5 4 3 1>

99 0 0xffffff7f81d5c000 0xb3000 0xb3000 com.apple.driver.AppleHDA (1.7.9a4) <98 83 82 80 64 62 5 4 3 1>

100 1 0xffffff7f808d3000 0x5000 0x5000 com.apple.kext.triggers (1.0) <7 6 5 4 3 1>

101 0 0xffffff7f808d8000 0x9000 0x9000 com.apple.filesystems.autofs (3.0) <100 7 6 5 4 3 1>

103 0 0xffffff7f8139e000 0x4000 0x4000 com.apple.driver.AppleUSBCDCACMControl (4.1.15) <33 4 3>

105 0 0xffffff7f81395000 0x7000 0x7000 com.apple.driver.AppleUSBCDCACMData (4.1.15) <87 33 5 4 3>

107 0 0xffffff7f8138f000 0x6000 0x6000 com.apple.driver.AppleUSBCDCDMM (4.1.15) <87 33 4 3>

109 0 0xffffff7f81e2b000 0xb000 0xb000 com.apple.driver.AGPM (100.12.42) <64 62 9 5 4 3>

111 0 0xffffff7f81c6d000 0x5000 0x5000 com.apple.driver.AppleHWSensor (1.9.4d0) <5 4 3>

112 0 0xffffff7f815ca000 0x12000 0x12000 com.apple.driver.IOBluetoothHIDDriver (4.0.1f4) <57 29 5 4 3>

Link to comment
Share on other sites

Hello, I noticed the other thread got deleted. And yes I posted this thread before the other one was posted.. It's an older version so I'll have to update it.

Edit: Updated


Have you run [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] yet? Make sure you select everything that was posted in the guide. I should reinstall the PS2 drivers and chimera should fix compatibility issues


For specifics your missing:

org.voodoo.driver.PS2Keyboard (1.1.0)

com.Apple.driver.PS2Trackpad (1.1.0)

hence the reason you dont have keyboard or trackpad support


The discussion contiunes here for development in perfecting the system

Link to comment
Share on other sites

Hi - yes, I did install [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]. In the description of 'PS/2 Keyboard/Mice' [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] says it installs AppleACPIPS2Nub.kext and ApplePS2Controller.kext, which are installed according to the kextstat so that part worked, but they aren't the 2 missing ones you've highlighted above. Since I am using the latest version (4.1) it seems to have replaced the voodoo kexts with these new ones. Is this a bug on these kexts or something else? Anyhow, I tried installing the 2 kexts above using [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] 4.0.3 but I am clearly making a noob error as they don't seem to load just by selecting the voodoo kext choices in the menu.


The keyboard and trackpad stopped working on step 13, I think.


System is L502X, i7 2630QM, NVidia 540M, 8GB DDR3 and 240GB OCZ Vertex 3 max iops SSD.


>>UPDATE: installed the voodoo kexts from the L701X forum and now internal keyboard+trackpad works. Maybe you should include this in your pack.

Link to comment
Share on other sites

Ok for XPS_ALC665.kext, since it is a system file, I presume I have to change the ownership to edit the plist. Is there a link to how to do this step by step please?


Have to say thank you for this guide - am fairly happy with the results. I needed to use Xcode and already had a decent platform, so didn't really see the need to buy the overpriced hardware all over again and get the fancy logo.

Link to comment
Share on other sites

voodoo kexts aren't needed. But glad you got it working


And for the kext: yes you have to add permission to edit the kext. But what I'd do is go to show contents, navigate to the info.plist. delete the info.plist and authenticate yourself. Then copy the info.plist I had in the pack and authenticate yourself. Rebuild kext cache and permissions and reboot

Link to comment
Share on other sites

  • 4 weeks later...

Thank you very much for this guide AKennedy_4,

I still got a question: How do you get the sound working?! I tried every kext and the thing with the "plist" but no sound :(.


My System:

Dell XPS 15 L502x

Intel i7-2670qm


8GB Ram

NVIDIA GeForce GT 540m


Maybe you can guess why my xps is very slow after the combo update .... did this happen with your ones too?

Link to comment
Share on other sites

Thank you very much for this guide AKennedy_4,

I still got a question: How do you get the sound working?! I tried every kext and the thing with the "plist" but no sound :(.


After installing one of the provided sound-kexts from the pack, go to system preferences-sound and set the output to the internal speakers. Now restart.

Both kexts worked for me, i just had to set the output to the correct entry in system preferences.

Link to comment
Share on other sites

After installing one of the provided sound-kexts from the pack, go to system preferences-sound and set the output to the internal speakers. Now restart.

Both kexts worked for me, i just had to set the output to the correct entry in system preferences.


thank you for your answer bastisk8,

but I can't even see an audio interface in the system preferences, they're just not given.

Link to comment
Share on other sites

Click the sound icon in the status bar and check that the sound is not greyed out. If it is, then you installed the kext wrong. Reinstall the kext and update chimera to 1.7 from tonymac as this is known to fix some things (at least for me)

Link to comment
Share on other sites

doesn't work... but the universal sound drivers given by tonymac work so that's no problem anymore.

But there is another thing: I don't need the dsdt.aml for the hd graphics, the screen is just fine; but when I use it (I've got the normal HD screen) my screen is divided in 4 parts! (They act the same somehow)

After a time I've recognized that the screen has got some "graphic bugs" without the dsdt.aml. It looks a bit like in a cinema where are those stripes in the back but they keep in the screen. Most of the time they stick around a program like little squares in the colours: pink or neon green.

And like I already mentioned the XPS is damn slow after the update... by example: I click on safari > the icon jumps > sticks in the air > I wait for like 10 seconds (sometimes) > the icon gets to the floor > the program opens.



The VooDoo Audio Drivers are absolutely great, even the HDMI sound works ... fantastic



Finally the sound is working perfectly, what I did was installing the VooDoo Audio Drivers, then theones given by AKennedy_4 and then the info.plist optimizing thing. Maybe you can add this to your tutorial.

Link to comment
Share on other sites



I tried it so many times to get Lion working with iAtkos on my XPS 15 but I always fail.

I never get the system starting up without a CD/DVD.


I tell you how I'm doint it:


1. Install iAtkos L1 through a DVD and the -v GraphicsEnabler=no busratio=22 (in my case) cpus=1

2. Then I format the whole disk (750gb) with usual Journaled format, because I erased Windows before. I chose the right customization and install it.

3. After the installation I boot with rBoot and the same arguments

4. Then I continue with the L502X zip file, run kext Wizard to install the kexts in the "Kexts" folder. It doesn't matter if I install the Diox's files or not, I don't see changes. Which files are really necessary to install from his package?

5. Now I continue with step 11, 12 but what do you mean with step 13) Reboot OS X. It should boot normally now with the CD or any arguments?

Do you mean that it should boot without the CD and without the arguments?


When I go through all points I can still only start with the DVD (which takes always long). But system doesn't work good.

For example if I put in a simple USB stick it crashes with a lot of panic text.


What am I doing wrong? Can somebody help?


Thnx in advance!

Link to comment
Share on other sites

Owen: post your specs


You should be installing all the kext in my pack or check the corresponding kext in DoiX's Package. If they install correctly, and you install chimera 1.7,the system should boot flawlessly.


Make sure your installing the kext into S/L/E using Kext Wizard (If your using my kext folder). Run Kext utility and disk utility after words.

Link to comment
Share on other sites

My Specs are:



XPS 502x : 2nd generation Intel Core i7-2670QM processor 2.20 GHz with Turbo Boost up to 3.10 GHz 1 SR

N11X5M06 1 SR

Display : 15.6" HD WLED True-Life (1366x768) with 2.0 Mega Pixel Integrated Camera 1 SR

LCD Back Cover : Metalloid Aluminum (WLAN) L501X 1 SR

Resource DVD : XPS L502x Diagnostics and Drivers 1 SR

Ship Accessory : German Docs 1 SR

RAM : 8.192MB (2x4.096) 1.333MHz DDR3 Dual Channel 1 SR

HDD : 750GB Serial ATA (7.200 1/min) 1 SR

Optical Drive : 8x DVD+/-RW Optical Drive 1 SR

Battery : 9 cell 90Wh LI-ION 1 SR

Graphics : 2GB NVIDIA GeForce GT 540M Graphics card 1 SR

Wireless : European Intel Centrino Wireless-N 1000 1 SR

Keyboard : Internal US/International Qwerty Keyboard 1 SR


When I boot without the DVD after the whole installation procedure I get this: 'Operation System not found'.


Maybe there is something wrong with the partiotion? I'm just using one, the whole drive for OS X.


So I should your kext package OR the one from Diox? I did it last time, used yours, sound works and graphics too, but the system doesn't boot itself, I have to boot with the dvd.


What can it be?

Link to comment
Share on other sites

Hmm.. The error message sounds like it says "operating system no found" not "operation"


If that's the case, its simply a bootloader issue. simply boot with the rbootle cd and reinstall chimera boot loader.


As for the kext issue. You can use either. Personally, I've used the pack to manually install as I've only had one succesful attempt at using DoiX's package to install the kext. Usually they installed incorrectly and I couldn't boot without the cd. But that's just personal experience. It may be different for you.

Link to comment
Share on other sites

Exactly, I mean ' Operation System not found'.


I've installed the Chimera Bootloader through [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] again but still cannot boot in it.

What can it be? Am I doing something wrong with the kexts? Btw. I cannot chose the Mac drive anymore if I try to install them through the Kext Wizard. Only Item 1 and Item 2, whatever it is.



Link to comment
Share on other sites

Unless your English is bad and your saying operation instead of operating, I do not know how to help you. I haven't occurred or found any info on an operation system not found error.


The only thing I can ask is when you turn your computer on. Do you ever reach the chimera boot loader with the ability to select drives? It sounds like your computer isn't picking up yhe chimera boot loader or your booting the wrong device. Make sure your internal hard drive is the first device you boot from in the BIOS

Link to comment
Share on other sites

It really says 'Operation System not found'. But I think that it is a bad german translation, which means that it is saved somewhere in the Bios or something.

It should mean the same as operating system...


I never reach the chimera bootloader without the cd. Maybe theres something wrong with the master boot record?

I have deleted the whole drive in the disk utility and just have one partition.


My hard drive is the first in the boot priority and the computer doesn't pick up chimera.

Are there any other changes that I should do in the Bios?

Link to comment
Share on other sites

Make sure your on A06 Bois (download from Dell).


Hmm heres the easiest way to go. Use Gparted to delete your drive and all partitions so you have a drive with unallocated space. Create a 50 gb partition at the END of your drive for windows 7. Install windows 7 to that partition.( NOTE: if you plan on dual booting you can go ahead and create a data partition at this point. Just make sure Windows 7 is at the end of the drive in case you decide to get rid of it. This way you can easily delete and expand your data partition) Make sure your computer can boot regularly with windows after install


Now install iAtkos L1 to the big partition and after installing all the kext and getting to the point in the guide where you are supposed to be able to reboot normally. Check that the chimera bootloader is working. If not well proceed from there but it should

Link to comment
Share on other sites

I got iAtkos L1 installed on my L502x now (same specs as AKennedy, except 4GB) I have a few questions.


1. How can I fix the startup of windows? Because I have missing BOOTMGR now. Can I just use these commands: BootRec /FixMBR, BootRec /FixBoot and BootRec /RebuildBCD?

Or does this break the boot loader? If so, what can I use to fix this?



2. My audio hardware isn't recognized when I open Audio/MIDI-configuration. It was recognized one time before (don't know if it was this install) but I don't know with which kextx that was or if I used both kexts. Can you use both kexts at the same time or do I need to delete one if I want to try the other one? And were do I need to delete the kexts? Here? /System/Library/Extensions


3. I have the idea my Kext Wizzard isn't working properly anymore. In the beginning it selected automaticly my OS X target disk. But now it say Choose and I can only choose between Choose / Item 2 / Item 3. How does this come? I downloaded it again from the forum topic of (http://www.insanelym...howtopic=253395 newer?) and it works again!


Thnx for the great TUT!


EDIT: All is working great except the dual boot with windows. I can't get Windows 7 to boot up. I tried the three commands listed above but that doesn't solve the problem. I also tried the automatic startup repair with windows 7 but also that doesn't fix the boot. And I tried the following commands what also doesn't work for me:

bcdedit /export C:\BCD_Backup


cd boot

attrib bcd -s -h -r

ren c:\boot\bcd bcd.old

bootrec /RebuildBcd


What can I do to make it work? I need my windows too.. :(

Link to comment
Share on other sites

Owen, when you need to install the kext, try the package from DoiX first. Youll Probably get an error saying the kext were improberly installed, but just run kext utility an Disk utility and reboot like normal. I'll update the guide sometime later this week when I get a chance. Good luck on installing

Link to comment
Share on other sites

1. How can I fix the startup of windows? Because I have missing BOOTMGR now. Can I just use these commands: BootRec /FixMBR, BootRec


2. My audio hardware isn't recognized when I open Audio/MIDI-configuration. It was recognized one time before (don't know if it was this install) but I don't know with which kextx that was or if I used both kexts. Can you use both kexts at the same time or do I need to delete one if I want to try the other one? And were do I need to delete the kexts? Here? /System/Library/Extensions


3. I have the idea my Kext Wizzard isn't working properly anymore. In the beginning it selected automaticly my OS X target disk. But now it say Choose and I can only choose between Choose / Item 2 / Item 3. How does this come? I downloaded it again from the forum topic of (http://www.insanelym...howtopic=253395 newer?) and it works again!


Thnx for the great TUT!


EDIT: All is working great except the dual boot with windows. I can't get Windows 7 to boot up. I tried the three commands listed above but that doesn't solve the problem. I also tried the automatic startup repair with windows 7 but also that doesn't fix the boot. And I tried the following commands what also doesn't work for me:



What can I do to make it work? I need my windows too.. :(

I had the EXACT SAME PROBLEMS except 2nd one, Solved the 1st problem, 3rd one skipped as I used drop kext software

1st time I tried on my system, the boot loader didnt work, rest all worked. So I decided to format everything and start from scratch.

1.Install win7 drivers etc.

2.Install Mac follow the guide

and magically the bootloader works without a hickup!

Anyway Back to the topic, I made the win 7 partition active http://www.tonymacx8...1&view=previous

Then when I tried to boot same error as yours, so I tried to select the 100MB System partition and Vola it booted into Win7

I tried all 701, 502 kexts and none of them give me sound, finally decided to use voodoohda and it works but sound is little distorted and there is a hissing noise, goes off when I mute the speakers. Also my sleep isnt working, it goes into sleep loop, sleeps for 1 sec->wakes up->sleeps for 1 sec and this goes on. Bluetooth seems to be not working, says module isnt present

Anyway keep up the great work guys! Finally I have a WORKING DUAL boot L502x

Thanks DoiX and AKennedy_4 WONDERFUL WORK!! :)

p.s where do I buy you a beer? :P

Link to comment
Share on other sites

Underage my friend :)


But that works because that's where windows 7 stores the boot loader. If you have maxed out the number of primary partitions (4 with MBR partition table) the win installer will install the boot loader to the win 7 partition itself. Not to a separate system partition.

But anyways, cheers to finding a solution


Also sleep wont work on a07 bios. Only on a06


And make sure you have speedstep installed or sleep won't work without the sleep enabler kext


Also, the audio kext should work. Make sure your updated to the latest chimera (Don't know why but this did effect me at some point), and make sure you select internal speakers in the sound in systems preferences.

Link to comment
Share on other sites


  • Create New...