Jump to content

VoodooHDA - common problems


oldnapalm
 Share

179 posts in this topic

Recommended Posts

This is a really noob question but how do you install the latest voodooHDA kext (2.8.2d6 by Zenith432) and VoodooHDA.prefPane ?

 

I am used to dropping a kext on Kexthelper which rebuilds the cache and permissions. Do I do the same for this kext and if so what about VoodooHDA.prefPane and VoodooHDASettings Loader, where should they be installed/copied.

I had to delete VoodooHDA.kext as I got kernel panics on every boot. Removing AppleHDA.kext also made no difference but although I can now boot OK I have no sound without a driver.

Fozzie

Link to comment
Share on other sites

This is a really noob question but how do you install the latest voodooHDA kext (2.8.2d6 by Zenith432) and VoodooHDA.prefPane ?

 

I am used to dropping a kext on Kexthelper which rebuilds the cache and permissions. Do I do the same for this kext and if so what about VoodooHDA.prefPane and VoodooHDASettings Loader, where should they be installed/copied.

I had to delete VoodooHDA.kext as I got kernel panics on every boot. Removing AppleHDA.kext also made no difference but although I can now boot OK I have no sound without a driver.

Fozzie

 

The latest VoodooHDA is 2.8.4. I wouldn't even recommend 2.8.2

 

2.8.0 is the last best release. 2.8.2+ has some major quality issues.

 

To download it, seek "Easy VoodooHDA 2.8.0 installer 1.0". This package installs a HDADisabler so you don't have to worry about deleting AppleHDA. Plus, it also installs Voodoo prefpane

Link to comment
Share on other sites

Hy there,

I have a p5b-plus vista edition motherboard the audio codec is AD 1988

I have installed voodoohda but i have no sound, i try the folliwn aproch without success

<key>IOPCIClassMatch</key>
<string>0x04030000&0xffff0000</string>
<key>IOPCIPrimaryMatch</key>
<string>0x284b8086</string>
i don't have sound and none kernel error/warning

 

if i only put

<key>IOPCIPrimaryMatch</key>
<string>0x284b8086</string>
 

i get no sound and the follwing errors

Loading VoodooHDA 0.2.1 (based on hdac version 20090401_0132)
Controller: Intel 82801H (vendor ID: 8086, device ID: 284b)
error: unable to put controller in reset
error: resetController failed
error: unable to put controller in reset
warning: resetController failed
Any suggestion?
Link to comment
Share on other sites

Hi!

 

I have crackling sound on Maveric. I'm using the same 2.8.4 driver wich I used for OSX 10.8.4. Sound was fine on 10.8.4, But no anymore with Maverick. At the beginning sound si fine, but after short usage it become weird, cracks, distrupted. When I change from Audio Midi Setup utility the sample rate to anothe, sound becomes normal again. But only for short period and then sound is again crackled and distrupted. 

 

Any suggestions. Have tried all suggestion given on first post of this thread. Nothing seems to help.



Could you elaborate on that. System clock....effect? That's the issue I'm having. The only version working for me is 2.8.2. Sound starts out perfect but after a few minutes static, crackle, distortion, sets in until it totally looses the sound, left with popping distorted bits of sound. Also on booting speaker give off a pop. Going to midi setup and changing frequency fixes it but only temporarily after a few minutes same thing. Can't figure it out. Force HPET did not work for me.

I have the same issue on Maverick. The same ddriver worked fine on OSX 10.8.4. Uneable to figure out what happens.

Link to comment
Share on other sites

  • 3 weeks later...

 

No sound after sleep.

Tried unloading VoodooHDA before sleep and loading after. No luck.

In dmesg after sleep:

Controller: Intel Panther Point (vendor ID: 8086, device ID: 1e20)
error: numPcmDevices is zero

 

What is your SMBios set to?

Link to comment
Share on other sites

Patched AppleHDA for VT1802. Get sound working, but same issue.

I think audio controller doesn't wakeup (according to numPcmDevices is zero)

Can someone take a look on my dsdt

What version of VoodooHDA did you use?

Sleep issue resolved from version 2.5 and above.

 

 

Hy there,

I have a p5b-plus vista edition motherboard the audio codec is AD 1988

I have installed voodoohda but i have no sound, i try the folliwn aproch without success

<key>IOPCIClassMatch</key>
<string>0x04030000&0xffff0000</string>
<key>IOPCIPrimaryMatch</key>
<string>0x284b8086</string>
i don't have sound and none kernel error/warning

 

if i only put

<key>IOPCIPrimaryMatch</key>
<string>0x284b8086</string>
 

i get no sound and the follwing errors

Loading VoodooHDA 0.2.1 (based on hdac version 20090401_0132)
Controller: Intel 82801H (vendor ID: 8086, device ID: 284b)
error: unable to put controller in reset
error: resetController failed
error: unable to put controller in reset
warning: resetController failed
Any suggestion?

 

Change VoodooHDA version from your 0.2.1 to actual 2.8.4.

Link to comment
Share on other sites

  • 2 weeks later...

VoodooHDA 2.8.4

 

After sleep i have sound from connected headphones.

But there is no sound from internal speakers and internal mic doesn't work.

Make voodoohda dump before sleep and after to see what is changed.

Link to comment
Share on other sites

  • 1 month later...

Hello to all,

 

first of all I want to say thank for this topic ! this is awesome explanation in the world for sound driver :)

 

I want to ask, my sound is cracking in the application or youtube page. and I check the voodoo panel "use SSE2"

 

and this is the solved my problem. But If I reboot device. It will uncheck automatically. How can I solve this problem ?

 

I going to share with you my plist file;

 

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>BuildMachineOSBuild</key>
<string>11A511</string>
<key>CFBundleDevelopmentRegion</key>
<string>English</string>
<key>CFBundleExecutable</key>
<string>VoodooHDA</string>
<key>CFBundleIdentifier</key>
<string>org.voodoo.driver.VoodooHDA</string>
<key>CFBundleInfoDictionaryVersion</key>
<string>6.0</string>
<key>CFBundleName</key>
<string>VoodooHDA</string>
<key>CFBundlePackageType</key>
<string>KEXT</string>
<key>CFBundleShortVersionString</key>
<string>2.7.3</string>
<key>CFBundleSignature</key>
<string>????</string>
<key>CFBundleVersion</key>
<string>2.7.3</string>
<key>DTCompiler</key>
<string>4.2</string>
<key>DTPlatformBuild</key>
<string>4B110</string>
<key>DTPlatformVersion</key>
<string>GM</string>
<key>DTSDKBuild</key>
<string>10J567</string>
<key>DTSDKName</key>
<string>macosx10.6</string>
<key>DTXcode</key>
<string>0410</string>
<key>DTXcodeBuild</key>
<string>4B110</string>
<key>IOKitPersonalities</key>
<dict>
<key>VoodooHDA</key>
<dict>
<key>CFBundleIdentifier</key>
<string>org.voodoo.driver.VoodooHDA</string>
<key>IOClass</key>
<string>VoodooHDADevice</string>
<key>IOMatchCategory</key>
<string>VoodooHDADevice</string>
<key>IOPCIPrimaryMatch</key>
<string>0x293e8086</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>IOUserClientClass</key>
<string>VoodooHDAUserClient</string>
<key>InhibitCache</key>
<true/>
<key>MixerValues</key>
<dict>
<key>iGain</key>
<string>90</string>
<key>iMix</key>
<string>0</string>
</dict>
<key>NodesToPatch</key>
<array/>
<key>Noise</key>
<integer>2</integer>
<key>Vectorize</key>
<false/>
<key>VoodooHDAEnableHalfMicVolumeFix</key>
<false/>
<key>VoodooHDAEnableHalfVolumeFix</key>
<false/>
<key>VoodooHDAEnableMuteFix</key>
<false/>
<key>VoodooHDAEnableVolumeChangeFix</key>
<false/>
<key>VoodooHDAVerboseLevel</key>
<integer>0</integer>
</dict>
</dict>
<key>OSBundleLibraries</key>
<dict>
<key>com.apple.iokit.IOAudioFamily</key>
<string>1.1fc9</string>
<key>com.apple.iokit.IOPCIFamily</key>
<string>2.1</string>
<key>com.apple.kpi.iokit</key>
<string>9.0.0</string>
<key>com.apple.kpi.libkern</key>
<string>9.0.0</string>
<key>com.apple.kpi.mach</key>
<string>9.0.0</string>
<key>com.apple.kpi.unsupported</key>
<string>9.0.0</string>
</dict>
</dict>
</plist>
Link to comment
Share on other sites

 

Hello to all,

 

first of all I want to say thank for this topic ! this is awesome explanation in the world for sound driver :)

 

I want to ask, my sound is cracking in the application or youtube page. and I check the voodoo panel "use SSE2"

 

and this is the solved my problem. But If I reboot device. It will uncheck automatically. How can I solve this problem ?

 

I going to share with you my plist file;

 

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>BuildMachineOSBuild</key>
<string>11A511</string>
<key>CFBundleDevelopmentRegion</key>
<string>English</string>
<key>CFBundleExecutable</key>
<string>VoodooHDA</string>
<key>CFBundleIdentifier</key>
<string>org.voodoo.driver.VoodooHDA</string>
<key>CFBundleInfoDictionaryVersion</key>
<string>6.0</string>
<key>CFBundleName</key>
<string>VoodooHDA</string>
<key>CFBundlePackageType</key>
<string>KEXT</string>
<key>CFBundleShortVersionString</key>
<string>2.7.3</string>
<key>CFBundleSignature</key>
<string>????</string>
<key>CFBundleVersion</key>
<string>2.7.3</string>
<key>DTCompiler</key>
<string>4.2</string>
<key>DTPlatformBuild</key>
<string>4B110</string>
<key>DTPlatformVersion</key>
<string>GM</string>
<key>DTSDKBuild</key>
<string>10J567</string>
<key>DTSDKName</key>
<string>macosx10.6</string>
<key>DTXcode</key>
<string>0410</string>
<key>DTXcodeBuild</key>
<string>4B110</string>
<key>IOKitPersonalities</key>
<dict>
<key>VoodooHDA</key>
<dict>
<key>CFBundleIdentifier</key>
<string>org.voodoo.driver.VoodooHDA</string>
<key>IOClass</key>
<string>VoodooHDADevice</string>
<key>IOMatchCategory</key>
<string>VoodooHDADevice</string>
<key>IOPCIPrimaryMatch</key>
<string>0x293e8086</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>IOUserClientClass</key>
<string>VoodooHDAUserClient</string>
<key>InhibitCache</key>
<true/>
<key>MixerValues</key>
<dict>
<key>iGain</key>
<string>90</string>
<key>iMix</key>
<string>0</string>
</dict>
<key>NodesToPatch</key>
<array/>
<key>Noise</key>
<integer>2</integer>
<key>Vectorize</key>
<false/>
<key>VoodooHDAEnableHalfMicVolumeFix</key>
<false/>
<key>VoodooHDAEnableHalfVolumeFix</key>
<false/>
<key>VoodooHDAEnableMuteFix</key>
<false/>
<key>VoodooHDAEnableVolumeChangeFix</key>
<false/>
<key>VoodooHDAVerboseLevel</key>
<integer>0</integer>
</dict>
</dict>
<key>OSBundleLibraries</key>
<dict>
<key>com.apple.iokit.IOAudioFamily</key>
<string>1.1fc9</string>
<key>com.apple.iokit.IOPCIFamily</key>
<string>2.1</string>
<key>com.apple.kpi.iokit</key>
<string>9.0.0</string>
<key>com.apple.kpi.libkern</key>
<string>9.0.0</string>
<key>com.apple.kpi.mach</key>
<string>9.0.0</string>
<key>com.apple.kpi.unsupported</key>
<string>9.0.0</string>
</dict>
</dict>
</plist>

 

 

 

is there anybody to help me ?

Link to comment
Share on other sites

  • 5 weeks later...
Hello, I managed to configure VoodooHDA 2.8.4, operate all the doors except the ine-in but never use it, I have a problem when I use the microphone, it happens that you hear a loud noise, the noise was continuous before and I deleted the two files "com.apple.audio.DeviceSettings.plist" and "com.apple.audio.SystemSettings.plist." 

I also noticed that the microphone is connected that is on front or on rear is always active, for example if I set the audio settings as an input jack on the rear and connect the microphone on the front works the same even if it should not. 

add getdump and the info.plist file.

Link to comment
Share on other sites

im having an issue where audio starts out perfectly fine then gradually starts delaying and getting distorted to the point where it's muted. any ideas on a fix? been looking around everywhere and other people have the problem but haven't gotten a fix yet

Link to comment
Share on other sites

im having an issue where audio starts out perfectly fine then gradually starts delaying and getting distorted to the point where it's muted. any ideas on a fix? been looking around everywhere and other people have the problem but haven't gotten a fix yet

 

any  ideas on how to fix? ive been trying to do this for awhile now lol.

 

i also saw other people ITT were having the same problem but didnt get it fixed.

Link to comment
Share on other sites

  • 4 weeks later...

Strange thing happens to my audio. :(

 

On my Qosmio X70 I have a Conexant cx20755 sound board. I have tested all the VoodooHDA but the only one that seem to work is version 2.8.4.

 

The strange thing is that sound works for 5 seconds, let say, from the speakers and then shut down. To have the sound back I have to switch to the headphones and than the sound works correctly for other 5 seconds and then shut down. If I then select the speakers again the sound get back but only for this bloody 5 seconds and so on.

 

What could be the reason? Any one other faced this problem?

Link to comment
Share on other sites

  • 3 months later...

Hi

I have installed voodoohda 2.8.5 in my system with IDT audio card.

Everything works good except for a non perfect sync in video playback (vlc,quicktime)

The audio is out of about 0.2 seconds, not so much but this annoy me.

How can I get rid of this situation ?

Link to comment
Share on other sites

 Share

×
×
  • Create New...