Jump to content

[Guide] GA-EP45-UD3 retail install guide!

Gigabyte Boards  

441 members have voted

  1. 1. Do you own a Gigabyte board(s)???

    • Yes
    • No
  2. 2. Is it a EP45, EP45C or EP45T board?

    • Yes
    • No
  3. 3. What are you using it for/ how did you install???

    • I use Windows or linux of some description
    • I use Mac OS 10.5 (Leopard) or 10.4 (Tiger)
    • I installed OSX using a distro... (iPC, iAtkos, Kalyway etc)
    • I installed a retail setup. (Guide below or other guide) (or made it up as I went along)
    • I am still installing

172 posts in this topic

Recommended Posts





Updated 5th September with Pack V2.5, includes better AppleVIAATA.kext and JMicronATA.kext for a much more stable system for many boards. In the optional kexts folder... Affects UD3, UD3P, UD3R and possibly others(just not tested on others as i don't own them all).


Also changed file structure of the folders... other applications and such are now in Utilities...


Updated 6th July to include BootThink guide and steps involved. Can be used over the top of other bootloaders, but optimum result is over a completely vanilla system.


Updated 15th May to include 10.5.7 update...

If just upgrading, see bottom of guide.





This is a guide to installing a retail copy of leopard, onto a computer with a GA-EP45-UD3 motherboard or (presumably) similar gigabyte board. e.g. EP45-UD3L, UD3LR, UD3R etc. The method can be used, with some changes, for other boards!




I have noticed how few proper guides there are for my motherboard for people lacking knowledge etc... There is only one other thread (that I can find) which deals with the install/post install process, and that guide was brief. So I decided to share the "experience" with everyone else. Other people around 'here' have said this board is a nightmare, but it was really easy for me. This is because everyone's hardware is different, and therefore, will react differently to the install process...


Note: Since this guide was written, Weaksauce wrote a specific UD3P guide available elsewhere, and a few others are also available...


This guide will give instructions to install a retail 10.5 disk then update to 10.5.7 and then make it bootable and perfect *perfect setup required*. The install is also updateable from apple!




What you need!


A GA-EP45-UD3 or variant motherboard, this method works also on very well on the GA-EP45-UD3L , GA-EP45-UD3LR and GA-EP45-UD3P boards. The following motherboards are the variant boards, and should also work...


GA-EP45-UD3 (works well and tested, I own one and can support you)






GA-EP45-DS4 (works well, others got it working and has kext pack in Uinstaller)




GA-EP45-DS3R (works well, others got working)

GA-EP45-DS3 (works well, others got this working and there is an optional pack in UInstaller)



GA-EP45-DS3L (works well, others got this working)


GA-EP45-UD3P (works well, I own one and can support you)

GA-EP45-UD3R (works well, I own one and can support you)








A intel dual core processor (or better) is strongly recommended! I don't know about AMD and single core processors are a pain to get working. If you don't have one, then you would need to try something like the Munky Method... Available elsewhere or use a common run of the mill distro.


A retail leopard disk like a 10.5 or 10.5.6 retail disk or box set. I don't think 10.5.7 or 10.5.8ones are out yet, if ever)... I recommend buying it!


The Apple 10.5.7 combo update (kinda optional, if you don't want to download it or want a older version of leopard) if the retail disk is not a 10.5.7 disk. OR the 10.5.8 delta from 10.5.7 or combo from fresh install


This can be downloaded either through software update in mac, or with link below. I recommend downloading it with link, as it allows you to keep the file if the mac dies, saving another 730MB download.




10.5.8 can be used, but still has some little issues with sleep, bluetooth and seems sluggish on the UD3 that i tested it on...



Files you Need.... My EP45-UD3 package which contains most necessary kexts and optional kexts. AND INSTALLERS, the supplied kexts may vary for board, but this few will be the bare basic.


Everything is available at my FTP in a nice zip file currently weighing in a 18MB.


File Pack


The optional BootThink Bootloader and guide i Have written are up there also. weighing in a 12MB.

see link below for guide.






My Boot 123 iso (found in pack with kexts), which is required to boot the retail disk and contains the following:







and some others... but that was there for the curious people...



Note 1: This may not work for you! You may need to add to this. eg, If you need a PS2 kext for a laptop keyboard, then put one in etc...The same applies to video etc,


Note 2:This type of CD is now slightly outdated due to Charmelon 2's new method. I have not tried this and if anyone gets an iso working, please submit it so we can improve the guide. That said, it still gets the job done. I have tried about 5 revisions, each getting a Cannot Find Mach Kernel Error... I have since given up on that, as Snow Leopard is out...



The Guide


1. Booted off the supplied boot-132 disk. When prompted, removed the disk and inserted the install disk.


2. With an internal IDE (200GB) ready to use I formatted it in HSF+ Journaled. Sata Drives are supported of course, but the ability to use ATA drives is still there. I found that most Boot-123 disks did not contain this ability!


3. Install OS X. Note: Near the end of the install, it will fail. This is normal, just force reboot to the boot 123 CD, but when prompted, type the dive number eg 81.


4. OS X booted normally, though"bare" with no other kext files or patches and with the ugly default video drivers. To skip the registration process, press cntl+q to quit it.


5. Install the 10.5.7 combo update or 10.5.8 and other updates like the security updates. *OPTIONAL* but recommended.


6. Reboot, still using the CD as before. Note 2: The start-up will appear normal, but take a while, then randomly reboot. Then boot again using the CD as normal. This is due to the update you probably should have applied.


7. You should now be using 10.5.7 or 10.5.8 with the latest updates. Check in System Info for info.


8. Now for the hardish part.


You have several options on which boot-loader to use and how you want them to work. You can install to the harddisk, either with OSX, on its own partition or on a USB (recommended) Keeping the bootloader away from OSX means it is update proof, and keeps the mac drive clean (EFI Method). There is a EFI option available with BootThink and Char 2



Option 1: PCEFI v9, what I used. Basic text interface. PCEFI v10 is also out with support for Snow Leopard which works well on our boards.


Option 2: Charmeleon 1 (the old one) pretty much the same as opt 1...


Option 3: Charmeleon 2. The newest and best in boot-loading and multi-booting. Provides a nice graphical interface that is skinnable, and lets you choose your OS, and can be skinned to appear like bootcamp... (botched my last install, if this happens to you, boot with the CD and install a different bootloader) I recommend that you install it to a flash drive or small 100mb partition. All the below mentioned Kexts go in there, keeping the OSX drive clean.


OR, the newest, latest and (possibly) greatest bootloader, BOOT THINK


BootThink is a new bootloader, looks exactly like the BootCamp on macs, allows nice installation and has better support for multibooting. Best results on a USB flash drive, allowing a complete vanilla system. See my guide below for install... This removes the need to install any kexts or bootloaders to the Mac drive, keeping it clean.




9. Install the desired bootloader (PCEFI with UInstaller provided skip to step 11) (Chameleon 1 and 2 with installer provided ) ( BootThink with pack at link or my FTP )


IF BOOT THINK, SKIP STEPS 10, 11 and 12. Instead, follow link to guide and follow. This guide follows the creation process, installing of Kexts and customisation.


10. (If using PCEFI, SKIP THIS STEP)


If installing the Charmeleon bootloader, double click the icon in the icon and follow the prompts, install in the correct drive! Reboot without the CD! YAY... If that fails, use the CD to boot and try installing again, or a different bootloader.


11. Use UInstaller to install PCEFI v9. IF you do not install Charmeleon as above mentioned.


Reboot without the CD! YAY... If that fails, use the CD to boot and try installing again, or a different bootloader. or make sure the flashdrive bootloader is plugged in and set to 1st boot in the BIOS.


12. Use UInstaller (or EFI Studio) to add EFI Strings for your graphics card, apply the time Machine fix, and all the kexts provided in the "Needed Kexts" folder. If using a EFI partition or USB, don't install the kexts. Set a bootloader timeout and screen res if desired. If there is no string for your Video card or the string dosen't work properly, use NVinject for NVidia Cards and ATInject for ATI cards... You can figure this one out easily by searching.


If using a separated Bootloader, read below:


Char 2: put the kexts into the System/Library/Extensions folder and delete the Extensions.mkext. Done


BootThink: put the kexts into the Darwin/System/Library/Extensions and delete the Extensions.mkext you see along the way.


13. Reboot. When back at the desktop, everything should be working, sound etc. Change the display resolution, and sound settings, if sound is not working, try switching the physcal output (where its plugged in) and the one in Sound in the System Preferences. You aremost likely have problems with small things... See below for possible solutions.


Other Random Problems and Solutions



If you have random numbers or letters in your "About this Mac" menu, use OSX86Tools to change it! If you want more info to be in the system info, then a edited SMBIOS.plist is needed, I have not as yet experimented with this, but I know that Charmeleon 2 can do this automatically. There is a About this mac modifier in pack v2.5 and above.


Kernel Panics (crashes needing a restart)


If you get kernel panics doing things with large files etc like I did for a while then either:


you have a mismatched seatbelt.kext and kernel version and you need to install the seatbelt.kext in the optional kexts folder using kext helper or Uinstaller. Or go to




and obtain the latest version and search there...





You have some wrong/missing kexts...








reboot and test, slowly add more kexts from the Optional Kexts folder rebooting and testing each time.



Time Machine


If time machine is complaining about something like 'backup volume could not be found' then the time machine fix should be reapplied. If that fails, install the IONetworkingFamily.kext. If, for some reason that your hack cannot detect another mac or airport, then installing the Realteak 1000 kext has a good chance of fixing this...




If your sound is not working, as some people have experienced, try the steps at link, or installing the sound kext into the actual Extensions folder if you are/were using Char 2 or bootthink. I will also add the linked 889a kexts in the optional kexts folder.




The above two solutions from Doug the Impaler and others, who managed to experience these sound and lan issues. Thanks for your contribution.


Already Installed 10.5.6 or earlier and want to upgrade to the newest 10.5.7 or 10.5.8??? easy!


Download the update from the Apple Software update or from either the below links:





Combo (10.5.5 or earlier): 730MB





Delta (10.5.6): 442MB




Install, reboot (it will automatically do this again so don't worry) and you should be on the desktop, probably without sound (if not using a EFI Partition method) simple, reinstall the AppleHDA and ALCInject .kexts with something like Kext Helper to the correct location. Reboot... You should have working sound. That's it.


If you can't get into mac, with various issues etc, try booting with one or more of the following (without quotes or the explanation after the term) " -x (safe mode) -s (single user mode ) -f (ignore cached drivers) -v (verbose (outputs errors etc) " or use the great boot123 disk to get in and reinstall the bootloader and kexts! Post success or failure as always!





Thanks for reading/using my guide. If this works for you, post success or failure, and if problems arise, search the forum or hackintosh community with the custom goggle search





Ask for solutions to odd problems, and help the people and report what you did to fix issues!



And (for those with limited bandwidth or who only need smaller installers) the individual files and installers (without the kext packs!)


BOOT-123 CD Found at





Search using google for the other utilities, Uinstaller, EFI Studio, OSX86Tools

Share this post

Link to post
Share on other sites

just received my ep45 ud3r and i can't wait to try it out. I have read that others have used your guide and their systems are running great can't wait to give it a try. ;)

Share this post

Link to post
Share on other sites

ok i will be installing over the weekend i just put it in yesterday to make sure the sound and lan is working ok.




the guide is very easy to follow

:( thanx for the making it for people like me

Share this post

Link to post
Share on other sites

Is there any way you can zip everything up? I'm trying to use cyberduck to get into your ftp and of course it's crapping out on me, and if I click the link I can't use anything like DownloadThemAll because it's some bogus HTML page.

Share this post

Link to post
Share on other sites

Sorry about that... Will change it soon, and link to the actual files... I couldn't find any free hosting that lets me upload entire folders and large files...

Share this post

Link to post
Share on other sites

OK, thanks a bunch. I just received my EP45-UD3L yesterday and was going to follow your guide but I couldn't download anything. :D


Since the plain UD3 and the UD3L have basically the same hardware (the difference being that the UD3 has firewire where the UD3L does not - otheriwse it's all the same. 8111C LAN, ALC889a audio, P45, ICH10), I'm planning on your guide pretty much working with my computer. :rolleyes:


edit: I see that you've got it ZIP'd. Thanks a ton. I'll be trying it this weekend and will update on my success. Thanks for making everything understandable. :D

Share this post

Link to post
Share on other sites

Hey, I'm back. I've had great success. Three issues:


1.) My Radeon 3850 did not get assigned to the right framebuffer so the graphics were garbled. I had to boot everything in safemode until I used EFISTUDIO_EXTENDED to do a 512MB Radeon 3800 Megalodon. After that, this issue is resolved.


2.) No sound. I have all kexts (need and option) in /Extra/Extensions and I can boot up just fine after installing Chameleon v2.0 RC1. I have network and QE/CI and time machine fixed and I ran software update, but still no sound. Any suggestions? ALC889a, same as your board, although you have some sort of Logitech sound system in your sig? Any hints appreciated.


I used a retail DVD from the Mac Box Set, so 10.5.6 was installed out of the box. Software update running now, maybe that'll sort out my audio problem.


edit: nope, still no audio. I'll have to go Linux codec dumping I guess. And after software update I still don't see network stuff automatically.


edit2: The network problem where nothing showing up was fixed by using the RTL1000 driver from sourceforge, installed with Kexthelper. If that breaks with 10.5.7, it's a super-easy fix. I'd recommend adding it to your package.

Share this post

Link to post
Share on other sites

Hi, Great to hear that almost everything worked... I tried using the realteak1000 hda file and this had litle success, also, if you are familiar with UInstaller, you could try downloading the DS4 package or something similar and installing it? I found that is botched my install 2 ot of 5 times, and so resorted to manually installing kexts...


I have a different 899a that also worked though provided a nice pop for the first sound per boot, and i will try to dig it up and attach it...


Also, could you attach the lan kext, I cannot find it. I wonder why your lan didn't work when mine worked from the first boot...


Note: Pack link updated, FTP updated also.

Share this post

Link to post
Share on other sites

The realtek1000 LAN driver has to go in /System/Library/Extensions, for some reason CHameleon 2.0 RC1 doesn't use it if it's in /Extra/Extensions so that might be why you didn't have much success.


Re-downloading the pack for the audio driver. A pop on boot isn't that big of a deal.


That did not help. But here's something amusing...from LSPCI, the only line for audio:


01:00.1 Audio device [0403]: ATI Technologies Inc Radeon HD 3870 Audio device [1002:aa18]


so is it that my mobo has found the HDMI audio built into the 3800 series and therefore disabled the Realtek?

Share this post

Link to post
Share on other sites
The realtek1000 LAN driver has to go in /System/Library/Extensions, for some reason CHameleon 2.0 RC1 doesn't use it if it's in /Extra/Extensions so that might be why you didn't have much success.


I don't get what you mean by that... I don't use Chameleon 2 and I haven't had any problems with Lan (yet)... or do you mean where to find it???


as for the audio, well I guess that's a possibility, my 8600 doesn't have a HDMI without the little supplied connector, so I wouldn't know what would happen with it... I think the best bet would be to find a thread around somewhere, or start one and ask some people. I have absoluteky no experience with ATI cards in Mac...

Share this post

Link to post
Share on other sites

The audio was just not finding the right kexts. These instructions got me going with 2-channel out, 2x mic (rear and front), and headphones - since I have just plain 2-channel stereo speakers, that was sufficient.




The problem with LAN isn't that the internet doesn't work; it works fine. It's that for some reason it was unable to discover my real Mac and my Airport Extreme, and therefore Airport utility didn't work. So I installed that Realtek 1000 kext in /System/Library/Extensions using Kext Helper, and after I rebooted I was discovering items on the network again.


so I don't have a completely vanilla install using Chameleon, but the two things I fixed are easily repaired should they get broken in 10.5.7.


I do want to thank you for the pack you provide, it got the basics going very quickly - in particular the required kexts and the boot ISO. Those were invaluable in terms of time saved.

Share this post

Link to post
Share on other sites

hey guys

i followed everything i have a gigabyte UD3L - UD3R

when i boot and load into mac it comes with this error saying "Sorry Mac OS X cannot be installed on this machine".

any ideas

Share this post

Link to post
Share on other sites

I had that problem when I had more drives connected. Cut it down to the bare minimum, eg, CD/DVD and the install disk... Also, I found that on my other simmilar system, it was fixed by rebooting, and then reformating the HD/partition as (FAT32, then HSF+J) that seemed to work. Also, when installing, make sure you have the right partition type, eg MBR, GUID etc...


More info needed??? Try page 2 of this,




I found it irrelevant, as we are not patching anything at install, or restoring from an image to install to.... but it may help

Share this post

Link to post
Share on other sites

Ok here is my update. I just finished installing retail on my PC using this guide and another guide because that one had pictures and it had some files that i found useful. Anyway all is good, I would have not been able to do this without your boot 132 disc thanks again.


The only thing i had trouble with was the orange icons. Trying to find a fix now.

Share this post

Link to post
Share on other sites

I didn't really bother, as I change them with Candybar anyway, and I find the ejectability usefull... Can you post the other guide you used??? And if you fixed the drive icons, could you link that also...



Share this post

Link to post
Share on other sites

It was when I was using 10.5.6... I haven't tried it since the update, as the comp is either on or off....


EDIT: It came back to everything, then had a kernel panic... Know the solution???

Share this post

Link to post
Share on other sites
I didn't really bother, as I change them with Candybar anyway, and I find the ejectability usefull... Can you post the other guide you used??? And if you fixed the drive icons, could you link that also...




I think i will start using candy bar too. Here is the guide i also used along with your guide but it is for a p35 gigabyte mb which as not that far from the p45 mb. I am also using 10.5.7.


What i did was after mac install i used your boot132 then used chameleon v1 with the kext supplied by the site below it had the same kext you used but had more that seemed to help out alot. His site says you can use software update but i never trust software update rather i download the package and then install the update.




I downloaded a package from pcwiz site to fix the orange icons. The only thing is that it no longer say ichr10 but unknown i read at on the internet that all you have to do is use the legacy ahciblockstorage kext but some reason it did not work for me. The guide above also tell you how to fix that and it worked but you have to do it for each each drive.


here is another cite that talks about orange icons but as i said ich10r becomes shown as unknown.




Thanks again for the great guide as i said before i would have never gotten this far without your boot 132 disc. :)

Share this post

Link to post
Share on other sites

Hi everyone,

I just wanted to report my findings. As i stated before i used this guide and another guide to install retail leopard on my mb. I just installed chameleon rc1 on my machine and i love it. All i did was run the installer selected customize and that was it. The only thing that i noticed was it now reports my memory wrong as ddr2 667 not ddr2 800.


So next i deleted deleted the whole /extra folder(after backing it up) and installed the 3files form the installer customize and it installed the 3 kexts nothing else. After reboot it saw everything correctly but because i was confortable with how my system was working so i replace the folder with my backup folder and all was back to way it was when i installed chameleon 2.




Hi everyone

everything is working fine now i no longer need any injector for system profilers to be recognized correctly.

Just use the installer. if you make changes just redo the mkext file located in /extra folder and that is it. For memory to show up correctly create a smbios.plist file out a vanilla apple smbios and that is it. all my mess ups took 3 days but it was worth it.


The reason for my report is to let everyone know that it is safe now that it is in installer form.


As always thanks for the great guide :unsure:

Share this post

Link to post
Share on other sites

its almost the same process... the slimbuild cd mentioned is the same as the boot132 disk supplied by me... The only difference, is i don't give details on making a EFI partition, but the idea/process to install is the same, make a small partition, install the kexts and bootloader instead of the main OSX partition and then you have a untouched install, completely unbreakable in theory... The script provides charmeleon 2 the ability to install to the efi partition...


I use bootthink on a flash drive, so my mac is untouched, and i can plug in different bootloaders if i want... no partitioning needed.

Share this post

Link to post
Share on other sites

Guys I am pulling my hair out trying to get the audio working with this build.. I have spent sooo many hours on it.. I have tried the included Kexts using uiinstaller, I have used someone EP43 audio fix etc..


If I use the EP43 fix I think someone referenced in this thread, I can get it to show an audio device, but no sound comes out.. period.. lol..


This is the last major thing I need to over come... Any advice?


PS thanks for the guide and the compilation of tools it made this a lot easier then it would have been..

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.