Jump to content

AppleIntelPIIXATA kext fully working for all ICHx Mobo (All Sata Channels working)


  • Please log in to reply
417 replies to this topic

#401
brandscill

brandscill

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Can anyone help giving me a way to add this kext file to the install DVD?

#402
Maxetto

Maxetto

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 509 posts
  • Gender:Male
  • Location:Cecina
(Sorry for UP)
IDE Boot works in Lion with ultimate KEXT :D

Thanks!

#403
MacKonsti

MacKonsti

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Male
  • Location:Muppet Show
Guys, thank you all for your hard work on this kext.
It hasn't been updated for the latest versions of 10.6.x Snow Leopard...
...especially since Apple now supports TRIM for SSDs with a simple patch!

So I wanted to ask you--if this can apply to my problem.
It seems my mobo/BIOS doesn't support AHCI at all, so I cannot get my ICH7 controller to show in System Profiler. Will this patched kext work and make my controller visible in System Profiler?
If it will do, then I urge you to fix the 10.6.7 kext since it can support TRIM for SSD drives!
Many thanks.
Konsti

#404
romefolks

romefolks

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Does installing this Kext allow you to boot retail snow leopard 10.6.7 with bios set to AHCI mode disabled? I replaced the default appeintelPIIXATA kext however i just get still waiting on root device...over and over again. However when i switch the bios to AHCI mode, it will load with no problems. I have a gigabit ga-ep35-ds3p Mobo. I am dual booting windows xp, which i why i want to keep the the ACHI disabled?

I know snow leopard can boot with ACHI disabled and IDE mode, because hazard 10.6.6i has no issues at all booting. do i need a updated AppleIntelPIIXATA.kext to stop the waiting on root device or what?


EDIT: The answers to my questions above is yes. I used Kext helper this time to install the updated AppleIntelPIIATA Kext and it worked. All works fine with bois set to ACHI disabled and IDE on a gigabit ga-ep35-ds3p.

#405
taky2008

taky2008

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 112 posts
i've Foxconn MXE g41 MOobo with ICH7 only how can i install Any ver of OSx ??? I've no AHCI Option in my Bios

#406
nexus77777

nexus77777

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
Hi, could you please re up the Tiger 10.4.1x version, for a Toshiba A100 ???
Thanks...

#407
douggle

douggle

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts
workig in Lion GM!

#408
xorne

xorne

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

workig in Lion GM!


Yes, but only on the SATA1 and SATA2 port :P
Under 10.6.x all sata ports are OK, any idea how to fix that with Lion ?

#409
scorer13

scorer13

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Hi i have a msi p55-cd53 mainboard and 10.6.7.
2 sata ports work they are jmicron ports.
But the other 6 ports don't work they are intel sata ports.
What should i do? Can i solve this problem with this kexts here?

#410
xorne

xorne

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

Yes, but only on the SATA1 and SATA2 port -_-
Under 10.6.x all sata ports are OK, any idea how to fix that with Lion ?


I found the solution : copy the IOSCSIArchitectureModelFamily.kext from Snow Leo and all ports are OK for me :D

#411
RaMDaY

RaMDaY

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 184 posts
  • Gender:Male
  • Location:New York City
This is giving me a kernel panic with 10.7.2 on Dell XPS420 desktop. Any ideas?

#412
redreda

redreda

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Anyone know how to put it on iatkos i5 installation usb with chameleon on it?

#413
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,121 posts
  • Gender:Male
  • Location:Brazil
Place it in /Extra/Extensions.

#414
Xenophage

Xenophage

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Central NY
Download link for the Tiger version is broken. Anyone still have this lying around?

#415
ytrox

ytrox

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 502 posts
  • Gender:Male
  • Location:Italy
I'm asking why people uses external link to up files!! damn!

#416
lia1971

lia1971

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts

I found the solution : copy the IOSCSIArchitectureModelFamily.kext from Snow Leo and all ports are OK for me :D

Hi,
I see your solution but don't work for me: any ideas?
Thanks

Lia1971 ;)


Leopard 10.5.8 Retail - Snow Leo 10.6.8 Retail - Lion 10.7.2 Retail - Win8 Pro - Win 7 Ultimate - Lion 10.7.4 su MBP

- MSI P35 Neo-F⌘ICH9/88SE6111(BIOS modify)⌘Intel© Core©2 Duo E7200 Enabled⌘RAM 4x 1Gb 667 Mhz⌘HD 3x 320Gb MAXTOR SATA + 1 HD SEAGATE 500 Gb⌘1x HD SEAGATE 1Tb USB⌘ALC888 only OUT Enabled⌘XFX HD 6850 Dual Fan 1GB with QE/CI Enabled⌘DVD-R PHILIPS SPD6005T PATA Enabled⌘DVD LG PATA Enabled⌘LAN REALTEK RTG 8168/8111 Enabled⌘FireWire TI Chipset 400 Mb/sec Enabled⌘HP LaserJet Pro 200 color MFP M276mw⌘LOGITECH QuickCam Communicate STX Mic & VIDEO Enabled with MACAM -

#417
kocoman

kocoman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 325 posts
Does this work with mountain lion? thanks

#418
bobymc

bobymc

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

I'm working on HP XW6000 PC-desktop, the APPle intel io ata or ApplePATA thingy and replacing the io ata ktext only makes dirves appear,

 

wise I;m still stuck on UNMOUNTING disk-s

 

the HP XW6000 still could NOT unmounting harddisk

or it takes whole years to unmounts the drive

it's the same old problem

 

I assumed installing OSX 10.6xx TO> NON-SATA interface is IMPOSIBLE....

Probably someone find a way to install OSX to "NON PLUG and PLAY"  mainboard....?

UNMOUNTING means > pull out a device from your computer

MOUNTING means > plug in a device to your computer

 

for such primitive BIOS or NON-Plug and play BIOS = mounting and unmoungting is exactly IMPOSIBLE

it's a HARDWARE phenom NOT a SOFTWARE

even a bunch of patches could NOT evercome this BIOS limitation...

 

Cheers and have a good day.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy