Jump to content

[HOW TO] ATI Radeon HD2600 Series for Hackintosh


  • Please log in to reply
287 replies to this topic

#81
wodonwong

wodonwong

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:HK
I have downloaded Triakis_2400_2600_2900_3800 and installed. I then followed the readme and looked into Info.plist of ATIRadeonX2000.kext.
From System Profiler my ATI Radeon HD 2600 XT has been recognized as HD 2600Pro, Vendor ID (0x1002), Device ID (0x9588)
In Info.plist of ATIRadeonX2000.kext, the Device ID 0x95881002 is already there, how can I further add?
Also, still cannot get the DVI working, using DVI2VGA is OK though. QE, CI OK, resolution OK.
Please help!
Thanks!

EDIT
Got it fixed by updating my Asus P5K Bios from 6.03 to 7.04.
Many thanks to netkas and asap18

#82
pippocal

pippocal

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
I have an HD2600pro agp 512mb with a Triakis driver all resolutions work but no qe ci. Have you same suggest? My id card is 0x9587?

Thanks

#83
crazyJAT

crazyJAT

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 301 posts
  • Gender:Male
  • Location:US
Ok, I now have my HD2600xt working on Leopard 10.5 with dual monitor, but core image says software and quartz extreme is not supported. I used Triakis_2400_2600_2900_3800 installer. What did i do wrong?

#84
Genj

Genj

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hello to all, I have a notebook with RADEON HD 2600 XT. Can something as native to include screen. I install radeon_hd_2600_2900 driver from irc, and now I have a black screen ;) .
-x not working(Black screen too). But I can to boot only from KismusDVD tools to edit some files. Thanks
p.s. Sorry for my English

DevID 9581
Vendor 1002

#85
Geysa

Geysa

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 840 posts
Hello, sorry for my english but im french user...

I have installed the triakis driver for my 2600xt, it work well after editing the Dev ID (for QE/CI)

My 2600xt heats lot, I can not even put my finger on it ...

You think it is normal?

#86
darkland

darkland

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
  • Gender:Male
  • Location:Amsterdam
I also got a Radeon 2600Pro agp 512 Mb (dev.id 9587).
Installed the Triakis_2400_2600_2900_3800 drivers and added the dev id to the list. Now profiler recognizes it as ATI,RadeonHD2600 but with only 256mb and no qe. Possible resolutions only 1024x768.

Did I miss a step? Looks like the driver assumes this is the older 256mb model.
Anybody have a clue as to how can I fix this?

Running uphuck 10.4.9.

#87
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years

I also got a Radeon 2600Pro agp 512 Mb (dev.id 9587).
Installed the Triakis_2400_2600_2900_3800 drivers and added the dev id to the list. Now profiler recognizes it as ATI,RadeonHD2600 but with only 256mb and no qe. Possible resolutions only 1024x768.

Did I miss a step? Looks like the driver assumes this is the older 256mb model.
Anybody have a clue as to how can I fix this?

Running uphuck 10.4.9.


You need to have the imac update that has the 2600 and 10.4.10 update with atleast 8.10.1 kernel

#88
Genj

Genj

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Triakis_2400_2600_2900_3800 drivers not helped. Could the reason not to drivers?

#89
@Steph

@Steph

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male
  • Location:France
I tried on my laptop HP HDX 9000 series (9050EF) with Leopard Flat Image (the only one that works a little), but triakis gave my black screen (even with -V -X). My ATI Mobility HD 2600XT DEVID: 9583 VEN: 1002.
Then can't boot, I have to install again :rolleyes:

#90
Genj

Genj

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

I tried on my laptop HP HDX 9000 series (9050EF) with Leopard Flat Image (the only one that works a little), but triakis gave my black screen (even with -V -X). My ATI Mobility HD 2600XT DEVID: 9583 VEN: 1002.
Then can't boot, I have to install again ;)



same. drivers for "mobility" cards is yet to be developed. Are you tried to plugin monitor in your laptop?

#91
@Steph

@Steph

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male
  • Location:France
No. I have no other monitor

#92
qh187

qh187

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Hello to all, I have a notebook with RADEON HD 2600 XT. Can something as native to include screen. I install radeon_hd_2600_2900 driver from irc, and now I have a black screen :) .
-x not working(Black screen too). But I can to boot only from KismusDVD tools to edit some files. Thanks
p.s. Sorry for my English

DevID 9581
Vendor 1002


mine is doing the same thing. except i have a desktop. DEVID 9588. Any suggestions?

#93
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years
For anyone with a ATI Radeon HD 2600 with AGP Device id 9587 i fixed it for anyone with agp


Download
Use Kext Helper to install the kexts
You still need to download the natit from IRC #RadeonHD ..The first link in the topic
Also report back if Dual DVI works should work fine i just need confirmed report of it

Posted Image

#94
JPearce

JPearce

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
lastExile, i'm sorry, but this is my first try to use mac os
Can you help me and write mini-guide step by step what I must do to make my AGP Radeon HD 2600 XT 512Mb fully work?

P.S. In any case thank you and sorry for my English, i'm from Russia.

#95
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years

lastExile, i'm sorry, but this is my first try to use mac os
Can you help me and write mini-guide step by step what I must do to make my AGP Radeon HD 2600 XT 512Mb fully work?

P.S. In any case thank you and sorry for my English, i'm from Russia.



Whats your device ID ?

Go to system profiler just click the apple logo then about this mac and more info under video it should say Device ID

#96
jsl

jsl

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 376 posts

good to see it worked <_<

2600pro needs GL
2600XT just needs natit & atindrv

But 2600 has now PC.EFI Support


Does it work on ATI Mobility Radeon HD2600 ?

#97
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years

Does it work on ATI Mobility Radeon HD2600 ?


no not yet im trying to get internal screen working

#98
KeepSmiling

KeepSmiling

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Location:Germany
Hi,

I have the Gigabyte HD 2600 Pro 512 MB with ID 9589, passive Cooling.

Have installed at first Driver from Netkas, then LasExile's Patch for the white Mens. And then Triakis Solution for DVI. All works great!

i have some curious things, when i watch videos: There are sometimes some lines in the screen, very short, they come and disappear.
And this appears the last 1 week: There Black Screens in the Videos, 1 second long the Videos. Can someone report the same things?

KS

Posted Image


My Config:

Kalyway 10.5.1 Leopard
Gigabyte GA P35-DS4
Gigabyte HD Radeon 2600 Pro with DVI

#99
igyo

igyo

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
I have ATI mobility HD2600 too, and it not working too :blink:

#100
davidcape

davidcape

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
I HAVE ATI HD MOBILITY 2600 512 MB and dont working quarz and resolution. my device id is 0x9581 ! HELP





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy