Jump to content

The Complete Dell XPS m1210 Installation + Dual Boot Tutorial

- - - - -

  • Please log in to reply
571 replies to this topic

#561
Mad_DuFFeR

Mad_DuFFeR

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hello all, I figured I'd post my same question on this thread as well they are both related and I'm unsure which one sees the most traffic.

I've never really had any problems with my OS after following the guide at the beginning. I have since then upgraded to 10.5.6 and now recently to 10.5.8. I never had a problem with the 10.5.6 upgrade nor did I have to enter any safe mode to reinstall drivers.

10.5.8 however is a different story. After making the upgrade, rebooted back into OS X to find my sound was not working working and the touchpad and keyboard do not work on the M1210. I didn't know that at the time as I was using a USB keyboard/mouse setup. I've re-patched the audio with AppleHDAPatcher and successfully brought my sound back. The keyboard and touchpad however, I have no clue what to do.

Also, does anyone know of a later video driver setup? I tried a dvd the other day and it caused all the menus to go a scratchy green; very difficult to find the restart button thereafter. I'm currently using the NVinjectGo setup provided at the beginning of this thread.


Thanks in advance and I'll chime it if I figure anything out on my end.

Cheers,

duff

#562
borges27

borges27

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Dell XPS M1210: XP + JAS 10.4.8 Mifki
CPU: Intel Core 2 Duo T7200 2.0Ghz - (Only one core works) <---- both cores are working now =)
RAM: 2GB @ 667mhz DDR2
Video: Nvidia Geforce GO7400 - (QE/QE2D/CI supported w/Natit universal 1.0)
Audio: Sigmatel 9220 - (FULLY WORKING! speakers and all!!!)
Storage:100gb 7200RPM Seagate SATA
Optical: Dual layer DVD +/- RW - (Fully working)
Ethernet: Broadcom 440x - (Fully working)
Dell 1390 b/g - (Working as Airport Express)
Bluetooth: Dell 355 - (Working)
Touchpad/usb: works - (no 2 finger scrolling, tapping works)
Webcam: tried macam and Logitech osx drivers - (NOT working)
Interal card reader - (not working)
ACPI- DISPLAY WON'T RECOVER FROM SLEEP HELP!

Click here for my XPS m1210 Installation Tutorial


"Also, I have not tried the 10.4.9 update yet. I'm kinda scared that one of my apps will quit working properly, I use OSX for work alot. The apps I use the most are Photoshop CS2, garagesale, firefox, thunderbird and aperture."


I can see your point for not wanting to mess with a good thing, I haven't had any problems at all, but I don't use this for work, and I don't use photoshop. A good indicator for what would be affected is probably the official notes for the 10.4.9 install. I've installed ilife, iwork, office 2004, firefox all preupdate and no problems.



Jami,

The mifki kernal is only needed to get the speakers working. I'm sorry about your slow internet speeds, that's rough.

As for getting that card in India, I think your best bet is going through Dell directly

here are the product links for both the 1390 and 1490 cards, so you can get part/model numbers

http://accessories.u...mp;sku=430-1731
http://accessories.u...mp;sku=430-1733

here is the phone number for Dell in India, I'm not sure if the 1-800 number will work there.

Call1800- 425- 4026 Toll Free or Call 080-2506-8026 (standard charges apply)



as I've said before...
Good Luck
you definitely have a challange on your hands


I hope this isn't too far off topic, but since we are all m1210 owners, and OSx86 users, and macbooks have slot load drives...

I saw this, and now I'm getting tempted to get one just for the hell of it.

http://www.zipzoomfl...ductCode=175305


How did you do for the core CPUs, it only shows one core!
thanks

#563
Ombaudsman

Ombaudsman

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
I used to have Leopard installed on my Dell XPS m1210. Everything (except USB) used to work perfectly, including wi-fi. I had to change the HD for a larger one (500gb) and I have bought an original copy of Snow Leopard that I’m using on my Desktop Hackintosh. For now I can only find tutorials about how to install “Leopard” on it, but I was willing to use my original copy of Snow Leopard instead of downloading those hacked distributions of Leopard. Anyone have already tried to install SL on a Dell XPS m1210?

#564
blindjackal

blindjackal

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts

I used to have Leopard installed on my Dell XPS m1210. Everything (except USB) used to work perfectly, including wi-fi. I had to change the HD for a larger one (500gb) and I have bought an original copy of Snow Leopard that I’m using on my Desktop Hackintosh. For now I can only find tutorials about how to install “Leopard” on it, but I was willing to use my original copy of Snow Leopard instead of downloading those hacked distributions of Leopard. Anyone have already tried to install SL on a Dell XPS m1210?



Yes, 10.6.4 retail with EmpireEFI 1.0.85 R2

I will make a tuto these next days...

but it is easy, you need only three packages
VoodooHDA.kext
VoodooTSCSync.kext
NVEnabler.kext for geforce go 7400

#565
hectorhaces

hectorhaces

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Yes, 10.6.4 retail with EmpireEFI 1.0.85 R2

I will make a tuto these next days...

but it is easy, you need only three packages
VoodooHDA.kext
VoodooTSCSync.kext
NVEnabler.kext for geforce go 7400


Hi ..


What's up with tuto?

#566
ThePwrSerg

ThePwrSerg

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
yES, where is the tuto?!

lol ;)

#567
callummc

callummc

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 8 posts
Hi all,

I've just gotten my m1210 set up with dual boot (Win 7 + OSX 10.6.4) with nearly everything working.

Is there still any interest in a tutorial for this?

#568
Bmc401

Bmc401

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Hi all,

I've just gotten my m1210 set up with dual boot (Win 7 + OSX 10.6.4) with nearly everything working.

Is there still any interest in a tutorial for this?



Very much so. - at least from me

#569
dumraja

dumraja

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
still waiting for the tut

#570
pcmodem2009

pcmodem2009

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Hi all,

I've just gotten my m1210 set up with dual boot (Win 7 + OSX 10.6.4) with nearly everything working.

Is there still any interest in a tutorial for this?



I would really love to see this tutorial. I have my m1210 running with mac os x 10.5.6 with everything working. But now I want to upgrade to snow leopard.

Please send me the tutorial or post asap.

Thanks.

#571
zafoxy

zafoxy

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Foreword/disclaimer:


The following is a step by step tutorial for installing osx on a Dell XPS m1210 laptop. Note that it is illegal to download or obtain an x86 Intel OSX image from any source including torrent sites. It is also a breach of the EULA to make your own. The information presented here was collected from various online sources. Also note that I am not responsible for any problems with your computer that may occur because of this guide.



how'd you get the external display working?

#572
zerolimit

zerolimit

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Anyone can help what is the best way! I got to boot but pc super laggy and keep loosing Internet connection please update guide thank you





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy