Jump to content

Sapphire HD 7850 Full Works !


  • Please log in to reply
75 replies to this topic

#41
XITE666

XITE666

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Location:RUSSIA

Any help would be greatly appreciated. Thanks!                             

 

 

http://cl.ly/29381a3E2y3H

 

Check . 

 

 

All kexts should return to the place



#42
rootedheart

rootedheart

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Spain

The first, thank you for edit my DSDT. Now, I put clover boot loader and I downloaded your edited kext, now I'm using ATI_inject = Yes, that is the same GE=YES. Now I've got the card recognized as a 7850 card, but it's appear as 7850 7 MB instead of 2048 MB :S

I record a video in that you can see how I've got use your kext, and AMDradeonx4000 kext with 0x68181002 device id.

Now I think, the problem can be with the device id, when I booted in windows, I saw my divice id with GPU-Z, and my divice id is 0x68191002 how appear recognized by clover in the video (0x68191002) and inside the kexts, you can see 0x68181002. I've got a 7850 2 GB OC by Sapphire.

I'm using your kext AMD7000 controller, the native Radeox4000 kext with 0x68181002 id and the DSDT you edited for me. So, I think, that maybe the problem is because, my correct device id is 0x68191002 how appear in GPU-Z. Really I don't know.

 

Can you give me yours kexts please? The both. Radeonx400 and AMD7000controller. If you can give me a copy edited with my divice id 0x68191002 of AMD 7000controller, I'd appreciate it. When I try to edit you AMD 7000 controller kext, displays a similar message of this: "This file is damage". Or anything like this.

 

 



#43
XITE666

XITE666

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Location:RUSSIA

 

 

:lol: Who taught you so edit ?

 

Reinstall the hotfix kexts using Kext Wizard .



#44
rootedheart

rootedheart

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Spain

:lol: Who taught you so edit ?

 

Reinstall the hotfix kexts using Kext Wizard .

 

 

I've done it and have obtained the following results. I'm in Mavericks 10.9.0, using HDMI.

 

  1. With the original kexts without edit:

 

  • Ati_inject = Yes or GE=Yes.

 

I've got a black screen when I boot. I think this is because, your kexts AMD7000controller has the video out ports edited and the original kexts, have the standar ports. So, I suspect, that how a user say in this post, If I buy a mdp adapter on ebay, I'd can use the original kexts. But now, I can see only a black screen then of boot.

 

  • Ati_inject = No or GE= No.

 

I've got GE, but not full, I can't play games, record the screen with Quicktime or anything like this, but I haven't got lagg. My card is recognized as a 7XXX 2048 MB.

 

 

 

 

 

  1. With your edited kext AMD7000controller on the op:

 

  • Ati_inject = Yes or GE = Yes.

 

My graphic card is recognized as 7850 7 MB. Lagg and no GE.

 

  •  Ati_inject = No or GE= No.

 

My graphic card is recognized as 7XXX 7 MB. Lagg and no GE.

 

 

 

 

Can you give me the two kext for your 7850 are you using now please? 



#45
booblej

booblej

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

http://cl.ly/29381a3E2y3H

 

Check . 

 

 

All kexts should return to the place

 

Thanks for the DSDT patch. Unfortunately I'm still having problems with AMD kexts from 10.9.2.

 

GE=Yes:   Monitor turns off after Apple boot screen. I can hear sound if i turn up the volume with the keyboard. It seems the port isn't detected. 

GE=No:    Freezes instantly at Apple boot screen. If i boot -v, i get stuck at this text:  https://onedrive.liv...int=photo,.jpeg

 

Not sure what to do from here.



#46
XITE666

XITE666

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Location:RUSSIA

Thanks for the DSDT patch. Unfortunately I'm still having problems with AMD kexts from 10.9.2.

 

GE=Yes:   Monitor turns off after Apple boot screen. I can hear sound if i turn up the volume with the keyboard. It seems the port isn't detected. 

GE=No:    Freezes instantly at Apple boot screen. If i boot -v, i get stuck at this text:  https://onedrive.liv...int=photo,.jpeg

 

Not sure what to do from here.

 

You reinstall OSX! 
 
Edit kexts do not!
 
GE=NO
 
Ati_inject DELETE ! 
 
 
Advisable to install Clover  http://www.osx86.net...8-lite-no-uefi/
 
 
 

 

 

Can you give me the two kext for your 7850 are you using now please? 

 

http://cl.ly/1a0m2830440L

 

Set with the Wizard

 

 

http://rghost.ru/52829556/image.png

Attached Files



#47
rootedheart

rootedheart

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Spain


You reinstall OSX!

Edit kexts do not!

GE=NO

Ati_inject DELETE !


Advisable to install Clover http://www.osx86.net...8-lite-no-uefi/





http://cl.ly/1a0m2830440L

Set with the Wizard


http://rghost.ru/52829556/image.png


Thank you!

#48
booblej

booblej

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

 

You reinstall OSX! 
 
Edit kexts do not!
 
GE=NO
 
Ati_inject DELETE ! 
 
 
Advisable to install Clover  http://www.osx86.net...8-lite-no-uefi/
 
 
 

 

http://cl.ly/1a0m2830440L

 

Set with the Wizard

 

 

http://rghost.ru/52829556/image.png

 

Reinstalled 10.9.2....Same problems.

 

Tried your kexts.....Same problems.

 

I haven't tried using Clover yet. I will let you know if it changes anything.



#49
XITE666

XITE666

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Location:RUSSIA

Recommend Clover  ( without uefi )

 

http://cl.ly/3T1J0G2C1n0i

 

Many problems with the OEM folder .

 

OEM folder was deleted by me .

 

With UEFI use standard Clover ....... check folder OEM .



#50
XITE666

XITE666

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Location:RUSSIA

OSX 10.9.3 full support HD 7850 ! 

 

 

Attached Files



#51
XITE666

XITE666

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Location:RUSSIA

In OSX 10.9.3 running another option

 

04  00  00  00  14  03  00  00  00  01  01  01  10  00  06  06

00  08  00  00  04  03  00  00  00  01  02  01  22  05  04  03

00  04  00  00  04  02  00  00  00  01  03  00  12  04  05  01

00  04  00  00  04  02  00  00  00  01  04  00  11  02  01  05

Device (PEX)
            {
                Name (_ADR, 0x00010000)
                Device (GFX)
                {
                    Name (_ADR, Zero)
                    Method (_DSM, 4, NotSerialized)
                    {
                        Store (Package ()
                            {
                                "@0,name", 
                                Buffer ()
                                {
                                    "ATY,Aji"
                                }, 
                                "@1,name", 
                                Buffer ()
                                {
                                    "ATY,Aji"
                                }, 
                                "@2,name", 
                                Buffer ()
                                {
                                    "ATY,Aji"
                                }, 
                                "model", 
                                Buffer ()
                                {
                                    "AMD Radeon HD 7850"
                                }, 
                                "hda-gfx", 
                                Buffer ()
                                {
                                    "onboard-1"
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                    }
                }
                Device (HDAU)
                {
                    Name (_ADR, One)
                    Method (_DSM, 4, NotSerialized)
                    {
                        Store (Package ()
                            {
                                "hda-gfx", 
                                Buffer ()
                                {
                                    "onboard-1"
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                    }
                }
            }

Attached Files



#52
XITE666

XITE666

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Location:RUSSIA

AMD7000Controller for 10.9.3 13D17

 

ATY Aji

Device (PEX)
            {
                Name (_ADR, 0x00010000)
                Device (GFX)
                {
                    Name (_ADR, Zero)
                    Method (_DSM, 4, NotSerialized)
                    {
                        Store (Package ()
                            {
                                "@0,name", 
                                Buffer ()
                                {
                                    "ATY,Aji"
                                }, 
                                "@1,name", 
                                Buffer ()
                                {
                                    "ATY,Aji"
                                }, 
                                "@2,name", 
                                Buffer ()
                                {
                                    "ATY,Aji"
                                }, 
                                "model", 
                                Buffer ()
                                {
                                    "AMD Radeon HD 7850"
                                }, 
                                "hda-gfx", 
                                Buffer ()
                                {
                                    "onboard-1"
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                    }
                }
                Device (HDAU)
                {
                    Name (_ADR, One)
                    Method (_DSM, 4, NotSerialized)
                    {
                        Store (Package ()
                            {
                                "hda-gfx", 
                                Buffer ()
                                {
                                    "onboard-1"
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                    }
                }
            }

Attached Files



#53
devBrian

devBrian

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:root

Hi everyone, here are my specs, to begin:

 

i5 3570k

8GB DDR3 1600

Sapphire 7850 OC 2048MB

Gigabyte Z77MX-D3H Motherboard

Mavericks 10.9.3

 

Everything works out of the box, basically, including the video card, however the card does not work properly in games, flash videos, etc, and in the Device list, it is listed as:

 

AMD Radeon 7xxx 2048MB, so the framebuffer is not set properly.

 

Now, I went into the AMD 7000 kext and the 4000 kext and added 0x68191002.

 

However, after that, the device is still listed as 7xxx.  I also tried a DSDT edit to add the edits confirmed working here:

http://www.insanelym...850-full-works/

 

After that, I still get 7xxx.

 

I am using the latest revision of Clover.

 

Any recommendations? :|



#54
XITE666

XITE666

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Location:RUSSIA

 

 

Any recommendations? :|

 

Post # 53

 

Add in DSDT Aji + modkext . 



#55
devBrian

devBrian

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:root

Post # 53

 

Add in DSDT Aji + modkext . 

 

Works perfectly with Aji framebuffer.  I was trying to use Hamachi and Futomaki as I thought the 7850 2GB was using a different one, but this works perfectly with DSDT fix and kext.  Thanks!



#56
XITE666

XITE666

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Location:RUSSIA

7000Controller for 10.9.3 13D33

 

 

ATY Aji

Attached Files



#57
electonic

electonic

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

OSX 10.9.3 full support HD 7850 ! 

 

Could you please clarify: 

That means 7850 is now natively supported in 10.9.3 without any hack?

 

I want to run dual GPU in Mac Pro and that would be a great solution, because they only use 1 x 6 Pin power connector each.

 

Thanks for your help!



#58
XITE666

XITE666

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Location:RUSSIA

Could you please clarify: 

That means 7850 is now natively supported in 10.9.3 without any hack?

 

 

In 10.9.3 appeared ID 6819 .


I want to run dual GPU in Mac Pro and that would be a great solution, because they only use 1 x 6 Pin power connector each.

 

Thanks for your help!

 

I do not know



#59
Dontview

Dontview

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Germany

In 10.9.3 appeared ID 6819 .

 

 

So, no dsdt injection needed??



#60
electonic

electonic

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

In 10.9.3 appeared ID 6819 .

 

So that means 3D works plug and play? No hacks?

Or is it just 2D Desktop and still hack for 3D?

 

Thanks in advance! :D







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy