Jump to content

Mavericks AppleHDA HDMI Audio

AppleHDA HDMI Sound Realtek

  • Please log in to reply
239 replies to this topic

#41
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 910 posts
  • Gender:Male

The attached display is an HDMI Samsung Display.

Never tried HDMI audio on a non HD TV resolution; try 720p.



#42
slayer2333

slayer2333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 204 posts
  • Gender:Male

The weird thing about my laptop is that:

-The speakers on OSX won't work (still i have audio control) except if i boot in windows first.

-HDMI audio is not detected until i boot in windows first before booting into OSX.

 

I had a previous unlocked Bios where i found that Azalia audio was set on auto, so i guess it needs to detect an official OS (windows or Linux) before it can activate. 

 

The plugged TV is an HD TV but i set the resolution to 720p for bigger text on TV (as shown in my screenshot), it is plugged to a Home Theatre first then goes to TV, i will try to plug it to TV directly.

Edit: no change with a direct connection unfortunately. 

Can it be a problem from the patch command on the AppleHDA.kext (which can be specific to desktop harware) ?



#43
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 910 posts
  • Gender:Male

Can it be a problem from the patch command on the AppleHDA.kext (which can be specific to desktop harware) ?

No, if it didn't work with the native AppleHDA, it is not going to work.  As you imply, OS X has issues on your laptop.



#44
slayer2333

slayer2333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 204 posts
  • Gender:Male

No, if it didn't work with the native AppleHDA, it is not going to work.  As you imply, OS X has issues on your laptop.

Alright, i will get back to that once i unlock my Bios and check again the hidden audio settings there, i will survive without HDMI audio.  Really appreciate your patience Toleda, thank you very much.



#45
naidb

naidb

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 187 posts
  • Gender:Male
  • Location:ThaiLand
  • Interests:mainboards gigabyte GA-Z87X-UD3H
    CPU intel HasWell Core i5 4670K
    Gell 16Gb 1866
Hello toleda 
Sequel to this topic # 147 I read a profile. Unfortunately with 
Questions through 
I have tried to plug the DP 10.9.2 The result was a black screen on restart. 
What's curious is why the DP is not. 
Try with DP 10.8.5 and it works fine. 
Want you to help guide


#46
marco.pisellonio80

marco.pisellonio80

    InsanelyMac Sage

  • Donators
  • 438 posts
  • Gender:Male
  • Interests:Libri, musica e natura

Hi Toleda,

 

in your first post in the requirements you say that the supported Nvidia cards are:

 

"""""Nvidia 4xx/5xx/6xx/7xx

  1. GTS450, GTX550ti, GTX 560ti not supported natively""""""""

This mean that your guide does'nt works for my GT220 or it could?

In first case could it works with voodoo audio?

Thank you.



#47
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 910 posts
  • Gender:Male

This mean that your guide does'nt works for my GT220 or it could?

In first case could it works with voodoo audio?

The GT 240 does make HDMI audio in OS X, no success with the GT210 and a few users have success with the GT220.  Try it.  

Voodoo is alway an option, however, I have no knowledge or experience with Voodoo.



#48
marco.pisellonio80

marco.pisellonio80

    InsanelyMac Sage

  • Donators
  • 438 posts
  • Gender:Male
  • Interests:Libri, musica e natura

Thank you for your reply, Toleda, I'll try and feedback here :)

Bye



#49
Crabhunter

Crabhunter

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 254 posts

I want to try and enable hdmi sound on my Acer V5-171

It has an Acer Mimic type2 motherboard with an Acer bios

I am using "normal" bios not UEFI

An HM77 South bridge

The processor is an i3 Ivybridge with HD4000 graphics

At present alc269 sound is working with a patched hda and hdaenabler.

Is there any chance this method will work for me and if so which would be the best patch?

Mike



#50
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 910 posts
  • Gender:Male

Is there any chance this method will work for me and if so which would be the best patch?

Try post #1, 3. HD4000/7 Series MB HDMI Audio (dsdt) - Desktop/Laptop. Edit ig-platform-id in the patch to the framebuffer currently working on your laptop,



#51
Crabhunter

Crabhunter

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 254 posts

Edit ig-platform-id in the patch to the framebuffer currently working on your laptop,

 

 

Thanks, where do I find my current frame buffer?

Mike



#52
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 910 posts
  • Gender:Male

Thanks, where do I find my current frame buffer?

IOReg (View Raw for download) audio_ALCInjection/IORegistryExplorer_v2.1.zip at master · toleda/audio_ALCInjection



#53
Crabhunter

Crabhunter

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 254 posts

Thanks, will have a go tomorrow.

Mike



#54
Crabhunter

Crabhunter

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 254 posts

I spent a bit of time reading the instructions for this method and I'm not sure it will work for me.

The most suitable patch says it will only work with AMI bios and my bios is ACER

Also it says to remove HDAEnabler1 (is this the same as HDAEnabler?) and any injection both of which I need to enable sound and graphics.

What would I have to do to manually edit my DSDT for this?

Mike



#55
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 910 posts
  • Gender:Male

The most suitable patch says it will only work with AMI bios and my bios is ACER

Attach the dsdt.



#56
Crabhunter

Crabhunter

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 254 posts

Thanks, here are all the files I think you might need.

Mike

Attached Files



#57
naidb

naidb

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 187 posts
  • Gender:Male
  • Location:ThaiLand
  • Interests:mainboards gigabyte GA-Z87X-UD3H
    CPU intel HasWell Core i5 4670K
    Gell 16Gb 1866
Why no sound In a yellow box 
Please explain 
Thanks
Screenshot+2014-02-12+17.07.30.jpg


#58
Allaп

Allaп

    InsanelyMacaholic

  • Local Moderators
  • 2,809 posts
  • Gender:Male
  • Location:Brazil

Hi Toleda!

 

Your tutorial, works in chip series 76?

Attached File  Screen Shot 2014-02-12 at 8.46.45 AM.png   221.79KB   2 downloads

 

Or only this is supported?

Intel Motherboards

8 Series - Z87, H87, B85

7 Series - Z77, H77, B75

6 Series - Z68, P67, H67, H61

5 Series - P55, H55

 

 

Thanks



#59
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 910 posts
  • Gender:Male

Why no sound In a yellow box 

System Information/Hardware/Audio/Intel High Definition Audio (not Devices), what is your Audio ID?

The orange port is the 2nd Line Out in System Preferences/Sound/Output.

For screenshots of what does what, see (View Raw), audio_ALCInjection/M-Realtek_ALC_AppleHDA_Screenshots.pdf.zip at master · toleda/audio_ALCInjection


Your tutorial, works in chip series 76?

Yes, what codec?



#60
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 910 posts
  • Gender:Male

Thanks, here are all the files I think you might need.

Missed your post.  Several issues.

What version is AppleHDA?  There will be problems if it is not v2.5.2 or newer.

Remove the audio enabler.  Confirm onboard audio is working,  Back up the dsdt

dsdt is AMI, has dual link injection and does not have GFX0/hda-gfx injection

Compile, delete line with error, compile

Edit dsdt, compile, save, install.

Since the IOreg does not have an HDMI device attached, no way to know what framebuffer edits are required.  

Reply with edited dsdt and new IOReg withedits and HDMI device attached.

Find "AAPL00,DualLink", add additional injection as shown.            

Method (DSM, 4, NotSerialized)
            {
                Store (Package (0x08)
                    {
                        "device-id", 
                        Buffer (0x04)
                        {
                            0x66, 0x01, 0x00, 0x00
                        }, 

                        "AAPL,ig-platform-id", 
                        Buffer (0x04)
                        {
                            0x03, 0x00, 0x66, 0x01
                        }, 

                        "hda-gfx", 
                        Buffer (0x0A)
                        {
                            "onboard-1"
                        }, 

                        "AAPL00,DualLink", 
                        Buffer (0x04)
                        {
                            0x01, 0x00, 0x00, 0x00
                        }
                    }, Local0)
                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                Return (Local0)
            }







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy