Jump to content

Mavericks AppleHDA HDMI Audio


340 posts in this topic

Recommended Posts

HDMI audio is not native in OS X. See Post #1, edit the dsdt or install a ssdt. Download the guide for the selected method and install.

You are kidding me right? I have read that guide more than ten times and have uploaded requested files over and over yet you do not seem to want to assist me. This is easy for you yet you seem to want to belittle me as a grade school teacher does to a child who does not understand their homework. I don't have much experience in the hack but have invested a lot of time in learning about it and have had much help from another member as well who luckily has had patience with me. In the end it does not make a difference if the mac system does not

work perfect for me--but I can't believe someone with your ability finds it easier to play a noob off instead of simply "trying" to give some assistance.

Link to comment
Share on other sites

All files show the same thing, no HDMI audio edits present.  Why?

No edits, your problem.

Right...the problem is, is I don't understand this:


Location.aml - ssdt.aml installation folder

1. Chameleon: Extra/

2. Clover: EFI/Clover/ACPI/Patched/

Installation - HDMI audio ssdt (audio_ssdt-hdmi…)

1. Copy Downloads/audio_ssdt-hdmi.. . ./SSDT-1.aml to Location.aml

1. If Location.aml/SSDT.aml is present, install SSDT-1.aml as is:


2. If no Location.aml/SSDT.aml, rename SSDT-1.aml to SSDT.aml and

install as: Location.aml/SSDT.aml

3. The 1st SSDT is SSDT, 2nd is SSDT-1, 3rd is SSDT-2, etc.; no gaps

2. Enable SSDT

1. Chameleon - Extra/org.chameleon.Boot.plist



2. Clover_v2000+ - EFI/Clover/config.plist/ACPI/SSDT



3. Rebuild kernel cache, see Tools 1.

4. Restart

5. Verify HDMI audio




I know I have award Bios..I tried simply placing the SSDT-1 file into my extra folder..that didn't work. Guess I need to use MacIasl? Problem is, is that I don't know how to do this and am not as savvy on what to do as you. That's why I came here looking for some direction.

Link to comment
Share on other sites

I tried simply placing the SSDT-1 file into my extra folder..

dsdt edits use MaciASL, ssdt does not need edits or MaciASL.

Chameleon use a particular order to load ssdts, explained in installation guide.

It says: if you do not have Extra/SSDT.aml rename SSDT-1.aml to SSDT.aml and install as Extra/SSDT.aml. Restart.

Reply with Chameleon Boot log, IOReg, and the installed ssdt.

Link to comment
Share on other sites

  • 2 months later...

I have attempted to use your audio_cloverALC-HDMI-110.command_v0.8.1 script to enable HDMI audio on my Hackintosh. It says: No AMD/Nvidia discrete graphics card found. I set gDebug=2 to get more info, output attached.


The machine has an Asus P8H61 motherboard running Mavericks OSX 10.9.5 with an Asus HD5450 Silent graphics adapter. It uses the AMD5000Controller and AMDRadeonX3000 kexts. I have to edit the AMDRadeonX3000 Info.plist to add the IOPCIMatch id 0x68E11002 for the graphics acceleration to work. This id is already in the AMD5000Controller Info.plist. I have previously used your audio_realtekALC-110_v1.0o1.command script to enable the ALC887 audio, which worked fine. I have also attached the output from the command 'ioreg -rxn PEG0@1' which picks up the graphics and HD audio, and a screenshot of IORegistryExplorer.



Terminal Saved Output.txt




config copy.txt


Link to comment
Share on other sites

I have tried your updated script - it found the graphics card and installed a SSDT. After reboot HDMI audio does not appear in the sound preferences, so I ran the script again - it said AMD HDMI audio is not enabled, just like the first time. I have attached the output from running ioreg and the output from your script the first and second time.




Link to comment
Share on other sites

can't get clover to generate a boot log file

Clover log: DPCI Manager/Misc/Boot log

ssdt is not loading.

Config.plist is a disaster. Remove any property starting with #


ACPI/DSDT/Fixes/ Set the following properties to NO:


Attach new files
Attach EFI/CLOVER/ACPI/origin/  (1st and last dsdt)
Link to comment
Share on other sites

Ok, nothing in EFI/CLOVER/ACPI/origin/, nothing in EFI/CLOVER/misc, can't find a folder 'DPCI Manager' on the machine.

Frankly, no difference between IORegs, was the edited config.plist installed?

See El Capitan AppleHDA HDMI Audio for

Post #1/IX - Tools/2. DPCIManager/Misc/Boot log

Post #1/IX - Tools/3. MaciASL/File/Extract Tableset....


Attach new files

Link to comment
Share on other sites

I replaced some valid keys I cut out of config.plist. There are two OSX partitions on this disk - El Capitan and Mavericks. I thought that Clover was reading the config.plist on this partition - Mavericks as it is set as the DefaultVolume, but it appears to have been reading both. So I have made the same changes to the El Capitan config.plist. Now the HDMI audio works on Mavericks, I haven't got to El Capitan yet. It's working on El Capitan as well - Thanks.

config.plist 3.zip

Cynthia.ioreg 3.zip



Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...