Jump to content

Bluetooth stuck in "ON" state and not working


  • Please log in to reply
113 replies to this topic

#81
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 743 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

I do wanna see the BT setting screenshot for real mac because the BT setting panel is so much cleaner that I doubt if it has something to do with hack.



#82
network0771

network0771

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

The same problem,AR5B195 with ar3011 bluetooth,10.9

I can‘t turn off the Bluetoothonce i click turn off the Bluetooth, can not search any devices.

just Changed the "ControllerPowerState" to 1,then it's work again.



#83
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary

I do wanna see the BT setting screenshot for real mac because the BT setting panel is so much cleaner that I doubt if it has something to do with hack.

It looks the same on a real mac, I saw it.



#84
johnard

johnard

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

No changes yet. Tried some methods here but nothing different happened. Does anyone discovered the solution?

 

Everything that is happening was told by nyolc8 in this post:

 

Okay so I played with it for 1-2 hours and the situation for me is this:

 

 

Using 10.9 original IOBluetoothFamily.kext:

 

-the bluetooth preferences panel (and/or the bluetooth kext) CAN'T get the device's power state

-the bluetooth preference panel (and/or the bluetooth kext) CAN set the device's power state

 

-if I click on the "disable bluetooth" button in the bluetooth preferences, it sets the device power state to 0, but because it can't get it's state, the button (and the whole preferences window) not updating to "disabled state" and it remains as the bluetooth would be enabled. So then the button wants to disable an already disabled device, and because of this, I can only enable the device again in the plist file.

 

But beside this, I CAN pair,connect,browse,receive.

 

 

Using 10.8.4 IOBluetoothFamily.kext:

 

-the bluetooth preferences panel (and/or the bluetooth kext) CAN get the device's power state

-the bluetooth preference panel (and/or the bluetooth kext) CAN set the device's power state

 

But I CAN'T pair,connect,browse,receive.

 

So, the problem for me is that the stock 10.9 driver can't get the device's power state. If it could, than it would work perfectly with 10.9 kext. The question is... how we could make it to get the power state of the device... :ninja:

 

 

Basically the situation:

10.8.4 kext handles power state correctly, but not the connections

10.9 kext handles connections correctly, but not the power state

:wallbash:

 

Any thoughts?



#85
johnard

johnard

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Does anyone tried with com.apple.bluetooth.plist from 10.8.4?



#86
Scellow

Scellow

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:France
  • Interests:while{true||false}
    {
    dream();
    }

Here is how i did to solve my problem :

sudo defaults write /Library/Preferences/com.apple.Bluetooth ControllerPowerState -int 1
sudo launchctl unload /System/Library/LaunchDaemons/com.apple.blued.plist
sudo launchctl load /System/Library/LaunchDaemons/com.apple.blued.plist


#87
Edwin_3930K

Edwin_3930K

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

My problems are fixed! I'v made a file for you guys which should fix your bluetooth problems in mavericks.

 

This fix should repair connection/discover/pair problems with bluetooth in Mavericks.

 

Also helped me fix a problem were my magic mouse was recognised as normal mouse. (no multitouch/gestures enabled.)

 

Drop all the files (simultaneously) into the Kext Utility. Wait until process is done (fill in password when ask).

 

Reboot.

 

Bluetooth should now work properly.

 

——

Note: Do not turn off bluetooth. 

——

 

Attached File  Screen Shot 2013-11-09 at 17.29.27.png   351.27KB   218 downloadsAttached File  Screen Shot 2013-11-09 at 17.29.11.png   250.11KB   178 downloads

 

Attached File  Bluetooth 10.9.0 Fix.zip   3.52MB   1411 downloads

 

 

 

 

Let me know if it worked  ^_^

 

*Try at own risk*



#88
nattplus

nattplus

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Thanks Edwin_3930K.  It works..!

I now can use my Trackpad with Mavericks.  :thumbsup_anim: 



#89
boy_iran_64

boy_iran_64

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

Thanks Edwin_3930K....  But not works for me :(



#90
Edwin_3930K

Edwin_3930K

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

Thanks Edwin_3930K.  It works..!

I now can use my Trackpad with Mavericks.  :thumbsup_anim: 

Good to hear.  :)

 

Thanks Edwin_3930K....  But not works for me :(

 

What is the problem? not connecting? 

 

Also make sure your mouse or whatever is on while booting. Sometimes when i turn on my magic mouse in MacOSX it won't connect. 



#91
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

my problem  is with sleep,  Apple Trackpad and Keyboard, any one have a fix for it ?

 

LocalHost:~ iFire$ pmset -g assertions

10/11/13 10:18:12 GMT+1  

Assertion status system-wide:

   BackgroundTask                 0

   PreventDiskIdle                0

   ApplePushServiceTask           0

   UserIsActive                   1

   PreventUserIdleDisplaySleep    0

   InteractivePushServiceTask     0

   PreventSystemSleep             0

   ExternalMedia                  0

   PreventUserIdleSystemSleep     0

   NetworkClientActive            0

Listed by owning process:

   pid 75(hidd): [0x0000000a00000257] 09:14:58 UserIsActive named: "com.apple.iohideventsystem.queue.tickle"

Timeout will fire in 586 secs Action=TimeoutActionRelease

Kernel Assertions: 0xc=USB,BT-HID

   id=500  level=255 0x4=USB mod=09/11/13 21:19 description=EHC1 owner=AppleUSBEHCI

   id=501  level=255 0x4=USB mod=09/11/13 21:19 description=EHC2 owner=AppleUSBEHCI

   id=526  level=255 0x8=BT-HID mod=01/01/70 01:00 description=com.apple.driver.IOBluetoothHIDDriver owner=BNBTrackpadDevice

   id=527  level=255 0x8=BT-HID mod=01/01/70 01:00 description=com.apple.driver.IOBluetoothHIDDriver owner=AppleBluetoothHIDKeyboard

LocalHost:~ iFire$ 



#92
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 743 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

my problem  is with sleep,  Apple Trackpad and Keyboard, any one have a fix for it ?

 

LocalHost:~ iFire$ pmset -g assertions

10/11/13 10:18:12 GMT+1  

Assertion status system-wide:

   BackgroundTask                 0

   PreventDiskIdle                0

   ApplePushServiceTask           0

   UserIsActive                   1

   PreventUserIdleDisplaySleep    0

   InteractivePushServiceTask     0

   PreventSystemSleep             0

   ExternalMedia                  0

   PreventUserIdleSystemSleep     0

   NetworkClientActive            0

Listed by owning process:

   pid 75(hidd): [0x0000000a00000257] 09:14:58 UserIsActive named: "com.apple.iohideventsystem.queue.tickle"

Timeout will fire in 586 secs Action=TimeoutActionRelease

Kernel Assertions: 0xc=USB,BT-HID

   id=500  level=255 0x4=USB mod=09/11/13 21:19 description=EHC1 owner=AppleUSBEHCI

   id=501  level=255 0x4=USB mod=09/11/13 21:19 description=EHC2 owner=AppleUSBEHCI

   id=526  level=255 0x8=BT-HID mod=01/01/70 01:00 description=com.apple.driver.IOBluetoothHIDDriver owner=BNBTrackpadDevice

   id=527  level=255 0x8=BT-HID mod=01/01/70 01:00 description=com.apple.driver.IOBluetoothHIDDriver owner=AppleBluetoothHIDKeyboard

LocalHost:~ iFire$ 

Whats wrong with that? here;s my output.

 

Notebook:~ ph$ pmset -g assertions

11/10/13, 18:15:03 GMT+8 

Assertion status system-wide:

   BackgroundTask                 0

   PreventDiskIdle                0

   ApplePushServiceTask           0

   UserIsActive                   1

   PreventUserIdleDisplaySleep    0

   InteractivePushServiceTask     0

   PreventSystemSleep             0

   ExternalMedia                  0

   PreventUserIdleSystemSleep     0

   NetworkClientActive            0

Listed by owning process:

   pid 48(hidd): [0x0000000a0000014e] 00:03:34 UserIsActive named: "com.apple.iohideventsystem.queue.tickle" 

Timeout will fire in 597 secs Action=TimeoutActionRelease

Kernel Assertions: 0xc=USB,BT-HID

   id=500  level=255 0x4=USB mod=11/10/13, 10:38 description=EHC2 owner=AppleUSBEHCI

   id=501  level=255 0x4=USB mod=11/10/13, 10:51 description=EHC1 owner=AppleUSBEHCI

   id=506  level=255 0x8=BT-HID mod=1/1/70, 8:00 description=com.apple.driver.IOBluetoothHIDDriver owner=AppleBluetoothHIDKeyboard

   id=509  level=255 0x8=BT-HID mod=1/1/70, 8:00 description=com.apple.driver.IOBluetoothHIDDriver owner=BNBTrackpadDevice



#93
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

for me don´t work  sleep, this prevent my idlle sleep   :(  

my USBBluethooth idProduct an idDevice is native in the kext 10.9 BroadcomBluetoothControllerUSBTransport.kext, any edit is needed

 

<key>BroadcomUSBBluetoothHCIController - BLUETOOTH USB +EDR ADAPTER v2.1 UHE</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport</string>
<key>IOClass</key>
<string>BroadcomBluetoothHostControllerUSBTransport</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>idProduct</key>
<integer>362</integer>
<key>idVendor</key>
<integer>1293</integer>
 
 
 
 
 
 
 

 

 

 



#94
mikeguru

mikeguru

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

My problems are fixed! I'v made a file for you guys which should fix your bluetooth problems in mavericks.

 

This fix should repair connection/discover/pair problems with bluetooth in Mavericks.

 

Also helped me fix a problem were my magic mouse was recognised as normal mouse. (no multitouch/gestures enabled.)

 

Drop all the files (simultaneously) into the Kext Utility. Wait until process is done (fill in password when ask).

 

Reboot.

 

Bluetooth should now work properly.

 

——

Note: Do not turn off bluetooth. 

——

 

attachicon.gifScreen Shot 2013-11-09 at 17.29.27.pngattachicon.gifScreen Shot 2013-11-09 at 17.29.11.png

 

attachicon.gifBluetooth 10.9.0 Fix.zip

 

 

 

 

Let me know if it worked  ^_^

 

*Try at own risk*

First of all, THANK YOU FOR THE KETXTS!! THEY WORKED!! (With one minor caveat that I'll detail shortly).

I have a Dell Inspiron 17-3721 laptop, running (Retail) 10.9, in which I replaced the Dell 1704 combo WiFi/Bluetooth module with the Atheros AR5B195 module. This was necessary to get WiFi working on this laptop in OS-X. That said, Bluetooth has NEVER WORKED, even though in 10.9 all looked "normal" - the icon is in the menu bar and System Preferences. The problem, before installing your Kexts, was that it could be seen by other computers in THEIR Bluetooth settings, but it could NOT see any Bluetooth devices to connect to.

 

After installing your Kexts, it now sees all Bluetooth devices. Here's the problem: Bluetooth mice are nearly unusable because the cursor is "jumpy". It is like this with 2 different Bluetooth mice I've tried. And no, changing the "tracking speed" settings in the "Mouse" preference pane is of NO HELP. I first tried an Apple "Magic Mouse", which seems to have a "lag" in the cursor compared to the mouse's movement. (If I move it slowly, it seems to be better). I then tried a Logitech V470, which exacerbated the problem. With the Logitech, besides being "jerky", it is so sensitive that it is virtually unusable.

 

QUESTION: Is there a way to edit any "attributes" inside a particular "Kext"or perhaps a "Preference" file to alter the "tracking" and "cursor acceleration" attributes of Bluetooth mice?

 

Thanks!


You are all going to think I'm CRAZY - right after I posted my problem about "jerky cursor" with my Apple "Magic Mouse", it lost its connection. I waited a couple of seconds, used my trackpad to click on the Bluetooth Menu (in the menu Bar), and at the same time, it re-connected on its own. Now the cursor is PERFECT! Smooth, and scrolling works as it should, both vertically AND horizontally. I am at a loss.....

 

But I'm also THRILLED that it works now!

 

THANKS AGAIN to "edwin_3930K"



#95
phaberest

phaberest

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male

I solved backing up and deleting /Library/Preferences/com.apple.Bluetooth.plist, then rebooted and everything worked as usual. :)



#96
jjsanderson

jjsanderson

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Useful thread, thanks. My Mac Pro lost its bluetooth card a few years ago, and I've been relying on a third-party USB module since then. For the most part I forget about it and it 'just works.'

 

After a power outage last night: no mouse on restart. My troubleshooting brought me here, and it turned out the fix was as simple as removing /Library/Preferences/com.apple.Bluetooth.plist and restarting. I'm slightly surprised that worked, since I guess there's little difference between a Mac Pro and a Hackintosh running third-party bluetooth adaptors.



#97
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary

Useful thread, thanks. My Mac Pro lost its bluetooth card a few years ago, and I've been relying on a third-party USB module since then. For the most part I forget about it and it 'just works.'

After a power outage last night: no mouse on restart. My troubleshooting brought me here, and it turned out the fix was as simple as removing /Library/Preferences/com.apple.Bluetooth.plist and restarting. I'm slightly surprised that worked, since I guess there's little difference between a Mac Pro and a Hackintosh running third-party bluetooth adaptors.

when you delete the plist, by doing that you just change the bluetooth adapter power state to 1 (so if you edit the plist, you'll get the same effect)

Also this problem is present on real macs too. Apple simply dropped some bluetooth adapter support by modifying the driver structure. If you read my post in this topic (don't know which page, I'm on mobile now) you can see that I wrote what they changed exactly. So this is not hackintosh related problem.

#98
cuckooklukka

cuckooklukka

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

My problems are fixed! I'v made a file for you guys which should fix your bluetooth problems in mavericks.

 

This fix should repair connection/discover/pair problems with bluetooth in Mavericks.

 

Also helped me fix a problem were my magic mouse was recognised as normal mouse. (no multitouch/gestures enabled.)

 

Drop all the files (simultaneously) into the Kext Utility. Wait until process is done (fill in password when ask).

 

Reboot.

 

Bluetooth should now work properly.

 

——

Note: Do not turn off bluetooth. 

——

 

attachicon.gifScreen Shot 2013-11-09 at 17.29.27.pngattachicon.gifScreen Shot 2013-11-09 at 17.29.11.png

 

attachicon.gifBluetooth 10.9.0 Fix.zip

 

 

 

 

Let me know if it worked  ^_^

 

*Try at own risk*

 

Works perfect. Thanks Edwin!



#99
th3joker

th3joker

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts

Thanks for the files to fix my bluetooth was driving me round the bend :-)



#100
insoft

insoft

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

My problems are fixed! I'v made a file for you guys which should fix your bluetooth problems in mavericks.

 

This fix should repair connection/discover/pair problems with bluetooth in Mavericks.

 

Also helped me fix a problem were my magic mouse was recognised as normal mouse. (no multitouch/gestures enabled.)

 

Drop all the files (simultaneously) into the Kext Utility. Wait until process is done (fill in password when ask).

 

Reboot.

 

Bluetooth should now work properly.

 

——

Note: Do not turn off bluetooth. 

——

 

attachicon.gifScreen Shot 2013-11-09 at 17.29.27.pngattachicon.gifScreen Shot 2013-11-09 at 17.29.11.png

 

attachicon.gifBluetooth 10.9.0 Fix.zip

 

 

 

 

Let me know if it worked  ^_^

 

*Try at own risk*

 

Hello Edwin,

 

I have an issue with my Atheros 3011. It is stuck on 'ON' sate and i cannot disable it at os level. I am able to pair and send files. However I am not able to receive files to my laptop. I tried your kexts and it too made no difference.  I tried deleting com.apple.bluetotth.plist and rebooting. Still no luck.







2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy