Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
nyolc8

Bluetooth stuck in "ON" state and not working

121 posts in this topic

Recommended Posts

I never had to do anything with the bluetooth kexts to get working bluetooth. My adapter vendor id and device id are in the kext by default. It's in the 10.9 bluetooth kext too. Bluetooth icon appears in system preferences, but I just can't disable it, I push the button and nothing happens. And also it can't find any bluetooth device. Is this a bug in the kext? My device is in the kext by default so I don't get why it's not working. I tried to use 10.8 kext and everything works fine. So something wrong with the 10.9 bluetooth kext. Is anyone else have similar problem?

 

The button not working and the indicator spins forever, and no device appears.

post-150972-0-47323600-1371291796_thumb.png

Share this post


Link to post
Share on other sites

Same issue here. However i can see my devices, but im unable to connect / pair. And it's stuck in ON. Working fine in 10.8, with wireless trackpad / keyboard. Could you tell me what .kext u used from the 10.8 partition for your 10.9 DP1 install?

Only things i tried yet to get it going was doing some resets with the "bluetooth explorer" utility. 

Share this post


Link to post
Share on other sites

I'm using the IOBluetoothFamily.kext from 10.8.4. I just replaced it. I hope I won't have to do this in final...

Share this post


Link to post
Share on other sites

Gigabyte GA-G31M-ES2C and a bluetooth adapter made by Trust   Vendor ID: 0xa5  Product ID: 0x2101.  I have the same strange connectivity issues. Bluetooth seems to be on but no device is detected. Any ideas?

Share this post


Link to post
Share on other sites

Bluetooth has the same issue in Maverick dp1, I think it is not working on purpose.... cause maybe Bluetooth 5.0 on the door (u never know)


I have the same issue, I can see all my devices including iphone 5, magic mouse, etc....


Share this post


Link to post
Share on other sites

You can use the ML IOBluetoothFamily kext and it will work fine. It works for me. I hope this is just a bug and will be fixed in later builds.

Share this post


Link to post
Share on other sites

Hi Nyolc8.I'm using IOBluetoothFamily.kext version 4.0.7 at the moment. With this version I at least can see the bluetooth icon.If I use version 4.2.0 the Bluetooth icon disappears. What version are you using?

Share this post


Link to post
Share on other sites

Same issue here! I tried 3 different USB dongles with different chips, so I wonder if its a USB controller issue. Tried swapping IOBluetoothFamily kext with one from 10.8.3 but doesn't change anything. I'll grab the kext from 10.8.4 tomorrow at work and post again. Good luck!

Share this post


Link to post
Share on other sites

Weird! I swapped my kext with 4.1.4 from ML using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], but after several reboots my system profiler still reports "Apple Bluetooth Software Version: 4.2 beta" and the problem remains.

 

Is IOBluetoothFamily kext the only ingredient here? Or am I missing something??

Share this post


Link to post
Share on other sites

I reinstalled by making my own vanilla USB installer (not myhack) which got rid of my bluetooth problem. The stock 10.9 DP1 kexts are working fine now.

Share this post


Link to post
Share on other sites

I always make my installer without any tool, so I did mine without anything, and I've got this problem... so... I think it's caused by something else...

Share this post


Link to post
Share on other sites

i have the same problem here. With my macbook the bluetooth is working but on my hack it's not working :(

 

EDIT: Using the version from 10.8.4 everything is working ;)

Share this post


Link to post
Share on other sites

DP2 came out, same problem persist... I think we'll need to figure out same bin patching.... (or rollback)

Share this post


Link to post
Share on other sites

With 10.8.4 kext, it's working, and I can turn it off/on, but I would prefer to use the original kext like I did before on ML... But it looks like this will ends now... :(

Share this post


Link to post
Share on other sites

DP2 here. Patched to the 10.8.4 kext. Bluetooth turns on an off, but I can't connect to my devices. Worked fine after patching on DP1. Anybody else getting this?

Share this post


Link to post
Share on other sites

DP2 here. Patched to the 10.8.4 kext. Bluetooth turns on an off, but I can't connect to my devices. Worked fine after patching on DP1. Anybody else getting this?

Anybody? Still haven't gotten this fixed on DP2. Bluetooth goes into discoverable mode (I can see the light flashing on my usb dongle), but my devices never show up in the list when I try to pair.

Share this post


Link to post
Share on other sites

I just got WORKING BLUTOOTH WITH UNMODIFIED 10.9 DP2 KEXT! :thumbsup_anim:

post-150972-0-79284500-1372941356_thumb.jpg

 

And the solution was extremely easy:

- just went to /Library/Preferences/com.apple.Bluetooth.plist

- Changed the "ControllerPowerState" to 1.

- Reboot.

- And boom, it's working lol. :lol:

 

(but can't/don't disable it because then you have to modify the plist again to get it working)

 

So it looks like they changed some power state related things in the kext, and that is the problem. Btw I read on some forum that there is people with bluetooth problems on real macs too. So still hoping that this is just some bug.

 

edit: tested every function that I could, and looks like everything works, file sending, browsing the bluetooth device, etc... Just can't disable bluetooth, and can't change the "discoverable" setting anywhere. I just can't find the place for discoverable option... And I see that discoverable is disabled (and greyed out) in the cmd+click bluetooth menu.

 

edit2: just noticed the stretched bluetooth icon on the file sending window, it looks like bluetooth is not completed yet...

Share this post


Link to post
Share on other sites

I just got WORKING BLUTOOTH WITH UNMODIFIED 10.9 DP2 KEXT! :thumbsup_anim:

I did tried this, but I'm still having issues. Changed the setting, rebooted, but my mouse, keyboard, and phone don't show up in the Bluetooth page in System Preferences. Oddly, when I have the page open, the menubar actually says it's in discoverable mode, and I see the lights blinking on my dongle, so that's funny you can't get yours in discoverable mode.

 

Now that I think abut it, I'm not sure if I'm using the kext from DP1 or 2 (things got lost from swapping out kexts and whatnot). Does anybody have a copy of the DP2 kext they can post/share in case the previous method only works with the DP2 kext and not DP1?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×