Jump to content

iMessage/Messages Fix-How To

iMessage Messages Fix

  • Please log in to reply
102 replies to this topic

#61
HBP112358

HBP112358

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts
  • Location:USA

Thank you for the tip but nothing changed. "Timeout" and some Partition Hide functions arent working, but stuff like the monitor resolution is working... strange.

Sorry for offtopic :king:


check for unclosed <keys> that is what killed mine

HBP

#62
doteleven

doteleven

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Getting a different problem here, I didn't see anybody else see the same, seems these are from Clover though.

Switched over to clover using the fixed. and viola! It works. I can now use iMessage again, however I noticed 2 things at least:

1. My clock keeps becoming off, It has gotten as far as 15 mins behind until I fixed it, I just resync the times.
2. I have to unplug my USB keyboard, to select a boot hd, and then move it again to get it to work after being booted, any ideas?

#63
c0d3s

c0d3s

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Are there possibilities to do that fix in chameleon?

#64
cracklincrotch

cracklincrotch

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
I already had Clover R1000 installed when I found this was a problem for me. I modified the config.plist file on the EFI partition only by adding the keys noted below with the following procedure:

1. Open a terminal screen

2. mkdir /volumes/efi

3. sudo mount -t msdos /dev/disk0s1 /volumes/efi (use whatever hard disk name is appropriate for you)

4. nano -w /volumes/efi/config.plist

5. Paste in the following. Change the serial number


<key>RtVariables</key>
<dict>
<key>MLB</key>
<string>W88GG136DHJQ13579</string>
</dict>
<key>SMBIOS</key>
<dict>
<key>SerialNumber</key>
<string>W88GG136DHJQ13579</string>
</dict>

6. Modify the serial number "W88...." to match yours, and add five random digits. I added 13579 to my existing serial number. I got my serial from "About this Mac" > "More info..." Don't know if the original serial number is important or not and I didn't care to find out.

7. Save file.

8. Rebooted and logged in successfully.

#65
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary

Are there possibilities to do that fix in chameleon?

I think somebody will make the fix (like for facetime), or they just copy the fix from clover, and then that will integrated into chameleon.
(waiting for this too)

#66
nateB

nateB

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
I'm not sure where I'm going wrong. I'm stable with Clover and my system runs well. But I can't seem to get this iMessage thing fixed. I'm using a patched DSDT.aml, ALC8xxHDA.kext, AppleRTC.kext, FakeSMC.kext, IOAHCIBlockStorageInjector.kext, and JMicron36xeSATA.kext on a Gigabyte EX58-UD5.

This is my config.plist (where the XXXXXXXXXXX represents the SN):

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SystemParameters</key>
<dict>
  <key>boot-args</key>
  <string>-v npci=0x2000</string>
  <key>prev-lang:kbd</key>
  <string>en:0</string>
  <key>InjectSystemID</key>
  <string>Yes</string>
  <key>LegacyBoot</key>
  <string>PBR</string>
  <key>DefaultBootVolume</key>
  <string>256M41</string>
</dict>
<key>Pointer</key>
<dict>
  <key>Speed</key>
  <string>8</string>
</dict>
<key>Graphics</key>
<dict>
  <key>GraphicsInjector</key>
  <string>Yes</string>
  <key>PatchVBiosBytes</key>
  <dict>
   <key>Find</key>
   <data>gAeoAqAF</data>
   <key>Replace</key>
   <data>gAeoAjgE</data>
  </dict>
</dict>
<key>RtVariables</key>
<dict>
<key>MLB</key>
<string>XXXXXXXXXXX12345</string>
</dict>
<key>SMBIOS</key>
<dict>
<key>SerialNumber</key>
<string>XXXXXXXXXXX12345</string>
</dict>
</dict>
</plist>

Am I off on syntax or is it something else? Thanks.

#67
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
for me is ok!!! put your serial and test if work, if not work try change your Apple Passw, this work for me

#68
Adam1203

Adam1203

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Has anyone else noticed that after using the clover fix, there's now a boot.log and nvram.plist on the root of the boot driver after reboots?

#69
Regi Yassin

Regi Yassin

    Who am I ?

  • Members
  • PipPipPipPipPip
  • 278 posts
  • Gender:Not Telling

Has anyone else noticed that after using the clover fix, there's now a boot.log and nvram.plist on the root of the boot driver after reboots?

yes, its autogenerated
Chameleon has fixed this issue :D

#70
Adam1203

Adam1203

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

yes, its autogenerated
Chameleon has fixed this issue :D


Are there any extra steps to install the Cham 2170 after the clover fix has been used?

#71
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,957 posts
  • Gender:Male
New Chameleon not working still...

#72
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,827 posts
  • Gender:Male
Hi, Rampage!

It worked like a charm for me, with little effort. Which errors are you experiencing?

Best regards.

#73
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary
I installed chameleon 2171 with that fileNVram module, and now iMessage says that my Apple ID can't be used for iMessage this time, and there is a button which is to register my appleid throught some phone number... Anyone else getting this?

#74
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
change your passw in your AppleID account, and try again

#75
Adam1203

Adam1203

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

New Chameleon not working still...


I ended up reloading my hack. Something with the Clover fix was left behind, and I couldn't get the Chameleon fix to work.

Now, it works great.

#76
ameris_cyning

ameris_cyning

    I don't know what to write here

  • Donators
  • 956 posts
  • Gender:Male
  • Location:My apartment
  • Interests:OSx86, female anatomy, electronic music, Clover EFI
Ive noticed that iMessage still works with Chameleon now. I guess that means that iMessage only registers once (when Clover EFI was used)

#77
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,957 posts
  • Gender:Male

Hi, Rampage!

It worked like a charm for me, with little effort. Which errors are you experiencing?

Best regards.


Same error as before... no changes.

#78
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,827 posts
  • Gender:Male
"Call Apple"?

#79
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,957 posts
  • Gender:Male

"Call Apple"?


No I did not

Error:

Attached File  Screen Shot 2013-01-23 at 9.32.00 AM.png   101.15KB   12 downloads

#80
maximus

maximus

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Croatia
  • Interests:Everything IT related, Hi-Fi audio, good books
I am getting the "call support" error. Tried changing password,tried new account,all I get is "call support with this number " error.





Also tagged with one or more of these keywords: iMessage, Messages, Fix


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy