Jump to content

Lion kernel testing on AMD (don't ask help here: use the Help Topic)


  • Please log in to reply
605 replies to this topic

#221
instant idiot

instant idiot

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts
  • Gender:Male
http://wiki.osx86pro...Patched_Kernels

#222
geminidragonrx7

geminidragonrx7

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:USA
Running great with Bronzovka 32/64-bit kernel. :thumbsup_anim: Can boot in either 32-bit kernel with 64-bit userland or 64-bit kernel with no graphics issue. Only problem is in 64-bit kernel that certain kext does not work properly or not at all, for example sound. Flash does not work well with 64-bit kernel. I did an install of snow leo, then using the mpkg install of lion, then replaced with the amd kernel. Note: Anv AutoAMDTool doesn't work and just instantly closes. I tried to patch in System and Applications as directed.

System Build:
CPU: AMD Phenom II x4 820 2.8Ghz with L3 unlocked to 6MB
Mainboard: MSI 790FX-GD70
Graphics: AMD/ATI Radeon HD5850 flashed rom to clock high as HD5870
Storage: 74GB Raptor Sata Drive and 750GB Western Digital Black Edition Sata Drive
OS: Dual boot with Windows 8 Pro 64-bit and Mac OS X Lion

Can't wait to see a 32-bit/64-bit kernel with 64-bit userland on Mountain Lion. :afro:

#223
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 243 posts
I tried the http://osx86.co/f100...d-kernel-t7687/ kernel I thought this will be a good 64 bit, but does not go further than USBF or jnl . this is not a help post.

#224
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 243 posts
Anyone facing problems like flash videos in youtube ?

#225
srwind

srwind

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male

Anyone facing problems like flash videos in youtube ?


Yes, i've this problem too in Firefox but in Safari all OK

i restarted firefox with switched Off applets and all working...

#226
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 243 posts

Yes, i've this problem too in Firefox but in Safari all OK

i restarted firefox with switched Off applets and all working...


So FF is the problem and not flash. What applets did you switch off ?

#227
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 809 posts
  • Gender:Male
i did kernel for 10.7.5 and works on FX .
For Mountain i no did , is no time .

#228
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,531 posts
  • Gender:Male
Hi, Bronzovka!

Can you please provide a link for your new 10.7.5 kernel?

Does it work with nVidia cards?

Is it 32-bit with 64-bit userland, or is it arch=x86_64?

Best regards!

#229
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 809 posts
  • Gender:Male
Theconnactic , yes , http://www.mediafire...lz9gow6rw3k6dav . It is lion 10.7.5 !
But in here post only for Muontain )))
It is 32 bit with 64 bit userland ! And fix 64 bit and work only 64 bit with flag arch=x86_64 !
You can test only x86_64 or i386 .

#230
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,531 posts
  • Gender:Male
Yes, thank you, Bronzovka: we need it for our kernel database. :)

One last question: will it work with nVidia cards?

#231
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 809 posts
  • Gender:Male

Yes, thank you, Bronzovka: we need it for our kernel database. :)

One last question: will it work with nVidia cards?


I think maybe yes . You should test for nvidia .

#232
srwind

srwind

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male

So FF is the problem and not flash. What applets did you switch off ?


switched off all applets
and than flash starts to work
else it dosen't work

#233
gils83

gils83

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,276 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique
hello Bronya

why FX 6100 / GT 610 = KP :(

#234
geminidragonrx7

geminidragonrx7

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:USA

switched off all applets
and than flash starts to work
else it dosen't work


I had the same problem because Firefox was running in 64-bit and Flash is 32-bit. Run Firefox in 32-bit and Flash will run properly. Go to Application->Firefox->Right Click->Get Info->Check "Open in 32-bit mode". That should solve it. If anyone can guide me how to make a DSDT file for my setup, so I can share it with people with a similar build?

Theconnactic , yes , http://www.mediafire...lz9gow6rw3k6dav . It is lion 10.7.5 !
But in here post only for Muontain )))
It is 32 bit with 64 bit userland ! And fix 64 bit and work only 64 bit with flag arch=x86_64 !
You can test only x86_64 or i386 .


Does this work for Phenom II CPU's? I have a Phenom II x4 820 quad core working well on your 10.7.4 kernel.

#235
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 809 posts
  • Gender:Male

hello Bronya

why FX 6100 / GT 610 = KP :(


What KP ? AppleEFIRuntime.kext ? You can sent your's picture for KP ?

#236
gils83

gils83

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,276 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique

What KP ? AppleEFIRuntime.kext ? You can sent your's picture for KP ?



I kp loading NVDAGF100Hal.kext


I found the problem, the kernel works 100% in i386 with 64 bit support ;)


c'était le kext AppleTyMCEDriver.kext qui posait problème ;)

#237
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,531 posts
  • Gender:Male
Interesting, Gilles! Can you upload a screenshot? Would be useful to see the adresses/opcodes listed in the panic message. :)

#238
gils83

gils83

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,276 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique
:)

voilà quelques résultats encouragent après avoir supprimé AppleTyMCEDriver.kext ;)

here are some encouraging results after removing AppleTyMCEDriver.kext :)


Posted Image


Posted Image

L'encodeur QuickTime fonctionne :)

The QuickTime encoder works :)

Posted Image


VLC fonctionne :)

VLC works :)


Posted Image


http://www.youtube.com/watch?feature=player_detailpage&v=waqDZuce9Xk

Edited by gils83, 09 February 2013 - 12:23 PM.


#239
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,531 posts
  • Gender:Male
Gilles, if i understand you correctly, you're running Lion 10.7.5 with a Mountain Lion kernel. Is there accurate?

#240
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 243 posts


I am using in 32 bit and my GT 210 got accepted during install and did not need any kexts of EFI strings , but being on an AMD @32bit I am not getting dual screen , one is on DVI and the other on VGA.

Hmm if I use arch=x86_64 I get to the login screen but with graphics corruption.






2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy