Jump to content

Instant Reboot at the Apple Logo (Pre-Installation) (Vaio VPCEB46FG)

vaio reboot vpceb46fg stuck Empire EFI

  • Please log in to reply
84 replies to this topic

#1
kushsolitary

kushsolitary

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male
Hey!

I just tried to install Mountain Lion on my Vaio VPCEB46FG but when I inserted the ML DVD (after loading i B o o t) and pressed enter, I saw the apple logo for a few milliseconds and then the laptop rebooted. I also tried PCIRootUID=1 flag with -x but then it gets stuck on the apple logo (no loading animation, just the apple logo).

This is the image of the apple logo my laptop gets stuck at

Posted Image

I don't have any option in my BIOS for enabling AHCI but I am pretty sure it's already enabled. Check the image below:

Posted Image

I tried with -v -x flags and as it got rebooted again, I made a video for you guys to see the errors. Here's the video



and here's the same screen (without ATI info) in Virtual Box. Yes, the same reboot thing happens in virtual box too!

Posted Image

I think this information will be enough to track down the error. Oh, and here's my config
  • Intel Core i5 480M
  • 4GB DDR3 RAM
  • 500GB Hard disk
  • ATI Mobility Radeon 5650HD
Btw, I only tried with i B o o t and Empire EFI with same results. Tell me if I should try i B o o t Legacy too. Thanks

#2
HUSABER

HUSABER

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 938 posts
  • Gender:Male
  • Location:Cyprus
  • Interests:HusabergFC-600 FourStroke,KTM500 TwoStroke,TM300 TwoStroke
    Free Time-My Hackintosh&Ap...
Bootloader is problem here.(for me :wink2: )

#3
kushsolitary

kushsolitary

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male
Which one should I try then?

#4
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
Hi, kushsolitary!

Refer to this link, that gives a comprehensive step by step on how to instal Mountain Lion on any PC: The all-in-one guide to Vanilla OS X Mountain Lion + Cham...

Good Luck, and report back - i want to know what worked for you.

P.S.: beware of misleading titles: your problem is everything but an instant reboot. :)

#5
everdone

everdone

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 303 posts
Major problem: arch=i386 - signifies 32 bit operation, ML is 64 bit only.

#6
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
Yeah, but since the T.S. didn't mention this flag, i think perhaps it was added automatically by the bootloader he

#7
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Aside from the obvious issues such as using #####, what was that about a ML DVD?

#8
kushsolitary

kushsolitary

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male

Aside from the obvious issues such as using ######, what was that about a ML DVD?


Yes I am using the ML DVD. I think this problem is specific to ML as many people are having the same problem. I will get the Lion DVD soon to test it. Apart from ###### and Empire EFi, what are my other optionS?

Major problem: arch=i386 - signifies 32 bit operation, ML is 64 bit only.


This bootflag is in the screenshot from Virtual Box. I never entered it manually.

Hi, kushsolitary!

Refer to this link, that gives a comprehensive step by step on how to instal Mountain Lion on any PC: The all-in-one guide to Vanilla OS X Mountain Lion + Cham...

Good Luck, and report back - i want to know what worked for you.

P.S.: beware of misleading titles: your problem is everything but an instant reboot. :)


I don't have access to a mac so this method ain't for me. Anyways, thanks for the fast replies! :)

#9
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
man, try this and 0 problems:OS X 10.8 Mountain Lion bootable USB

#10
kushsolitary

kushsolitary

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male

man, try this and 0 problems:OS X 10.8 Mountain Lion bootable USB


This seems to be a good choice. I will download it right now and btw, I just ordered a 16GB pen drive for this :D

Edit: Started downloading, it will take 2 days :/
I will update about my progress. Thanks again :)

Btw, can anyone confirm that I have AHCI already enabled by looking at the second image?

Edited by kushsolitary, 26 September 2012 - 11:52 AM.


#11
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
for AHCI you need see in your Bios, if your bios have this option set SATA for AHCI

#12
kushsolitary

kushsolitary

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male

for AHCI you need see in your Bios, if your bios have this option set SATA for AHCI


As I already mentioned in my first post, there is no option for setting up AHCI in my BIOS (it's hidden by default) but I have heard that these laptops come with AHCI pre-enabled.

#13
kushsolitary

kushsolitary

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male
Got the pen drive delivered just now and ML finished downloading. Trying it now and will report soon :)

Edit: upon first run, I got ApplePolicy KP which I fixed by deleting the respective Kext. After that, I got stuck at [PCi Configuration Begins] which I again fixed by using old IOPCIFamily.kext. After that, I got some USBF errors which I fixed using "USBBusFix=Yes"

But now, I am getting stucked here. I tried deleting all the ATI*.kext files and booting with "-f GraphicsEnabler=No" but still no success.

Posted Image

#14
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
this is the mkext or the kext from Extra/Extensions of the your USBInstaller VoodooTrackpad.kext, see if you can delete this kext and use a mouse and keyboard USB for install

#15
kushsolitary

kushsolitary

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male

this is the mkext or the kext from Extra/Extensions of the your USBInstaller VoodooTrackpad.kext, see if you can delete this kext and use a mouse and keyboard USB for install


Yes, I have a USB mouse and keyboard. Lemme try this

Edit: There is no "Extensions" folder in my /Extra folder. It only contains Preboot.dmg

Edited by kushsolitary, 28 September 2012 - 08:44 AM.


#16
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
mount prebot.dmg and you have Extra/Extensionss

#17
kushsolitary

kushsolitary

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male
After mounting, I found Extensions.mkext and org.Chameleon.Boot.plist. What should I do with the Extensions.mkext?

#18
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
you can delete de mkext and put only two kexts, FakeSMC.kext and NULLCPUPowermanegement

#19
kushsolitary

kushsolitary

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male

you can delete de mkext and put only two kexts, FakeSMC.kext and NULLCPUPowermanegement


now I am getting stuck at "DSMOS has arrived"

#20
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
backup first all graphics kexts, now delete all from S/L/E USBInstaller





Also tagged with one or more of these keywords: vaio, reboot, vpceb46fg, stuck, Empire EFI

  Topic Stats Last Post Info

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy