Jump to content

[GUIDA][90%WORK]Installare Snow Leopard Retail su Acer Aspire 5733

aspire 5733 i3 installazione acer snow leopard retail 10.6 combo update 10.6.7 boot

  • Please log in to reply
10 replies to this topic

#1
alexgti18

alexgti18

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Macherio
Ciao a tutti,
dopo anni passati dal mio primo e "Full Work" hack usando una iDeneb 10.5.6 -su un Extensa 5220- e senza aver avuto necessità di usare questo magnifico forum, ora chiedo gentilmente aiuto a voi!
Premetto che ho cercato in tutta la rete..ma per questo Aspire 5733 nessuno ha fatto un hack -possibile che sia io il primo?-
Passiamo ai fatti:
inizialmente provai con una Lion (precisamente iAtkos_L2) ma senza nessun risultato..non ne vuole sapere di partire..ho provato in tutte le maniere ed ho alla fine mollato.
Adesso mi ritrovo con Snow, però niente Hazard o distro..solo con un DVD originale acquistato direttamente (ho anche un MacBookPro, "originale") alla Apple.
Bene, ho seguito la procedura classica per una Retail: lboot. Funziona. Si installa tutto e dopo i famosi 26 minuti, entro nella Scrivania del felino bianco.
Piccoli problemi però:
niente wifi, niente ethernet, niente USB, niente risoluzione a 1366x768, niente.
Cercando in giro i vari Kext mi trovo di fronte alla più totale ombra, ma è possibile che non ci sia nulla? L'unica cosa che funziona subito è l'audio.
Ho provato anche ad installare chamaleon, ma l'installazione non va a buon fine, mai. Devo lasciar perdere? Su questo Acer non si può testare nulla?
Per aiutarvi al meglio, vi posto un lspci -nn dell'hardware.

0:00.0 Host bridge [0600]: Intel Corporation Core Processor DRAM Controller [8086:0044] (rev 02)
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)
00:16.0 Communication controller [0780]: Intel Corporation 5 Series/3400 Series Chipset HECI Controller [8086:3b64] (rev 06)
00:1a.0 USB controller [0c03]: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller [8086:3b3c] (rev 05)
00:1b.0 Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio [8086:3b56] (rev 05)
00:1c.0 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 [8086:3b42] (rev 05)
00:1c.1 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 [8086:3b44] (rev 05)
00:1d.0 USB controller [0c03]: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller [8086:3b34] (rev 05)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev a5)
00:1f.0 ISA bridge [0601]: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller [8086:3b09] (rev 05)
00:1f.2 SATA controller [0106]: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller [8086:3b29] (rev 05)
00:1f.3 SMBus [0c05]: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller [8086:3b30] (rev 05)
00:1f.6 Signal processing controller [1180]: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem [8086:3b32] (rev 05)
01:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe [14e4:1692] (rev 01)
02:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)
ff:00.0 Host bridge [0600]: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers [8086:2c62] (rev 02)
ff:00.1 Host bridge [0600]: Intel Corporation Core Processor QuickPath Architecture System Address Decoder [8086:2d01] (rev 02)
ff:02.0 Host bridge [0600]: Intel Corporation Core Processor QPI Link 0 [8086:2d10] (rev 02)
ff:02.1 Host bridge [0600]: Intel Corporation Core Processor QPI Physical 0 [8086:2d11] (rev 02)
ff:02.2 Host bridge [0600]: Intel Corporation Core Processor Reserved [8086:2d12] (rev 02)
ff:02.3 Host bridge [0600]: Intel Corporation Core Processor Reserved [8086:2d13] (rev 02)


Per qualsiasi domanda, sono qui.

Grazie a tutti coloro che vorranno aiutarmi, in questa -mi viene da dire- impresona su questo strano modello di Acer (in firma).



UPDATE ore 01.31 del 1 Agosto 2012:
Dopo ore e ore, sono riuscito ad installare la 10.6 e subito dopo anche il combo update 10.6.7
Funziona l'audio, le USB e sono riuscito a far riconoscere l'ethernet.
Per le USB occorre eliminare da S/L/E/ il kext: AppleHPET.kext;
bisogna eliminare anche IOPlatformPluginFamily.kext per evitare un bel kernel panic al riavvio;
per l'ethernet servono dei kext nuovi e una modifica al solito org.chameleon.boot.plist (ma ce ne occuperemo dopo);

sembra che tutto sia pronto, faccio per riavviare..e..

ACPI_SMC_PlatformPlugin::start - waitForService (resourceMatching (AppleIntelCPUPowerManagement) timed out
provo con -v -x, npci=0x2000, PciRootUID=1...ma nada...sempre la stessa storia con quel messaggio ACPI..

come si può fare? non ho più idee...forse occorre rimuovere qualche kext ancora...avete idee? adesso la storia è diversa..qualcuno che si mette insieme a me a cercar di capire?

#2
alexgti18

alexgti18

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Macherio
Dio salvi la community ;-)
Sbattendoci la testa, sbattendoci kext, rimuovendoli, testando e ritestando...finalmente sono (quasi) riuscito a trovare una configurazione completamente funzionante per questa "dannata" installazione di Snow Leo Retail e successivo update alla 10.6.7 (con una combo ovviamente) sull'Acer in firma.
Cercando in rete ho trovato (finalmente) altri utenti -sempre pochissimi però- che hanno tentato questa impresa, ma non sono riusciti ad andare oltre che il boot.
Vorrei iniziare una [GUIDA] per tutti coloro che si cimentano, provano o incombono in problemi (sia sullo stesso tipo di PC che magari sulle stesse periferiche), sperando di fare cosa gradita.
Preavviso subito che la guida per il momento è da ritenersi [SEMI-COMPLETA], in quanto mancano ancora dei passaggi, che spero di risolvere a breve e di riuscire sopratutto a risolverli! ;-)

Partiamo con la guida:

Occorrente:
1_ DVD Retail di Snow Leopard 10.6
2_ lboot+MultiB. per Snow
3_ CD-R da sfruttare in seguito per portare sull'HD i tools e i kext utili (le USB non funzionano da subito)
4_ pazienza, molta pazienza (io sono alla decima installazione da zero..ma adesso, che già funziona abbastanza bene, clono ;-) )
5_ tempo

Iniziamo -come primo passaggio- con il procurarci i "presunti" kext (e tools) che ci serviranno poi per far "funzionare" i device:
CI serve:
lboot, multib, kext per BROADCOM57780, KextWizard, kext per IntelHD (cercate in google: kext 8086:0046 ), a questo punto dovremmo esserci (come primi step).

Iniziamo:

00) il BIOS deve essere in AHCI, quindi prima cosa, settatelo correttamente ;-)
01) preso lboot, masterizziamo la ISO su CD;
02) facciamo il boot da CD;
03) quando il bootloader viene caricato, rimuoviamo il CD e inseriamo quello di Snow;
04) aspettiamo 5-10 sec. e premiamo F5;
05) quando trovate "Mac Os X Install DVD" siamo pronti: -v -f e premiamo Invio.

A questo punto dobbiamo aspettare che tutto vada bene durante il primo caricamento, ci vorrà un po' ma non siate impazienti!

06) ci dovremmo trovare alla schermata di inizio installazione, scegliete la lingua preferita;
07) dobbiamo preparare l'Hard Disk adesso: dal menù principale clicchiamo Utiliy -> Utility Disco;
08) partizioniamo come vogliamo l'hard disk dandogli un nome (MacHD); N.B. Tabella Partizioni GUID ovviamente e Mac Os Esteso Journaled;
09) adesso selezioniamo proprio MacHD (qui verrà installato Snow);
10) facciamo partire l'installazione (ci vorranno 27-30 minuti) -pazienza, ricordate?-
11) al termine dobbiamo riavviare, teniamo presente che non è stato inserito alcun bootloader, quindi appena si riavvia, dobbiamo reinserire il CD di lboot.
12) a questo punto riparte il bootloader e questa volta troviamo la scritta "MacHD"; anche qui -v -f e premiamo Invio;

Arrivati qui -se tutto è andato liscio- ci troviamo di fronte alla personalizzazione del nostro OS. Fate tutto quello che dovete e proseguiamo.

13) adesso ci troveremo -finalmente, direte voi- sulla Scrivania di OSX.

Non funzionerà nulla via che tastiera, mouse, audio (per il momento).
Siamo fortunati ad avere come risoluzione 1024x768 -meglio che 800x600 no?- ma per la 1366x768 non ho ancora risolto :( ma ci sto lavorando;

Ora dobbiamo sistemare un po' di cose:

14) USB: andate in /Sistema/Libreria/Extension/ e rimuoviamo "AppleHPET.kext", riavviamo e abbiamo le USB che andranno (ricordiamoci di tenere il cd di boot altrimenti non riusciamo ancora ad entrare);
15) a questo punto possiamo importare sull'hd i tools e kext che ci siamo preparati in precedenza; salviamoli in una cartella sulla Scrivania;
16) prima di procedere con l'update alla 10.6.7 (che provvederemo a scaricare su un altro pc e poi ad importare la dmg tramite pendrive sul nostro sistema) dobbiamo assolutamente rimuovere un kext che causa un bel kernel panic durante la conclusione dell'update: sempre in S/L/E rimuoviamo "IOPlatformPluginFamily.kext".
17) riavviamo per essere più puliti;
18) passiamo ora all'update di OSX: apriamo Multib. (dobbiamo solo aprirlo per adesso, non facciamo nient'altro) e montiamo la dmg dell'update di OSX;
19) installiamo l'update e aspettiamo la corretta conclusione: N.B. NON dobbiamo RIAVVIARE al termine, ma entra in gioco Multib. adesso;
20) selezioniamo EasyB. e System Utility, per il resto non ho selezionato nulla e tutto sembra andare comunque;
21) adesso possiamo RIAVVIARE, togliamo il cd di boot in quanto con Multib. abbiamo un bootloader su hd;
22) nella schermata di boot, su MacHD facciamo il solito -v -f e speriamo di non incombere in errori;

NOTA BENE:
Non so il motivo, ma dopo questo reboot tastiera e mouse del portatile non vanno più, per continuare sto usando una tastiera USB e un mouse USB. Questi vengono riconosciuti perfettamente.

[HELP_RISOLTO] Qualche idea per risolvere la tastiera e il mouse? (vedi UPDATE_POST successivo per risoluzione!)

Finalmente abbiamo aggiornato alla 10.6.7!
Ecco il risultato:
Attached File  012.JPG   1.7MB   10 downloads

Più dettagliato:
Attached File  013.JPG   1.37MB   18 downloads

ed infine la Scrivania:
Attached File  011.JPG   874.94KB   15 downloads

Adesso possiamo passare al riconoscimento della ethernet.
usiamo i kext BROADCOM 57780,

23) installiamoli usando KextWIzard e ripariamo i permessi;
24) riavviamo;
25) dobbiamo aggiungere nel file org.chameleon.boot.plist situato nella cartella /Extra/ queste righe:
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>device-properties</key>
<string>"14e4,1692"</string>
26) rechiamoci adesso in /Library/Preferences/SystemConfigurations/ ed eliminiamo NetworkInterfaces.plist;
27) dobbiamo riavviare ancora;
28) appena rientriamo, se ci rechiamo in Preferenze di Sistema -> Network troviamo nel menù laterale la nostra bella interfaccia enthernet. Dovremmo essere in grado di connetterci ad internet.

[KEXT ICONA BATTERIA][RISOLTO]
Se avete notato, l'icona della batteria non è presente, ma ho risolto anche questo problema:
usate questo kext: Attached File  226-VoodooBattery.kext.zip   40.82KB   12 downloads
cercate che non ci siano altri kext che possano andare in conflitto con questo, nel caso rimuoveteli. Usate il KextWizard per installare, riparate i permessi di S/L/E e l'icona della batteria comparirà in alto!

[KEXT VIDEO][NON RISOLTO]
Personalmente ho rimosso tutti i kext che non riguardando la scheda video in questione, ho installato con KextWizard i kext trovati in rete per questa scheda, ma per adesso non riesco a far rilevare la 1366x768x32, se c'e' qualcuno che può dare una mano, adesso è il momento.

[KEXT AUDIO][RISOLTO]
Dopo l'update, ho riscontrato che l'audio ha smesso di funzionare, non mi sono ancora cimentato, lo lascio per ultimo, in quanto (credo) il meno difficile. Però se qualcuno ha idee, è cosa ben accetta che lo dica ;-)
UPDATE:
per risolvere l'audio, scaricate questa pkg: Attached File  2509-VoodooHDA-2.7.3.pkg.zip   241.16KB   23 downloads
installate, riparate i permessi in /Extra e in S/L/E e l'audio torna a funzionare e bene!

[WIFI NATIVO][NON RISOLTO]
Non mi sono cimentato ancora, ma ho provato con una antenna esterna e funziona al 100%, prossimamente proverò a far funzionare la Atheros nativa di questo Aspire;

Per adesso è tutto (o quasi), siamo al 90% circa per avere un ottimo Snow.

Ho bisogna adesso davvero di qualcuno che mi aiuti a capire per la risoluzione video (faccenda più importante adesso!).

Ho provato con un flag "Graphics Mode"="1366x768x32" ma non lo considera minimamente.

COSA MANCA PER COMPLETARE IL TUTTO:

i) tastiera e mouse del portatile DEVONO tornare a funzionare, quale potrà essere la causa? [RISOLTO]
ii) risoluzione video, che si può fare?[SVARIATI TENTATIVI, NON RISOLTO]
iii) audio: cosa manca? [RISOLTO]
iv) wifi nativo?[NON RISOLTO]

Ora, che il grosso è fatto, qualcuno appassionato che mi aiuta?
Se abbiamo più idee, una soluzione si trova, sia per questo laptop, sia per le periferiche che potrebbero interessare altri!

#3
alexgti18

alexgti18

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Macherio
[UPDATE] Risoluzione tastiera e mouse non funzionanti al riavvio successivo all'installazione del combo update 10.6.7

Torno con un'ottima notizia! Sono riuscito a far ri-funzionare tastiera e mouse del laptop, dopo che appunto smettono drasticamente di funzionare in seguito al combo update di OSX.
La corretta procedura da me realizzata e testata è la seguente:

i) prendete questi kext: Attached File  1448-PS2-Synaptics-Keyboard-32+64.zip   121.58KB   6 downloads

ii) controllate che non ci siano voodoops2 in S/L/E e in /Extra;

iii) con KextWizard installate i kext presenti nel pacchettino che ho messo prima;

iv) riparate i permessi e cache di sistema;

FATTO! Ora siete tornati di nuovo abili ad usare tastiera e mouse!

#4
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 1,887 posts
  • Gender:Male
  • Location:Roma
ciao se non sei riuscito con la video prova questi
http://www.osx86.net...ics_latest.html

#5
alexgti18

alexgti18

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Macherio
ciao carlo e grazie per la risposta.
ho già usato questi kext..però riprovo ancora questa sera cercando di capire perché non si riesce a farli andare...
rimane impiantata a 1024x768 e senza tutto il resto ovviamente..

una volta sistemato questo problema, la guida si conclude e l'hack è perfettamente funzionante in tutto -escluso wifi nativo in quanto credo che per questa atheros non ci sia davvero nulla da fare- però sisitema con una antenna esterna (stasera posto il modello dell'antenna che ho che funziona al 100%).

#6
alexgti18

alexgti18

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Macherio
sera a tutti,
niente cattive notizie..il video proprio non riesco a sistemarlo..le ho provate tutte...ho seguito anche questo topic:
http://www.insanelym...pic=261912&st=0
ma non sono riuscito a schiodarmi oltre il 1024x768.
ho una partizione clone, diciamo funzionante -perché quella attuale sull'hd di prova- l'ho sputtanata con tutti i test, prove e il possibile per farla -o meglio cercare di farla- funzionare.
se qualcuno riesci in qualche modo a fixare sta benedetta Intel HD Graphics, lo faccia sapere!
grazie a tutti!

#7
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 1,887 posts
  • Gender:Male
  • Location:Roma
scusa ma il tuo acer non ha una gma 4500
mia sorella ha un acer5734
e credo che non vada cosi lontano dal tuo

prova questi

ce anche una guida su osx86project
prova anche ad aggiornare a 10.6.8

http://wiki.osx86pro...es#Aspire_5734z

http://www.insanelym...howtopic=280407
brutte notizie
se lo dice lui buoo hai perso

Attached Files



#8
alexgti18

alexgti18

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Macherio
ciao carlo,
niente, con amara delusione, dopo un'altra notte e tutta questa mattina passata a far prove e prove e prove..la scheda video non va.
ho provato anche i tuoi kext, ma non c'e' alcun verso di farla andare.
alla fine ho notato che anche la ethernet incontra problemi a seguito di tutte le modifiche fatte..
Snow su questo aspire proprio non ne vuole sapere, se non a 1024x768...ma non si può vedere questa risoluzione, fa proprio schifo! :thumbsdown_anim:
ci abbiamo provato e come conclusione, questo modello di acer è davvero pessimo per gli hack.
grazie per il tempo che mi hai dedicato.

#9
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 1,887 posts
  • Gender:Male
  • Location:Roma
di niente mi dispiace :worried_anim:

#10
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 1,887 posts
  • Gender:Male
  • Location:Roma
http://www.osx86.net...do=file&id=1037
prova un po ' questi

#11
alexgti18

alexgti18

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Macherio
di nuovo ciao,
ho provato anche con questi, tutto il possibile, abilito il quartz, la dock ha l'effetto specchio, ma la risoluzione è sempre fissa con quell'odiato 1024x768.
niente..non c'e' proprio verso di andare a 1366x768 con sta scheda :wallbash:
il caso sembra essere chiuso -purtroppo- :hammer:

p.s.
vorrei rifare un hack sull' eeepc 1001ha, ai tempi riuscii con una ideneb 10.5.6...ora riprovo con la snow...o addirittura una iatkos..così porto lui al mare :thumbsup_anim:

speriamo però di non incombere in problemi come questo!





Also tagged with one or more of these keywords: aspire, 5733, i3, installazione, acer, snow leopard, retail, 10.6, combo update 10.6.7, boot


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy