Jump to content

OS X Mountain Lion Install Guide for Dell XPS 17 L702x Optimus

* * * * * 6 votes

  • Please log in to reply
912 replies to this topic

#521
mackyreddy

mackyreddy

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 245 posts
  • Gender:Not Telling
  • Interests:Building Operating Systems from scratch
released new XPS 17 10.8.2 Kexts pack.

By the way guys just found that Safari is broken on the Micro OS X 10.8.2 Pre installed image, Shall i remove the download links and upload a new version ? Or shall i release a patch where u can copy & paste the safari app into applications folder.

#522
gabn

gabn

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

It's ST Accelerometer driver that is causing the hangs.
For Safe Mode to be accessible your computer has to fail at booting 3 times in a row. Then you are prompted to repair it, there-s no F8 hotkey in Windows 8's boot manager.

Strange... Enter key is not working when replying to your post 8-) But I know how to get into safe mode ;) That is not the problem. The problem is to install the quickset in safe mode... But I will uninstall the Accelerometer and report back! UPDATE: After uninstalling the ST Accelerometer driver and rebooting, the laptop still freezes when trying to install Dell Quickset... Also when pressing FN+F2, the laptop still freezes :(
<br>
I'am wondering if you could write a guide for the people that are booting from the UEFI instead of the old lagacy BIOS? That should be different, right? I would like to have both mac os x and windows 8 on the same SSD :)

#523
romturk

romturk

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

released new XPS 17 10.8.2 Kexts pack.

By the way guys just found that Safari is broken on the Micro OS X 10.8.2 Pre installed image, Shall i remove the download links and upload a new version ? Or shall i release a patch where u can copy & paste the safari app into applications folder.

A patch would be appreciated mackyreddy . took some time to download them all :)

#524
webcivilian

webcivilian

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 143 posts

uploading has just finished, check now

@webcivillian

regarding USB 3.0, have u installed PXHCD.kext ? try to install from desktop using kextutility.app, My usb 3.0 port is working fine, I dont think there is any problem with Custom A.19 bios. And with regards to Sleep, Firstly Do u have i7 2630 QM or 2670 QM ? have u used the SSDT's which i provided in the archive A.19 DSDT & SSDT's.zip ? The SSDT's which i provided are for i7 2630 QM, i forgot to add i72670 QM, i will add them now or u can find them Doix 1.4 universal installer.


@ mackyreddy

Everything works fine now. I had installed an USB3 kext which was the culprit. The only issue currently seems to be is Youtube flash 1080p/720p playback. It shows some artifacts on screen. Quicktime works fine btw.

#525
robin_hood

robin_hood

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Moscow
NEC/RENESAS USB3 Controller

1) firmwares update & Drivers for Windows Xp/Vista/7/8 32/64bits
http://www.station-d...age/renesas.htm

2) LaCie USB 3.0 drivers are here for OS X
http://www.insanelym...-here-for-os-x/

3) LaCie Mac Driver USB 3.0 (PXHCD kext of 1.0.11 version)
http://www.lacie.com...er.htm?id=10239

#526
mackyreddy

mackyreddy

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 245 posts
  • Gender:Not Telling
  • Interests:Building Operating Systems from scratch
well 1.0.11 version is quite buggy, try to boot in verbose mode after installing the kext.

But even i would recommend to update ur card specific firmware on windows and it should also stabilize functionality on OS X.

#527
JohnnyD

JohnnyD

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Location:Ohio, US
  • Interests:Computers
Well I got OS X 10.8.2 installed and going. Only problem I have is the damn artifacts. I tried updating my FakeSMC as I read it fixes on some systems. With 10.7 it was as simple as using SMCPingDaemon or FanControl. I have the unlocked bios is there something I can adjust to make them all go away? or some other solution Im not finding anywhere.

#528
mackyreddy

mackyreddy

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 245 posts
  • Gender:Not Telling
  • Interests:Building Operating Systems from scratch
@ JohnnyD

Well this trick always worked for me whenever i had artifacts, Try to clear caches /System/Library/Caches, except for these 4 folders com.apple.bootstamps, com.apple.corestorage, com.apple.CVMS and com.apple.kext.caches delete any files present in caches folder. Then Delete any sub folders & files present in those 4 folders but do note don't delete Directories & startup sub folder in com.apple.kext.caches but delete the files inside these folders.

Now days whenever I install OS X, i make sure i delete these things and then boot in to OS X, i never had any artifacts.

Hope this works.

#529
mackyreddy

mackyreddy

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 245 posts
  • Gender:Not Telling
  • Interests:Building Operating Systems from scratch
Well previous OS X 10.8.2 Pre installed image was a mess with lot of things broken, MBR patch was the culprit, uploading a new version ( Don't worry tested this time). Also integrated OS X 10.8.2 supplemental update in to the Pre installed image, updated download link on the first post. have fun.

cheers

#530
jbaribeault

jbaribeault

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Mackyreddy - excellent work!
I've been downlowding your pre-built 10.8.2 image but I've noticed that part 12 is missing. Any way to get that in there?

Cheers!

EDIT:
Looks like its there now! Thanks!

#531
romturk

romturk

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
hey @mackyreddy .. can you post a guide to install this 10.8.2 for noobs like myself :) regards

#532
raviji

raviji

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

hey @mackyreddy .. can you post a guide to install this 10.8.2 for noobs like myself :) regards


+1. Noob myself and looking forward to a guide :)

#533
romturk

romturk

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

+1. Noob myself and looking forward to a guide :)

anybody know how to extract this packages ?

#534
mackyreddy

mackyreddy

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 245 posts
  • Gender:Not Telling
  • Interests:Building Operating Systems from scratch
@ romturk & raviji

Well i think webcivillian has written a good tutorial. So i haven't published any tutorial as it would be more or less a similar guide.

#535
mackyreddy

mackyreddy

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 245 posts
  • Gender:Not Telling
  • Interests:Building Operating Systems from scratch
uploading OS X 10.8.2 Pre installed image has been finished.Keep all files in one folder, then run zip file and extract.

#536
TimeWalker75a

TimeWalker75a

    InsanelyMac Legend

  • Gurus
  • 1,020 posts
  • Gender:Male

I'am wondering if you could write a guide for the people that are booting from the UEFI instead of the old lagacy BIOS? That should be different, right? I would like to have both mac os x and windows 8 on the same SSD :)

Nothing different.. you have to have Clover UEFI configured as a bootloader, possibly a boot order entry added via shell 2.0 bcfg command....
I'm sorry I'm not good at writing guides. I have been hackintoshing since 2008 and my ways are somewhat different from what I can still read around here.. people have gotten lazy and yet want everything working perfectly. mackyreaddy still haven't figured out that for brightness hotkeys to work a properitaory kext IOWMIFamily by hotkoffy (recompiled to support new Dell WMI) is required. for brightness levels to be restored after reboots clover is required (I have proposed the backlight-level runtime variable to slice, so now the bootloader restores the value after reboot properly).. nor do I have an exact model discussed in this thread, so this makes my potential guide even more useless.

#537
Zpecter

Zpecter

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
  • Gender:Male
  • Location:Málaga (Spain)
Hi, I have tried the new 10.8.2 pre-installed image and I still have the same problem, it starts loading the kexts but when it finishes, the system reboots. :(

#538
mackyreddy

mackyreddy

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 245 posts
  • Gender:Not Telling
  • Interests:Building Operating Systems from scratch
Updated first post attachment with a new A.19 DSDT which has Fn Brightness keys patch and few other optimization fixes and also updated with IOWMIFamily.kext.

#539
c_cube

c_cube

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
been a while since i visited this thread.. been away for a loooooong time because of work..

decided to reformat my dell and reinstall hackintosh 10.7.4

but im experiencing kernell panic when i use this kext "AppleIntelCPUPowerManagement.kext" need to delete it in windows for mac os to boot.

Tried geekbench (64-bit) and only got 7328

specs - i7 2670QM

definitely something wrong here hehee

UPDATE:
i used the old "AppleIntelCPUPowerManagement.kext" from the old kext uploaded by mahesh for 10.7.2 before

now geekbench is up to 9335, still a far cry away from 10200 but better

#540
JohnnyD

JohnnyD

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Location:Ohio, US
  • Interests:Computers

Updated first post attachment with a new A.19 DSDT which has Fn Brightness keys patch and few other optimization fixes and also updated with IOWMIFamily.kext.


Did you update the DSDT that has the nvidia turned off as well?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy