Jump to content

OpenCL Oceanwave & Bandwidth Bench - 07. March 2013

OpenCL AMD NVIDIA

  • Please log in to reply
343 replies to this topic

#41
shatterhenner

shatterhenner

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
OS 10.7.1
Gigabyte GTX460 OC2

no multisampling

Run - 3,7 ms / 271 fps
Pause - 1,8 ms / 557 fps

#42
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Thanks !
My CPU has very less cpu % load when running that OpenCL bench. C2D less than 15% overall.
Good, because we be safe to measure more gnu than cpu.
WHats your CPU% load when running the bench? Should also be less 20%, otherwise some problem.

#43
shatterhenner

shatterhenner

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
cpu load is 5-7%

#44
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Cool, my C2D has more to do ;)
No other cpu loads needed, only post if your load is > 20%.

#45
Prowlerblizz

Prowlerblizz

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I'm facing this error.
Connecting to NVIDIA GeForce GTX 480...
Error opening file compute_kernels.cl
Segmentation fault: 11

What am i doing wrong here?

#46
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany

I'm facing this error.
Connecting to NVIDIA GeForce GTX 480...
Error opening file compute_kernels.cl
Segmentation fault: 11

What am i doing wrong here?

THat kind of error, Error opening + segmentation fault 11 tell us:
App started but some files missed because working path isn't the folder which contains app + needed files.
Double click the app starts it but MUST fail.
First start the terminal and then change directory to the unzipped folder by cd (drag & drop folder in terminal) ENTER
Then drag & Drop the app also in terminal ENTER

#47
Prowlerblizz

Prowlerblizz

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

THat kind of error, Error opening + segmentation fault 11 tell us:
App started but some files missed because working path isn't the folder which contains app + needed files.
Double click the app starts it but MUST fail.
First start the terminal and then change directory to the unzipped folder by cd (drag & drop folder in terminal) ENTER
Then drag & Drop the app also in terminal ENTER


Posted Image

#48
amit_talkin

amit_talkin

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Sapphire Vapor-X HD4890 1GB

no multisampling

Run - 6.7 ms / 155 fps
Pause - 1.24 ms /810 fps


#49
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany

400 FPS

THanks.
You posted your GPU NVIDIA GeForce GTX 480 before. But are the 400 fps in normal mode or after pressing space = pause?

After some no multisampling results we can see that nvidia gpus have more speed win compared to the multisampling results as the ati typegpus.

#50
Prowlerblizz

Prowlerblizz

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
The post on top was my first post. I finally got it to work

400 FPS in normal mode
800 FPS in pause mode

Looks like the openCL on my machine is working fine however Main Stage 2.13 is crashing whenever I load up a template and crash reports points to geforcegldriver. Dudes in discussion.apple.com says it has something to do with opencl.

Been busting my head trying to get it not to crash upon loading a template but no luck so far.

Posted Image

Posted Image

#51
Armacham

Armacham

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
Asus GTX580 Direct CU II 10.7.2 (11C62)

run:
ESC key abort / [GPU] Compute: 2.40 ms Display: 417.48 fps

pause:
Starting event loop...
ESC key abort / [GPU] Compute: 1.41 ms Display: 708.04 fps

Oh, the first one was with Multisampling, this is without, was hard to catch the text because of heavy flickering, see title for compute time and fps.

Posted Image
Posted Image

#52
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany
WoW record :rolleyes: 417 FPS with GTX 580

#53
SuperHack

SuperHack

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
Lion 10.7.1

Core i7-950
EVGA GTX 480

NO-Multisampling

416 fps
925 fps (when paused)

Can't wait to see what performance in 10.7.2 is like!

#54
diskeeper

diskeeper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
10.7.2 11C62

EVGA GTX 460 SuperClocked with patched GeForceGLDriver & libclh.dylib

No multisampling:

173,18 fps - 5,77 ms
290,91 fps - 3,44 ms (paused)

#55
amit_talkin

amit_talkin

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Gigabyte HD5970 ( single GPU enabled )

153 FPS / 698 FPS

whats wrong here? I got 155/810 FPS with my Sapphire Toxic HD4890, while with more powerful HD5970 ( with single GPU enabled , its still powerful than 4890 ) I get 153/698 FPS! :D

#56
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany
It can be that the OpenCL compiler (complies on the fly at runtime) better knows 47xx gnu than 5xxx gnu type and so better produces the gnu program.
Also it seems that Nvidia gpus GTX get much faster gnu code than AMDs. Even the high end AMDs are faster "on the paper".
Last but not least it can be that both gpus run at different PCI speed (count of lanes for data transfer). Alls complex CUDA + OpenCL apps are bond by transfer speed CPU<> GPU beside VRAM speed and gnu speed - and that of core isn't slow with AMD 4890 compared to 5xxx gnu.

#57
strelok1911

strelok1911

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
Attached File  Screen_Shot_2011_09_28_at_12.28.33_PM.png   54.85KB   70 downloads
10.7.1

#58
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany

Attached File  Screen_Shot_2011_09_28_at_12.28.33_PM.png   54.85KB   70 downloads
10.7.1

.... Error opening file ....
Please so the steps in the how to .
STart Terminal cd (change directory) to the folder with the files content, start the app by drag & drop into the terminal + ENTER
Simple double click doenst work and gives that error you posted.

#59
diskeeper

diskeeper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
10.7.2 11C71

EVGA GTX 460 SuperClocked with patched GeForceGLDriver & libclh.dylib

No multisampling:

172,12 fps - 5,84 ms
289,09 fps - 3,53 ms (paused)

#60
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Thanks
Big diff to Gigabyte GTX460 OC2 10.7.1 271 fps user.
Maybe AGPM settings (GPU clock) is reason ?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy