Jump to content

[Guida] OS X Lion 10.7 (GM e RTM) su Asus X58 LGA 1366 i7 9xx

Lion Lionize AsusX58 LGA1366

  • Please log in to reply
1004 replies to this topic

#101
Frenky94c

Frenky94c

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts

Da come dici intendo che stai usando il VodooHDA e non AppleHDA la procedura è questa :
elimini il VodooHDA che trovi in S-L-E
Dentro la cartella Base V 1.3 troviamo la cartella AD2000B_LION che serve per la tua scheda
S-L-E AppleHDA e sostituiamo i 3 file plist con quelli della cartella AD2000B seguendo questo percorso :
System/Library/Extensions/AppleHDA.kext/Contents/Resources/layout12.xml
System/Library/Extensions/AppleHDA.kext/Contents/Resources/Platforms.xml
System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHardwareConfigDriver.kext/Contents/Info.plist
Ultima cosa da Terminale digita questo comando :
sudo kextcache -v 1 -a i386 -a x86_64 -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions
Riavvia

Siccome ho eliminato l'AppleHDA nel momento in cui ho inserito il VoodooHDA, dove posso reperirlo ora? Basta uno qualunque preso da kext.com? E invece per quanto riguarda la 295? Sei riuscito a fare nulla con il DSDT base?

#102
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 7,290 posts
  • Gender:Male
  • Location:Italy
Ti posto quello già modificato

#103
Frenky94c

Frenky94c

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts

Ti posto quello già modificato

Devo comunque eseguire quel comando da terminale giusto? E invece per la 295? Nessuno risultato immagino...eppure io ero riuscito ad avere la risoluzione Full HD, ora non va più con lo stesso metodo...che strano.

#104
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 7,290 posts
  • Gender:Male
  • Location:Italy
Rileggi quello che ti scritto prima per AppleHDA
Domanda per la video fai questi passi :
preferenze di sistema - monitor - rotazione
Dico questo perchè se non dico una stupidata l'ultimo boot chameleon dovrebbe riconoscerla nativamente e basterebbe
GraphicsEnable
Ma forse mi sbaglio

#105
Frenky94c

Frenky94c

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts

Rileggi quello che ti scritto prima per AppleHDA
Domanda per la video fai questi passi :
preferenze di sistema - monitor - rotazione
Dico questo perchè se non dico una stupidata l'ultimo boot chameleon dovrebbe riconoscerla nativamente e basterebbe
GraphicsEnable
Ma forse mi sbaglio

Rotazione non compare neppure in monitor...

Edit: Ho seguito la guida per l'AppleHDA passo passo, inclusa ricostruzione della cache ma non ne vuole sapere proprio di funzionare...resto col Voodoo mi sa...

#106
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,668 posts
  • Gender:Male
  • Location:Canary Islands

Thanks for the guide. Worked perfectly with my P6T-SE.


Thx for the feedback

Fabio

#107
M J

M J

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 130 posts
  • Gender:Male
  • Location:Milano, Italy
Sto finendo di scaricare Lion poi proverò questa installazione (funziona anche con Lion retail vero? o solo con GM?)

ho due domande:
vorrei mantenere per qualche tempo la possibilità di caricare anche Leopard, come posso fare?
c'è un modo per "trasportare" la macchina del tempo da leopard a lion?

grazie!

#108
M J

M J

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 130 posts
  • Gender:Male
  • Location:Milano, Italy
uhm... problema:

Attached File  Immagine_1.png   51.23KB   42 downloads

qualche idea?

nulla, risolto.

#109
spartacus85

spartacus85

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Per l'audio prova a ricostruire la cache con questo da terminale :
sudo kextcache -v 1 -a i386 -a x86_64 -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions
Questo comando lo trovi in fondo alla guida


nulla...non funziona.

ho provato anche le indicazioni dei post successivi(l'inserimento manuale dei file da Base all'AppleHDA)....continua a non funzionare.

qualche idea per la scheda video?ho controllato e l'id è correttamente presente nel plist all'interno del ATI6000Controller.kext;continua a funzionare ma in modalità "GraphicsEnabler=No"....nn dovrebbe funzionare tutto nativamente?

#110
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 7,290 posts
  • Gender:Male
  • Location:Italy

la possibilità di caricare anche Leopard


Puoi creare due partizioni una per Leopard e l'altra per Lion

nulla, risolto.


Errore strano sembrerebbe che non carichi la directory della cartella base
Prova a rifare la procedura

#111
Matte_487

Matte_487

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Prima cosa complimenti per la Guida e per la pazienza!!!

Ho installato Lion seguendo i vari passi e devo dire che più semplice di così non si poteva fare.

Lion funziona alla grande, tranne l'audio che mi aveva già dato problemi con Snow e che non ero riuscito a far andare.
Qualcuno sa dirmi come procedere o quali prove fare per farlo funzionare??

Una cosa strana che ho notato è lo scroll del mouse che funziona al contrario :P

Matteo

#112
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 7,290 posts
  • Gender:Male
  • Location:Italy

Prima cosa complimenti per la Guida e per la pazienza!!!

Ho installato Lion seguendo i vari passi e devo dire che più semplice di così non si poteva fare.

Lion funziona alla grande, tranne l'audio che mi aveva già dato problemi con Snow e che non ero riuscito a far andare.
Qualcuno sa dirmi come procedere o quali prove fare per farlo funzionare??

Una cosa strana che ho notato è lo scroll del mouse che funziona al contrario :P

Matteo


Ciao Matte_487 per l'audio prova a ricostruire la cache, avviando da terminale :
sudo kextcache -v 1 -a i386 -a x86_64 -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions

Per il mouse Preferenza di sistema - Muose - Togli la spunta dove dice Sposta il contenuto ecc.

#113
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,668 posts
  • Gender:Male
  • Location:Canary Islands

Ho installato Lion seguendo i vari passi e devo dire che più semplice di così non si poteva fare.


Ho quasi ultimato il "Base_v1.4" (forse questo fine settimana) e dovrebbe essere ancora più facile... :P
PS anche per la "RTM" Retail... al momento in input accetta solo la GM ma con un po di malizia carica anche la TRM...
Basta rinominare la Retail come la GM...(mi riferisco all'installer.app...)... chi ha orecchie per intendere intende...

Fabio

#114
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 7,290 posts
  • Gender:Male
  • Location:Italy
Ciao Emac un attimo OT
Ho fatto una prova aggiornando alla 10.7.2
Se ti può essere di aiuto per la tua guida l'unica cosa che non funziona è l'Audio per il resto è OK
Se devi fare qualche test chiedi pure reinstallo
Chiudo OT

#115
M J

M J

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 130 posts
  • Gender:Male
  • Location:Milano, Italy

Puoi creare due partizioni una per Leopard e l'altra per Lion



Errore strano sembrerebbe che non carichi la directory della cartella base
Prova a rifare la procedura


Leopard era già su un disco fisso diverso, chameleon l'ha semplicemente riconosciuto da sè, perfetto!
l'altro problema era perchè avevo scompattato anche il il secondo dmg.

Anche per me l'installazione è stata veloce e senza problemi, davvero ottimo lavoro! ma... l'audio non funziona. ora provo con il kext che avevo su Leopard.

10.7.2? dove l'hai recuperato?

#116
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,668 posts
  • Gender:Male
  • Location:Canary Islands

10.7.2? dove l'hai recuperato?


Per cortesia non fomentiamo pirateria... grazie.

Fabio

#117
M J

M J

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 130 posts
  • Gender:Male
  • Location:Milano, Italy

Per cortesia non fomentiamo pirateria... grazie.

Fabio


scusa, era stupore in realtà.

ho provato a installare l'AppleHDA.kext che mi faceva funzionare l'audio su Leopard, aggiornato la kextcache, ma ancora niente.

#118
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,668 posts
  • Gender:Male
  • Location:Canary Islands

scusa, era stupore in realtà.

ho provato a installare l'AppleHDA.kext che mi faceva funzionare l'audio su Leopard, aggiornato la kextcache, ma ancora niente.


nessun problema M J.

Molti qui ti devono molto, io primo tra tutti, senza la tua guida per la P6T Deluxe (sull'internazionale),
non avrei sperimentato questa fantastica esperienza! :D

Fabio

#119
dani0177

dani0177

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:modena

uhm... problema:

Attached File  Immagine_1.png   51.23KB   42 downloads

qualche idea?

nulla, risolto.


ciao m j come hai risolto perche è due giorni che provo ma non ci salto fuori mi da quell errore anche a mè ?

#120
M J

M J

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 130 posts
  • Gender:Male
  • Location:Milano, Italy
Sono contento che sia servita Fabio :angel:

@dani: apri il file mkboot e modifica la linea 19 in:
IN_APP_DMG='InstallESD.dmg'
quindi invece di trascinare l'"Installa Mac OS X Lion.app" che trovi dentro InstallESD.dmg, trascina la cartella che contiene InstallESD.dmg (es. /Users/Te/Download).

L'audio funziona! Dopo averne provate mille alla fine mi è bastato reinstallare l'AppleHDA.kext patchato (quello nel Base System) e aggiornare la cache come specificato nella guida.
Non mi resta che aggiornare la firma!





Also tagged with one or more of these keywords: Lion, Lionize, AsusX58, LGA1366


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy