Jump to content

ApplePCIIDE.kext


  • Please log in to reply
43 replies to this topic

#21
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 294 posts
  • Gender:Male
I have not tested Sil0680, but Via6421 works in Lion without modification.

#22
geigi

geigi

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Thanks ;) I will try it.

#23
angus_72

angus_72

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi.
Today I downloaded your ApplePciIde driver, but I noticed that is compiled for intel processors.
Since I have to install a VIA VT6421A card in a G4 Powermac, is there any way to compile the driver for osx 10.5 PowerPC?
Thank you.
Best regards

Federico

#24
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 294 posts
  • Gender:Male
Get the source from osx86drivers.sourceforge.net using subversion, and modify its xcode project as needed.
I have never tried ppc build.

#25
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,634 posts
  • Gender:Male
  • Location:Canary Islands
Hi!
Any chance for Marvell 88SE6111 ?
(Sil5723)...
Also discussed here --> [help] Esata: Marvell 88se6121 Sata II Controller [11ab:6121]

Fabio

#26
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 294 posts
  • Gender:Male
Unfortunately, I don't have any hardware using the chip, so it's practically impossible to develop a driver.

#27
CaptHowie

CaptHowie

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Melbourne, Australia
Is it possible to get a version for 10.4.11? I want to install it on a Power Mac G4, but I'm running a MacBook Air with 10.6 as my primary machine, so I can't build a 10.4 PowerPC distribution. :)

#28
kris27

kris27

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

I have just uploaded 10.5 build.
merry christmas!

I am trying to build on PowerMAC G4 running osx 10.5.8 I use Xcode V3. Few attempts, following the APPLE manuals, build is success ..... but when trying to use load kext the message is ApplePCIIDE.kext does not contain code for this architecture. When looking at target.info, which was modified, VAILD_ARCHS ppc, GCC_MODEL_TUNING G4, and ???? just can not remember ..... There are no kextutil, but found on the net that it comes with 10.6 OSX.
Could you please advise what parameters to be modified to get build on OSX 10.5.8 G4 ??? I think started going the loop by now ..... can not see trees in the forest.

Kind regards Kris

#29
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 294 posts
  • Gender:Male
I chose the build target as "Release_Leo" on Xcode 3.2.6, then added "ppc" to "ARCH" parameter and could start building for ppc, but could not compile as there are some undefined symbols in ppc architecture ( IODTAIOReg8, IOATAIOReg32 ) . You must modify the code to support ppc hardware.

Is it possible to get a version for 10.4.11? I want to install it on a Power Mac G4, but I'm running a MacBook Air with 10.6 as my primary machine, so I can't build a 10.4 PowerPC distribution. :(

You can optionally install 10.4u SDK with Xcode 3.2.6, though you must modify the code.

#30
kris27

kris27

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Sorry for dragging on - it was a while ago now, and I was very busy with my telescope controller.
1. Modify or
#define IOATAIOReg32 .... as what ??????
#define IOATAIOReg8 ..... as what ?????

Is this the only mod required ??? I am not familiar with APPLE ideas of programming, simply not ISO compatible, nor GNUcc.

Sorry for being a bit ignorant but APPLE ideas for me are murky like waters in the pond.

Regards Kris

#31
kdtt

kdtt

    InsanelyMac Protégé

  • Members
  • PipPip
  • 76 posts
Thank you for driver.
Siliconimage 0680 ata works fine in Lion except after wake there's error message"IOATA Controller device
blocking bus".
4hds are connected in master/slave mode.
ide bios 3.4

more test
I have os x in jmicronata and windows xp in silicon 0680, In case like this , You should connect Windows as master mode in primary channel, if not , even latest chameleons can not boot with ebios error 0x42.

Edited by kdtt, 09 March 2012 - 06:01 AM.


#32
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 294 posts
  • Gender:Male
Sory, I have not checked this thread for long.
You can find sample souces at Darwin ATA project - http://code.google.com/p/darwin-ata/
I found some ppc specific code there, but never used them.

#33
ElGringo

ElGringo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
Hi there,
Seems to work for everybody but me. I am on Dell Inspiron 545 running 10.6.6. System profiler does not show any PCI cards, eSATA drive is not recognized and the kext was loaded with Kext Utility in the System/Library/Extensions folder.

#34
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 294 posts
  • Gender:Male
Did you insert a card with one of the supported chips ?

#35
SnoopKatt

SnoopKatt

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
Thank you! This works flawlessly in Lion.

Here is the card I'm using:

http://www.amazon.co...eywords=PCI+IDE

#36
ElGringo

ElGringo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts

Did you insert a card with one of the supported chips ?

The card seems to be right - VIA VT6421. Since this happened, I got a SATA (from the internal SATA port of the card) to eSATA cable and now the eSATA drive is working fine. It is not available for booting at the Chameleon splash window (as when the external HDD is connected with USB cable), but that is OK. So, the problem appears to be the eSATA port on the card itself, as it is not working under Windows XP as well.
Anyway, thanks for the help and for developing the kext!

#37
emig647

emig647

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
FYI, this worked for me for a SYBA SD-SATA-4P with a blu-ray drive on port 0. Thank you!!!!

#38
maleorderbride

maleorderbride

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 275 posts
  • Gender:Male
I installed this on a 10.7.4 build and I do not see any extra drivers or entries under System Profiler.

I am using a rosewill (re-branded Sil3114) controller.

Does this work on Lion for anyone else?

#39
SnoopKatt

SnoopKatt

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
I use this card on Lion: http://www.amazon.co...ywords=via 6421

With the kext, it works flawlessly.

#40
thanasis19994

thanasis19994

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
hello, my hackintosh finally recognized my ide dvd-rom after installing applepciide.kext so many thanks for this!
But there's another issue: i can write cds without a problem but when it comes to dvds when it starts writing for ex. an .dmg the light of the drive starts blinking for about 3-4 secs and then it stops and the procedure 'freezes' at 0%. (I ve been waiting for over half an hour)
Any help would be appreciated!
Thanks





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy