Jump to content

[GUIDE] Scripted Retail Mavericks/Mountain Lion Install on Gigabyte Mobos


  • Please log in to reply
4375 replies to this topic

#4361
VirusX

VirusX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:Germany

did you set 'InjectKexts' to true?

 

Thanks for the new networking kext, I'll have a look at that these days. I don't really need a new one since the old one is working even in Yosemite, but it's always good to check out the alternatives ;)



#4362
@ROBASEFR

@ROBASEFR

    InsanelyMac Geek

  • Members
  • PipPipPipPipPip
  • 299 posts
  • Gender:Male
  • Location:France

Yes, I did. By the way a little bit confusing the difference between Yes and true !

Inject of kexts works better now, but not working for my DVD -IDE and had to install in S/L/E drivers for my USB3/SATA3 card too, to get them working !

I saw in your config.plist no SMBIOS data ! Is that volontarely ?

 

The new RealtekRTL8111.kext copied in S/L/E has the convenient that it's not inside IONETWORKINGfamily.kext (plugin) so not affected when updating !

;)



#4363
VirusX

VirusX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:Germany

Clover is boolean values (true / false) to toggle options on/yes or off/no.

Regarding SMBIOS I quote the clover wiki: " Clover will do this task automatically based on the given processor, video card and signs of mobility. However, you may choose differently." Because of this, I left everything for clover to set and it works, so I don't mess with it haha

 

Regarding the networking kext: Again, since I let clover inject my kexts, I never have problems when updating. But depending on the method you chose for Audio patching (Toleda offers several options), you need to run his script again after Apple updated its AppleHDA.kext.

 

Since I don't have IDE or USB3 devices, I don't need kexts for that but theoretically, clover should be able to handle that too so that you don't have to install them in S/L/E. Maybe you have to ask in the clover thread - I'm not an expert ;)

 

I think the whole idea behind clover is to have a vanilla install (everything untouched) and let clover work its magic while booting (patching DSDT, injecting kext, setting all parameters). So an update from Apple won't kill your system and in case you want to change things with clover, you can easily do that on a thumb drive and don't kill your install with the wrong kext in S/L/E ;)



#4364
itdoesnotwork

itdoesnotwork

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 102 posts

Updated to 10.9.4 - went smooth as usual. Needed to re-run kext installer in order to get sound back.



#4365
@ROBASEFR

@ROBASEFR

    InsanelyMac Geek

  • Members
  • PipPipPipPipPip
  • 299 posts
  • Gender:Male
  • Location:France

Updated to DP4 and 5 -went smooth too !

:thumbsup_anim:



#4366
legends74

legends74

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Anyone else notice the SSD trim enabler doesn't work after updating to 10.9.4?



#4367
digital_dreamer

digital_dreamer

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,077 posts
  • Gender:Male
  • Location:Missouri USA

legends74,

Try running the following command in Terminal (copy/paste) to enable TRIM (this should work for any version of OS X):

 

sudo perl -i.bak -pe 's|(Rotational\x00{1,20})[^\x00]{9}(\x00{1,20}[^\x00])|$1\x00\x00\x00\x00\x00\x00\x00\x00\x00$2|sg' \

/System/Library/Extensions/IOAHCIFamily.kext/Contents/PlugIns/IOAHCIBlockStorage.kext/Contents/MacOS/IOAHCIBlockStorage

 

best of wishes,

MAJ



#4368
@ROBASEFR

@ROBASEFR

    InsanelyMac Geek

  • Members
  • PipPipPipPipPip
  • 299 posts
  • Gender:Male
  • Location:France

Updated to DP6  -went smooth  !

:thumbsup_anim:

 

I joint my config.plist for Clover bootloader r2818 for EX58-UD5

Attached File  config.plist.zip   1.61KB   14 downloads



#4369
Windows04

Windows04

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 214 posts

Updated to DP6  -went smooth  !

:thumbsup_anim:

 

I joint my config.plist for Clover bootloader r2818 for EX58-UD5

attachicon.gifconfig.plist.zip

 

Hi ROBASEFR/VirusX!

 

Using this config.plist, are you able to boot the system without any further customizations in terms of kexts (aka are all the patches that are needed in the config file or do you also use some kexts in combination with this file)?

 

Would also like to make the switch to Clover, but I'm a long time Chameleon user, also running on a GA-EX58-UD5 board. Maybe your config.plist could be a starting point ;).

 

Specifically: I would like to know how you got sound working through Clover... I'm currently not finding any solution through Clover (I just wouldn't get ANY sound options in DP6, although I would get them up until DP4)



#4370
@ROBASEFR

@ROBASEFR

    InsanelyMac Geek

  • Members
  • PipPipPipPipPip
  • 299 posts
  • Gender:Male
  • Location:France

Hello Windows04,

 

I use this patch for audio;

https://github.com/t...audio_CloverALC

And this kext for LAN (885) in S/L/E

http://www.insanelym... realtekrtl8111

Latest FakeSMC.kext with plugins is 6.11.1328  : http://hwsensors.com/

For USB3 I took this method: http://www.insanelym...d-appleusbxhci/

 

 

The rest is in config.plist !

Use Clover configurator (4.12.1) : to see in détail:http://www.hackintos...r-configurator/

 

Important:

 

I use Kext Wizard (3.7.10) to install kext in S/L/E and rebuild cache (when already In Yosemite)

 

When updating cache from an other disk then Yosemite,  I use  in terminal : (where "Yosemite" is the disk to update):

sudo kextcache -prelinked-kernel /Volumes/Yosemite/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache -K /Volumes/Yosemite/System/Library/Kernels/kernel /Volumes/Yosemite/System/Library/Extensions

 

Good luck.

;)

 

P.S : I can say as an Chameleon transfuge that Clover is the best way to boot in OSX !



#4371
uEih

uEih

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

I'm not sure if I'm understanding what I'm suppose to do but every time I run the Run_Hackinstaller file and pick Install OS X then Boot Disk, it'll tell me the OS X ISO/DVD/ESD file couldn't be found. I'm doing this on my macbook, unless I'm doing something incorrect I'm not quite following it. 

 

EDIT: After redownloading the .app again it works.



#4372
VirusX

VirusX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:Germany

Thanks @ROBASEFR for your step-by-step guide. I just couldn't help and notice some unnecessary steps in between. With Clover and our mainboard setup, you really only need two kexts: FakeSMC and IONetworking. Everything else, including DSDT patching, is done by Clover.

 

1) create USB yosemite installer

2) my tip: install clover on an extra thumb drive / sd card. 

3) copy FakeSMC and IONetworking kext to Clover/kexts/10.10 and add "kext-dev-mode=1" to the boots args in the clover config

4) boot from clover usb drive and select yosemite usb installer and install on hard drive

5) boot from clover usb drive and select hard drive with yosemite.

6) add/apply toleda's audio patch to clover's config and run his script.

DONE

 

Sleep and all the other things are working thanks to clover. No need for tons of kexts. No need to install kexts to S/L/E and rebuild caches (those things will break anyway with the next OS update!).

 

Now you can check out all the other options in clover's config file and adjust things if you want to. Like inject graphic settings/framebuffers.

 

Once you have found the perfect clover config, install clover to your hard drive, copy the kexts to the clover/kexts/10.10 folder and replace the standard config plist with your perfect one.

 

 

--> if there's an update for clover or you want to try a new setting for clover, test it on the clover usb drive first, before you apply it to your real install on the hard drive so you won't destroy your install ;)

 

edit: I added my config.plist. ATTENTION: A framebuffer patch for my MSI R9 270X is included. Remove that if you don't have the same card ;)

 

 

Hi ROBASEFR/VirusX!

 

Using this config.plist, are you able to boot the system without any further customizations in terms of kexts (aka are all the patches that are needed in the config file or do you also use some kexts in combination with this file)?

 

Would also like to make the switch to Clover, but I'm a long time Chameleon user, also running on a GA-EX58-UD5 board. Maybe your config.plist could be a starting point ;).

 

Specifically: I would like to know how you got sound working through Clover... I'm currently not finding any solution through Clover (I just wouldn't get ANY sound options in DP6, although I would get them up until DP4)

 

 

Hello Windows04,

 

I use this patch for audio;

https://github.com/t...audio_CloverALC

And this kext for LAN (885) in S/L/E

http://www.insanelym... realtekrtl8111

Latest FakeSMC.kext with plugins is 6.11.1328  : http://hwsensors.com/

For USB3 I took this method: http://www.insanelym...d-appleusbxhci/

 

 

The rest is in config.plist !

Use Clover configurator (4.12.1) : to see in détail:http://www.hackintos...r-configurator/

 

 

Hi Windows04,

 

 sorry for my late response. I quoted my how-to from 1 or 2 pages before to install yosemite. The procedure is still the same but I'm using the Realtek8111.kext now, as ROBASEFR suggested.

 

BUT: I would NOT suggest you put any kexts in S/L/E! As I described above, all kexts go to the Clover folder and get loaded from there. No need to change anything in the install (which might get changed by the next OS update anyway.)

 

For sound, I'm also using Toleda's patch which should be able to survive OS updates as well.

 

If you have more questions, like my post or write me a private message after you replied so that I get a notification (I don't check this thread regularly any more).

 

Good luck! 



#4373
iceage2609

iceage2609

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
For now reason,the system was working just fine after a reboot onMavs 10.9.4 i am stuck in verbose mode at IOBluetoothHostControllerUSBTransport][SuspendDevice] --Suspend--suspenddevicecallresult = 0X0000 (kIO Returnsucess)
Any clue?

Thanks

#4374
@ROBASEFR

@ROBASEFR

    InsanelyMac Geek

  • Members
  • PipPipPipPipPip
  • 299 posts
  • Gender:Male
  • Location:France

Update to DP8 without problems with Clover r2877

:thumbsup_anim:



#4375
VirusX

VirusX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:Germany

yup, DP8 running on Clover 2890 here. No need to reapply patches - everything survived the update :)



#4376
@ROBASEFR

@ROBASEFR

    InsanelyMac Geek

  • Members
  • PipPipPipPipPip
  • 299 posts
  • Gender:Male
  • Location:France

Update to 10.9.5, No problems as useall with Combo update and Pacifist install from scratch disk. Permission and cache rebuild. :lol:

 

(Updates in Yosemite are even better on my config directly from Appleupdate !)







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy