Jump to content

[GUIDE] Snow Leopard Vanilla Retail Guide for GA-P35-DS4 and other related boards


  • Please log in to reply
782 replies to this topic

Poll: Did it work without issues? (428 member(s) have cast votes)

Install check

  1. Yes (GA-P35-DS4) (165 votes [38.55%])

    Percentage of vote: 38.55%

  2. No (GA-P35-DS4) (43 votes [10.05%])

    Percentage of vote: 10.05%

  3. Yes (Different MB) (164 votes [38.32%])

    Percentage of vote: 38.32%

  4. No (Different MB) (56 votes [13.08%])

    Percentage of vote: 13.08%

Vote Guests cannot vote

#41
gizmos41

gizmos41

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

Thx Ilan

So in Snow, there are no QE /Ci line in System Profile ....

That's would say that I have QE /Ci enable :P

#42
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

Thanks Tseug for this Package.
I will try this soon.
Meanwhile, I did a successful installation of 10.6 on my own and started playing with it, and after installation of iLife 09, I had many problems and KP. :unsure:
I was wondering if you have ever experienced system crashes using 10.6 as delivered with your procedure ?

Thanks !
:D
Gloops92
GA-P35-DS4 Rev2.0 - NV 8800GTS


I haven't had any crashes. I have iLife 09 installed, but I don't use it much at the moment. However, iMovie loaded up without problems.

Guide updated with succes stories on other boards.

#43
Marcel Bidon

Marcel Bidon

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male

Hi,
At this moment i have 10.5.8, and want to do a clean install and use Snow Leopard.
I would like to buy a new harddrive, is a 1TB drive supported?
thnx


Not tried with snow, but with 10.5.8 no problem.
This computer is using a 1TB drive, leopard is on 1 partition of 180 GB MBR.
Regards.

#44
mactheworld77

mactheworld77

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
Will this install work from an imaged snow install disk using a 10.5.8 hackintosh to another sata drive in the case? Getting that "you must restart the computer" screen after the apple shows up with the light grey background> I did the image from a bought copy of snow. My dvd rom stopped working and dont have another sata one to throw in so I was using a .dmg file i created with the disk

#45
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

Will this install work from an imaged snow install disk using a 10.5.8 hackintosh to another sata drive in the case? Getting that "you must restart the computer" screen after the apple shows up with the light grey background> I did the image from a bought copy of snow. My dvd rom stopped working and dont have another sata one to throw in so I was using a .dmg file i created with the disk


Yes. That should work. You may have to repartition the drive? Make sure that "Ignore ownership on this volume" is not checked in Get Info on the target partition.

You can also restore the DVD to a partition and follow the steps as if you had installed SL. I've tested this on a 8 GB USB stick. Use the disk utility restore functionality. Make sure that the DVD is scanned prior to restoration by clicking Images->Scan Image for Restore... Otherwise it will fail.

In addition, if you boot up with '-v', You can see exactly what went wrong.

#46
Gloops92

Gloops92

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

I haven't had any crashes. I have iLife 09 installed, but I don't use it much at the moment. However, iMovie loaded up without problems.

Guide updated with succes stories on other boards.


Ok, I installed it again using your package and guide. No problem at install. But, after working for 15 minutes on SL, I had a System crash ;)

As I had 3 other hard disks mounted in my PC, I decided to disconnected all drives except SL.
And now it is stable so far ! :P
I think this can be related to Spotlight indexing other disks and running over weird files that would cause a crash ???
Anyway, I will keep going on my installation of apps and customization.
My goal is to have full 64bits running, so I will take a look at Bonjour with Realtek in the forums.

Thank you very much for your work.

Keep updating this thread for all GA-P35-DS4 owners ! We are a lot ;)

#47
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

Ok, I installed it again using your package and guide. No problem at install. But, after working for 15 minutes on SL, I had a System crash :blink:

As I had 3 other hard disks mounted in my PC, I decided to disconnected all drives except SL.
And now it is stable so far ! ;)
I think this can be related to Spotlight indexing other disks and running over weird files that would cause a crash ???


I don't know. It doesn't seem likely. You can prohibit spotlight from indexing the other drives by adding them to Privacy in spotlight preferences.

Anyway, I will keep going on my installation of apps and customization.
My goal is to have full 64bits running, so I will take a look at Bonjour with Realtek in the forums.


I've seen a hack using a patched ifconfig, but personally I'm fine with the 32 bit kernel.

#48
Bït

Bït

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Working on a GA-X38-DS5.

Thank you!

#49
CmCd01

CmCd01

    InsanelyMac Protégé

  • Donators
  • 74 posts
Success on a GA-P35-DS4! Thank you for your work, tseug.

I ran the installation from a separate partition with a SuperDuper copy of my previous 10.5.7 installation. I have a single disk, dual-boot setup with XP, so I installed to a GUID partition on a MBR disk. To do this, I used a modified OSinstall.mpkg which allows installation to an MBR disk - create your own using the guide linked in my signature. That resulted in a modified Snow Leopard install image (i.e., .dmg file) that I mounted to install from.

I have an ATI video card, so I didn't run step #11 assuming the result was tailored to nvidia cards - is that correct (wasn't exactly clear in the guide, I thought)? Consequently, I haven't applied any kexts for my video card, so I'm dealing with the default driver - subpar resolution, no dual dvi, etc. It appears the previous Bronya kexts I used are having difficulty with Snow Leopard - any suggestions would be appreciated.

EDIT: also need to add support for PS/2 keyboard, which is preferred over my cheap USB version. Previously used pcwiz command center, not sure if works for SL...

#50
LS8

LS8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 573 posts
  • Gender:Male
  • Location:Reality Distortion Field

Thanks for all the work that has gone into this...

I'm having some troubles with the GA-P35-DS4 Snow Leopard Installer though.

It fails running the "postupgrade script for snowjob". Any thoughs?


/Extra/Extensions folder must exist on the destination partition. If it does not (e.g. if you install Chameleon 2.0 RC3 manually), you have to create it prior installing the drivers package. It works perfectly for me on my P35-DS4, thanks tseug!

Tseug, does your package install some files to the system tree, or are all files stored in /Extra?

#51
CmCd01

CmCd01

    InsanelyMac Protégé

  • Donators
  • 74 posts
I updated to Chameleon RC3, which was released this past weekend. With RC2 already installed, to update I just copied the single boot file from the binaries distribution to /, replacing the older Chameleon boot file. Also, to run in 32-bit, had to replace arch=x86_32 with arch=i386 -legacy in apple.Boot.plist.

It was any easy update, though I'm not sure whether I'm benefiting from any of the improvements :P

#52
the_gael

the_gael

    not a complete idiot - some parts are missing

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
Many thanks for this guide - just installed Snow Kitty seamlessly on my GA-P35-DS4 using this.

I just ignored the section on EFi Studio as I use an ATi RadeonX X1950Pro 512mb - i installed Bronya's latest driver for Snow Leopard from this thread Bronya's ATi x1950 Drivers

I have not done any rigorous use or testing yet but all appears fine.

#53
Hardflip

Hardflip

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Nice job, thank you for your work! It's working with my P35-DS4, Q6600 and my geforce 8800 gtx. Does anybody know what's about analog 5.1 sound!? I only have 2.0 sound, I think I should try VoodooHDA. And what's about the DVD-Drive, I've one from asus, it can't be recognized by the OS, an ideas? Thank you!

#54
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

/Extra/Extensions folder must exist on the destination partition. If it does not (e.g. if you install Chameleon 2.0 RC3 manually), you have to create it prior installing the drivers package. It works perfectly for me on my P35-DS4, thanks tseug!


No problem. I installed Leopard using your guide back in the day, so right back at you :)

Tseug, does your package install some files to the system tree, or are all files stored in /Extra?


It installs RealtekR1000.kext to /S/L/E and Netkas boot to /. Everything else goes in /Extra.

Chameleon RC3 also works fine, but I haven't gotten around to updating the package yet. I'll do that today or tomorrow.

#55
CmCd01

CmCd01

    InsanelyMac Protégé

  • Donators
  • 74 posts

I just ignored the section on EFi Studio as I use an ATi RadeonX X1950Pro 512mb - i installed Bronya's latest driver for Snow Leopard from this thread Bronya's ATi x1950 Drivers

That's good news, The Gael. Could you tell me the method you used to install Bronya's driver? Did you copy out the kexts/plugins to the /Extra folder? Or did you just run his load program? If the former, how exactly did you setup the files?
THANKS

#56
CmCd01

CmCd01

    InsanelyMac Protégé

  • Donators
  • 74 posts

It installs RealtekR1000.kext to /S/L/E and Netkas boot to /. Everything else goes in /Extra.
Chameleon RC3 also works fine, but I haven't gotten around to updating the package yet. I'll do that today or tomorrow.

So, if I updated my /boot file with the Chameleon RC3 version, then I wiped out the Netkas boot file your installer installed? I think it booted fine - what am I missing out on by using the RC3 boot file instead of the Netkas version?

#57
LS8

LS8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 573 posts
  • Gender:Male
  • Location:Reality Distortion Field

...It installs RealtekR1000.kext to /S/L/E and Netkas boot to /. Everything else goes in /Extra.

Chameleon RC3 also works fine, but I haven't gotten around to updating the package yet. I'll do that today or tomorrow.


Thanks. What version of RealtekR1000 is included in your package? The latest one 2.0.3, released on 2009-08-11? Link: http://www.realtek.c...GetDown=false#7

Can you please update your installer so it creates /Extra/Extensions if it does not exist? Can you include Chameleon 2.0 RC3 in the installer? Thank you!

#58
the_gael

the_gael

    not a complete idiot - some parts are missing

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male

That's good news, The Gael. Could you tell me the method you used to install Bronya's driver? Did you copy out the kexts/plugins to the /Extra folder? Or did you just run his load program? If the former, how exactly did you setup the files?
THANKS


If you follow the link in my previous post which you quoted; you will find the link to Bronya's drivers - he has updated the original thread with Snow Leopard compatible drivers. Download, check whether your card is Device ID 7280 or 7288 and then run the appropriate load.command. The system will reboot and your graphics will work. I did not have to do any setup - it just works!

#59
mafiasilk

mafiasilk

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
I've been trying different methods for about a week no joy!

Until this thread!

running first time in 15 minutes! You ROCK!!!!! Can I donate to you using PayPal for this! Im shocked and amazed by your work, its amazing!!!

#60
xaverloisl

xaverloisl

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Works great for me on several Gigabyte MBs like P35-DS4 and EP35-DS4 with different BIOS.
After installing newest Chameleon 2 RC3 removing the kernel flag <arch=x86_32> is no problem too and 64bit is enabled.

NTFS-3G 4.4 does only work in 32bit however but it can be switched on and off.

Thank you!





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy