Jump to content

Driver for Laptop Card-Readers (Internal PCI Bus)


  • Please log in to reply
152 replies to this topic

#61
wingrunr21

wingrunr21

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 496 posts

Still no luck, everything freezes when I insert the SD card :wacko:


macgirl try this one. Works fine for me on my vanilla install.

Attached Files



#62
Boombeng

Boombeng

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 598 posts
  • Gender:Male
  • Location:France
djmastera2000 : what is your card reader ? Ricoh ? what device id ?

#63
djmastera2000

djmastera2000

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts
Please read carefully:

....
PS: Pre-patched fc1 version with 0x08221180 id attached.


My CR is a RICOH...

#64
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets

macgirl try this one. Works fine for me on my vanilla install.

Thanks I'll try when back at home, here at the office do not have an SD card.

#65
Boombeng

Boombeng

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 598 posts
  • Gender:Male
  • Location:France

Please read carefully:



My CR is a RICOH...


I have seen this device id but it didn't know if it was yours... even "reading carefully" the information is not there dude :blink:
I can share kext patched with different id even if ot's not mine
good luck for your issue

#66
djmastera2000

djmastera2000

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts

I have seen this device id but it didn't know if it was yours... even "reading carefully" the information is not there dude :)
I can share kext patched with different id even if ot's not mine
good luck for your issue


Sorry hehe, was my fault...peace? :gun:

I think macgirl has the same issue...

#67
wingrunr21

wingrunr21

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 496 posts

Sorry hehe, was my fault...peace? :thumbsdown_anim:

I think macgirl has the same issue...


The kext I gave should work in macgirl's laptop since we both have XPS 1330s.

#68
MiniBUU

MiniBUU

    Inspiron 1525 User

  • Members
  • PipPipPip
  • 104 posts
  • Gender:Male
  • Location:New Jersey (U.S.A.)
The only bad part about having a working sd card reader is that I am so use to just pulling out the card when I am done. I have to learn to make a habit of ejecting it in the system first before physically removing it. Other than that It works great on my Dell Inspiron 1525 and I am glad to see this finally has become a hot topic to be (sticky).

#69
Boombeng

Boombeng

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 598 posts
  • Gender:Male
  • Location:France

Sorry hehe, was my fault...peace? ;)

I think macgirl has the same issue...


No problems, peace and happy new year to all the lucky (and unlucky for the moment) SD cards reader users!
:)

#70
Turanli

Turanli

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
Someone mind uploading vanilla iopcifamily(leo 10.5.6)?
Thx!

#71
icemanzh

icemanzh

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Location:Always around !
  • Interests:Learn, what ever it comes around...
thaks a lot for this kext, alive and kicking on my dv9780ez.

thanks again

#72
djmastera2000

djmastera2000

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts

The kext I gave should work in macgirl's laptop since we both have XPS 1330s.


And what is different in "your" kext and which version is it?

#73
wingrunr21

wingrunr21

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 496 posts
Beta 1 with the device ids updated so basically nothing.

Attached is an SVN release build with device ids updated. Haven't tested this one.

Attached Files



#74
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,875 posts
  • Gender:Male
  • Location:Moscow
I check latest kext from sf.net dated by 05 january 2009.
It works on my Dell Inspiron with Ricoh 08221180 without any problem. Read and write SD card fast and without cpu load.

#75
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
@wingrunr21 The kext you attach in post #74 did work, thanks. So what was the difference with others?

#76
djmastera2000

djmastera2000

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts

@wingrunr21 The kext you attach in post #74 did work, thanks. So what was the difference with others?


This one freezes too :P This time tested with last versions Chunnans' b2 of iopcmciafamily, because of my 3g pcmcia card...

Anybody succesfully tested card reader driver with chunnans' iopcifamily/iopcmciafamily?

#77
aliasa_anderson

aliasa_anderson

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts

This one freezes too :) This time tested with last versions Chunnans' b2 of iopcmciafamily, because of my 3g pcmcia card...

Anybody succesfully tested card reader driver with chunnans' iopcifamily/iopcmciafamily?



I did but got IOKIT timeout errors and very slow bootup.

#78
djmastera2000

djmastera2000

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts

I did but got IOKIT timeout errors and very slow bootup.


Strange...will test vanilla iopcifamily again with this version if i have more time...thx

#79
Wiwi

Wiwi

    InsanelyMac Guy

  • Members
  • PipPipPipPip
  • 212 posts
  • Gender:Male
Lastests version (since the one for macgirl) load successfully without freezing for me, but sd card doesn't mount, never...

10/01/09 13:15:48 kernel SDHCI: BaseClock = 33MHz 
10/01/09 13:15:48 kernel SDHCI: SD Clock = 257KHz 
10/01/09 13:15:48 kernel powerSD:  0x1f021a1 
10/01/09 13:15:49 kernel SDHCI: No Response from CMD8 
10/01/09 13:15:49 kernel SDHCI: No Response from CMD8 
10/01/09 13:15:50 kernel SDHCI: BaseClock = 33MHz 
10/01/09 13:15:50 kernel SDHCI: SD Clock = 16500KHz 
10/01/09 13:15:50 kernel SDHCI: RCA 0x00001234 
10/01/09 13:15:50 kernel SDHCI: RCA 0x00001234 
10/01/09 13:15:52 kernel SDHCI: Response: 0x00004F00 0x325F5983 0xCBF6DBFF 0x8F8A4000 
10/01/09 13:15:52 kernel SDHCI: Response: 0x00004F00 0x325F5983 0xCBF6DBFF 0x8F8A4000

----> kext loaded without card in

And sometimes it talk about 4 bit mode... when i load kext without card in and i plug it later...
Oh, and in this case i can see AppleXsanFilter loaded to the end of the IORegistry tree of
IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/P0P9@1E/IOPCI2PCIBridge/pci1180,822@3,1
...

I use IOPCIfamily vanilla and tested with ChunNan one... no change.

It's strange, because i have an Asus A8sc motherboard, sister of the A8sr one...

Many thanks for your work man, it's pretty cool to think that my HAck will be 100% operational after more than one year of *****...

#80
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,875 posts
  • Gender:Male
  • Location:Moscow
I use my own version of IOPCIFamily 2.5.4. (see signature).

Funny result:
WindowsXP can't read SD SanDisk 16Gb.
MacOSX with driver fc1 from sf.net read this card without any problem. :P





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy